גירסאות ורכיבים DeployR 7.3

לא יוצא דופן יופיע ארגוני להעדיף לפרוס DeployR על-פני משלו התשתית הקיימת Apache Tomcat או MongoDB במקום להתקין עם הרכיבים Tomcat ו- MongoDB הכלולה ההתקנה DeployR. פעולה זו יכולה להתבצע אך הבאות יש לקחת בחשבון:

MongoDB

DeployR 7.3 בדקה והיא נתמכת ב MongoDB 2.4.5. גירסאות ישנות יותר של MongoDB לא יפעלו עם DeployR. כדי להשתמש בהתקנה MongoDB אחר בארגון, תחילה לבצע התקנה של DeployR 7.3 ולאחר מכן צור קובץ dump של מסד הנתונים המוגדר כברירת מחדל מהתקנה MongoDB ברירת המחדל של DeployR ולשחזר לתוך ההתקנה באמצעות mongorestore. לאחר מכן להגדיר מחדש את החיבור בהתקנה MongoDB חדש ב- deployr.groovy.

Apache Tomcat

DeployR 7.3 בדקה והיא נתמכת על Apache Tomcat 7.0.34. DeployR משתמשת ב- sockets אינטרנט. לכן, לכל הפחות, עליך להשתמש Tomcat 7.0.27. כל דבר לפני 7.0.27 תגרום לניתוק פונקציונליות DeployR.

תצורת tomcat:

כדי להפעיל היציאות באותו DeployR אנו משתמשים כברירת מחדל ולאחר מכן יהיה עליך לדגום את פרטי המחבר מתוך server.xml ברירת המחדל הכלולה DeployR. אחרת, לכל הפחות, יהיה עליך לשנות את המיפויים היציאה נמצא בקובץ deployr.groovy כדי להתאים את תצורת מחבר Tomcat הנוכחית שלך:

grails.plugin.springsecurity.portMapper.httpPort=7300 
grails.plugin.springsecurity.portMapper.httpsPort=7301

ערכי יציאת 7300 ו- 7301 יצטרך להיות מעודכן כך שיתאים יציאות שאתה משתמש.

יהיה עליך גם לשנות את catalina.sh או catalina.bat כדי להבטיח ערימה Java המוקצים DeployR הולמת באמצעות JAVA_OPTS המתאים. ברירות מחדל אלה יהיו זמינים ב- catalina.sh/bat שנכלל ב- DeployR.

לבסוף, במקום כלשהו בסביבת REVODEPLOYR_HOME משתנה הסביבה חייב להיות מוגדר.

זקוק לעזרה נוספת?

הרחב את הכישורים שלך
סייר בהדרכה
קבל תכונות חדשות לפני כולם
הצטרף למשתתפי Microsoft insider

האם מידע זה היה שימושי?

תודה על המשוב!

תודה על המשוב! נראה שכדאי לקשר אותך לאחד מנציגי התמיכה של Office.

×