Premda ne možete izvesti Excel iz tekstne datoteke ili dokumenta programa Word, pomoću čarobnjaka za uvoz teksta u programu Excel podatke iz tekstne datoteke u radni list. Čarobnjak za uvoz teksta pregledava tekstnu datoteku koju uvozite i pridonosi tome da se podaci uvoze na način koji želite.     

Napomena: Čarobnjak za uvoz teksta naslijeđena je značajka koja je i dalje podržana za kompatibilnost sa stražnjom kompatibilnošću. Možete i uvesti tekstnu datoteku povezivanjem s njom pomoću dodatka Power Query.

Idite na karticu Podaci > pristup vanjskim podacima > iz teksta. Zatim u dijaloškom okviru Uvoz tekstne datoteke dvokliknite tekstnu datoteku koju želite uvesti, a otvorit će se dijaloški okvir Čarobnjak za uvoz teksta.

1. korak od 3

Izvorna vrsta podataka    Ako su stavke u tekstnim datotekama odvojene tabulatorima, dvotočkama, točkama sa zarezom, razmacima ili drugim znakovima, odaberite Razgraničeni. Ako su sve stavke u svakom stupcu iste duljine, odaberite Fiksna širina.

Početak uvoza u retku    Upišite ili odaberite broj retka da biste odredili prvi redak podataka koje želite uvesti.

Izvor datoteke    Odaberite skup znakova koji se koristi u tekstnu datoteku. U većini slučajeva tu postavku možete ostaviti po zadanom. Ako znate da je tekstna datoteka stvorena pomoću drugog skupa znakova od skupa znakova koji koristite na računalu, tu postavku promijenite tako da odgovara tom skupu znakova. Ako je, primjerice, računalo postavljeno tako da koristi skup znakova 1251 (ćirilica, Windows), ali znate da je datoteka proizvedena pomoću skupa znakova 1252 (zapadnoeuropski, Windows), trebali biste postaviti Izvor datoteke na 1252.

Pretpregled datoteke    U ovom se okviru prikazuje tekst koji će se prikazivati kada je odvojen u stupce na radnom listu.

2. korak od 3 (razgraničeni podaci)

Graničnici    Odaberite znak koji razdvaja vrijednosti u tekstnu datoteku. Ako znak nije naveden, potvrdite okvir Ostalo, a zatim upišite znak u okvir koji sadrži pokazivač. Te mogućnosti nisu dostupne ako je vrsta podataka Fiksna širina.

Tretiranje uzastopnih graničnika kao jednog    Potvrdite taj okvir ako podaci sadrže graničnik više od jednog znaka između podatkovnih polja ili ako podaci sadrže više prilagođenih graničnika.

Kvalifiker teksta    Odaberite znak koji u tekstnu datoteku sadrži vrijednosti. Kada Excel naiđe na znak kvalifikera teksta, sav tekst koji slijedi nakon tog znaka i prethodi sljedećem pojavljivanju tog znaka uvozi se kao jedna vrijednost, čak i ako tekst sadrži znak graničnika. Na primjer, ako je graničnik zarez (,) , a kvalifiker teksta navodni je znak ("), "Dallas, Texas" uvozi se u jednu ćeliju kao Dallas, Texas. Ako nijedan znak ili apostrof (') nisu navedeni kao kvalifiker teksta, "Dallas, Texas" uvozi se u dvije susjedne ćelije kao "Dallas i Texas".

Ako se razgranični znak odvija između kvalifikatori teksta, Excel izuzima kvalifikatori u uvezenoj vrijednosti. Ako se između kvalifikatori teksta ne pojavljuje znak graničnika, Excel u uvezenu vrijednost sadrži znak kvalifikatori. Stoga se "Dallas Texas" (koji koristi kvalifikaciju teksta navodnika) uvozi u jednu ćeliju kao "Dallas Texas".

Pretpregled podataka    Pregledajte tekst u ovom okviru da biste provjerili hoće li tekst biti odvojen u stupce na radnom listu kako želite.

2. korak od 3 (podaci fiksne širine)

Pretpregled podataka    Postavite širine polja u ovom odjeljku. Kliknite prozor pretpregleda da biste postavili prijelom stupca koji predstavlja okomita crta. Dvokliknite prijelom stupca da biste ga uklonili ili povucite prijelom stupca da biste ga premjestili.

Treći korak od 3

Kliknite gumb Dodatno da biste učinite nešto od sljedećeg:

  • Navedite vrstu decimalnih razdjelnika i razdjelnika tisućica koji se koriste u tekstnu datoteku. Kada se podaci uvezu u Excel, razdjelnici će se podudarati s onima koji su navedeni za vaše mjesto u odjeljku Regionalne i jezične mogućnosti ili Regionalna Postavke (Windows upravljačkoj ploči).

  • Navedite da jedna ili više brojčanih vrijednosti može sadržavati znak minus koji se ne može pratiti.

Oblik podataka stupca    Kliknite oblik podataka stupca koji je odabran u odjeljku Pretpregled podataka. Ako ne želite uvesti odabrani stupac, kliknite Ne uvozi stupac (preskoči).

Kada odaberete mogućnost oblika podataka za odabrani stupac, naslov stupca u odjeljku Pretpregled podataka prikazuje oblik. Ako odaberete Datum, u okviru Datum odaberite oblik datuma.

Odaberite oblik podataka koji se usko podudara s podacima pretpregleda da Excel pravilno pretvoriti uvezene podatke. Na primjer:

  • Da biste stupac svih brojeva valute pretvorili u oblik valute Excel, odaberite Općenito.

  • Da biste stupac svih brojeva pretvorili u oblik Excel, odaberite Tekst.

  • Da biste pretvorili stupac svih znakova datuma, svaki datum redoslijedom godine, mjeseca i dana u oblik datuma Excel odaberite Datum,a zatim u okviru Datum odaberite vrstu datuma YMD.

Excel će uvesti stupac kao općenito ako pretvorba može dati neželjene rezultate. Na primjer:

  • Ako stupac sadrži kombinaciju oblika, kao što su abecedni i numerički znakovi, Excel pretvara stupac u Općenito.

  • Ako se u stupcu datuma svaki datum nalazi u redoslijedu godina, mjeseca i datuma, a zatim odaberete Datum zajedno s vrstom datuma MDY, Excel stupac pretvara u opći oblik. Stupac koji sadrži znakove datuma mora se usko podudarati s Excel ugrađenim datumom ili prilagođenim oblicima datuma.

Ako Excel stupac ne pretvori u oblik koji želite, podatke možete pretvoriti nakon uvoza.

Kada odaberete željene mogućnosti, kliknite Završi da biste otvorili dijaloški okvir Uvoz podataka i odabrali mjesto podataka.

Import Data

Postavite te mogućnosti da biste upravljali načinom na koji se postupak uvoza podataka izvodi, uključujući svojstva podatkovne veze koja će se koristiti te koju datoteku i raspon popuniti uvezenim podacima.

  • Mogućnosti u odjeljku Odabir željenog prikaza podataka u radnoj knjizi dostupne su samo ako ste pripremili podatkovni model i odabrali mogućnost dodavanja tog uvoza u taj model (pogledajte treću stavku na popisu).

  • Navedite ciljnu radnu knjigu:

    • Ako odaberete Postojeći radni list, kliknite ćeliju na listu da biste prvu ćeliju uvezenih podataka prvu ćeliju uvezli ili kliknite i povucite da biste odabrali raspon.

    • Odaberite Novi radni list da biste ga uvezli na novi radni list (počevši od ćelije A1)

  • Ako imate podatkovni model na mjestu, kliknite Dodaj te podatke u podatkovni model da biste u model uvrstili taj uvoz. Dodatne informacije potražite u članku Stvaranje podatkovnog modela u programu Excel.

    Imajte na umu da odabirom te mogućnosti otvaraju se mogućnosti u odjeljku Odabir željenog prikaza podataka u radnoj knjizi.

  • Kliknite Svojstva da biste postavili sva svojstva raspona vanjskih podataka koja želite. Dodatne informacije potražite u članku Upravljanje vanjskim rasponima podataka i njihovim svojstvima.

  • Kada budete spremni za uvoz podataka, kliknite U redu.

Napomene: Čarobnjak za uvoz teksta naslijeđena je značajka koju je možda potrebno omogućiti. Ako to još niste učinili, onda: 

  1. Kliknite Mogućnosti > datoteka > podaci.

  2. U odjeljku Pokaži naslijeđene čarobnjake za uvoz podatakaodaberite Iz teksta (naslijeđe).

Kada omogućite, idite na karticu Podaci > Get & Transform Data > Get Data > Legacy Wizards > From Text (Legacy) (Naslijeđeni). Zatim u dijaloškom okviru Uvoz tekstne datoteke dvokliknite tekstnu datoteku koju želite uvesti, a otvorit će se čarobnjak za uvoz teksta.

1. korak od 3

Izvorna vrsta podataka    Ako su stavke u tekstnim datotekama odvojene tabulatorima, dvotočkama, točkama sa zarezom, razmacima ili drugim znakovima, odaberite Razgraničeni. Ako su sve stavke u svakom stupcu iste duljine, odaberite Fiksna širina.

Početak uvoza u retku    Upišite ili odaberite broj retka da biste odredili prvi redak podataka koje želite uvesti.

Izvor datoteke    Odaberite skup znakova koji se koristi u tekstnu datoteku. U većini slučajeva tu postavku možete ostaviti po zadanom. Ako znate da je tekstna datoteka stvorena pomoću drugog skupa znakova od skupa znakova koji koristite na računalu, tu postavku promijenite tako da odgovara tom skupu znakova. Ako je, primjerice, računalo postavljeno tako da koristi skup znakova 1251 (ćirilica, Windows), ali znate da je datoteka proizvedena pomoću skupa znakova 1252 (zapadnoeuropski, Windows), trebali biste postaviti Izvor datoteke na 1252.

Pretpregled datoteke    U ovom se okviru prikazuje tekst koji će se prikazivati kada je odvojen u stupce na radnom listu.

2. korak od 3 (razgraničeni podaci)

Graničnici    Odaberite znak koji razdvaja vrijednosti u tekstnu datoteku. Ako znak nije naveden, potvrdite okvir Ostalo, a zatim upišite znak u okvir koji sadrži pokazivač. Te mogućnosti nisu dostupne ako je vrsta podataka Fiksna širina.

Tretiranje uzastopnih graničnika kao jednog    Potvrdite taj okvir ako podaci sadrže graničnik više od jednog znaka između podatkovnih polja ili ako podaci sadrže više prilagođenih graničnika.

Kvalifiker teksta    Odaberite znak koji u tekstnu datoteku sadrži vrijednosti. Kada Excel naiđe na znak kvalifikera teksta, sav tekst koji slijedi nakon tog znaka i prethodi sljedećem pojavljivanju tog znaka uvozi se kao jedna vrijednost, čak i ako tekst sadrži znak graničnika. Na primjer, ako je graničnik zarez (,) , a kvalifiker teksta navodni je znak ("), "Dallas, Texas" uvozi se u jednu ćeliju kao Dallas, Texas. Ako nijedan znak ili apostrof (') nisu navedeni kao kvalifiker teksta, "Dallas, Texas" uvozi se u dvije susjedne ćelije kao "Dallas i Texas".

Ako se razgranični znak odvija između kvalifikatori teksta, Excel izuzima kvalifikatori u uvezenoj vrijednosti. Ako se između kvalifikatori teksta ne pojavljuje znak graničnika, Excel u uvezenu vrijednost sadrži znak kvalifikatori. Stoga se "Dallas Texas" (koji koristi kvalifikaciju teksta navodnika) uvozi u jednu ćeliju kao "Dallas Texas".

Pretpregled podataka    Pregledajte tekst u ovom okviru da biste provjerili hoće li tekst biti odvojen u stupce na radnom listu kako želite.

2. korak od 3 (podaci fiksne širine)

Pretpregled podataka    Postavite širine polja u ovom odjeljku. Kliknite prozor pretpregleda da biste postavili prijelom stupca koji predstavlja okomita crta. Dvokliknite prijelom stupca da biste ga uklonili ili povucite prijelom stupca da biste ga premjestili.

Treći korak od 3

Kliknite gumb Dodatno da biste učinite nešto od sljedećeg:

  • Navedite vrstu decimalnih razdjelnika i razdjelnika tisućica koji se koriste u tekstnu datoteku. Kada se podaci uvezu u Excel, razdjelnici će se podudarati s onima koji su navedeni za vaše mjesto u odjeljku Regionalne i jezične mogućnosti ili Regionalna Postavke (Windows upravljačkoj ploči).

  • Navedite da jedna ili više brojčanih vrijednosti može sadržavati znak minus koji se ne može pratiti.

Oblik podataka stupca    Kliknite oblik podataka stupca koji je odabran u odjeljku Pretpregled podataka. Ako ne želite uvesti odabrani stupac, kliknite Ne uvozi stupac (preskoči).

Kada odaberete mogućnost oblika podataka za odabrani stupac, naslov stupca u odjeljku Pretpregled podataka prikazuje oblik. Ako odaberete Datum, u okviru Datum odaberite oblik datuma.

Odaberite oblik podataka koji se usko podudara s podacima pretpregleda da Excel pravilno pretvoriti uvezene podatke. Na primjer:

  • Da biste stupac svih brojeva valute pretvorili u oblik valute Excel, odaberite Općenito.

  • Da biste stupac svih brojeva pretvorili u oblik Excel, odaberite Tekst.

  • Da biste pretvorili stupac svih znakova datuma, svaki datum redoslijedom godine, mjeseca i dana u oblik datuma Excel odaberite Datum,a zatim u okviru Datum odaberite vrstu datuma YMD.

Excel će uvesti stupac kao općenito ako pretvorba može dati neželjene rezultate. Na primjer:

  • Ako stupac sadrži kombinaciju oblika, kao što su abecedni i numerički znakovi, Excel pretvara stupac u Općenito.

  • Ako se u stupcu datuma svaki datum nalazi u redoslijedu godina, mjeseca i datuma, a zatim odaberete Datum zajedno s vrstom datuma MDY, Excel stupac pretvara u opći oblik. Stupac koji sadrži znakove datuma mora se usko podudarati s Excel ugrađenim datumom ili prilagođenim oblicima datuma.

Ako Excel stupac ne pretvori u oblik koji želite, podatke možete pretvoriti nakon uvoza.

Kada odaberete željene mogućnosti, kliknite Završi da biste otvorili dijaloški okvir Uvoz podataka i odabrali mjesto podataka.

Import Data

Postavite te mogućnosti da biste upravljali načinom na koji se postupak uvoza podataka izvodi, uključujući svojstva podatkovne veze koja će se koristiti te koju datoteku i raspon popuniti uvezenim podacima.

  • Mogućnosti u odjeljku Odabir željenog prikaza podataka u radnoj knjizi dostupne su samo ako ste pripremili podatkovni model i odabrali mogućnost dodavanja tog uvoza u taj model (pogledajte treću stavku na popisu).

  • Navedite ciljnu radnu knjigu:

    • Ako odaberete Postojeći radni list, kliknite ćeliju na listu da biste prvu ćeliju uvezenih podataka prvu ćeliju uvezli ili kliknite i povucite da biste odabrali raspon.

    • Odaberite Novi radni list da biste ga uvezli na novi radni list (počevši od ćelije A1)

  • Ako imate podatkovni model na mjestu, kliknite Dodaj te podatke u podatkovni model da biste u model uvrstili taj uvoz. Dodatne informacije potražite u članku Stvaranje podatkovnog modela u programu Excel.

    Imajte na umu da odabirom te mogućnosti otvaraju se mogućnosti u odjeljku Odabir željenog prikaza podataka u radnoj knjizi.

  • Kliknite Svojstva da biste postavili sva svojstva raspona vanjskih podataka koja želite. Dodatne informacije potražite u članku Upravljanje vanjskim rasponima podataka i njihovim svojstvima.

  • Kada budete spremni za uvoz podataka, kliknite U redu.

Napomena: Ako su podaci u dokumentu programa Word, najprije ih morate spremiti kao tekstnu datoteku. Kliknite Datoteka > Spremi kaoi odaberite Običan tekst (.txt) kao vrstu datoteke.

Je li vam potrebna dodatna pomoć?

Uvijek možete postaviti pitanje stručnjaku u tehničkoj zajednici za Excel ili zatražiti podršku u zajednici za odgovore.

Dodatne informacije

Uvod u Microsoft Power Query za Excel

Potrebna vam je dodatna pomoć?

Proširite svoje vještine
Istražite osposobljavanje
Prvi koristite nove značajke
Pridružite se Microsoft Insidere

Jesu li ove informacije bile korisne?

Koliko ste zadovoljni kvalitetom prijevoda?
Što je utjecalo na vaše iskustvo?

Hvala vam na povratnim informacijama!

×