Pomoću dodatka Power Query kombinirajte više datoteka s istom shemom pohranjenom u jednoj mapi u jednu tablicu. Svaki mjesec, primjerice, želite kombinirati radne knjige proračuna iz više odjela, gdje su stupci isti, ali se broj redaka i vrijednosti razlikuje u svakoj radnoj knjizi. Kada ga postavite, možete primijeniti dodatne transformacije kao i kod bilo kojeg pojedinačnog uvezenog izvora podataka, a zatim osvježiti podatke da biste vidjeli rezultate za svaki mjesec.  

Konceptualni pregled kombiniranja datoteka mapa

Napomena    U ovoj se temi pokazuje kako kombinirati datoteke iz mape. Možete i kombinirati datoteke pohranjene u SharePoint pohrani blobova na servisu Azure i pohrani na azure podatkovnom jezeru. Postupak je sličan.

Neka bude jednostavno:

  • Provjerite nalaze li se sve datoteke koje želite kombinirati u namjenska mapa bez dodatnih datoteka. U suprotnom se sve datoteke u mapi i sve podmape koje odaberete uvrste u podatke koje želite kombinirati.

  • Svaka bi datoteka trebala imati istu shemu s dosljednim zaglavljima stupaca, vrstama podataka i brojem stupaca. Stupci se ne moraju nalaziti istim redoslijedom kao i podudaranje prema nazivima stupaca.

  • Ako je moguće, izbjegavajte nepovezane podatkovne objekte za izvore podataka koji mogu imati više podatkovnih objekata, kao što su JSON datoteka, Excel ili baza podataka programa Access.

Svaka od tih datoteka prati jednostavan uzorak, samo jednu tablicu podataka u svakoj datoteci.

  1. Odaberite Data > Get Data > From File >From Folder (Podaci iz mape). Prikazat će se dijaloški okvir Pregled.

  2. Pronađite mapu koja sadrži datoteke koje želite kombinirati.

  3. Popis datoteka u mapi prikazuje se u dijaloškom okviru <mapa> mapa. Provjerite jesu li navedene sve datoteke koje želite.

    Primjer dijaloškog okvira uvoza teksta

  4. Odaberite jednu od naredbi pri dnu dijaloškog okvira, primjerice Kombiniranje> kombiniranje & učita. U odjeljku O svim tim naredbama objašnjene su dodatne naredbe.

  5. Ako odaberete neku naredbu Kombiniranje, prikazat će se dijaloški okvir Kombiniranje datoteka. Da biste promijenili postavke datoteke, odaberite svaku datoteku u okviru Ogledna datoteka, postavite željenu postavkuIzvor datoteke,Graničnik i Otkrivanje vrste podataka. Možete i odabrati ili poništiti potvrdni okvir Preskoči datoteke s pogreškama pri dnu dijaloškog okvira.

  6. Odaberite U redu.

Rezultat

Power Query automatski stvara upite da bi konsolidirao podatke iz svake datoteke u radni list. Stvoreni koraci i stupci upita ovise o tome koju naredbu odaberete. Dodatne informacije potražite u odjeljku O svim tim upitima.

  1. Odaberite Data > Get Data > From File >From Folder (Podaci iz mape). Prikazat će se dijaloški okvir Pregled.

  2. Pronađite mapu koja sadrži datoteke koje želite kombinirati.

  3. Popis datoteka u mapi prikazuje se u dijaloškom okviru <mapa> mapa. Provjerite jesu li navedene sve datoteke koje želite.

  4. Odaberite jednu od naredbi pri dnu dijaloškog okvira, primjerice Kombiniranje > kombiniranje & pretvorbe. U odjeljku O svim tim naredbama objašnjene su dodatne naredbe.

    Prikazat će se uređivač dodatka Power Query.

  5. Stupac Vrijednost strukturirani je stupac Popis. Odaberite ikonu Proširi Ikona za proširivanje stupaca , a zatim Proširi na nove retke. 

    Proširivanje JSON popisa

  6. Stupac Vrijednost sada je strukturirani stupac Zapis. Odaberite ikonu Proširi Ikona za proširivanje stupaca proširivanje. Prikazat će se padajući dijaloški okvir.

    Proširivanje JSON zapisa

  7. Zadržite odabrane sve stupce. Možda želite poništiti potvrdni okvir Koristi izvorni naziv stupca kao prefiks. Odaberite U redu.

  8. Odaberite sve stupce koji sadrže vrijednosti podataka. Odaberite Polazno, strelicu pokraj mogućnosti Ukloni stupce, a zatim Ukloni ostale stupce.

  9. Odaberite Polazno > Zatvori & Učitaj.

Rezultat

Power Query automatski stvara upite da bi konsolidirao podatke iz svake datoteke u radni list. Stvoreni koraci i stupci upita ovise o tome koju naredbu odaberete. Dodatne informacije potražite u odjeljku O svim tim upitima.

Svaki od tih izvora podataka može imati više objekata za uvoz. Radna Excel može imati više radnih listova, Excel tablica ili imenovanih raspona. Baza podataka programa Access može imati više tablica i upita. 

  1. Odaberite Data > Get Data > From File >From Folder (Podaci iz mape). Prikazat će se dijaloški okvir Pregled.

  2. Pronađite mapu koja sadrži datoteke koje želite kombinirati.

  3. Popis datoteka u mapi prikazuje se u dijaloškom okviru <mapa> mapa. Provjerite jesu li navedene sve datoteke koje želite.

  4. Odaberite jednu od naredbi pri dnu dijaloškog okvira, primjerice Kombiniranje> kombiniranje & učita. U odjeljku O svim tim naredbama objašnjene su dodatne naredbe.

  5. U dijaloškom okviru Kombiniranje datoteka:

    • U okviru Ogledna datoteka odaberite datoteku koju želite koristiti kao ogledne podatke koji se koriste za stvaranje upita. Objekt ne možete odabrati ni odabrati samo jedan objekt. No ne možete odabrati više od jednog.

    • Ako imate mnogo objekata, pomoću okvira za pretraživanje pronađite objekt ili mogućnosti prikaza zajedno s gumbom Osvježi da biste filtrirali popis.

    • Potvrdite ili poništite potvrdni okvir Preskoči datoteke s pogreškama pri dnu dijaloškog okvira.

  6. Odaberite U redu.

Rezultat

Power Query automatski stvara upit za konsolidaciju podataka iz svake datoteke u radni list. Stvoreni koraci i stupci upita ovise o tome koju naredbu odaberete. Dodatne informacije potražite u odjeljku O svim tim upitima.

Radi veće fleksibilnosti datoteke u uređivaču dodatka Power Query možete eksplicitno kombinirati pomoću naredbe Kombiniraj datoteke. Recimo da izvorišna mapa sadrži mješavinu vrsta datoteka i podmapa te želite ciljati određene datoteke s istom vrstom datoteke i shemom, ali ne i drugima. To može poboljšati performanse i pojednostavniti vaše transformacije.

  1. Odaberite Data > Get Data > From File > From Folder (> Iz mape). Prikazat će se dijaloški okvir Pregled.

  2. Pronađite mapu koja sadrži datoteke koje želite kombinirati, a zatim odaberite Otvori.

  3. Popis svih datoteka u mapi i podmapama prikazuje se u dijaloškom okviru<mapa> mapa. Provjerite jesu li navedene sve datoteke koje želite.

  4. Pri dnu odaberite Transformiraj podatke. Otvorit će se uređivač dodatka Power Query i prikazati sve datoteke u mapi i svim podmapama.

  5. Da biste odabrali željene datoteke, filtrirajte stupce, kao što su Proširenje ili Put mape.

  6. Da biste kombinirali datoteke u jednu tablicu, odaberite stupac Sadržaj koji sadrži svaki binarni (obično prvi stupac), a zatim Odaberite Polazno > Kombiniraj datoteke. Pojavit će se dijaloški okvir Kombiniranje datoteka.

  7. Power Query po zadanom analizira oglednu datoteku prvu datoteku na popisu da bi se upotrijebio odgovarajući poveznik i identificirao podudarne stupce.

    Da biste za oglednu datoteku koristili drugu datoteku, odaberite je na padajućem popisu Ogledna datoteka.

  8. Ako želite, pri dnu odaberite Preskoči datoteke s pogreškamada biste iz rezultata izuzeli te datoteke.

  9. Odaberite U redu.

Rezultat

Power Query automatski stvara upite za konsolidaciju podataka iz svake datoteke u radni list. Stvoreni koraci i stupci upita ovise o tome koju naredbu odaberete. Dodatne informacije potražite u odjeljku O svim tim upitima.

Možete odabrati nekoliko naredbi, a svaka ima drukčiju svrhu.

  • Kombiniranje i pretvaranje podataka    Da biste kombinirali sve datoteke s upitom, a zatim pokrenuli uređivač dodatka Power Query, odaberite Kombiniraj > Kombiniraj i transformiraj podatke.

  • Kombiniranje i učitavanje   Da biste prikazali dijaloški okvir Ogledna datoteka, stvorite upit, a zatim ga učitajte na radni list, odaberite Kombiniraj> Kombiniraj i učitaj.

  • Kombiniranje i učitavanje u   Da biste prikazali dijaloški okvir Ogledna datoteka, stvorite upit, a zatim prikažite dijaloški okvir Uvoz, odaberite Kombiniraj> Kombiniraj i učitaj u.

  • Učitaj    Da biste stvorili upit jednim korakom, a zatim učitajte na radni list, odaberite Učitaj > Učitaj.

  • Učitaj u   Da biste stvorili upit jednim korakom, a zatim prikazali dijaloški okvir Uvoz, odaberite Učitaj > Učitaj u.

  • Pretvorba podatakaDa biste stvorili upit jednim korakom, a zatim pokrenuli uređivač dodatka Power Query, odaberite Pretvori podatke.

No ako kombinirate datoteke, u oknu Upiti u grupi "Upiti pomagača" stvara se nekoliko upita podrške.

Popis upita stvorenih u oknu Upiti

  • Power Query stvara upit "Ogledna datoteka" na temelju oglednog upita.

  • Upit funkcije "Transform File" koristi upit "Parametar1" za određivanje svake datoteke (ili binarne datoteke) kao ulaz u upit "Ogledna datoteka". Taj upit stvara i stupac Sadržaj koji sadrži sadržaj datoteke i automatski proširuje strukturirani stupac Zapis da bi se podaci stupca dodali u rezultate. Upiti "Pretvorba datoteke" i "Ogledna datoteka" povezani su tako da se promjene upita "Ogledna datoteka" odražavaju u upitu "Pretvorba datoteke".

  • Upit koji sadrži konačne rezultate nalazi se u grupi "Ostali upiti". Po zadanom se zove po mapi iz koje ste uvezli datoteke.

Da biste dodatno provjerili, desnom tipkom miša kliknite svaki upit i odaberite Uredi da biste pregledali svaki korak upita i vidjeli kako upiti funkcioniraju na koncertu.

Da biste pokrenuli postupak kombiniranja više datoteka, najprije provjerite nalaze li se sve datoteke koje želite kombinirati u jednoj mapi datoteka.

Napomena: Excel, Tekst, CSV, JSON, XML i Access datoteke su podržane.

  1. Kliknite karticu Power Query, a zatim Iz datoteke > Iz mape.

    Mogućnosti dodatka Power Query > iz > iz mape
  2. Kliknite gumb Pregledaj da biste pronašli mapu.

    Prikazat će se popis datoteka u mapi. Odaberite mogućnost Uređivanje da biste otvorili uređivač upita. U tom smo slučaju učitali 4 Excel radnih knjiga.

    Dijaloški okvir Kombiniranje binarne datoteke s datotekama za kombiniranje
  3. Kada provjerite jesu li navedene sve datoteke koje želite, kliknite gumb Kombiniraj binarne datoteke iz stupca Sadržaj.

    Pritisnite gumb Kombiniraj binarne datoteke iz stupca Sadržaj upita ili iz odjeljka Kombiniranje na vrpci dodatka Power Query
  4. Analizira se svaka datoteka, a određuje se odgovarajući oblik datoteke, kao što su tekst, Excelili JSON. U tom se slučaju prikazuje popis radnih listova iz prve Excel radne knjige. Odaberite radni list koji želite koristiti, a zatim kliknite U redu.

    Dijaloški okvir Kombiniranje binarnih podataka s prikazom dostupnih Excel radnih listova da biste odabrali primarni cilj konsolidacije
  5. Postupak pretvaranja binarnih datoteka automatski će stvoriti upit za konsolidaciju podataka iz svake datoteke i prikaz pretpregleda. Ako ste zadovoljni ishodom, kliknite Zatvori & učitaj.

    Dijaloški okvir Kombiniranje pretpregleda binarnih podataka. Pritisnite Zatvori & učitaj da biste prihvatili rezultate i uvezli ih u Excel.

    Postupak kombiniranja binarnih podataka zatim će konsolidirati navedene radne listove u jedan radni list.

  6. Ako se izvorne podatkovne datoteke promijene, uvijek možete osvježiti uvezene podatke. Kliknite bilo gdje unutar raspona podataka, a zatim idite na Alati za upite > Osvježi. Osim toga, možete jednostavno primijeniti dodatne korake pretvorbe ili izdvajanja izmjenom automatski stvorenog primjernog upita, a da ne morate brinuti o izmjeni ili stvaranju dodatnih koraka upita funkcije; sve promjene primjernog upita automatski se generiraju u upitu s povezanom funkcijom.

Poznati problemi

Prilikom učitavanja postupka kombiniranja binarnih poruka Excel možda ćete vidjeti sljedeću poruku o pogrešci:

Poruka o pogrešci Kombiniraj binarne datoteke. To je poznata pogreška koja se rješava.

Ako odbacite pogreške klikom na U redu,postupak kombiniranja binarnih datoteka dovršit će i pravilno učitati podatke unatoč pogrešci. Radimo na ispravljanju pogreške.

Vidi također

Power Query za Excel pomoć

Dodavanje upita

Kombiniranje pregleda datoteka (docs.com)

Kombiniranje CSV datoteka u dodatku Power Query (docs.com)

Potrebna vam je dodatna pomoć?

Proširite svoje vještine
Istražite osposobljavanje
Prvi koristite nove značajke
Pridružite se Microsoft Insidere

Jesu li ove informacije bile korisne?

Koliko ste zadovoljni kvalitetom prijevoda?
Što je utjecalo na vaše iskustvo?

Hvala vam na povratnim informacijama!

×