A feltételek igaz vagy hamis állapotának tesztelése és a kifejezések közötti logikai összehasonlítások sok feladatban gyakoriak. Feltételes képletek létrehozásához használhatja az ÉS, a VAGY, a NEM és a HA függvényt.

A HA függvény például az alábbi argumentumokat használja.

képlet a HA függvénnyel

A HA függvényt használó képlet

Gomb képe logical_test: Az ellenőrizni kívánt feltétel.

2. ábrafelirat value_if_true: A visszaadandó érték, ha a feltétel Igaz.

Gombkép value_if_false: A visszaadandó érték, ha a feltétel Hamis.

További információ a képletek létrehozásáról: Képlet létrehozása vagy törlése.

Kapcsolódó műveletek

Logikai értéket eredményező feltételes képlet létrehozása (IGAZ vagy HAMIS)

Ehhez használja az AND, a VAGY és a NOT függvényt és az operátorokat az alábbi példában látható módon.

Példa

A példa könnyebben megérthető, ha üres munkalapra másolja.

Példa másolása

  1. Jelölje ki a cikkben szereplő példát.

    példa választása a Windows Excel 2013 súgójából

    Példa kijelölése a súgóban

  2. Nyomja le a CTRL+C billentyűkombinációt.

  3. Az Excelben hozzon létre egy üres munkafüzetet vagy munkalapot.

  4. A munkalapon jelölje ki az A1 cellát, és nyomja le a CTRL+V billentyűkombinációt.

Fontos: A példa akkor működik megfelelően, ha a munkalap A1 cellájába illeszti be.

  1. Az eredmények és az azokat eredményező képletek megjelenítése közötti váltáshoz nyomja le a CTRL+` (fordított ékezet) billentyűkombinációt, vagy kattintson a Képletek lap Képletvizsgálat csoportjának Képletek megjelenítése gombjára.

Miután a példát egy üres munkalapra másolta, módosíthatja azt igényeinek megfelelően.

Adatok

15

9

8

Lánckerékkel

Kütyü

Képlet

Leírás (eredmény)

=ÉS(A2>A3; A2<A4)

Meghatározza, hogy az A2 cellában lévő érték nagyobb-e az A3 cellában lévő értéknél, és azt is, hogy az A2 cellában lévő érték kisebb-e, mint az A4 cellában lévő érték. (HAMIS)

=VAGY(A2>A3; A2<A4)

Meghatározza, hogy az A2 cellában lévő érték nagyobb-e az A3 cellában lévő értéknél, vagy az A2 cellában lévő érték kisebb-e, mint az A4 cellában lévő érték. (IGAZ)

=NEM(A2+A3=24)

Azt határozza meg, hogy az A2 és az A3 cella értékeinek összege nem egyenlő-e 24-nel. (HAMIS)

=NEM(A5="Lánckerék")

Azt határozza meg, hogy az A5 cellában lévő érték nem egyenlő-e a "Lánckerék" értékkel. (HAMIS)

=VAGY(A5<>"Sprockets";A6 = "Widgets")

Meghatározza, hogy az A5 cellában lévő érték nem egyenlő-e a "Sprockets" értékkel, vagy az A6 cellában lévő érték egyenlő-e a "Widgetekkel". (IGAZ)

További információ a függvények használatáról: AND függvény, OR függvény és NOT függvény.

Vissza a lap tetejére

Olyan feltételes képlet létrehozása, amely más számítást eredményez, vagy nem IGAZ vagy HAMIS értéket ad meg

A feladat végrehajtásához használja a HA, AZ és és a VAGY függvényt és az operátorokat az alábbi példában látható módon.

Példa

A példa könnyebben megérthető, ha üres munkalapra másolja.

Példa másolása

  1. Jelölje ki a cikkben szereplő példát.

    Fontos: A sor- és oszlopazonosítókat ne vegye bele a kijelölésbe.

    példa választása a Windows Excel 2013 súgójából

    Példa kijelölése a súgóban

  2. Nyomja le a CTRL+C billentyűkombinációt.

  3. Az Excelben hozzon létre egy üres munkafüzetet vagy munkalapot.

  4. A munkalapon jelölje ki az A1 cellát, és nyomja le a CTRL+V billentyűkombinációt.

Fontos: A példa akkor működik megfelelően, ha a munkalap A1 cellájába illeszti be.

  1. Az eredmények és az azokat eredményező képletek megjelenítése közötti váltáshoz nyomja le a CTRL+` (fordított ékezet) billentyűkombinációt, vagy kattintson a Képletek lap Képletvizsgálat csoportjának Képletek megjelenítése gombjára.

Miután a példát egy üres munkalapra másolta, módosíthatja azt igényeinek megfelelően.

Adatok

15

9

8

Lánckerékkel

Kütyü

Képlet

Leírás (eredmény)

=HA(A2=15; "OK"; "Nem OK")

Ha az A2 cellában lévő érték 15, akkor az "OK" értéket adja vissza. Ellenkező esetben a "Nem OK" értéket adja vissza. (OK)

=HA(A2<>15; "OK"; "Nem OK")

Ha az A2 cellában lévő érték nem egyenlő 15-rel, akkor az "OK" értéket adja vissza. Ellenkező esetben a "Nem OK" értéket adja vissza. (Nem OK)

=HA(NEM(A2<=15), "OK", "Nem OK")

Ha az A2 cellában lévő érték nem kisebb, mint 15, akkor az "OK" értéket adja vissza. Ellenkező esetben a "Nem OK" értéket adja vissza. (Nem OK)

=HA(A5<>"SPROCKETS"; "OK"; "Nem OK")

Ha az A5 cellában lévő érték nem egyenlő az "SPROCKETS" értékkel, akkor az "OK" értéket adja vissza. Ellenkező esetben a "Nem OK" értéket adja vissza. (Nem OK)

=HA(ÉS(A2>A3; A2<A4), "OK", "Nem OK")

Ha az A2 cellában lévő érték nagyobb, mint az A3 cellában lévő érték, és az A2 cellában lévő érték szintén kisebb, mint az A4 cellában lévő érték, akkor az "OK" értéket adja vissza. Ellenkező esetben a "Nem OK" értéket adja vissza. (Nem OK)

=HA(ÉS(A2<>A3; A2<>A4), "OK", "Nem OK")

Ha az A2 cellában lévő érték nem egyenlő az A3 cellával, és az A2 cellában lévő érték szintén nem egyenlő az A4 cellában lévő értékkel, akkor az "OK" értéket adja vissza. Ellenkező esetben a "Nem OK" értéket adja vissza. (OK)

=HA(VAGY(A2>A3; A2<A4), "OK"; "Nem OK")

Ha az A2 cellában lévő érték nagyobb, mint az A3 cellában lévő érték, vagy az A2 cellában lévő érték kisebb, mint az A4 cellában lévő érték, akkor az "OK" értéket adja vissza. Ellenkező esetben a "Nem OK" értéket adja vissza. (OK)

=HA(VAGY(A5<>"Sprockets", A6<>"Widgets"), "OK", "Not OK")

Ha az A5 cellában lévő érték nem egyenlő a "Sprockets" értékkel, vagy az A6 cellában lévő érték nem egyenlő a "Widgetek" értékkel, akkor az "OK" értéket adja vissza. Ellenkező esetben a "Nem OK" értéket adja vissza. (Nem OK)

=HA(VAGY(A2<>A3; A2<>A4), "OK"; "Nem OK")

Ha az A2 cellában lévő érték nem egyenlő az A3 cellában lévő értékkel, vagy az A2 cellában lévő érték nem egyenlő az A4 cellában lévő értékkel, akkor az "OK" értéket adja vissza. Ellenkező esetben a "Nem OK" értéket adja vissza. (OK)

A függvények használatáról további információt a HA függvény, AZ ÉS és a VAGY függvény című témakörben talál.

Vissza a lap tetejére

További segítségre van szüksége?

Ismeretek bővítése
Oktatóanyagok megismerése
Új szolgáltatások listájának lekérése
Csatlakozás Microsoft Office Insiderekhez

Hasznos volt az információ?

Mennyire elégedett a fordítás minőségével?
Mi befolyásolta a felhasználói élményét?

Köszönjük a visszajelzését!

×