A Wordben makrók létrehozásával és futtatásával automatizálhatja a gyakran használt feladatokat. A makró parancsok és utasítások sorozata, amelyek egyetlen parancsként csoportosítva automatikusan elvégeznek egy feladatot.

A gyakran használt feladatokon időt takaríthat meg, ha a lépéseket egy makróba kötege. Először rögzítse a makrót. Ezután a makrót a gyorselérési eszköztár egyik gombjára kattintva vagy billentyűkombinációk lenyomásával futtathatja. A beállításától függ.

  1. Kattintson a Nézet > Makrók > Makró rögzítése parancsra.

    A Makró rögzítése parancs

  2. Adja meg az új makró nevét.

    Makrónév mező

  3. Ha a makrót minden új dokumentumban használni szeretné, az Elérhetőség mezőben a Minden dokumentum (Normal.dotm) lehetőség legyen kiválasztva.

    A makró rögzítési helyének kiválasztására szolgáló mező.

  4. Ha a makrót egy gombra kattintva szeretné futtatni, kattintson a Gomb gombra.

    Kattintás a makró gombhoz történő hozzárendeléséhez

  5. Kattintson az új makróra (az elnevezése valami ilyesmi lesz: Normal.NewMacros.<az Ön makróneve>), majd a Felvétel gombra.

    A makró és a Felvétel gomb

  6. Kattintson a Módosítás gombra.

    A gyorselérési eszköztár testreszabása panel Módosítás gombja

  7. Válasszon gombképet, írja be a nevet, és kattintson az OK gombra, majd újból arra.

    Gombképek a Gomb módosítása párbeszédpanelen

  8. Következhet a lépések rögzítése. Kattintson a feladat egyes lépéseinek megfelelő parancsokra, vagy nyomja le a billentyűket. A Word rögzíti a kattintásokat és a leütéseket.

    Megjegyzés: A makró rögzítése közben történő szövegkijelöléshez a billentyűzetet használja. A makrók nem rögzítik az egérrel végzett kijelölést.

  9. A rögzítés leállításához kattintson a Nézet > Makrók > Rögzítés vége parancsra.

    A Rögzítés vége parancs

A makróhoz rendelt új gomb megjelenik a gyorselérési eszköztárban.

A makró gombja a gyorselérési eszköztárban.

A makró futtatásához kattintson a gombra.

  1. Kattintson a Nézet > Makrók > Makró rögzítése parancsra.

    A Makró rögzítése parancs

  2. Adja meg az új makró nevét.

    Makrónév mező

  3. Ha a makrót minden új dokumentumban használni szeretné, az Elérhetőség mezőben a Minden dokumentum (Normal.dotm) lehetőség legyen kiválasztva.

    A makró rögzítési helyének kiválasztására szolgáló mező.

  4. Ha a makrót egy billentyűparancs lenyomásával szeretné futtatni, kattintson a Billentyűzet elemre.

    Kattintás a makró billentyűparancshoz történő hozzárendeléséhez

  5. Adja meg a billentyűkombinációt az Új billentyűparancs mezőben.

  6. Ellenőrizze, hogy a megadott billentyűkombináció hozzá van-e rendelve már valami máshoz. Ha igen, próbálkozzon egy másik kombinációval.

  7. Ha a billentyűparancsot minden új dokumentumban használni szeretné, a Módosítás mentése mezőben a Normal.dotm lehetőség legyen kiválasztva.

  8. Kattintson a Hozzárendel gombra.

  9. Következhet a lépések rögzítése. Kattintson a feladat egyes lépéseinek megfelelő parancsokra, vagy nyomja le a billentyűket. A Word rögzíti a kattintásokat és a leütéseket.

    Megjegyzés: A makró rögzítése közben történő szövegkijelöléshez a billentyűzetet használja. A makrók nem rögzítik az egérrel végzett kijelölést.

  10. A rögzítés leállításához kattintson a Nézet > Makrók > Rögzítés vége parancsra.

    A Rögzítés vége parancs

A makró futtatásához nyomja le a billentyűparancs billentyűit.

Makró futtatásához kattintson a gombra a gyorselérési eszköztáron, vagy nyomja le a hozzá tartozó billentyűparancsot. A makrót a Makrók listából is futtathatja.

  1. Kattintson a Nézet > Makrók > Makrók megjelenítése parancsra.

    A Makrók megjelenítése parancs

  2. A Makrónév mezőben látható listában kattintson a futtatni kívánt makróra.

  3. Kattintson az Indítás gombra.

Ha a dokumentumban egy olyan makrót szeretne készíteni, amelyet az összes új dokumentumban használni tud, adja hozzá a Normal.dotm sablonhoz.

  1. Nyissa meg a makrót tartalmazó dokumentumot.

  2. Kattintson a Nézet > Makrók > Makrók megjelenítése parancsra.

    A Makrók megjelenítése parancs

  3. Kattintson a Szervező gombra.

    A Szervező gomb a Makrók megjelenítése párbeszédpanelen

  4. Kattintson a Normal.dotm sablonhoz hozzáadandó makróra, és kattintson a Másolás gombra.

  1. Kattintson a Fájl > Beállítások > Menüszalag testreszabása kategóriára.

  2. A Választható parancsok helye listában válassza a Makrók listaelemet.

  3. Kattintson a kívánt makróra.

  4. A Menüszalag testreszabása csoportban kattintson arra a lapra és egyéni csoportra, amelyhez a makrót hozzá szeretné adni.

Ha még nem hozott létre egyéni csoportot, kattintson az Új csoport gombra. Ezután kattintson az Átnevezés gombra, és adjon nevet az egyéni csoportnak.

  1. Kattintson a Hozzáadás gombra.

  2. Az Átnevezés gombra kattintva kiválaszthatja a makró képét és adhat neki egy tetszőleges nevet.

  3. Kattintson mindkétszer a megjelenő OK gombra.

  1. A Fejlesztőeszközök lap Kód csoportjában kattintson a Makrók gombra.

  2. A Makrónév mezőbe írja be a makró nevét.

    Megjegyzés: Ha egy új makrónak ugyanazt a nevet adja, mint a Word beépített makrója, az új makróműveletek felülírják a beépített makrót. A beépített makrók listájának megtekintéséhez kattintson a Word-parancsok elemre a Makrók a listában.

  3. A Makrók a következőben listában kattintson arra a sablonra vagy dokumentumra, amelyben a makrót tárolni szeretné.

    Ha a makrót az összes dokumentumban elérhetővé tenni, kattintson a Normal.dotm gombra.

  4. A Létrehozás gombra kattintva nyissa meg a Visual Basic Editort.

A Visual Basic Editor megnyitása után további információra lehet szükség a Visual Basic for Applications használatával kapcsolatban. További információért kattintson a Súgó menü Microsoft Visual Basic Helpparancsára, vagy nyomja le az F1 billentyűt.

Rögzíthet műveletek sorozatát, vagy egy új makrót is írhat, ha visual basic for Applications-kódot ad meg a Visual Basic Editor.

Megjegyzés: Ha a makrókat a Office Word 2007, meg kell mutatnia a Fejlesztőeszközök lapot.

  1. Kattintson a Microsoft Office gombra Gombkép, majd A Word beállításai parancsra.

  2. Kattintson a Népszerű elemek lehetőségre.

  3. A Legnépszerűbb beállítások a Word alkalmazáshoz csoportbanjelölje be a Fejlesztőeszközök lap megjelenítése a szalagon jelölőnégyzetet.

    Megjegyzés: A menüszalag a Microsoft Office Fluent felhasználói felület része.

  1. Kattintson a Fejlesztőeszközök lap Kód csoportjában a Makró rögzítése gombra.

    A Fejlesztőeszközök lap Kód csoportja
  2. A Makrónév mezőbe írja be a makró nevét.

    Megjegyzés: Ha egy új makrónak ugyanazt a nevet adja, mint a makrók beépített Office Word 2007, az új makróműveletek felülírják a beépített makrót. A beépített makrók listájának megtekintéséhez kattintson a Fejlesztőeszközök lap Kód csoportjában aMakrók gombra. A Makrók a következőben listában kattintson a Word-parancsok elemre.

  3. A Makró tárolása a következőben listában kattintson arra a sablon dokumentumra, amelyben a makrót tárolni szeretné.

    Fontos: Ha a makrót az összes dokumentumban elérhetővé tenni, kattintson a Normal.dotm gombra.

  4. A Leírás mezőben adja meg a makró leírását.

  5. Hajtsa végre a megfelelő műveletet:

    • Felvétel megkezdése    Ha anélkül szeretne megkezdeni a makró rögzítését, hogy hozzá lenne rendelve a gyorselérési eszköztár egyik gombjához vagy egy billentyűparancshoz, kattintson az OK gombra.

    • Gomb létrehozása    Ha a makrót hozzá szeretne rendelni egy gombhoz a gyorselérési eszköztáron, tegye a következőket:

      1. Kattintson a Gomb gombra.

      2. A Gyorselérési eszköztártestreszabása alatt válassza ki azt a dokumentumot (vagy az összes dokumentumot), amelyhez hozzá szeretné adni a makrót a gyorselérési eszköztárhoz.

        Fontos: Ha a makrót az összes dokumentumban elérhetővé tenni, kattintson a Normal.dotm gombra.

      3. A Choose commands from dialog box (Parancsok kiválasztása a párbeszédpanelről) párbeszédpanelen kattintson a rögzített makróra, majd a Hozzáadás gombra.

      4. A gomb testreszabásához kattintson a Módosítás gombra.

      5. A Szimbólumalatt kattintson a gombhoz használni kívánt szimbólumra.

      6. A Megjelenítendő név mezőbe írja be a megjeleníteni kívánt makrónevet.

      7. Kattintson kétszer az OK gombra a makró rögzítésének megkezdéséhez.

        A választott szimbólum megjelenik a gyorselérési eszköztáron. A beírt név akkor jelenik meg, amikor a szimbólumra mutat.

    • Billentyűparancs hozzárendelése    A makró billentyűparancshoz való hozzárendeléshez tegye a következőket:

      1. Kattintson a Billentyűzet elemre.

      2. A Parancsok mezőben kattintson a rögzített makróra.

      3. Az Új billentyűparancs mezőbe írja be a kívánt billentyűsorozatot, majd kattintson a Hozzárendelés gombra.

      4. Kattintson a Bezárás gombra a makró rögzítésének megkezdéséhez.

  6. Végezze el a makróban szerepeletni kívánt műveleteket.

    Megjegyzés: Makró rögzítésekor az egérrel is kattinthat a parancsokra és a beállításokra, de nem jelölhet ki szöveget. Szöveg kijelöléséhez a billentyűzetet kell használnia. A szöveg billentyűzettel való kijelöléséről további információt a Szöveg kijelölése.

  7. Ha le kell állítania a műveletek rögzítését, kattintson a Rögzítés vége gombra a Kód csoportban.

Makró billentyűparancsának módosítása

  1. Kattintson a Microsoft Office gombra Gombkép, majd A Word beállításai parancsra.

  2. Kattintson a Testreszabás elemre.

  3. A Billentyűparancsokmellett kattintson a Testreszabás elemre.

  4. A Kategóriák listában kattintson a Makrók elemre.

  5. A Makrók listában kattintson a módosítani kívánt makróra.

  6. A Nyomja le az új billentyűparancsot mezőbe írja be a kívánt kombinációt.

  7. Jelölje be a Jelenlegi billentyűk jelölőnégyzetet, hogy biztosan ne rendeljen hozzá olyan billentyűkombinációt, amely már másik feladat végrehajtásához szükséges.

  8. A Módosítások mentése listában kattintson arra a beállításra, amely megfelel annak a helynek, ahol futtatni szeretné a makrót.

    Fontos: Ha a makrót az összes dokumentumban elérhetővé tenni, kattintson a Normal.dotm gombra.

  9. Kattintson a Bezárás gombra.

  1. A Fejlesztőeszközök lap Kód csoportjában kattintson a Makrók gombra.

    A Fejlesztőeszközök lap Kód csoportja

  2. A Makrónév listában kattintsona futtatni kívánt makróra.

  3. Kattintson az Indítás gombra.

  1. A Fejlesztőeszközök lap Kód csoportjában kattintson a Makrók gombra.

    A Fejlesztőeszközök lap Kód csoportja

  2. A Makrónév mezőbe írja be a makró nevét.

    Megjegyzés: Ha egy új makrónak ugyanazt a nevet adja, mint a makrók beépített Office Word 2007, az új makróműveletek felülírják a beépített makrót. A beépített makrók listájának megtekintéséhez kattintson a Word-parancsok elemre a Makrók a listában.

  3. A Makrók a következőben listában kattintson sablon vagy dokumentumra, amelyben tárolni szeretné a makrót.

    Ha a makrót az összes dokumentumban elérhetővé tenni, kattintson a Normal.dotm gombra.

  4. A Létrehozás gombra kattintva nyissa meg a Visual Basic Editort.

A Visual Basic Editor megnyitása után további információra lehet szükség a Visual Basic for Applications használatával kapcsolatban. További információért kattintson a Súgó menü Microsoft Visual Basic Helpparancsára, vagy nyomja le az F1 billentyűt.

A gyakran futtatott feladatok gyors végrehajtása érdekében a Word asztali verziójában a lépéseket makrókba kötegheti, amelyek egyetlen kattintással futtathatók. A Webes Word manuálisan kell végiglépkedni az ilyen feladatokon.

Ha van Wordje, először kattintson a Megnyitás a Wordben gombra a dokumentum Wordben való megnyitásához.

A Megnyitás asztali alkalmazásban parancs képe

Ezután kövesse a Word asztali verziójára vonatkozó utasításokat.

Amikor futtatja a makrót a Wordben, és menti a dokumentumot, látni fogja a makró eredményét, amikor újra megnyitja a dokumentumot a Webes Word.

További segítségre van szüksége?

Ismeretek bővítése
Oktatóanyagok megismerése
Új szolgáltatások listájának lekérése
Csatlakozás Microsoft Office Insiderekhez

Hasznos volt az információ?

Mennyire elégedett a fordítás minőségével?
Mi befolyásolta a felhasználói élményét?

Köszönjük a visszajelzését!

×