Jelenségek
Bizonyos Microsoft Outlook-ügyfélalkalmazások csatlakozási problémákat tapasztalnak, amikor számos, nyilvános mappában lévő Microsoft Exchange RPC ügyfélelérési szolgáltatáslánc az Elérhetőség szolgáltatás válaszait várja. Ez a probléma például akkor fordul elő, ha több mint 500 szál várakozik a válaszokra egy nyilvános mappában.
Megjegyzések
-
Nincs lehetőség az Elérhetőség szolgáltatás letiltására Exchange Server 2010 Service Pack (SP1) szervizcsomagot futtató kiszolgálón.
-
Ha újraindítja az Exchange RPC ügyfélelérési szolgáltatást az Exchange Server 2010 SP1 nyilvános mappakiszolgálón, a probléma átmenetileg megoldódik.
A probléma oka
Ez a probléma az Exchange Server 2010 SP1 új szolgáltatása miatt fordul elő. Ez az új funkció a Microsoft Exchange RPC Ügyfélelérési szolgáltatást használja proxyként az Elérhetőség szolgáltatás korábbi verzióihoz (elfoglaltsági adatok). Ezért ha egy Exchange Server 2010 SP1-kiszolgálón nyilvános mappa van telepítve, a Microsoft Exchange RPC Ügyfélelérési szolgáltatás elfogja a foglaltsági adatok kérését.
Megoldás
A probléma megoldásához használja az alábbi módszerek egyikét.
1. módszer
Frissítse az összes ügyfélprogramot az Outlook 2007-es vagy újabb verziójára, amely az Exchange Web Services (EWS) szolgáltatást használja, és így közvetlenül az Exchange Ügyfélelérési kiszolgálóra kezdeményezi az elérhetőségi szolgáltatási hívásokat.
2. módszer
Telepítse a következő frissítést a nyilvános mappaadatbázist üzemeltető Exchange Server 2010 SP1 postaláda-kiszolgálókon:
2497453 JAVÍTÁS: Előfordulhat, hogy az alkalmazás nem válaszol több HTTP-kérés megszakítása után, ha a HttpWebRequest osztály használatával küld kérelmeket a .NET-keretrendszerben
3. módszer
Fontos: Ez a szakasz, metódus vagy feladat a beállításjegyzék módosításának lépéseit tartalmazza. A beállításjegyzék helytelen módosítása azonban komoly problémákhoz vezethet. Ezért ügyeljen arra, hogy gondosan kövesse ezeket a lépéseket. A további védelem érdekében a módosítás előtt biztonsági gombra kell módosítania a beállításjegyzéket. Ezután probléma esetén visszaállíthatja a beállításjegyzéket. A beállításjegyzék biztonsági mentésével és visszaállításával kapcsolatos további információkért kattintson a következő cikkszámra a Microsoft Tudásbázisban található cikk megtekintéséhez:
322756 A beállításjegyzék biztonsági mentésének és visszaállításának módja a Windowsban – Figyelmeztetés: Az alábbi problémák léphetnek
fel, ha ezt a módszert alkalmazza:
-
Az Office 365-ben és a helyszíni Exchange Server hibrid telepítésében, illetve az összevont szervezetekben a régi ügyfélprogramokat, például a Microsoft Office Outlook 2007-et vagy a Microsoft Office Outlook 2003-ot, a továbbiakban nem kap szabad/foglalt adatokat a felhőwebhelyről vagy a távoli szervezettől.
-
A legújabb elfoglaltsági adatokat nem jelenti a rendszer a régi ügyféladatokról. Az adatok legfeljebb 15 percre elavultak.
A probléma megoldásához kövesse az alábbi lépéseket a nyilvános mappaadatbázist üzemeltető postaláda-kiszolgálón:
-
Az alábbi cikkszámra kattintva a Microsoft Tudásbázisban olvashatja el a cikket, majd telepítheti a cikkben ismertetett frissítésösszesítőt:
2579150 Az Exchange Server 2010 Service Pack 1 szervizcsomag 4. frissítésének leírása
-
Tiltsa le az elérhetőségi szolgáltatást.
Ha azt szeretné, hogy a 2579150-es frissítés telepítése után letiltsuk Önnek az elérhetőségi szolgáltatást, a "Javítás". Ha inkább saját maga szeretné letiltani az Elérhetőség szolgáltatást, akkor a "Haddjavítsam ki"című szakaszt.Javítás a következőre: Az Elérhetőség szolgáltatás automatikus letiltásához kattintson a Javítás gombra vagy hivatkozásra. Ezután kattintson a Fájl letöltése párbeszédpanel Futtatás gombjára, és kövesse a Fix it varázsló lépéseit.
Megjegyzések-
Előfordulhat, hogy a varázsló csak angol nyelven érhető el. Az automatikus javítás ugyanakkor a Windows többi nyelvi verziójával is működik.
-
Ha nem a problémát tartalmazó számítógépen van, mentse a Fix it megoldást egy flash meghajtóra vagy CD-re, majd futtassa a problémát tartalmazó számítógépen.
Ezután a"Megoldott ez a probléma?" szakaszhoz.A frissítés telepítése után az alábbi lépésekkel tiltsa le az elérhetőségi szolgáltatást:
-
Kattintson a Start gombra,írja be a regedit parancsot a Start keresőmezőbe, majd kattintson a regedit.exe.
-
Keresse meg a következő beállításkulcsot, és kattintson rá:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeRPC\
-
A Szerkesztés menüben mutasson az Újelemre, majd kattintson a Kulcs elemre.
-
Írja be a ParametersSystem parancsot, majd nyomja le az Enter billentyűt.
-
Keresse meg a következő beállításkulcsot, és kattintson rá:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeRPC\ParametersSystem
-
A Szerkesztés menüben mutasson az Újelemre, majd kattintson a Duplaszó parancsra.
-
Írja be a DisableAvailabilityServiceCalls parancsot, és nyomja le az Enter billentyűt.
-
A részletek ablaktáblában kattintson a jobb gombbal a DisableAvailabilityServiceCallselemre, és válassza a Modify (Módosítás) lehetőséget.
-
Az Érték mezőbe írja be az 1 értéket, majd kattintson az OK gombra.
-
Zárja be a Beállításszerkesztőt.
-
Megoldódott a probléma?
-
Ellenőrizze, hogy megoldódott-e a probléma. Ha a probléma megoldódott, nem kell továbbolvasnia ezt a szakaszt. Ha a probléma továbbra is fennáll, lépjen kapcsolatba a támogatási szolgálattal.
-
Nagyra értékeljük a visszajelzését. Ha visszajelzést szeretne küldeni, vagy bármilyen problémát szeretne jelenteni ezzel a megoldással kapcsolatban, kérjük, írjon egy megjegyzést a "Javítás" bloghoz, vagy küldjön nekünk e-mailt.
Állapot
A Microsoft megerősítette, hogy ez a probléma „A következőkre vonatkozik:” részben felsorolt Microsoft-termékekre vonatkozik.
További információ
Az elérhetőségi szolgáltatásról a Microsoft TechNet alábbi webhelyén talál további információt: