Jika Anda sebelumnya membuat Peta XML,Anda bisa menggunakannya untuk mengimpor data XML ke dalam sel yang dipetakan, tetapi juga ada beberapa metode dan perintah untuk mengimpor data XML tanpa Peta XML.

Jika Anda memiliki Peta XML, lakukan ini untuk mengimpor data XML ke dalam sel yang dipetakan:

  1. Di Peta XML, pilih salah satu sel yang dipetakan.

  2. Klik Pengembang > Impor.

    Jika Anda tidak melihat tab Pengembang, lihat Memperlihatkan tab Pengembang.

  3. Dalam kotak dialog Impor XML, temukan dan pilih file data XML (.xml) yang ingin Anda impor, dan klik Impor.

Cara lain untuk mengimpor data XML

Untuk informasi selengkapnya tentang masalah, lihat Masalah umum dalam mengimpor data XML di akhir artikel ini.

Mengimpor file data XML sebagai tabel XML

  1. Klik Pengembang > Impor.

    Jika Anda tidak melihat tab Pengembang, lihat Memperlihatkan tab Pengembang.

  2. Dalam kotak dialog Impor XML, temukan dan pilih file data XML (.xml) yang ingin Anda impor, dan klik Impor.

    Jika file data XML tidak merujuk ke skema, Excel akan menyimpulkan skema dari file data XML.

  3. Dalam kotak dialog Impor Data, lakukan salah satu hal berikut:

    1. Pilih tabel XML dalam lembar kerja yang sudah ada untuk mengimpor konten file data XML ke dalam tabel XML di lembar kerja Anda di lokasi sel yang ditentukan.

    2. Pilih tabel XML di lembar kerja baru untuk mengimpor konten file ke dalam tabel XML di lembar kerja baru yang dimulai dari sel A1. Skema file data XML ditampilkan di panel tugas Sumber XML.

  4. Jika file data XML tidak merujuk ke skema, Excel akan menyimpulkan skema dari file data XML.

  5. Untuk mengontrol perilaku data XML (seperti pengikatan data, format, dan tata letak), klik Properti,yang menampilkan kotak dialog properti Peta XML. Misalnya, data yang sudah ada dalam rentang yang dipetakan akan ditimpa saat Anda mengimpor data secara default, tapi Anda bisa mengubahnya.

Mengimpor beberapa file data XML

  1. Pilih sel yang dipetakan untuk mengimpor beberapa file XML ke dalam satu set sel yang dipetakan.

    Jika Anda ingin mengimpor beberapa file XML ke dalam beberapa set sel yang dipetakan, klik sel di mana saja pada lembar kerja yang tidak dipetakan.

  2. Klik Pengembang > Impor.

    Jika Anda tidak melihat tab Pengembang, lihat Memperlihatkan tab Pengembang.

  3. Dalam kotak dialog Impor XML, temukan dan pilih file data XML (.xml) yang ingin Anda impor.

    • Jika file bersebelahan, tekan Shift, dan klik file pertama dan terakhir dalam daftar. Semua data dari file XML akan diimpor dan ditambahkan ke sel yang dipetakan.

    • Jika file tidak bersebelahan, tekan dan tahan Ctrl, dan klik setiap file yang ingin Anda impor dalam daftar.

  4. Klik Impor.

    Jika Anda memilih file yang tidak bersebelahan, kotak dialog <file>.xml akan muncul. Pilih Peta XML yang sesuai dengan file data XML yang Anda impor untuk setiap file.

    Untuk menggunakan peta tunggal untuk semua file yang dipilih yang belum diimpor, pilih Gunakan Peta XML ini untuk semua file yang dipilih dari skema ini.

Mengimpor beberapa file data XML sebagai data eksternal

Untuk mengimpor beberapa file XML yang menggunakan ruang nama yang sama namun skema XML yang berbeda, Anda bisa menggunakan perintah Dari Impor Data XML. Excel membuat Peta XML unik untuk setiap file data XML yang Anda impor.

Catatan: Jika Anda mengimpor beberapa file XML yang tidak menentukan ruang nama, file XML ini akan diperlakukan seperti menggunakan ruang nama yang sama.

  1. Jika Anda menggunakan Excel dengan langgananMicrosoft 365 , klik Data > Dapatkan Data > Dari File > Dari XML.

    Jika Anda menggunakan Versi Excel 2016 yang lebih lama, klik Data > Sumber Lain > Dari Impor Data XML.

  2. Masuk ke drive, folder, atau lokasi internet yang memiliki file data XML (.xml) yang ingin Anda impor.

  3. Pilih file dan klik Buka.

  4. Dalam kotak dialog Impor Data, lakukan salah satu hal berikut:

    • Tabel XML dalam lembar kerja yang sudah ada    Konten file diimpor ke tabel XML baru dalam lembar kerja baru. Jika file data XML tidak merujuk ke skema, Excel akan menyimpulkan skema dari file data XML.

    • Lembar kerja yang sudah ada    Data XML diimpor dalam tabel dua dimensi dengan baris dan kolom yang memperlihatkan tag XML sebagai judul kolom, dan data dalam baris di bawah judul kolom. Elemen pertama (simpul akar) digunakan seperti judul dan ditampilkan di lokasi sel yang ditentukan. Sisa tag diurutkan menurut abjad di seluruh baris kedua. Dalam kasus ini, Excel tidak menyimpulkan skema, dan Anda tidak bisa menggunakan Peta XML.

    • Lembar kerja baru    Excel menambahkan lembar kerja baru ke buku kerja Anda dan secara otomatis menempatkan data XML di sudut kiri atas lembar kerja baru. Jika file data XML tidak merujuk ke skema, Excel akan menyimpulkan skema dari file data XML.

  5. Untuk mengontrol perilaku data XML, seperti pengikatan data, format, dan tata letak, klikProperti, yang menampilkan kotak dialog Properti Peta XML. Misalnya, data yang sudah ada dalam rentang yang dipetakan ditimpa saat Anda mengimpor data secara default, tapi Anda bisa mengubahnya.

Membuka file data XML untuk mengimpor datanya

  1. Klik File > Buka.

    Jika Anda menggunakan Excel 2007, klik Tombol Microsoft Office untuk Gambar tombol Office > Buka.

  2. Dalam kotak dialog Buka, klik drive, folder, atau lokasi Internet yang memiliki file yang ingin Anda buka.  

  3. Pilih file dan klik Buka.

  4. Jika kotak dialog Impor XML muncul, file yang Anda buka merujuk pada satu atau beberapa lembar gaya Extensible Stylesheet Language Transformation (XSLT), sehingga Anda bisa mengklik salah satu opsi berikut ini:

    • Membuka file tanpa menerapkan lembar gaya    Data XML diimpor dalam tabel dua dimensi dengan baris dan kolom yang memperlihatkan tag XML sebagai judul kolom, dan data dalam baris di bawah judul kolom. Elemen pertama (simpul akar) digunakan seperti judul dan ditampilkan di lokasi sel yang ditentukan. Sisa tag diurutkan menurut abjad di seluruh baris kedua. Dalam kasus ini, Excel tidak menyimpulkan skema, dan Anda tidak bisa menggunakan Peta XML.

    • Membuka file dengan lembar gaya berikut ini diterapkan (pilih salah satu)    Pilih lembar gaya yang ingin Anda terapkan, lalu klik OK. Data XML diformat sesuai dengan lembar gaya yang Anda pilih.

      Catatan: Data XML dibuka sebagai baca-saja di Excel sehingga Anda tidak secara tidak sengaja menyimpan file sumber asli dalam format file Buku Kerja Excel Macro-Enabled (.xlsm). Dalam kasus ini, Excel tidak menyimpulkan skema, dan Anda tidak bisa menggunakan Peta XML.

  5. Jika kotak dialog Open XML muncul, file XML tidak memiliki referensi lembar gaya XSLT apa pun. Untuk membuka file, klik salah satu opsi berikut:

    • Klik Sebagai tabel XML untuk membuat tabel XML dalam buku kerja baru.

      Konten file diimpor ke tabel XML. Jika file data XML tidak merujuk ke skema, Excel akan menyimpulkan skema dari file data XML.

    • Klik Sebagai buku kerja baca-saja.

      Data XML diimpor dalam tabel dua dimensi dengan baris dan kolom yang memperlihatkan tag XML sebagai judul kolom, dan data dalam baris di bawah judul kolom. Elemen pertama (simpul akar) digunakan seperti judul dan ditampilkan di lokasi sel yang ditentukan. Sisa tag diurutkan menurut abjad di seluruh baris kedua. Dalam kasus ini, Excel tidak menyimpulkan skema, dan Anda tidak bisa menggunakan Peta XML.

      Data XML dibuka sebagai baca-saja di Excel sehingga Anda tidak secara tidak sengaja menyimpan file sumber asli dalam format file Buku Kerja Excel Macro-Enabled (.xlsm). Dalam kasus ini, Excel tidak menyimpulkan skema, dan Anda tidak bisa menggunakan Peta XML.

    • Klik Gunakan panel tugas Sumber XML.

      Skema file data XML ditampilkan di panel tugas Sumber XML. Lalu Anda bisa menyeret elemen skema ke lembar kerja untuk memetakan elemen tersebut ke lembar kerja.

      Jika file data XML tidak merujuk ke skema, Excel akan menyimpulkan skema dari file data XML.

Masalah umum dalam mengimpor data XML

Excel menampilkan kotak dialog Kesalahan Impor XML ketika tidak bisa memvalidasi data menurut Peta XML. Dalam kotak dialog ini, klik Detail untuk informasi tambahan tentang setiap kesalahan. Tabel berikut ini mencantumkan beberapa kesalahan impor umum:

Kesalahan

Apa yang terjadi

Validasi skema yang gagal

Saat Anda mengklik Validasi data berdasarkan skema untuk impor dan ekspor di kotak dialog Properti Peta XML, data diimpor, tapi data tidak divalidasi berdasarkan Peta XML yang ditentukan.

Beberapa data diimpor sebagai teks

Beberapa atau semua data yang Anda impor dikonversi dari tipe data yang dideklarasikan menjadi teks. Untuk menggunakan data ini dalam perhitungan, Anda harus mengonversi data dari teks menjadi angka atau tanggal. Misalnya, nilai tanggal yang dikonversi menjadi teks tidak akan berfungsi seperti yang dimaksudkan dalam fungsi YEAR hingga Anda mengonversinya menjadi tipe data Tanggal. Excel mengonversi data menjadi teks bila:

  • Data berada dalam format Excel ini tidak didukung.

  • Data tidak kompatibel dengan representasi Excel internal tipe data XSD. Untuk memperbaiki masalah ini, periksa setiap deklarasi tipe data untuk memastikan data XML Anda valid menurut skema XML.

Kesalahan penguraian XML

Pemilah XML tidak bisa membuka file XML yang ditentukan. Pastikan file XML tidak memiliki kesalahan sintaks, dan XML dibentuk dengan baik.

Tidak bisa menemukan Peta XML yang sesuai dengan data

Masalah ini bisa terjadi ketika Anda memilih lebih dari satu file data XML untuk diimpor, Excel Anda tidak bisa menemukan Peta XML yang cocok untuk salah satu file itu. Untuk file yang diberi nama di bilah judul kotak dialog, impor skema yang sesuai terlebih dahulu, lalu cobalah mengimpor file lagi.

Tabel XML tidak bisa diubah ukurannya untuk mengakomodasi data

Anda sedang mencoba menambahkan baris dengan mengimpor atau menambahkan data ke tabel XML, tapi tidak ada ruang untuk memperluas tabel. Tabel XML hanya bisa diperluas dari bawah ke bawah. Misalnya, mungkin ada objek, seperti gambar atau tabel lain, tepat di bawah tabel XML yang mencegah tabel XML diperluas. Atau, agar tabel XML diperluas, itu akan melebihi batas Excel baris 1.048.576. Untuk memperbaiki masalah ini, susun ulang tabel dan objek pada lembar kerja untuk memungkinkan tabel XML diperluas dari bawah ke bawah.

File XML tertentu tidak merujuk ke skema

File XML yang coba Anda buka tidak merujuk ke skema XML. Untuk bekerja dengan data XML yang ada dalam file, Excel membutuhkan skema berdasarkan konten file XML. Jika skema tersebut tidak benar atau tidak cukup, hapus skema dari buku kerja Anda. Lalu buat file skema XML dan edit file data XML sehingga file data XML merujuk ke skema. Untuk informasi selengkapnya, lihat Memetakan elemen XML ke sel di Peta XML.

Catatan: Anda tidak bisa mengekspor Excel disimpulkan sebagai file data skema XML (.xsd) terpisah. Meskipun ada editor skema XML dan metode lainnya untuk membuat file skema XML, Anda mungkin tidak memiliki akses yang sesuai atau tidak mengetahui bagaimana cara menggunakannya.

Ikuti langkah-langkah ini untuk menghapus skema yang Excel buat dari buku kerja Anda:

  1. Klik Pengembang > Sumber.

    Perintah XML pada tab Pengembang

    Jika Anda tidak melihat tab Pengembang, lihat Memperlihatkan tab Pengembang.

  2. Di panel tugas Sumber XML, klik Xml Peta.

  3. Dalam kotak dialog Peta XML, klik peta XML yang Excel dibuat, dan klik Hapus.

Mengimpor beberapa file XML yang menggunakan ruang nama yang sama tapi skema berbeda tidak berfungsi seperti yang diharapkan

Ketika Anda bekerja dengan beberapa file data XML dan skema XML, Anda biasanya membuat Peta XML untuk setiap skema, memetakan elemen yang Anda inginkan, lalu mengimpor setiap file data XML ke Peta XML yang sesuai. Menggunakan perintah Impor untuk membuka beberapa file XML dengan ruang nama yang sama, Anda hanya bisa menggunakan satu skema XML. Saat Anda menggunakan perintah ini untuk membuka beberapa file XML yang menggunakan ruang nama yang sama tetapi skema yang berbeda, Anda bisa mendapatkan hasil yang tidak diharapkan. Misalnya, data mungkin ditimpa, atau file tidak terbuka.

Untuk mengimpor beberapa file XML yang menggunakan ruang nama yang sama namun skema XML yang berbeda, coba gunakan perintah Dari Impor Data XML (klik Data > Dari Sumber Lain). Perintah ini memungkinkan beberapa file XML dengan ruang nama yang sama untuk menggunakan beberapa skema XML. Excel membuat Peta XML unik untuk setiap file data XML yang ingin Anda impor.

Catatan: Jika Anda mengimpor beberapa file XML yang tidak menentukan ruang nama, file XML ini akan diperlakukan seperti menggunakan ruang nama yang sama.

Memperlihatkan tab Pengembang

Jika Anda tidak melihat tab Pengembang, lakukan hal berikut untuk menampilkannya:

  • Di Excel 2013 dan Excel 2010:

    1. Klik File > Opsi.

    2. Klik kategori Kustomisasi Pita.

    3. Di bawah Tab Utama, centang kotak Pengembang, dan klik OK.

  • Di Excel 2007:

    1. Klik tombol Microsoft Office bawah Gambar tombol Office> Excel Opsi.

    2. Klik kategori Populer.

    3. Di bawah Opsi terbaik untuk bekerja dengan Excel, centang kotak Perlihatkan tab Pengembang di Pita, dan klik OK.

Lihat Juga

Over view of XML in Excel

Memetakan elemen XML ke sel di Peta XML

Mengekspor data XML

Perlu bantuan lainnya?

Kembangkan keterampilan Anda
Jelajahi pelatihan
Dapatkan fitur baru terlebih dahulu
Gabung Microsoft Office Insiders

Apakah informasi ini bermanfaat?

Seberapa puaskah Anda dengan kualitas terjemahannya?
Apa yang memengaruhi pengalaman Anda?

Terima kasih atas umpan balik Anda!

×