Masuk dengan Microsoft
Masuk atau buat akun.
Halo,
Pilih akun lain.
Anda memiliki beberapa akun
Pilih akun yang ingin Anda gunakan untuk masuk.

Gejala

Perangkat SATA internal (HDD atau SSD) dapat ditampilkan sebagai media yang dapat dilepas di bilah tugas Anda.


Penyebab

Apakah perangkat dianggap dapat dilepas atau tidak ditentukan oleh BIOS sistem Anda dan bagaimana perangkat menandai berbagai port SATA pada motherboard. Driver kotak masuk secara langsung memeriksa port SATA dan menganggap perangkat yang tersambung ke port tersebut ditandai "eksternal" sebagai perangkat yang dapat dilepas. Tidak semua driver penyimpanan melakukan ini, yang dapat menjadi penyebab potensi kerusakan atau kehilangan data.

Pemecahan Masalah

Pertama, periksa dan instal pembaruan BIOS yang tersedia dari produsen PC Anda. Jika tidak ada yang tersedia, Anda dapat mengikuti langkah-langkah ini untuk menimpa cara driver kotak masuk memunculkan perangkat di port tertentu:

  1. Buka wantian perintah dengan keistimewaan administrator.

  2. Di jendela prompt perintah, ketikkan perintah berikut ini di tekan Enter: devmgmt.msc

  3. Di bawah Drive Disk, identifikasi perangkat SATA yang ingin Anda gunakan untuk mempertimbangkan properti internal dan terbuka untuk perangkat ini dengan mengklik kanan dan memilih Properti.

  4. Perhatikan nomor bus dari gambaran umum properti ("1" dalam contoh di bawah ini).

  5. Untuk Windows 7:

    1. Ketikkan perintah berikut di prompt perintah yang dibuka sebelumnya dan tekan Enter:

      reg.exe tambahkan "HKLM\SYSTEM\CurrentControlSet\Services\msahci\Controller0\Channelx\" /f /v TreatAsInternalPort /t REG_DWORD /d 0x00000001
      Tempat xcorresponds ke Nomor Bus yang Anda catat di langkah 4.


  6. Untuk Windows 8 dan yang lebih baru:

    1. Ketikkan perintah berikut di prompt perintah yang dibuka sebelumnya dan tekan Enter:

      reg.exe tambahkan "HKLM\SYSTEM\CurrentControlSet\Services\storahci\Parameters\Device" /f /v TreatAsInternalPort /t REG_MULTI_SZ /d x
      Tempat x terkait dengan Nomor Bus yang Anda catat di langkah 4.


Perlu bantuan lainnya?

Ingin opsi lainnya?

Jelajahi manfaat langganan, telusuri kursus pelatihan, pelajari cara mengamankan perangkat Anda, dan banyak lagi.

Komunitas membantu Anda bertanya dan menjawab pertanyaan, memberikan umpan balik, dan mendengar dari para ahli yang memiliki pengetahuan yang luas.

Apakah informasi ini berguna?

Seberapa puaskah Anda dengan kualitas bahasanya?
Apa yang memengaruhi pengalaman Anda?
Dengan menekan kirim, umpan balik Anda akan digunakan untuk meningkatkan produk dan layanan Microsoft. Admin TI Anda akan dapat mengumpulkan data ini. Pernyataan Privasi.

Terima kasih atas umpan balik Anda!

×