Masuk dengan Microsoft
Masuk atau buat akun.
Halo,
Pilih akun lain.
Anda memiliki beberapa akun
Pilih akun yang ingin Anda gunakan untuk masuk.

Gejala

Pertimbangkan skenario berikut:

  • Anda menggunakan Microsoft SQL Server 2016, 2014, atau 2012.

  • Anda memiliki database yang merupakan bagian dari grup ketersediaan AlwaysOn.

  • Pada replika utama, Anda menciutkan file database untuk mengurangi ukurannya.

  • Replika utama mengirim semua perubahan yang direkam dalam log transaksi ke replika sekunder.

  • Pada replika sekunder, untaian ulangi menerapkan perubahan dari log transaksi ke database yang merupakan bagian dari grup ketersediaan.

Dalam skenario ini, replika ditangguhkan. Selain itu, Anda mungkin menerima pesan kesalahan yang menyerupai berikut ini:

<stempel waktu> spid41s kesalahan: 3456, keparahan: 21, status: 1. <stempel waktu> spid41s tidak dapat mengulangi catatan log (#), untuk ID transaksi (#), pada halaman (#), database ' <dbname> ' (ID database #). Halaman: LSN = (#), Allocation unit = #, type = #. Log: OpCode = #, Context #, menang Pagelsn: (#). Pulihkan dari cadangan database, atau Perbaiki database. <stempel waktu> spid41s grup ketersediaan AlwaysOn gerakan data untuk database ' <dbname> ' telah ditangguhkan karena alasan berikut: "sistem" (ID sumber 2; String sumber: ' SUSPEND_FROM_REDO '). Untuk melanjutkan gerakan data di database, Anda perlu melanjutkan database secara manual. Untuk informasi tentang cara untuk melanjutkan database ketersediaan, lihat buku daring SQL Server. <stempel waktu> kesalahan spid41s: 3313, tingkat keparahan: 21, status: 2. <stempel waktu> spid41s selama pembuatan kembali operasi log dalam database ' <dbname> ', kesalahan terjadi pada log ID rekaman (#). Biasanya, kegagalan tertentu sebelumnya dicatat sebagai kesalahan dalam Layanan log kejadian Windows. Pulihkan database dari cadangan lengkap, atau Perbaiki database.

Penyebab

Masalah ini terjadi ketika perubahan diterapkan selama proses mengulang jika mesin database mengalami LSNs yang tidak dipesan di Halaman sistem (GAM, PFS).

Pemecahan Masalah

Masalah ini pertama kali diperbaiki dalam pembaruan kumulatif SQL Server berikut ini:

Setiap pembaruan kumulatif baru untuk SQL Server berisi semua hotfix dan semua perbaikan keamanan yang disertakan dengan pembaruan kumulatif sebelumnya. Kami menyarankan Anda mengunduh dan menginstal pembaruan kumulatif terbaru untuk SQL Server:

Pembaruan mencegah terjadinya masalah ini. Jika masalah telah terjadi, ikuti langkah-langkah ini untuk bergabung kembali ke grup ketersediaan AlwaysOn:

  1. Hapus replika sekunder AlwaysOn yang sudah ada.

  2. Jalankan perintah berikut pada file data yang terpengaruh untuk menghapus ruang yang tidak terisi dari database:

    DBCC SHRINKFILE(<file_id>, TRUNCATEONLY)

  3. Mencadangkan database dan file log.

  4. Pulihkan database dan log pada replika sekunder AlwaysOn.

  5. Bergabung dalam grup ketersediaan AlwaysOn.

Status

Microsoft telah mengonfirmasi bahwa ini adalah masalah pada produk Microsoft yang tercantum di bagian "Berlaku untuk".

Referensi

Pelajari tentang terminologi yang digunakan Microsoft untuk menjelaskan pembaruan perangkat lunak.

Perlu bantuan lainnya?

Ingin opsi lainnya?

Jelajahi manfaat langganan, telusuri kursus pelatihan, pelajari cara mengamankan perangkat Anda, dan banyak lagi.

Komunitas membantu Anda bertanya dan menjawab pertanyaan, memberikan umpan balik, dan mendengar dari para ahli yang memiliki pengetahuan yang luas.

Apakah informasi ini berguna?

Seberapa puaskah Anda dengan kualitas bahasanya?
Apa yang memengaruhi pengalaman Anda?
Dengan menekan kirim, umpan balik Anda akan digunakan untuk meningkatkan produk dan layanan Microsoft. Admin TI Anda akan dapat mengumpulkan data ini. Pernyataan Privasi.

Terima kasih atas umpan balik Anda!

×