Masuk dengan Microsoft
Masuk atau buat akun.
Halo,
Pilih akun lain.
Anda memiliki beberapa akun
Pilih akun yang ingin Anda gunakan untuk masuk.

Gejala

Pertimbangkan skenario berikut ini:

  • Anda memiliki beberapa relasional Online analitis pemrosesan (ROLAP) partisi dalam kubus Microsoft SQL Server 2008 R2 Analysis Services (SSAS 2008 R2).

  • Anda menjalankan kueri Multidimensional ekspresi (MDX) terhadap ROLAP partisi. Oleh karena itu, beberapa permintaan ROLAP dikirim ke SQL Server.

  • Terjadi kesalahan selama evaluasi MDX permintaan, dan tugas pemrosesan permintaan MDX membeku. Sebagai contoh, SQL Server mengembalikan pesan galat berikut ini pada permintaan ROLAP:

    Transaksi yang aktif pada sesi ini telah dilakukan atau diakhiri dengan sesi lain


Dalam skenario ini, transaksi yang tidak dapat dilakukan, dan Anda tidak dapat menyambung ke SSAS.

Penyebab

Masalah ini terjadi karena, ketika ROLAP permintaan dikirim ke SQL Server dan permintaan gagal dengan galat, anak thread query MDX berhenti berjalan di SSAS. Namun, thread utama permintaan masih menunggu thread anak-anak. Oleh karena itu, thread utama memblokir pemrosesan commit, dan evaluasi keamanan blok ini untuk semua pengguna sesi.

Setiap pembaruan kumulatif yang baru untuk SQL Server berisi semua hotfix dan semua perbaikan keamanan yang disertakan dengan pembaruan kumulatif sebelumnya. Periksa pembaruan kumulatif terbaru untuk SQL Server:


Tersedia hotfix yang didukung dari Microsoft. Namun, hotfix ini ditujukan untuk memperbaiki masalah yang dijelaskan di artikel ini. Menerapkan hotfix ini hanya ke sistem yang mengalami masalah khusus ini.

Apabila hotfix tersedia untuk diunduh, ada bagian "Tersedia Unduhan Hotfix" di bagian atas artikel Pangkalan Pengetahuan ini. Jika bagian ini tidak muncul, kirimkan permintaan ke layanan pelanggan Microsoft dan dukungan untuk mendapatkan hotfix.

Catatan Jika terjadi masalah tambahan atau apabila pemecahan masalah apa pun diperlukan, Anda mungkin harus membuat permintaan layanan secara terpisah. Biaya dukungan biasa akan berlaku untuk dukungan tambahan pertanyaan dan masalah yang tidak memenuhi syarat untuk hotfix ini. Untuk daftar lengkap nomor telepon layanan pelanggan Microsoft dan dukungan atau untuk membuat permintaan layanan terpisah, kunjungi situs web Microsoft berikut:

http://support.microsoft.com/contactus/?ws=supportCatatan Formulir "Tersedia Unduhan Hotfix" menampilkan bahasa hotfix tersedia. Jika Anda tidak melihat bahasa Anda, hal ini karena hotfix tidak tersedia untuk bahasa tersebut.

Status

Microsoft telah memastikan bahwa ini merupakan masalah di dalam produk Microsoft sebagaimana tercantum di bagian "Berlaku untuk".

Perlu bantuan lainnya?

Ingin opsi lainnya?

Jelajahi manfaat langganan, telusuri kursus pelatihan, pelajari cara mengamankan perangkat Anda, dan banyak lagi.

Komunitas membantu Anda bertanya dan menjawab pertanyaan, memberikan umpan balik, dan mendengar dari para ahli yang memiliki pengetahuan yang luas.

Apakah informasi ini berguna?

Seberapa puaskah Anda dengan kualitas bahasanya?
Apa yang memengaruhi pengalaman Anda?
Dengan menekan kirim, umpan balik Anda akan digunakan untuk meningkatkan produk dan layanan Microsoft. Admin TI Anda akan dapat mengumpulkan data ini. Pernyataan Privasi.

Terima kasih atas umpan balik Anda!

×