Gejala

Ketika menggunakan Portal Bisnis di Microsoft Dynamics SL atau di Microsoft Dynamics GP, Anda menerima pesan kesalahan berikut di komponen Web:

CurrentPrincipal tidak diautentikasi

Penyebab

Masalah ini terjadi ketika akses anonim diaktifkan untuk situs Web Portal Bisnis atau direktori virtual BusinessPortal.

Pemecahan Masalah

Untuk mengatasi masalah ini, ikuti langkah-langkah berikut:

  1. Di Manajer Microsoft Layanan Informasi Internet (IIS), klik kanan situs Web Portal Bisnis. Lalu, klik Properti.

  2. Pada tab Keamanan Direktori, klik Edit di bagian Autentikasi dan Kontrol Access.

  3. Klik untuk mengosongkan kotak centang Aktifkan Akses Anonim jika telah dipilih.

  4. Klik Terapkan, lalu klik OK.Catatan Jika Anda diminta untuk membuat perubahan ke semua node anak, klik Pilih Semua,lalu klik OK.

  5. Perluas situs Web Portal Bisnis, klik kanan direktori virtual BusinessPortal, lalu klik Properti.

  6. Pada tab Keamanan Direktori, klik Edit di bagian Autentikasi dan Kontrol Access.

  7. Klik untuk mengosongkan kotak centang Aktifkan Akses Anonim jika telah dipilih.

  8. Klik Terapkan, lalu klik OK.Catatan Jika Anda diminta untuk membuat perubahan ke semua node anak, klik Pilih Semua,lalu klik OK.

Perlu bantuan lainnya?

Ingin opsi lainnya?

Jelajahi manfaat langganan, telusuri kursus pelatihan, pelajari cara mengamankan perangkat Anda, dan banyak lagi.