Gejala
Ketika menggunakan Portal Bisnis di Microsoft Dynamics SL atau di Microsoft Dynamics GP, Anda menerima pesan kesalahan berikut di komponen Web:
CurrentPrincipal tidak diautentikasi
Penyebab
Masalah ini terjadi ketika akses anonim diaktifkan untuk situs Web Portal Bisnis atau direktori virtual BusinessPortal.
Pemecahan Masalah
Untuk mengatasi masalah ini, ikuti langkah-langkah berikut:
-
Di Manajer Microsoft Layanan Informasi Internet (IIS), klik kanan situs Web Portal Bisnis. Lalu, klik Properti.
-
Pada tab Keamanan Direktori, klik Edit di bagian Autentikasi dan Kontrol Access.
-
Klik untuk mengosongkan kotak centang Aktifkan Akses Anonim jika telah dipilih.
-
Klik Terapkan, lalu klik OK.Catatan Jika Anda diminta untuk membuat perubahan ke semua node anak, klik Pilih Semua,lalu klik OK.
-
Perluas situs Web Portal Bisnis, klik kanan direktori virtual BusinessPortal, lalu klik Properti.
-
Pada tab Keamanan Direktori, klik Edit di bagian Autentikasi dan Kontrol Access.
-
Klik untuk mengosongkan kotak centang Aktifkan Akses Anonim jika telah dipilih.
-
Klik Terapkan, lalu klik OK.Catatan Jika Anda diminta untuk membuat perubahan ke semua node anak, klik Pilih Semua,lalu klik OK.