Gejala
Pertimbangkan skenario berikut ini:
-
Anda membuat dialog untuk entitas kontak di Microsoft Dynamics CRM 2013 dari komputer yang memiliki Windows Internet Explorer 8 dipasang.
Catatan Bagian dari persyaratan dialog adalah bahwa CRM data dipertanyakan dan ditampilkan sebagai picklist. -
Anda menambahkan langkah Data CRM pertanyaan ketika Anda membuat dialog.
-
Filter permintaan dinamis (FirstName -> sama dengan -> {FirstName(Contact)}).
-
Langkah selanjutnya di dialog adalah halaman yang berisi Prompt dan respons di mana promptdiatur ke {FirstName(Contact)}, dan respons diatur untuk Mengatur opsi, di mana opsi yang tersedia diisi dari permintaan.
-
Anda menjalankan dialog terhadap data kontak tunggal.
Dalam situasi ini, ada opsi tidak tersedia di Prompt dan respons set opsi.
Penyebab
Masalah ini terjadi karena ruang yang akan ditambahkan di depan nilai yang dimasukkan ke dalam permintaan dengan menggunakan dynamics siput menyebabkan Internet Explorer 8.
Pemecahan masalah
Untuk mengatasi masalah ini, Anda dapat menggunakan Windows Internet Explorer 9 untuk membuat dan mempublikasikan dialog yang berisi langkah-langkah permintaan CRM.