Come ridurre i metadati in Word 2003


Per una versione di Microsoft Word 2002 di questo articolo, vedere 290945 .

Riepilogo


In questo articolo vengono descritti diversi metodi che è possibile utilizzare per ridurre al minimo i metadati nei documenti di Word.

Quando si crea, aprire o salvare un documento in Microsoft Office Word 2003, il documento può contenere contenuto che è possibile che si desidera condividere con altri utenti quando si distribuisce elettronicamente. Questa informazione è nota come metadati. Per migliorare la modifica, visualizzazione, archiviazione e recupero dei documenti di Office, i metadati vengono utilizzati per diversi scopi.

Alcuni di essi sono facilmente accessibili attraverso l'interfaccia utente di Word. Altri sono accessibili solo utilizzando metodi straordinari, ad esempio aprendo un documento in un editor di file binari di basso livello. Di seguito sono riportati alcuni esempi di metadati che possono essere memorizzati nei documenti:
  • Il tuo nome
  • Le iniziali
  • Il nome della società o organizzazione
  • Il nome del computer
  • Il nome del server di rete o disco rigido in cui è stato salvato il documento
  • Altre informazioni di riepilogo e le proprietà di file
  • Parti non visibili di oggetti OLE incorporati
  • Revisioni dei documenti
  • Versioni del documento
  • Informazioni sul modello
  • Testo nascosto
  • Commenti
I metadati vengono creati in vari modi nei documenti di Word. Di conseguenza, non vi è nessun singolo metodo per rimuovere tale contenuto dai documenti. Le sezioni seguenti descrivono aree in cui i metadati possono essere salvati nei documenti di Word.

In questo articolo vengono descritti diversi metodi che è possibile utilizzare per ridurre al minimo i metadati nei documenti di Word.

Microsoft fornisce esempi di programmazione illustrativo, senza alcuna garanzia espressa o implicita. Ciò include, ma non limitato a, le garanzie implicite di commerciabilità o idoneità per uno scopo particolare. In questo articolo si presuppone che si abbia familiarità con il linguaggio di programmazione in questione e gli strumenti utilizzati per creare ed eseguire la procedura di debug. I tecnici del supporto Microsoft possono spiegare la funzionalità di una particolare procedura, ma in nessun caso possono modificare questi esempi per fornire funzionalità aggiuntive o creare procedure atte a soddisfare specifiche esigenze. Per ulteriori informazioni su come utilizzare il codice di esempio in questo articolo, fare clic sul numero riportato di seguito per visualizzare l'articolo della Microsoft Knowledge Base:

290140 sull'esecuzione di codice di esempio per i programmi di Office XP da articoli della Knowledge Base

Torna all'inizio

Come rimuovere automaticamente le informazioni personali quando si salva

È ora possibile automaticamente rimuovere informazioni personali da un documento di Word quando si salva il documento. Per attivare questa opzione, attenersi alla seguente procedura:
  1. Dal menu Strumenti , fare clic su
    Le opzioni.
  2. Nella scheda protezione , fare clic per selezionare il
    Casella di controllo Rimuovi le informazioni personali dal momento del salvataggio di file in Opzioni Privacye quindi fare clic
    OK.
Nota: Questo è il metodo consigliato per rimuovere informazioni personali quando si salva un documento di Word.

Torna all'inizio

Come rimuovere manualmente il nome utente dai documenti

Per visualizzare o modificare il nome utente, attenersi alla seguente procedura:
  1. Dal menu Strumenti , fare clic su
    Opzioni, quindi scegliere la scheda Informazioni utente.

    Vengono visualizzate le seguenti caselle di modifica:
    Nome
    Iniziali
    Indirizzo postale
  2. Se non si desidera che queste informazioni siano contenute nei propri documenti, immettere stringhe insignificanti o spazi nelle appropriate caselle di modifica e quindi fare clic su OK per accettare le modifiche.
Nota: I nuovi documenti creati conterrà queste informazioni ignorando i valori predefiniti immessi durante l'installazione di Office. Tuttavia, i documenti esistenti potrebbero già contenere queste informazioni.

Torna all'inizio

Come rimuovere manualmente le informazioni di riepilogo personali

Quando si crea o si salva un documento in Word, le informazioni di riepilogo possono essere salvate nel documento. Esistono diversi metodi che è possibile utilizzare per accedere a queste informazioni:
  • Aprire il documento. Dal menu File , fare clic su
    Le proprietà. Il Riepilogo
    Statistiche, contenuto, e
    Schede personalizzate contengono varie proprietà, come il nome, il nome del manager e il nome della società.
  • In Microsoft Windows Explorer, il pulsante destro del documento e quindi scegliere proprietà. Le schede di
    Nella finestra di dialogo proprietà potrebbe contenere informazioni.
  • È possibile utilizzare un Visual Basic, Applications Edition di Microsoft () nella macro o codice di altri programmi per leggere le proprietà visualizzate di
    Finestra di dialogo proprietà .
Per cancellare informazioni riepilogative da un documento o modello esistente, procedere come segue:
  1. Aprire il documento o modello.
  2. Dal menu File , fare clic su
    Le proprietà.
  3. Nella scheda Riepilogo , fare clic per deselezionare la
    Autore, Manager, societàe altre caselle di modifica che si desidera distribuire.
  4. Nella scheda Personalizza , eliminare eventuali proprietà contenenti informazioni che si desidera distribuire.
  5. Fare clic su OK.

    Nel
    Dal menu file , fare clic su Salvae quindi fare clic su
    Chiudi.
Dopo aver completato questi passaggi, il documento non conterrà informazioni di riepilogo.

Torna all'inizio

Come rimuovere manualmente le informazioni di riepilogo personali quando si è connessi a una rete

Se è connessi a una rete, il proprio nome utente potrebbe apparire nella casella autore della scheda Riepilogo e nel campo Autore ultimo salvataggio sul
Scheda statistiche quando si salva un documento. Questo problema può verificarsi anche se è stato rimosso tutte le altre informazioni personali dal computer.

Per rimuovere le informazioni di riepilogo da un documento quando utilizza una rete, attenersi alla seguente procedura:
  1. Se il documento è archiviato su un server di rete, copiarlo sul disco rigido locale.
  2. Avviare il computer, a differenza non accede alla rete. Quando viene visualizzato nella finestra di dialogo di accesso di rete, fare clic su Annulla o premere ESC.

    Nota: Se non è possibile avviare Windows premendo ESC (ad esempio, il computer è in esecuzione Microsoft Windows NT), è possibile continuare questa procedura.
  3. Aprire il documento.
  4. Dal menu File , fare clic su
    Le proprietà.
  5. Nella scheda Riepilogo , fare clic per deselezionare la
    Autore, Manager, societàe nelle altre caselle che contengono informazioni che si desidera distribuire.
  6. Nella scheda Personalizza , eliminare eventuali proprietà contenenti informazioni che si desidera distribuire.
  7. Fare clic su OK.

    Nel
    Dal menu file , fare clic su Salvae quindi fare clic su
    Chiudi.
Quando si accede alla rete, non aprire il file. In tal caso, il proprio nome utente può scrivere nel file. Tuttavia, è possibile utilizzare Esplora risorse per copiare il file in un server di rete o un disco floppy.

Torna all'inizio

Come rimuovere manualmente i commenti nei documenti

Word offre la possibilità di aggiungere commenti ai documenti. In genere, i commenti contengono il nome della persona che li ha creati in modo da poter distinguere autore li.

In genere i commenti vengono visualizzati come una sezione evidenziata del testo; destro del mouse sul commento e quindi scegliere Elimina commento.

I nuovi commenti creati non conterrà il nome utente perché è stato rimosso dalla finestra di dialogo Opzioni come descritto nella sezione "Rimozione manuale del nome utente dai documenti" di questo articolo.

Torna all'inizio

Come rimuovere manualmente le intestazioni e piè di pagina dai documenti

Intestazioni e piè di pagina nei documenti possono contenere informazioni di identificazione. Per rimuovere informazioni da intestazioni e piè di pagina, attenersi alla seguente procedura:
  1. Dal menu Visualizza , scegliere intestazione e piè di pagina.
  2. L'intestazione e piè di pagina vengono visualizzati nella parte superiore e inferiore di ogni pagina del documento.

    Modificarli come desiderato.
  3. Fare clic su Chiudi sulla barra degli strumenti intestazione e piè di pagina .
Torna all'inizio

Come rimuovere manualmente i segni di revisione

I documenti possono contenere segni di revisione. Con segni di revisione è possibile determinare l'autore di determinate modifiche a un documento. Quando si accetta o rifiuta i segni di revisione, il testo revisionato viene salvato nel documento e vengono rimossi i segni di revisione.

Per accettare o rifiutare le revisioni, attenersi alla seguente procedura:
  1. Dal menu Strumenti , fare clic su Revisioni per attivarla.
  2. Sulla barra degli strumenti revisioni fare clic su precedente o successivo per individuare e selezionare revisioni specifiche. Quindi, fare clic su Accetta modifica o Rifiuta revisione/Elimina commento per accettare o rifiutare la revisione selezionata.
  3. Al termine, fare clic su
    Chiudi.
Nota: Se si modificano le impostazioni "Mostra" sulla barra degli strumenti Revisioni, le informazioni sulla revisione non viene rimosso. Torna all'inizio

Per la disattivazione del salvataggio veloce

Salvataggio veloce consente di velocizzare il processo di salvataggio salvando solo le modifiche apportate a un documento.

A causa della progettazione della funzionalità di salvataggio veloce, il testo eliminato da un documento rimanga nel documento anche dopo aver salvato il documento. Se si costituisce un problema, attenersi alla seguente procedura:
  1. Dal menu Strumenti , fare clic su
    Le opzioni.
  2. Scegliere la scheda Salva .
  3. Fare clic per deselezionare la casella di controllo Consenti salvataggio veloce e quindi fare clic su OK.
Per ulteriori informazioni sulla funzionalità di salvataggio veloce, fare clic sul numero riportato di seguito per visualizzare l'articolo della Microsoft Knowledge Base riportato di seguito:

291181 domande frequenti su "Consenti salvataggio veloce" in Word 2002

Torna all'inizio

Come cercare e rimuovere il testo formattato come nascosto

Nei documenti di Word, è possibile formattare il testo come nascosto. Poiché il testo nascosto può contenere informazioni che non è possibile distribuire, è possibile visualizzarlo e rimuoverlo. Per rimuovere tutto il testo in un documento che viene formattato come nascosto, attenersi alla seguente procedura:
  1. Dal menu Strumenti , fare clic su
    Opzioni, quindi scegliere la scheda Visualizza.
  2. Fare clic per selezionare la casella di controllo testo nascosto e quindi fare clic su OK.
  3. Dal menu Modifica , fare clic su
    Sostituire.
  4. Fare clic sul pulsante più per espandere la finestra di dialogo.
  5. Fare clic nella casella accanto a Trova.
  6. Fare clic sul pulsante formato e quindi fare clic su
    Tipo di carattere.

    Fare clic per selezionare la casella di controllo nascostoe quindi fare clic su OK.
  7. Fare clic su Sostituisci tutto.
Tutto il testo nascosto viene rimosso dal documento. Per disattivare la visualizzazione del testo nascosto, attenersi alla seguente procedura:
  1. Dal menu Strumenti , fare clic su
    Opzioni, quindi scegliere la scheda Visualizza.
  2. Fare clic per deselezionare la casella di controllo testo nascosto e quindi fare clic su OK.
Torna all'inizio

Rimozione di collegamenti ipertestuali dai documenti

I documenti possono contenere collegamenti ipertestuali ad altri documenti o pagine Web su una rete intranet o Internet. In genere vengono visualizzati come stringhe di testo blu sottolineato.

Per eliminare manualmente un collegamento ipertestuale da un documento, pulsante destro del mouse sul collegamento ipertestuale, scegliere collegamento ipertestualee quindi fare clic su
Rimuovi collegamento ipertestuale.

Se si desidera eliminare tutti i collegamenti ipertestuali in un documento, è possibile utilizzare una macro VBA per eseguire questa operazione. La macro di esempio seguente rimuove tutti i collegamenti ipertestuali in un documento.

Nota: Nella macro di esempio seguente viene rimosso solo il collegamento. Il testo del collegamento ipertestuale rimane nel documento.

Importante Prima di utilizzare il seguente esempio di macro, esaminare la declinazione di responsabilità in precedenza in questo articolo.
Sub RemoveHyperlinks()

Dim oDoc As Document
Dim oStory As Range
Dim oHlink As Hyperlink

For Each oStory In ActiveDocument.StoryRanges
For Each oHlink In oStory.Hyperlinks
oHlink.Delete
Next
Next

End Sub
Per rimuovere tutte le tracce sia il collegamento ipertestuale e il testo del collegamento ipertestuale del documento, è possibile utilizzare la seguente macro di esempio.
Sub RemoveAllHyperlinks()

Dim oDoc As Document
Dim oStory As Range
Dim oHlink As Hyperlink

For Each oStory In ActiveDocument.StoryRanges
For Each oHlink In oStory.Hyperlinks
oHlink.Range.Delete
Next
Next

End Sub
Torna all'inizio

Rimozione degli stili dai documenti

I documenti possono includere stili contenenti metadati. È possibile rimuovere questi stili o rinominarli. A tale scopo, attenersi alla seguente procedura:
  1. Aprire il documento che contiene gli stili.
  2. Dal menu formato , fare clic su
    Stile.
  3. Selezionare lo stile che si desidera eliminare o rinominare.


    Fare clic su Elimina per eliminare lo stile oppure fare clic su
    Modifica per rinominarlo.
Torna all'inizio

Rimozione di versioni precedenti dei File dai documenti

Word include una funzionalità che consente di salvare più versioni dello stesso documento nello stesso file. Si consiglia di eliminare le versioni precedenti del documento prima di condividerlo con altri utenti.

Per eliminare uno o più versioni di un documento, attenersi alla seguente procedura:
  1. Dal menu File , fare clic su
    Le versioni.
  2. Selezionare la versione del documento che si desidera eliminare.

    È possibile selezionare più di una versione tenendo premuto CTRL mentre si selezionano le versioni.
  3. Fare clic su Elimina.
  4. Dopo aver terminato l'eliminazione delle vecchie versioni del documento, scegliere Salva dal menu File.
Torna all'inizio

Rimozione di collegamenti dai codici di campo

Le immagini collegate e altri oggetti nei documenti di Word possono contenere informazioni sul collegamento, il percorso dell'immagine collegata o dell'oggetto. È possibile rimuovere informazioni sul collegamento dal documento modificando i codici di campo.

Per visualizzare i codici di campo, attenersi alla seguente procedura:
  1. Dal menu Strumenti , fare clic su
    Opzioni, quindi scegliere la scheda Visualizza.
  2. Fare clic per selezionare la casella di controllo codici di campo e quindi fare clic su OK.
Dopo i codici di campo sono visibili, è possibile verificare se uno di questi contengano informazioni identificative.

Per rimuovere informazioni sul collegamento da un collegamento a un'immagine o un altro oggetto, attenersi alla seguente procedura:
  1. Selezionare il collegamento a un'immagine o l'oggetto oppure selezionare il codice di campo per l'immagine o l'oggetto se i codici di campo sono visibili.
  2. Premere CTRL + MAIUSC + F9.
L'immagine o l'oggetto è scollegato. Quando un'immagine o un oggetto non collegato, è possibile modificarlo.

Torna all'inizio

Come rimuovere il nome del modello e la posizione

Tutti i documenti creati in Word si basano su un modello. Per impostazione predefinita, questo è il modello Normal dot nella cartella modelli. Tuttavia, è possibile creare un documento basato su un modello diverso in un'altra posizione. Il percorso e il nome del modello vengono memorizzate nelle proprietà del documento.

Per visualizzare il nome del modello e il percorso, scegliere proprietà dal menu File e quindi fare clic sulla scheda Riepilogo .

Anche se non si invia il documento con il modello, il documento mantiene il nome e il percorso del modello. Per modificare il nome del modello e la posizione di insignificanti valori, attenersi alla seguente procedura:
  1. Scegliere modelli e aggiuntedal menu Strumenti .
  2. Fare clic su Associa.
  3. Selezionare un modello che ha un nome e un percorso che non sono riservati né univoci.

    Ad esempio, poiché ogni computer in cui è installato Word include Normal. dot, si consiglia di selezionare Normal. dot.
  4. Fare clic su Aprie quindi fare clic su
    OK.
Nota: Il modello potrebbe contenere macro, voci di glossario, stili personalizzati e barre degli strumenti personalizzate. Modificando i modelli, si potrebbe rendere alcuni di questi elementi non disponibile al documento.

Torna all'inizio

Come rimuovere le informazioni allegate

Se si invia un documento tramite posta elettronica utilizzando una lista di distribuzione, le informazioni di routing vengono allegate al documento. Per rimuovere queste informazioni dal documento, è necessario salvare il documento in un formato che mantenga le informazioni allegate.

In Word, salvare il documento in formato HTML o RTF (RICH Text Format). Chiudere il documento e quindi riaprire il nuovo file. Poiché le informazioni della lista di distribuzione non sono presente, è ora possibile salvare il documento in formato Word.

È possibile anche eseguire la procedura seguente:
  1. Disattivare Consenti salvataggio veloce seguendo le istruzioni fornite in precedenza in questo articolo.
  2. Dal menu File , scegliere Invia ae quindi fare clic su Altro destinatario di distribuzione.
  3. Fare clic su Cancella per rimuovere la lista e quindi fare clic su OK.
  4. Dal menu File , fare clic su
    Salva.
A questo punto, il documento viene salvato senza le informazioni di trasporto.

Torna all'inizio

Come rimuovere il proprio nome da codice Visual Basic

Importante Prima di utilizzare il seguente esempio di macro, esaminare la declinazione di responsabilità in precedenza in questo articolo.

Quando si registra una macro VBA in Word, la macro registrata inizia con un'intestazione che è simile al seguente:
' Macro1 Macro
' Macro recorded 3/11/1999 by <User Name>
Per rimuovere il nome dell'utente dalle macro registrate, attenersi alla seguente procedura:
  1. Aprire il documento che contiene le macro.
  2. Dal menu Strumenti , scegliere
    Macro, quindi fare clic su Visual Basic Editor. O premere ALT + F11.
  3. Nella finestra progetto, fare doppio clic sul modulo che contiene le macro.
  4. Rimuovere il proprio nome dal codice della macro registrata.
Al termine della rimozione del nome, premere ALT + Q per tornare al programma e quindi scegliere Salva al
Dal menu file .

Torna all'inizio

Come rimuovere riferimenti di Visual Basic ad altri file

Nell'Editor di Visual Basic, è possibile creare un riferimento a un altro file. Se un utente apre un documento che contiene riferimenti ad altri file, è possibile leggervi i nomi dei file.

Per rimuovere questi riferimenti, attenersi alla seguente procedura:
  1. Aprire il documento che contiene i riferimenti.
  2. Dal menu Strumenti , scegliere
    Macro, quindi scegliere Visual Basic Editor oppure premere ALT + F11.
  3. Dal menu Strumenti , fare clic su
    I riferimenti.
  4. Fare clic per deselezionare la casella di controllo accanto ai file di riferimento.

    Al termine, fare clic su OK.
  5. Premere ALT + Q.
  6. Dal menu File , fare clic su
    Salva.
Nota: Se si rimuovono i riferimenti ad altri file, questo potrebbe influire negativamente le macro contenute nel documento per il corretto funzionamento.

Torna all'inizio

Rimozione di informazioni sui dischi rigidi o rete

Quando si salva un documento sul disco rigido locale o a un server di rete, informazioni che identificano il disco rigido locale o un server di rete vengono scritte nel documento.

Per rimuovere queste informazioni dal documento, attenersi alla seguente procedura:
  1. Aprire il documento.
  2. Scegliere Salva con nome dal menu File .

    Salvare il documento sull'unità disco floppy (in genere unità a).
  3. Dal menu File , fare clic su
    Chiudi.
  4. Rimuovere il disco floppy dall'unità disco floppy.
È ora possibile utilizzare Esplora risorse per copiare il documento dal disco floppy a qualsiasi disco rigido o server di rete.

Nota: A causa dei limiti di spazio di un disco floppy (in genere 1,44 megabyte [MB]), questo metodo non può essere utilizzato se le dimensioni del documento superano lo spazio libero sul disco floppy.

Torna all'inizio

Gli oggetti incorporati nei documenti possono contenere metadati

Se si incorpora un oggetto in un documento, l'oggetto conserva le sue proprietà, indipendentemente dalle operazioni eseguite per il documento. Ad esempio, se si incorpora una cartella di lavoro di Microsoft Excel, un documento, il documento e la cartella presenta proprietà.

Per rimuovere metadati da un oggetto incorporato, attivare l'oggetto, rimuovere eventuali metadati come descritto nelle sezioni precedenti, riattivare il documento contenitore e quindi salvare il documento contenitore.

Nota: Quando si attiva un oggetto incorporato in un documento, solo una parte dell'oggetto incorporato viene visualizzata nel documento. l'oggetto potrebbe contenere informazioni aggiuntive che non viene visualizzato. Se si desidera che il documento contenga solo un rendering dell'oggetto incorporato e non l'effettivo contenuto, utilizzare il
Comando Taglia dal menu Modifica per eliminare l'oggetto e quindi utilizzare il comando Incolla speciale per incollare l'oggetto nel documento utilizzando un formato Metafile. Dopo questa operazione, non modificare l'oggetto incorporato. tuttavia non conterrà tutti i metadati.

Torna all'inizio

Le variabili di documento possono contenere metadati

Importante Prima di utilizzare la seguente macro di esempio, esaminare la declinazione di responsabilità in precedenza in questo articolo.

Per eliminare le variabili di documento sono contenute nel documento di Word, utilizzare la macro di esempio seguente:
Sub DeleteDocVars()

Dim Response
Dim myVar As Variable

For Each myVar In ActiveDocument.Variables
Response = MsgBox("The document variable: " & myVar.Name & vbCr & _
"Value: " & myVar.Value & vbCr & vbCr & _
"Do you want to delete the variable from this document?", vbYesNo)

If Response = "6" Then
' Delete the variable.
myVar.Delete
Else
End
End If
Next myVar

MsgBox "There are no variables in the document."

End Sub
Per ulteriori informazioni sulle variabili, in Visual Basic Editor scegliere Guida in linea di Microsoft Visual Basic dal menu ? , digitare Proprietà variabili nell'Assistente di Office o nella ricerca libera e quindi fare clic su Cerca per visualizzare l'argomento.


Torna all'inizio

Suggerimenti generali sulla protezione

Di seguito sono riportati alcuni suggerimenti generali che è possibile utilizzare per aumentare il livello di protezione dell'ambiente:
  • Quando non si utilizza il computer, consentono di implementare la protezione tramite password di accensione, protetto da password screen saver o la funzione di blocco di Windows NT.
  • Se nel computer sono presenti cartelle condivise, assicurarsi di applicare password a essi in modo che solo gli utenti autorizzati possono accedere le condivisioni. Per maggiore sicurezza, utilizzare il controllo di accesso a livello utente in modo che è possibile controllare esattamente chi accede alle condivisioni del computer.
  • Quando si elimina un file, svuotare il Cestino immediatamente. È possibile prendere in considerazione un'utilità che cancelli o sovrascriva file quando questi vengono eliminati completamente.
  • Quando si esegue il backup dei dati, archiviare i backup in un luogo sicuro, ad esempio una cassaforte, una cassetta di sicurezza o un armadietto dotato di serratura.
  • Assicurarsi che i documenti importanti sono protetti da password in modo che solo gli utenti autorizzati possono aprirli. Conservare le password in un luogo sicuro e separato. Se non si ricorda la password, non è possibile recuperare il contenuto di un documento protetto da password.
  • Non distribuire documenti in formato elettronico. Al contrario, stamparli. Non utilizzare elementi identificativi come caratteri distintivi, filigrane, logo o carta speciale, a meno che non è necessario (ad esempio, per una presentazione).
  • Messaggio di posta elettronica non anonimo. Non di posta elettronica un documento se si teme la propria identità possa essere allegata in alcun modo al documento.
  • Non inviare un documento via Internet utilizzando il protocollo HTTP o FTP File Transfer Protocol (). Le informazioni inviate con questi protocolli sono trasmesse "testo non crittografato", ciò significa che è tecnicamente possibile, tuttavia poco probabile, che vengano intercettate.
Torna all'inizio