Al momento sei offline in attesa che la connessione Internet venga ristabilita

Che si verifichi una riduzione delle prestazioni quando si utilizza Trova orari disponibili in Microsoft Dynamics CRM 2011

Il presente articolo è stato tradotto tramite il software di traduzione automatica di Microsoft e non da una persona. Microsoft offre sia articoli tradotti da persone fisiche sia articoli tradotti automaticamente da un software, in modo da rendere disponibili tutti gli articoli presenti nella nostra Knowledge Base nella lingua madre dell’utente. Tuttavia, un articolo tradotto in modo automatico non è sempre perfetto. Potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli, più o meno allo stesso modo di come una persona straniera potrebbe commettere degli errori parlando una lingua che non è la sua. Microsoft non è responsabile di alcuna imprecisione, errore o danno cagionato da qualsiasi traduzione non corretta dei contenuti o dell’utilizzo degli stessi fatto dai propri clienti. Microsoft, inoltre, aggiorna frequentemente il software di traduzione automatica.

Clicca qui per visualizzare la versione originale in inglese dell’articolo: 2651621
Sintomi
Quando si tenta di utilizzare la funzionalità di pianificazione delle risorse Trova orari disponibili in Microsoft Dynamics CRM, è possibile che si verifichi una riduzione delle prestazioni. Se si utilizza Trova orari disponibili nuovamente e si avvia una nuova query, migliorano le prestazioni e i risultati impiegano meno tempo.
Cause
Questo problema si verifica perché la distribuzione di Microsoft Dynamics CRM contiene molte entità correlate alla pianificazione e l'esecuzione di più query SQL per recuperare i singoli record durante il processo di pianificazione delle risorse di trovare il tempo disponibile.
Risoluzione
Per risolvere questo problema, scaricare e installare aggiornamento cumulativo 8 per Microsoft Dynamics CRM. Per eseguire questa operazione, vedere il seguente articolo della Microsoft Knowledge Base:
2600644 È disponibile l'aggiornamento cumulativo 8 per Microsoft Dynamics CRM 2011

Dopo aver installato l'aggiornamento cumulativo, è necessario creare la seguente chiave del Registro di sistema sul server CRM per le entità correlate alla pianificazione:
SchedulingEngine.CacheConfiguration
In tal caso, queste entità verranno aggiunti alla cache per ottimizzare le prestazioni.

Per creare la chiave del Registro di sistema, attenersi alla seguente procedura:
  1. Sul server Microsoft Dynamics CRM scegliere il Avviare menu e quindi digitare Regedit Nella casella di ricerca per aprire l'Editor del Registro di sistema.
  2. Individuare la seguente sottochiave del Registro di sistema:
    HKEY_LOCAL_MACHINE\SOFTWARE\MICROSOFT\MSCRM
  3. Pulsante destro del mouse MICROSOFT CRM, scegliere Nuovo, quindi fare clic su Valore stringa.
  4. Tipo SchedulingEngine.CacheConfiguration.
  5. Il pulsante destro la nuova chiave e quindi fare clic su Modificare. Le modifiche apportate saranno simile al seguente codice XML. Tuttavia, è possibile che le modifiche dipenderà le entità e le opzioni che si desidera utilizzare. Per informazioni dettagliate, vedere "Informazioni".
    <CachingModes><CachingMode name="BookCaching"><Calendar>DefaultCache</Calendar><CalendarRule>DefaultCache</CalendarRule><Commitment>DefaultCache</Commitment><ConstraintGroup>DefaultCache</ConstraintGroup><Equipment>Direct</Equipment><PluginType>DefaultCache</PluginType><Resource>Direct</Resource><ResourceGroup>DefaultCache</ResourceGroup><ResourceExpansion>DefaultCache</ResourceExpansion><ResourceGroupExpansion>DefaultCache</ResourceGroupExpansion><ResourceSpec>Direct</ResourceSpec><Schedule>DefaultCache</Schedule><Service>DefaultCache</Service><SystemUser>Direct</SystemUser><Team>DefaultCache</Team></CachingMode> <CachingMode name="SearchCaching"><Calendar>DefaultCache</Calendar>... (and other entities like above)</CachingMode><CachingMode name="PublishResourceGroupsCaching"><Calendar>Direct</Calendar>
    (e altre, le entità simili)
    </CachingMode></CachingModes>
Informazioni
Per ogni entità che è possibile aggiungere alla cache, esistono due possibili valori: Diretto e DefaultCache.
  • Valore DefaultCacheSe si tenta di ottimizzare il numero di query SQL e recupera tutti i record alla volta utilizzando una singola query. Una volta recuperati tutti i record, i dati vengono memorizzati nella cache HTTP.
  • Valore Diretto query per ciascun record utilizzando una query separata di SQL.

Nota Se si aggiungono più entità nella cache, utilizzo della memoria può aumentare leggermente a causa delle dimensioni della cache maggiore.

Esistono tre tipi di modalità:
  • SearchCaching. Usata quando "Trova orari disponibili" o si esegue la convalida dell'appuntamento di servizio
  • BookCaching.Utilizzato quando viene salvato un appuntamento
  • PublishResourceGroupCaching. Utilizzato quando i gruppi di risorse vengono riorganizzati e viene eseguita la "pubblica la struttura di risorse"
La modalità per alcune entità può essere impostata collettivamente utilizzando il tag di risorse e il tag ResourceGroups . In alternativa, è possibile impostare separatamente le entità in un livello di dettaglio.

Entità di risorse includono i seguenti sottotipi:
  • Attrezzature
  • SystemUsers
  • ResourceSpec
ResourceGroups entità includono i seguenti sottotipi:
  • ConstraintBasedGroup
  • Team
Pianificazione dei servizi, le prestazioni, della cache

Avviso: questo articolo è stato tradotto automaticamente

Proprietà

ID articolo: 2651621 - Ultima revisione: 05/13/2012 15:52:00 - Revisione: 1.0

Microsoft Dynamics CRM 2011

  • kbautohotfix kbqfe kbhotfixserver kbfix kbmt KB2651621 KbMtit
Feedback
dy>