Symptoms
Assume that some Exchange ActiveSync (EAS) devices are synchronizing with servers in a Microsoft Exchange Server 2010 environment. When you check the status of the EAS devices in Exchange Control Panel (ECP) or by running the Get-ActiveSyncDevice cmdlet in Exchange Management Shell (EMS), the status is unexpectedly marked as Blocked. However, the data is synchronized successfully.
Cause
This issue occurs because the properties of the EAS devices in Active Directory are not updated regularly. Therefore, the actual synchronization status and the properties of the EAS devices that you retrieve from Active Directory are different.
Resolution
To resolve this issue, install the following update rollup:
2891587 Description of Update Rollup 3 for Exchange Server 2010 Service Pack 3
Status
Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.
More Information
For more information about the Get-ActiveSyncDevice cmdlet, go to the following Microsoft website: