Aggiungere o sottrarre tempo

Supponiamo di dover sommare due valori di tempo diversi per ottenere un totale. In caso contrario, è necessario sottrarre un valore di tempo da un altro per ottenere il tempo totale dedicato a un progetto.

Come si può vedere nelle sezioni seguenti, Excel semplifica l'aggiunta o la sottrazione di tempo.

Sommare tempo

Si supponga di voler sapere quante ore e quanti minuti sono necessari per completare due attività. Si stima che la prima attività richiederà 6 ore e 45 minuti e la seconda 9 ore e 30 minuti.

Ecco un modo per configurarlo in un foglio di lavoro.

  1. Immettere 6:45 nella cella B2e 9:30nella cella B3.

  2. Nella cella B4 immettere =B2+B3 e quindi premere INVIO.

    Somma del tempo di due attività

    Il risultato è 16:15, ovvero 16 ore e 15 minuti, per il completamento delle due attività.

    Suggerimento: È possibile sommare tempo anche usando la funzione Somma automatica per sommare numeri. Selezionare la cella B4, quindi nella scheda Home scegliere Somma automatica. La formula avrà l'aspetto seguente: =SOMMA(B2:B3). Premere INVIO per ottenere lo stesso risultato, 16 ore e 15 minuti.

Le cose si complicano quando il tempo supera le 24 ore. È necessario applicare un formato speciale al risultato della formula.

Per sommare più di 24 ore:

  1. Nella cella B2 digitare 12:45 e nella cella B3 digitare 15:30.

  2. Digitare =B2+B3 nella cella B4, quindi premere INVIO.

    Il tempo sommato che supera le 24 ore restituisce un risultato imprevisto di 4:15

    Il risultato è 4:15, che non è quello che ci si potrebbe aspettare. Questo perché il tempo per l'Attività 2 è di 24 ore. 15:30 è uguale a 3:30.

  3. Per visualizzare tempo che supera le 24 ore, selezionare la cella B4.

  4. Nel gruppo Celle della scheda Home scegliere Formato e quindi Formato celle.

    Nella scheda Home, pulsante Formato e pulsante Formato celle nel menu

  5. Nella casella Formato celle scegliere Personalizzato nell'elenco Categoria.

  6. Nella casella Tipo, all'inizio dell'elenco dei formati, digitare [h]:mm;@ e quindi scegliere OK.

    Prendere nota dei due punti dopo [h] e del punto e virgola dopo mm.

Il risultato è 28 ore e 15 minuti. La volta successiva il formato figurerà nell'elenco Tipo.

Sottrarre tempo

Ecco un altro esempio: Supponiamo che tu e i tuoi amici conoscete sia l'ora di inizio che quella di fine di un progetto di volontariato e che vogliate sapere quanto tempo avete trascorso in totale.

Seguire questa procedura per ottenere il tempo trascorso, ovvero la differenza tra due volte.

  1. Nella cella B2 immettere l'ora di inizio e includere "a" per AM o "p" per PM. Quindi premere INVIO.

  2. Nella cella C2 immettere l'ora di fine, inclusa "a" o "p" in base alle esigenze, quindi premere INVIO.

  3. Digitare le altre ore di inizio e fine per gli amici, Carlo e Luisa.

  4. Nella cella D2 sottrarre l'ora di fine dall'ora di inizio immettendo la formula =C2-B2e quindi premere INVIO.

    Sottrazione di un'ora da un'altra per ottenere il tempo trascorso

  5. Nella casella Formato celle scegliere Personalizzato nell'elenco Categoria.

  6. Nell'elenco Tipo fare clic su h:mm(per le ore e i minuti), quindi scegliere OK.

    Davide ha invece lavorato 3 ore e 45 minuti.

    Tempi trascorsi elencati nella colonna D

  7. Per ottenere i risultati per Carlo e Luisa, copiare la formula facendo clic nella cella D2 e trascinando fino alla cella D4.

    La formattazione della cella D2 viene copiata insieme alla formula.

Per sottrarre tempo superiore a 24 ore:

È necessario creare una formula per sottrarre la differenza tra due volte il totale di più di 24 ore.

Seguire la procedura seguente:

  1. Con riferimento all'esempio precedente, selezionare la cella B1 e trascinare fino alla cella B2 in modo da applicare il formato a entrambe le celle contemporaneamente.

  2. Nella casella Formato celle scegliere Personalizzato nell'elenco Categoria.

  3. Nella casella Tipo, all'inizio dell'elenco dei formati, digitare g/m/aaaa h:mm.

    Si noti lo spazio vuoto alla fine di aaaa e alla fine di mm.

    Il nuovo formato sarà disponibile nell'elenco Tipo.

  4. Nella cella B1 digitare la data di inizio, inclusi giorno/mese/anno e l'ora.

    Tempo trascorso che supera le 24 ore

  5. Nella cella B2 eseguire la stessa operazione per la data di fine.

  6. Nella cella B3 digitare la formula =(B2-B1)*24.

Il risultato è 31,5 ore.

Nota: È possibile aggiungere e sottrarre più di 24 ore in Excel per il Web ma non è possibile applicare un formato numero personalizzato.

Aggiungere tempo

Supponiamo di voler sapere quante ore e quanti minuti sono necessari per completare due attività. Si stima che la prima attività richiederà 6 ore e 45 minuti e la seconda 9 ore e 30 minuti.

  1. Nella cella B2 digitare 6:45 e nella cella B3 digitare 9:30.

  2. Digitare =B2+B3 nella cella B4, quindi premere INVIO.

Somma del tempo di due attività

Per completare le due attività saranno necessarie 16 ore e 15 minuti.

Suggerimento: È anche possibile sommare i tempi usando Somma automatica. Fare clic nella cella B4. Quindi fare clic su Home > Somma automatica. La formula avrà l'aspetto seguente: =SOMMA(B2:B3). Premere INVIO per ottenere il risultato, 16 ore e 15 minuti.

Sottrarre tempo

Supponiamo di conoscere l'ora di inizio e di fine di un progetto e di voler calcolare il tempo trascorso su di esso. In altre parole, si desidera calcolare la differenza tra i due tempi.

  1. Nella cella B2 digitare l'ora di inizio, immettere uno spazio, quindi digitare "a" per AM o "p" per PM, quindi premere INVIO. Nella cella C2 digitare l'ora di fine, incluso "a" o "p", quindi premere INVIO. Digitare l'ora di inizio e di fine di altri due colleghi Carlo e Luisa.

  2. Nella cella D2 sottrarre l'ora di fine dall'ora di inizio digitando la formula: =C2-B2, quindi premere INVIO.

Sottrazione di un'ora da un'altra per ottenere il tempo trascorso

Davide ha invece lavorato 3 ore e 45 minuti.

  1. Per ottenere i risultati per Carlo e Luisa, copiare la formula facendo clic nella cella D2 e trascinando fino alla cella D4. La formattazione della cella D2 viene copiata insieme alla formula.

Tempi trascorsi elencati nella colonna D

Serve aiuto?

Amplia le tue competenze su Office
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×