Supponiamo di voler sapere quanto tempo è necessario per completare un'operazione sulla linea di assemblaggio o un ordine di fast food nelle ore di punta. Esistono diversi modi per calcolare la differenza tra due volte.

Presentare il risultato nel formato ora standard

Esistono due approcci che è possibile adottare per presentare i risultati nel formato ora standard (ore : minuti : secondi). Usare l'operatore di sottrazione (-) per trovare la differenza tra le ore e quindi eseguire una delle operazioni seguenti:

Applicare un codice di formato personalizzato alla cella eseguendo le operazioni seguenti:

  1. Selezionare la cella.

  2. Nel gruppo Numero della scheda Homefare clic sulla freccia accanto alla casella Generale e quindi su Altri formati numero.

  3. Nella finestra di dialogo Formato celle fare clic su Personalizzato nell'elenco Categoria e quindi selezionare un formato personalizzato nella casella Tipo.

Usare la funzione TESTO per formattare gli orari: Quando si usano i codici di formato dell'ora, le ore non superano mai 24, i minuti non superano mai 60 e i secondi non superano mai 60.

Tabella 1 di esempio: presentare il risultato nel formato ora standard

Copiare la tabella seguente in un foglio di lavoro vuoto e quindi modificarla, se necessario.

A

B

1

Ora di inizio

Ora di fine

2

9/6/2007 10:35

9/6/2007 15.30

3

Formula

Descrizione (risultato)

4

=B2-A2

Ore tra due orari (4). È necessario applicare manualmente il formato personalizzato "h" alla cella.

5

=B2-A2

Ore e minuti compresi tra due orari (4:55). È necessario applicare manualmente il formato personalizzato "h:mm" alla cella.

6

=B2-A2

Ore, minuti e secondi compresi tra due orari (4:55:00). È necessario applicare manualmente il formato personalizzato "h:mm:ss" alla cella.

7

=TESTO(B2-A2;"h")

Ore tra due ore con la cella formattata come "h" usando la funzione TESTO (4).

8

=TESTO(B2-A2;"h:mm")

Ore e minuti compresi tra due orari con la cella formattata come "h:mm" usando la funzione TESTO (4:55).

9

=TESTO(B2-A2;"h:mm:ss")

Ore, minuti e secondi compresi tra due orari con la cella formattata come "h:mm:ss" usando la funzione TESTO (4:55:00).

Nota: Se si usa sia un formato applicato alla funzione TESTO che un formato numerico alla cella, la funzione TESTO avrà la precedenza sulla formattazione della cella.

Per altre informazioni su come usare queste funzioni, vedere Funzione TESTO e Visualizzare numeri come date o ore.

Tabella 2 di esempio: presentare il risultato in base a una singola unità di tempo

Per eseguire questa attività, si userà la funzione INT o le funzioni ORA,MINUTOe SECONDO, come illustrato nell'esempio seguente.

Copiare la tabella seguente in un foglio di lavoro vuoto e quindi modificarla in base alle esigenze.

A

B

1

Ora di inizio

Ora di fine

2

9/6/2007 10:35

9/6/2007 15.30

3

Formula

Descrizione (risultato)

4

=INT((B2-A2)*24)

Totale ore tra due orari (4)

5

=(B2-A2)*1440

Totale minuti tra due orari (295)

6

=(B2-A2)*86400

Totale secondi tra due orari (17700)

7

=ORA(B2-A2)

Differenza nell'unità oraria tra due orari. Questo valore non può essere maggiore di 24 (4).

8

=MINUTO(B2-A2)

Differenza nell'unità dei minuti tra due orari. Questo valore non può essere maggiore di 60 (55).

9

=SECONDO(B2-A2)

Differenza nell'unità di misura dei secondi tra due tempi. Questo valore non può essere maggiore di 60 (0).

Per altre informazioni su come usare queste funzioni, vedere Int (funzione INT),ORA (funzione HOUR),MINUTE (funzione MINUTE)e SECOND (funzione SECOND).

Serve aiuto?

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa a Microsoft Insider

Queste informazioni sono risultate utili?

Quanto ti soddisfa la qualità della traduzione?
Cosa ha influito sulla tua esperienza?

Grazie per il feedback!

×