Come correggere un errore #RIF! errore

L'errore #RIF! viene visualizzato quando una formula fa riferimento a una cella non valida. L'errore si verifica spesso quando le celle a cui fanno riferimento le formule vengono eliminate o sovrascritte con Incolla.

Esempio: errore #RIF! causato dall'eliminazione di una colonna

L'esempio seguente usa la formula =SOMMA(B2,C2,D2) nella colonna E.

Una formula che usa riferimenti di cella espliciti come =SOMMA(B2,C2,D2) può causare un errore #RIF! se una colonna viene eliminata.

Se si elimina la colonna B, C o D, viene restituito un errore #RIF!. . In questo caso viene eliminata la colonna C (Vendite 2007) e la formula diventa =SOMMA(B2,#RIF!,C2). Quando si usano riferimenti di cella espliciti simili al seguente, in cui si fa riferimento alle singole celle separate da un punto e virgola, e si elimina una riga o una colonna a cui si fa riferimento, Excel non riesce a risolvere la formula e restituisce l'errore #RIF! . Questo è il motivo principale per cui non si consiglia di usare i riferimenti di cella espliciti nelle funzioni.

Esempio di errore #RIF! causato dall'eliminazione di una colonna.

Soluzione

  • Se si eliminano accidentalmente righe o colonne, è possibile ripristinarle facendo subito clic sul pulsante Annulla nella barra di accesso rapido o premendo CTRL+Z.

  • Modificare la formula in modo che usi il riferimento a un intervallo invece che a singole celle, ad esempio =SOMMA(B2:D2). Ora è possibile eliminare qualsiasi colonna all'interno dell'intervallo della somma ed Excel modifica automaticamente la formula. È anche possibile usare =SOMMA(B2:B5) per sommare le righe.

Esempio: CERCA.VERT con riferimenti a un intervallo non corretti

Nell'esempio seguente =CERCA.VERT(A8,A2:D5,5,FALSO) restituisce un errore #RIF! perché cerca un valore da restituire per la colonna 5, ma l'intervallo di riferimento è A:D, che contiene solo 4 colonne.

Esempio di formula CERCA.VERT con un intervallo non corretto.  La formula è =CERCA.VERT(A8,A2:D5,5,FALSO).  L'intervallo CERCA.VERT non contiene una quinta colonna, quindi 5 restituisce un errore #RIF! .

Soluzione

Aumentare l'intervallo o ridurre il valore di ricerca sulle colonne in modo che corrisponda all'intervallo di riferimento. =CERCA.VERT(A8,A2:E5,5,FALSO) e = CERCA.VERT(A8,A2:D5,4,FALSO) rappresentano due intervalli di riferimento validi.

Esempio: INDICE con riferimento di riga o di colonna non corretto

In questo esempio la formula =INDICE(B2:E5,5,5) restituisce un errore #RIF! perché l'intervallo INDICE è di 4 righe per 4 colonne, mentre la formula chiede di restituire il contenuto della quinta riga e della quinta colonna.

Esempio di formula INDICE con un riferimento a un intervallo non valido.  La formula è =INDICE(B2:E5,5,5), ma l'intervallo è solo 4 righe per 4 colonne.

Soluzione

Modificare i riferimenti di riga o colonna in modo che siano compresi nell'intervallo di ricerca INDICE. =INDICE(B2:E5,4,4) restituisce un risultato valido.

Esempio: riferimento a una cartella di lavoro chiusa con INDIRETTO

Nell'esempio seguente, una funzione INDIRETTO prova a fare riferimento a una cartella di lavoro chiusa, causando un errore #RIF! .

Esempio di errore #RIF! causato da un riferimento INDIRETTO a una cartella di lavoro chiusa.

Soluzione

Aprire la cartella di lavoro a cui si fa riferimento. Si verifica lo stesso errore se si fa riferimento a una cartella di lavoro chiusa con una funzione di matrice dinamica.

Problemi OLE

Se si è usato un collegamento OLE (Object Linking and Embedding, collegamento ed incorporamento di oggetti) che restituisce un errore #RIF!, avviare il programma a cui il collegamento fa riferimento.

Nota: OLE è una tecnologia che consente di condividere informazioni tra i programmi.

Problemi DDE

Se è stato usato un argomento DDE (Dynamic Data Exchange) che restituisce un errore #RIF!, verificare prima di tutto di fare riferimento all'argomento corretto. Se si riceve ancora un errore #RIF!, controllare le impostazioni del Centro protezione per il contenuto esterno, come descritto in Bloccare o sbloccare il contenuto esterno nei documenti di Office.

Nota: DDE (Dynamic Data Exchange)è un protocollo consolidato per lo scambio di dati tra programmi basati su Microsoft Windows.

Problemi con le macro

Se una macro immette nel foglio di lavoro una funzione che fa riferimento a una cella sopra la funzione e la cella contenente la funzione si trova nella riga 1, viene restituito #RIF! perché non ci sono celle sopra la riga 1. Controllare la funzione per vedere se un argomento fa riferimento a una cella o a un intervallo di celle non valido. Questa operazione può richiedere la modifica della macro in Visual Basic Editor (VBE) per verificare la situazione.

Servono altre informazioni?

È sempre possibile rivolgersi a un esperto nella Tech Community di Excel oppure ottenere supporto nella community Microsoft.

Vedere anche

Panoramica delle formule in Excel

Come evitare errori nelle formule

Rilevare gli errori nelle formule

Funzioni di Excel (in ordine alfabetico)

Funzioni di Excel (in base alla categoria)

Serve aiuto?

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa a Microsoft Office Insider

Queste informazioni sono risultate utili?

Come valuti la qualità della lingua?
Cosa ha influito sulla tua esperienza?

Grazie per il feedback!

×