Se MEDIA o SOMMA fanno riferimento a celle che contengono #VALUE! , le formule avranno come risultato un errore #VALUE! .

Errore #VALORE! in MEDIA

Per ignorare i valori di errore, viene costruita una formula che ignora gli errori nell'intervallo riferimento durante il calcolo della media con i valori "normali" restanti.

Per risolvere questo scenario, viene usata una combinazione di MEDIA e SE più VAL.ERROREper determinare se è presente un errore nell'intervallo specificato. Questo specifico scenario richiede una formula di matrice:

=MEDIA(SE(VAL.ERRORE(B2:D2),"",B2:D2))

Si tratta di una formula di matrice. Quindi è necessario premere INVIO (solo se si usa Microsoft 365 ) o CTRL+MAIUSC+INVIO nella formula.

Nota: Se si ha una versione corrente di Microsoft 365, è sufficiente immettere la formula nella cella di output, quindi premere INVIO per confermare la formula come formula di matrice dinamica. In caso contrario, è necessario immettere la formula come formula di matrice legacy selezionando prima la cella di output, immettendo la formula nella cella di output e quindi premendo CTRL+MAIUSC+INVIO per confermarla. Excel inserisce automaticamente parentesi graffe all'inizio e alla fine della formula. Per ulteriori informazioni sulle formule di matrice, vedere Formule di matrice: indicazioni ed esempi.

Funzione di matrice in MEDIA per risolvere il #VALUE! #BUSY!

Nota: La funzione precedente non funziona solo per #VALORE!, ma anche per #N/D, #NULLO, #DIV/0! e altre funzioni.

È possibile usare SOMMA in modo analogo:

=SOMMA(SE(VAL.ERRORE(B2:D2),"",B2:D2))

Domande su funzioni specifiche?

Pubblicare una domanda nel forum della community di Excel

Servono altre informazioni?

È sempre possibile rivolgersi a un esperto nella Tech Community di Excel oppure ottenere supporto nella community Microsoft.

Vedere anche

Correggere un errore #VALORE! #BUSY!

MEDIA

SOMMA

Panoramica delle formule in Excel

Rilevare gli errori nelle formule

Tutte Excel (in ordine alfabetico)

Funzioni di Excel (in base alla categoria)

Serve aiuto?

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa a Microsoft Office Insider

Queste informazioni sono risultate utili?

Come valuti la qualità della lingua?
Cosa ha influito sulla tua esperienza?

Grazie per il feedback!

×