Come correggere un errore #VALORE! nelle funzioni INDICE/CONFRONTA

Questo argomento illustra gli scenari comuni in cui viene restituito l'errore #VALORE! quando si usano le funzioni INDICE E CONFRONTA contemporaneamente in una formula. La combinazione di INDICE e CONFRONTA viene usata spesso quando si vuole cercare un valore in uno scenario in cui non è possibile usare CERCA.VERT, ad esempio quando il valore di ricerca ha più di 255 caratteri.

Problema: La formula non è stata immessa come matrice

Se si usa INDEX come formula di matrice insieme a MATCH per poter recuperare un valore, sarà necessario convertire la formula in una formula in forma di matrice, altrimenti si vedrà un #VALUE. .

Soluzione: INDICE e CONFRONTA devono essere usati come una formula di matrice, quindi è necessario premere CTRL+MAIUSC+INVIO. La formula viene inserita automaticamente tra parentesi graffe {}. Se si prova a immettere la formula manualmente, Excel la visualizza come testo.

Se si usa INDICE/CONFRONTA quando si ha un valore di ricerca con più di 255 caratteri, è necessario immetterlo come formula di matrice.  La formula nella cella F3 è =INDICE(B2:B4,CONFRONTA(VERO,A2:A4=F2,0),0) e viene immessa premendo Ctrl+MAIUSC+INVIO

Nota: Se si ha una versione corrente di Microsoft 365, è possibile immettere semplicemente la formula nella cella di output, quindi premere invio per confermare la formula come formula di matrice dinamica. In caso contrario, la formula deve essere immessa come formula di matrice legacy selezionando prima la cella di output, immettendo la formula nella cella di output e premendo CTRL + MAIUSC + INVIO per confermarla. Excel inserisce le parentesi graffe all'inizio e alla fine della formula. Per ulteriori informazioni sulle formule di matrice, vedere Formule in forma di matrice: indicazioni ed esempi.

Servono altre informazioni?

È sempre possibile rivolgersi a un esperto nella Tech Community di Excel, ottenere supporto nella community Microsoft o suggerire una nuova caratteristica o un miglioramento in Excel UserVoice.

Vedere anche

Correggere un errore #VALORE! #NAME?

INDICE

CONFRONTA

Cercare valori con VLOOKUP, INDEX o MATCH

Panoramica delle formule in Excel

Come evitare errori nelle formule

Rilevare gli errori nelle formule

Tutte le funzioni di Excel (in ordine alfabetico)

Funzioni di Excel (in base alla categoria)

Nota:  Questa pagina è stata tradotta automaticamente e potrebbe contenere errori di grammatica o imprecisioni. L'intento è quello di rendere fruibile il contenuto. Queste informazioni sono risultate utili' Questo è l'articolo in inglese per riferimento.

Amplia le tue competenze su Office
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×