Creare un diagramma classi UML

È possibile creare un diagramma classi UML per mostrare una visualizzazione statica delle classi, degli attributi e dei metodi di un sistema e delle relazioni tra gli oggetti. Offre una panoramica di un'applicazione.

Le edizioni professionali di Visio includono il supporto per il diagramma di classi UML e lo stencil, ma le edizioni standard non lo fanno.)

Esempio di diagramma di classe UML che Mostra gli account di systemof di una banca per clienti personali.

Quando si avvia un nuovo diagramma di classe, viene visualizzato lo stencil della classe UML insieme alle forme conformi allo standard UML 2,5.

  1. Avviare Visio. In alternativa, se è già aperto un file, fare clic su File > Nuovo.

  2. Nella casella di ricerca digitare classe UML.

  3. Selezionare il diagramma classi UML .

  4. Nella finestra di dialogo selezionare il modello vuoto o uno dei tre diagrammi iniziali. Una descrizione di ognuno viene visualizzata a destra quando la si seleziona. Quindi selezionare unità metriche o unità USA.

  5. Selezionare Crea.

  6. Il diagramma viene aperto. Accanto al diagramma dovrebbe comparire la finestra Forme. Se non è visibile, vedere visualizzare > riquadri attività e verificare che sia selezionata l'opzione forme . Se ancora non viene visualizzato, fare clic sul pulsante Espandi la finestra forme a sinistra.

  7. Nella scheda Visualizza assicurarsi che la casella di controllo accanto a Punti di connessione sia selezionata. Questa opzione consente di visualizzare i punti di connessione quando si avvia la connessione delle forme.

  8. A questo punto, trascinare le forme da includere in un diagramma dalla finestra Forme alla pagina. Per rinominare le etichette di testo, fare doppio clic sulle etichette.

  9. Per aggiungere altri membri alla forma della classe, dell'enumerazione o dell'interfaccia, trascinare la forma membro dal pannello forma alla rispettiva forma. È anche possibile aggiungere un nuovo membro facendo clic con il pulsante destro del mouse su un membro esistente e scegliendo l'opzione per l'inserimento di un membro.

    Aggiungere un nuovo membro facendo clic con il pulsante destro del mouse su un membro esistente e scegliendo l'opzione per l'inserimento di un membro.

  10.  Connettere due forme con i connettori UML per rappresentare le relazioni tra le forme. Per modificare i tipi di relazione, fare clic con il pulsante destro del mouse sul connettore. Scegliere la relazione desiderata dal menu Imposta tipo di connettore .

    Fare clic con il pulsante destro del mouse su un connettore e scegliere Imposta tipo di connettore per visualizzare le opzioni per i tipi di connettore.

  11.  Ridimensionare una classe, un'enumerazione o una forma di interfaccia facendo clic sull'intestazione della forma per selezionarla e quindi spostando il punto di controllo giallo (sul bordo destro della forma) a sinistra o a destra per diminuire o aumentare la larghezza della forma.

  12.  Aggiungere campi parametro e stereotipo alle forme della classe selezionando la forma, facendo clic con il pulsante destro del mouse e scegliendo l'opzione corrispondente dal menu a comparsa.

    Aggiungere campi parametro e stereotipo alle forme della classe facendo clic con il pulsante destro del mouse su una forma.

Prima di tutto, si crea un diagramma e si aggiunge uno stencil della classe UML che contiene forme conformi allo standard UML 2,5.

  1. Aprire Visio per il Web.

  2. Nella raccolta scorrere verso il basso fino alla riga della classe UML , verso la metà della pagina.

    Il primo elemento della riga rappresenta un modello vuoto più lo stencil complementare. Gli altri elementi della riga sono diagrammi di esempio con alcune forme già disegnate per aiutarti a iniziare rapidamente.

  3. Fare clic su un elemento per visualizzare un'anteprima più grande.

  4. Quando si trova il diagramma che si vuole usare, fare clic sul relativo pulsante Crea .

    Il nuovo diagramma, con lo stencil correlato, viene aperto nel browser. Si è pronti per iniziare a disegnare il diagramma.

  5. A questo punto, trascinare le forme da includere in un diagramma dalla finestra Forme alla pagina. Per rinominare le etichette di testo, fare doppio clic sulle etichette.

  6. Per aggiungere altri membri alla forma della classe, dell'enumerazione o dell'interfaccia, trascinare la forma membro dal pannello forma alla rispettiva forma. È anche possibile aggiungere un nuovo membro facendo clic con il pulsante destro del mouse su un membro esistente e scegliendo l'opzione per l'inserimento di un membro.

    Aggiungere un nuovo membro facendo clic con il pulsante destro del mouse su un membro esistente e scegliendo l'opzione per l'inserimento di un membro.

  7.  Connettere due forme con i connettori UML per rappresentare le relazioni tra le forme. Per modificare i tipi di relazione, fare clic con il pulsante destro del mouse sul connettore. Scegliere la relazione desiderata dal menu Imposta tipo di connettore .

    Fare clic con il pulsante destro del mouse su un connettore e scegliere Imposta tipo di connettore per visualizzare le opzioni per i tipi di connettore.

  8.  Ridimensionare una classe, un'enumerazione o una forma di interfaccia facendo clic sull'intestazione della forma per selezionarla e quindi spostando il punto di controllo giallo (sul bordo destro della forma) a sinistra o a destra per diminuire o aumentare la larghezza della forma.

  9.  Aggiungere campi parametro e stereotipo alle forme della classe selezionando la forma, facendo clic con il pulsante destro del mouse e scegliendo l'opzione corrispondente dal menu a comparsa.

    Aggiungere campi parametro e stereotipo alle forme della classe facendo clic con il pulsante destro del mouse su una forma.

Prima di tutto, è possibile selezionare il diagramma classi UML , che include uno stencil della classe che contiene forme conformi alla specifica UML 2,0.

  1. Avviare Visio. In alternativa, se è già aperto un file, fare clic su File > Nuovo.

  2. Nella casella di ricerca digitare classe UML.

  3. Selezionare il diagramma classi UML .

  4. Nella finestra di dialogo selezionare unità metriche o unità USA.

  5. Selezionare Crea.

  6. Il diagramma viene aperto. Dovresti vedere lo stencil della classe UML nella finestra forme accanto al diagramma. Se non è visibile, vedere visualizzare > riquadri attività e verificare che sia selezionata l'opzione forme . Se ancora non è visibile, selezionare la freccia a sinistra del margine sinistro della finestra espandere il pulsante finestra forme.

  7. Nella scheda Visualizza assicurarsi che la casella di controllo accanto a Punti di connessione sia selezionata. Questa opzione consente di visualizzare i punti di connessione quando si avvia la connessione delle forme.

  8. A questo punto, trascinare le forme da includere in un diagramma dalla finestra Forme alla pagina. Per rinominare le etichette di testo, fare doppio clic sulle etichette.

In Visio 2010 la modalità di creazione di un diagramma classi UML consiste nell'uso di un diagramma a struttura statica. Per informazioni dettagliate, vedere creare un diagramma di struttura statica UML .

Suggerimenti per la creazione di un diagramma classi

  • Identificare ogni elemento e le relative relazioni.

  • Identificare chiaramente la responsabilità di ogni classe.

  • Non includere nel diagramma proprietà non necessarie che potrebbero renderlo troppo complicato.

Notazione della classe

Simbolo

Significato

-

L'attributo o l'operazione è privata.

+

L'attributo o l'operazione è pubblica.

Vedere anche

Diagrammi UML in Visio

Amplia le tue competenze su Office
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×