Importante
Il supporto per Microsoft InfoPath 2013 è terminato il 14 luglio 2026. È consigliabile eseguire la migrazione dei moduli e dei flussi di lavoro di InfoPath esistenti alle soluzioni Microsoft 365 supportate. Altre informazioni sul ritiro di InfoPath.
Le caselle di riepilogo a catena consentono agli utenti di compilare i moduli più rapidamente e di immettere i dati correttamente. Questo articolo descrive come creare e popolare le caselle di riepilogo a catena con i dati. In Microsoft Office InfoPath è possibile popolare un elenco con dati che usano valori della maschera, valori di un documento XML (Extensible Markup Language) esterno o valori di un database di Microsoft Office Access.
Contenuto dell'articolo
- Che cos'è una casella di riepilogo a catena?
- Passaggio 1: Inserire una casella di riepilogo a catena
- Passaggio 2: Fornire i dati
Che cos'è una casella di riepilogo a catena?
Una casella di riepilogo a catena è una casella di riepilogo con scelte che cambiano in base al valore selezionato dall'utente in un'altra casella di riepilogo. Ad esempio, se un utente fa clic su Condimenti nella casella Categorie mostrata nella figura seguente, nella casella Prodotti verrà visualizzato un elenco di condimenti.
Le sezioni seguenti descrivono come progettare un modello di modulo con due caselle di riepilogo, in cui la seconda casella di riepilogo viene filtrata in base al valore selezionato dall'utente nella prima casella di riepilogo. Quando il valore della prima casella di riepilogo cambia, il filtro viene applicato automaticamente alla seconda casella di riepilogo, che cambia i suoi valori.
Considerazioni sulla compatibilità
I filtri possono essere usati solo nei modelli di modulo progettati per essere compilati in InfoPath. I filtri non sono disponibili nei modelli di modulo compatibili con browser.
Inizio pagina
Passaggio 1: Inserire una casella di riepilogo a catena
Per creare una casella di riepilogo a catena, è necessario inserire due caselle di riepilogo nel modello di modulo.
Nota
Quando si inserisce una casella di riepilogo a catena nel modello di modulo, verificare che le due caselle di riepilogo non si trovino in una sezione o in una tabella ripetuta.
- Se il riquadro attività Controlli non è visibile, fare clic su Altri controlli nel menu Inserisci oppure premere ALT+I, C.
- In Inserisci controlli nel riquadro attività Controlli fare clic su Casella di riepilogo a discesa. Quando un utente compila un modulo basato sul modello di modulo, la selezione in questa casella di riepilogo a discesa determinerà le scelte disponibili nella seconda casella di riepilogo.
- Fare clic sulla casella di riepilogo. Il modello di modulo dovrebbe ora contenere una casella di riepilogo a discesa e una casella di riepilogo standard.
- Fare doppio clic sulla casella di riepilogo a discesa inserita nel modello di modulo nel passaggio 2.
- Nella finestra di dialogo Proprietà casella di riepilogo a discesa fare clic sulla scheda Dati .
- Nella casella Nome campo digitare listBox1 e quindi fare clic su OK.
- Fare doppio clic sulla casella di riepilogo inserita nel modello di modulo nel passaggio 3.
- Nella finestra di dialogo Proprietà casella di riepilogo fare clic sulla scheda Dati .
- Nella casella Nome campo digitare listBox2Cascade e quindi fare clic su OK.
Inizio pagina
Passaggio 2: Fornire i dati
Dopo aver inserito le caselle di riepilogo nel modello di modulo, è necessario fornire i dati che verranno visualizzati. Quindi occorre applicare un filtro in modo che le scelte nella seconda casella di riepilogo siano basate sulla selezione effettuata dall'utente nella prima casella di riepilogo.
In questa sezione viene illustrato come connettere le caselle di riepilogo ai dati usando tre metodi comuni: aggiunta dei dati alla maschera stessa; connessione del modulo a un documento XML esistente che contiene i dati; o connettere la maschera a un database che contiene i dati. Per completare la creazione della casella di riepilogo a catena, fare clic sul metodo che si desidera utilizzare nell'elenco seguente.
Connettersi ai dati nel modulo
In questa sezione verrà illustrato come popolare le caselle di riepilogo con i dati della maschera. A tale scopo, è necessario innanzitutto configurare i campi nel modello di modulo in modo da poter immettere i nomi delle categorie e un set di prodotti per ogni categoria.
Configurare i campi nel modello di modulo
- Se il riquadro attività Origine dati non è visibile, scegliere Origine dati dal menu Visualizza .
- Nel riquadro attività Origine dati fare clic con il pulsante destro del mouse sul gruppo myFields e quindi scegliere Aggiungi.
- Nella finestra di dialogo Aggiungi campo o gruppo della casella Nome digitare CategoriesAndProducts.
- Nell'elenco Tipo , fare clic su Gruppo.
- Selezionare la casella di controllo Ripetizione e quindi fare clic su OK.
- Nel riquadro attività Origine dati fare clic con il pulsante destro del mouse sul gruppo CategoriesAndProducts .
- Nella finestra di dialogo Aggiungi campo o gruppo della casella Nome digitare Categoria e quindi fare clic su OK. Questo campo conterrà i nomi delle categorie per la prima casella di riepilogo.
- Fare clic con il pulsante destro del mouse sul gruppo CategoriesAndProducts , quindi scegliere Aggiungi.
- Nella finestra di dialogo Aggiungi campo o gruppo della casella Nome digitare Prodotto.
- Selezionare la casella di controllo Ripetizione e quindi fare clic su OK. Questo campo conterrà i nomi dei prodotti per la seconda casella di riepilogo.
Poiché questa casella di riepilogo viene popolata con i dati della maschera, è necessario che i dati vengano aggiunti alla maschera. A tale scopo, è necessario creare valori predefiniti per i campi Prodotto e Categoria .
Suggerimento
È anche possibile creare caselle di riepilogo in cui vengono visualizzati i valori digitati dagli utenti nel modulo. A tale scopo, associare la casella di riepilogo ai campi associati ai controlli nella maschera. Quando un utente immette valori nei controlli, le opzioni nella casella di riepilogo cambiano.
Crea valori predefiniti
- Scegliere Valori predefiniti dal menu Strumenti.
- Nel gruppo CategorieAndProdotti della finestra di dialogo Modifica valori predefiniti selezionare il campo Categoria (non deselezionare la casella di controllo) e quindi nella casella Valore predefinito digitare Pesce.
- Selezionare il campo Prodotto (non deselezionare la casella di controllo), quindi nella casella Valore predefinito digitare Polpa di granchio.
- Fare clic con il pulsante destro del mouse sul campo Prodotto e quindi fare clic su Aggiungi un altro prodotto sopra. In questo modo è possibile aggiungere un secondo prodotto per Seafood come valore predefinito.
- Fare clic con il pulsante destro del mouse sulla seconda istanza del campo Prodotto (senza deselezionare la casella di controllo), quindi nella casella Valore predefinito digitare Salmone.
- Fare clic con il pulsante destro del mouse sul gruppo CategoriesAndProducts , quindi scegliere Aggiungi un altro CategoriesAndProducts di seguito. In questo modo è possibile aggiungere una seconda categoria come valore predefinito.
- Utilizzare i passaggi precedenti per specificare i valori predefiniti per la seconda istanza dei campi Categoria e Prodotto rispettivamente per Latticini, Cheddar e Latte al cioccolato.
- Fare clic su OK.
Dopo aver immesso i valori predefiniti per i campi Prodotto e Categoria , è possibile connettere la prima casella di riepilogo ai dati appena immessi.
Connettere la prima casella di riepilogo ai dati
- Nel modello di modulo fare doppio clic sulla casella di riepilogo a discesa inserita in precedenza.
- Fare clic sulla scheda Dati.
- Nella finestra di dialogo Proprietà casella di riepilogo a discesa , in Voci casella di riepilogo, fare clic su Cerca valori nell'origine dati del modulo.
- Fate clic su Seleziona XPath
accanto alla casella Voci (Entries box). - Nel gruppo CategorieAndProdotti della finestra di dialogo Selezionare un campo o un gruppo fare clic sul campo Categoria e quindi due volte su OK.
A questo punto è necessario connettere la seconda casella di riepilogo ai dati. Durante questa connessione dati, è consigliabile applicare un filtro alla seconda casella di riepilogo. Questo filtro popola la seconda casella di riepilogo con i prodotti appropriati, in base alla categoria selezionata nella prima. Il filtro confronta il valore selezionato nella prima casella di riepilogo (campo listBox1) con l'elenco di categorie salvate nel modulo (campo Categoria).
Connettere la seconda casella di riepilogo ai dati
- Nel modello di modulo fare doppio clic sulla casella di riepilogo standard inserita in precedenza.
- Fare clic sulla scheda Dati.
- Nella finestra di dialogo Proprietà casella di riepilogo , in Voci casella di riepilogo, fare clic su Cerca valori nell'origine dati della maschera.
- Fate clic su Seleziona XPath
accanto alla casella Voci (Entries box). - Nel gruppo CategorieAndProdotti della finestra di dialogo Selezionare un campo o un gruppo fare clic sul campo Prodotto e quindi su Filtra dati.
- Nella finestra di dialogo Filtra dati , fare clic su Aggiungi.
- Nella finestra di dialogo Specificare le condizioni di filtro , fare clic su Seleziona un campo o un gruppo nella prima casella.
- Nella finestra di dialogo Seleziona un campo o un gruppo fare clic su listBox1 e quindi su OK.
- Nella finestra di dialogo Specifica condizioni di filtro , fare clic su Seleziona un campo o un gruppo nella terza casella.
- Nella finestra di dialogo Selezionare un campo o un gruppo fare clic sul campo Categoria e quindi su OK per chiudere tutte le finestre di dialogo aperte.
Dopo aver connesso la seconda casella di riepilogo ai dati e applicato il filtro, è possibile testare le caselle di riepilogo per verificarne il corretto funzionamento.
Testare le caselle di riepilogo
Per verificare le modifiche, fare clic su Anteprima nella barra degli strumenti Standard oppure premere CTRL+MAIUSC+B.
Nella casella dell'elenco a discesa, fare clic su Frutti di mare. La casella di riepilogo standard dovrebbe mostrare una riga vuota, Polpa di granchio e Salmone.
Nota
La riga vuota consente agli utenti di deselezionare la propria scelta nella casella di riepilogo.
Se le caselle di riepilogo non funzionano correttamente, rivedere il filtro per la seconda casella di riepilogo per assicurarsi che il campo listBox1 venga confrontato con il campo Categoria .
Connettersi a un documento XML esterno
In questa sezione imparerai come creare una connessione dati a un documento XML contenente valori di prodotto e di categoria. Il documento XML sarà l'origine dati secondaria. Per creare questa connessione dati, è necessario creare il documento XML, associare le caselle di riepilogo nel modello di modulo al documento XML e quindi applicare un filtro alla seconda casella di riepilogo in modo che l'elenco dei prodotti venga modificato in modo appropriato.
Prima di poter associare la maschera a un'origine dati secondaria, è necessario creare il documento XML.
Creare il documento XML
Avviare il Blocco note o un altro editor di testo.
Copia e incolla i seguenti dati XML nell'editor di testo:
<?xml version="1.0" encoding="UTF-8"?> <ListBoxData> <CategoriesAndProducts> <Categories>Seafood</Categories> <Products> <Product>Crab meat</Product> </Products> <Products> <Product>Salmon</Product> </Products> </CategoriesAndProducts> <CategoriesAndProducts> <Categories>Dairy</Categories> <Products> <Product>Chocolate milk</Product> </Products> <Products> <Product>Cheddar</Product> </Products> </CategoriesAndProducts> </ListBoxData>Salva il file sul tuo computer come listBoxData.xml.
Dopo aver creato un documento XML, è possibile connetterlo al modello di modulo. Verrà creata un'origine dati secondaria.
Connettere il documento XML al modello di modulo
- Scegliere Connessioni dati dal menu Strumenti.
- Nella finestra di dialogo Connessioni dati fare clic su Aggiungi.
- Nella Creazione guidata connessione dati fare clic su Ricevi dati e quindi su Avanti.
- Nella pagina successiva della procedura guidata fare clic su Documento XML e quindi su Avanti.
- Nella pagina successiva della procedura guidata fare clic su Sfoglia, selezionare il filelistBoxData.xml salvato nel computer e quindi fare clic su Apri.
- Nella pagina successiva della procedura guidata fare clic su Includi i dati come file di risorse nella maschera o nella parte modello di modulo e quindi fare clic su Avanti.
- Nella pagina successiva della procedura guidata, nell'immettere un nome per la connessione dati , digitare listBoxDataXMLFile.
- Selezionare la casella di controllo Recupera automaticamente i dati all'apertura della maschera . In questo modo i dati della casella di riepilogo saranno disponibili a ogni apertura della maschera, invece di richiedere all'utente di eseguire una query.
- Fare clic su Fine.
- Nella finestra di dialogo Connessioni dati fare clic su Chiudi.
A questo punto è possibile collegare la prima casella di riepilogo nel modello di modulo ai dati nel documento XML.
Connettere la prima casella di riepilogo ai dati
Nel modello di modulo fare doppio clic sulla casella di riepilogo a discesa inserita in precedenza.
Fare clic sulla scheda Dati.
Nella finestra di dialogo Proprietà casella di riepilogo a discesa , in Voci casella di riepilogo, fare clic su Cerca valori da un'origine dati esterna.
Nella casella Origine dati fare clic su listBoxDataXMLFile.
Fate clic su Seleziona XPath
accanto alla casella Voci (Entries box).Nel gruppo CategorieAndProdotti della finestra di dialogo Selezionare un campo o un gruppo fare clic sul campo Categorie.
Nota
Lo sfondo giallo nella finestra di dialogo Selezionare un campo o un gruppo indica che si sta usando un'origine dati secondaria.
Fare clic su OK due volte.
A questo punto è necessario collegare la seconda casella di riepilogo al documento XML. Durante questa connessione dati, è consigliabile applicare un filtro alla seconda casella di riepilogo. Questo filtro popola la seconda casella di riepilogo con i prodotti appropriati, in base alla categoria selezionata nella prima. Il filtro confronta il valore selezionato nella prima casella di riepilogo (campo listBox1) con l'elenco di categorie salvate nel modulo (campo Categoria).
Connettere la seconda casella di riepilogo ai dati
- Nel modello di modulo fare doppio clic sulla casella di riepilogo standard inserita in precedenza.
- Fare clic sulla scheda Dati.
- Nella finestra di dialogo Proprietà casella di riepilogo , in Voci casella di riepilogo, fare clic su Cerca valori da un'origine dati esterna.
- Nella casella Origine dati fare clic su listBoxDataXMLFile.
- Fate clic su Seleziona XPath
accanto alla casella Voci (Entries box). - Nel gruppo CategorieAndProdotti della finestra di dialogo Selezionare un campo o un gruppo espandere il gruppo Prodotti e quindi fare clic sul campo Prodotto.
- Fare clic su Filtra dati.
- Nella finestra di dialogo Filtra dati , fare clic su Aggiungi.
- Nella finestra di dialogo Specificare le condizioni di filtro , fare clic su Seleziona un campo o un gruppo nella prima casella.
- Nella finestra di dialogo Seleziona un campo o un gruppo nella finestra di dialogo Origine dati fare clic su Principale.
- Fare clic su listBox1 e quindi su OK.
- Nella finestra di dialogo Specifica condizioni di filtro , fare clic su Seleziona un campo o un gruppo nella terza casella.
- Nella finestra di dialogo Selezionare un campo o un gruppo nella finestra di dialogo Origine dati fare clic su listBoxDataXMLFile (secondario) e quindi su Categorie.
- Fare clic su OK per chiudere tutte le finestre di dialogo aperte.
Dopo aver connesso la seconda casella di riepilogo al documento XML e applicato il filtro, è possibile testare le caselle di riepilogo per verificarne il corretto funzionamento.
Testare le caselle di riepilogo
Per verificare le modifiche, fare clic su Anteprima nella barra degli strumenti Standard oppure premere CTRL+MAIUSC+B.
Nella casella dell'elenco a discesa, fare clic su Frutti di mare. La casella di riepilogo standard deve mostrare solo una riga vuota, polpa di granchio e salmone.
Nota
La riga vuota consente agli utenti di deselezionare la propria scelta nella casella di riepilogo.
Se le caselle di riepilogo non funzionano correttamente, rivedere il filtro per la seconda casella di riepilogo per assicurarsi che il campo listBox1 venga confrontato con il campo Categoria .
Connettersi a un database
In questa sezione verrà descritto come creare una connessione dati a due tabelle in un database di Access. A tale scopo, associare le caselle di riepilogo nel modello di modulo al database e quindi applicare un filtro alla seconda casella di riepilogo in modo che l'elenco visualizzato nella seconda casella di riepilogo venga modificato in base al valore selezionato nella prima casella di riepilogo. In questo esempio si presuppone che il database di Access contenga due tabelle denominate Categories e Products e che le due tabelle siano correlate tra loro dal campo CategoryID, che viene utilizzato in ogni tabella.
Tabella Categorie
| ID categoria | CategoriaName |
|---|---|
| 1 | Frutti di mare |
| 2 | Latticini |
Tabella dei prodotti
| IDProdotto | ID categoria | NomeProdotto |
|---|---|---|
| 1 | 1 | Polpa di granchio |
| 2 | 1 | Salmone |
| 3 | 2 | Latte al cioccolato |
| 4 | 2 | Cheddar |
Connettere il modello di modulo all'origine dati
Prima di tutto, è necessario creare una connessione dati tra il modello di modulo e le tabelle nel database. Poiché si visualizzano solo i dati del database, anziché modificarli direttamente, il database di Access sarà un'origine dati secondaria per il modello di modulo.
Scegliere Connessioni dati dal menu Strumenti.
Nella finestra di dialogo Connessioni dati fare clic su Aggiungi.
Nella Creazione guidata connessione dati fare clic su Ricevi dati e quindi su Avanti.
Nella pagina successiva della procedura guidata fare clic su Database (solo Microsoft SQL Server o Microsoft Office Access) e quindi fare clic su Avanti.
Nella pagina successiva della procedura guidata fare clic su Seleziona database e quindi cercare e fare doppio clic sul database di Access sul disco rigido.
Nella finestra di dialogo Seleziona tabella fare clic sulla tabella contenente i dati che si desidera visualizzare nel primo elenco (in questo esempio la tabella Categorie), quindi fare clic su OK. La tabella viene specificata come tabella primaria per la connessione dati.
Nella procedura guidata fare clic su Aggiungi tabella.
Nella finestra di dialogo Aggiungi tabella o query fare clic sulla tabella che contiene i dati che si desidera visualizzare nel secondo elenco, in questo esempio la tabella Prodotti, e quindi fare clic su Avanti.
Nella finestra di dialogo Modifica relazione verificare che i campi di connessione siano corretti. In questo esempio le tabelle sono correlate tra loro dal campo IDCATEGORIA.
Suggerimento
Se i campi di connessione non sono corretti, selezionarli e quindi fare clic su Rimuovi relazione. Fare clic su Aggiungi relazione, selezionare i campi corretti e quindi fare clic su OK.
Fare clic su Fine.
Nota
In questo esempio la tabella delle categorie ha una relazione uno-a-molti con la tabella prodotti, il che significa che per ogni categoria ci possono essere molti prodotti. In un database questo tipo di relazione viene in genere stabilita usando i campi chiave. In questo caso, il campo chiave CategoryID consente ad Access di associare il set di prodotti corretto alla categoria appropriata.
Nella procedura guidata esaminare la struttura dell'origine dati. Dovrebbero essere visualizzate due tabelle collegate tra loro: la tabella principale e la tabella secondaria. Per visualizzare i singoli campi nella tabella, selezionare la casella di controllo Mostra colonne della tabella . Al termine della revisione della struttura dei dati, fare clic su Avanti.
Deselezionare la casella di controllo Memorizza una copia dei dati nel modello di modulo e quindi fare clic su Avanti.
Nella pagina successiva della procedura guidata nella casella Immettere un nome per la connessione dati .
Selezionare la casella di controllo Recupera automaticamente i dati all'apertura della maschera .
Fare clic su Fine e quindi su Chiudi nella finestra di dialogo Connessioni dati .
Connettere la prima casella di riepilogo ai dati
Dopo aver creato una connessione dati all'origine dati secondaria, è possibile connettere la prima casella di riepilogo del modello di modulo alle tabelle del database.
Nel modello di modulo fare doppio clic sulla casella di riepilogo a discesa inserita in precedenza.
Fare clic sulla scheda Dati.
Nella finestra di dialogo Proprietà casella di riepilogo a discesa , in Voci casella di riepilogo, fare clic su Cerca valori da un'origine dati esterna.
Nella casella Origine dati verificare che la connessione dati creata sia selezionata.
Fate clic su Seleziona XPath
accanto alla casella Voci (Entries box).Nella finestra di dialogo Selezionare un campo o un gruppo fare clic sul nome della tabella che contiene i dati che si desidera visualizzare nell'elenco a discesa (in questo esempio d:Categories ) e quindi fare clic su OK.
Nota
Lo sfondo giallo nella finestra di dialogo Selezionare un campo o un gruppo indica che si sta usando un'origine dati secondaria.
Fate clic su Seleziona XPath
accanto alla casella Valore (Value ).Nella finestra di dialogo Selezionare un campo o un gruppo verificare che il campo di connessione (in questo esempio :CategoryID) sia selezionato e quindi fare clic su OK. Si tratta del valore che verrà salvato quando l'utente effettua una selezione nella casella di riepilogo.
Fate clic su Seleziona XPath
accanto alla casella Nome visualizzato (Display Name ).Nella finestra di dialogo Selezionare un campo o un gruppo fare clic sul nome del campo che si desidera visualizzare nell'elenco a discesa, in questo esempio :NomeCategoria.
Fare clic su OK due volte.
Connettere la seconda casella di riepilogo ai dati
A questo punto sarà necessario connettere la seconda casella di riepilogo al database. Durante questa connessione dati, è consigliabile applicare un filtro alla seconda casella di riepilogo. Questo filtro popola la seconda casella di riepilogo con i valori appropriati, in base al valore selezionato nella prima.
Nel modello di modulo fare doppio clic sulla casella di riepilogo standard.
Fare clic sulla scheda Dati.
Nella finestra di dialogo Proprietà casella di riepilogo , in Voci casella di riepilogo, fare clic su Cerca valori da un'origine dati esterna.
Nella casella Origine dati verificare che la connessione dati creata sia selezionata.
Fate clic su Seleziona XPath
accanto alla casella Voci (Entries box).Nella finestra di dialogo Selezionare un campo o un gruppo espandere il gruppo primario, in questo esempio d:Categorie, e quindi fare clic sul gruppo secondario corrispondente alla tabella contenente i dati da visualizzare nella casella di riepilogo a catena (in questo esempio, Prodotti).
Fare clic su Filtra dati.
Nella finestra di dialogo Filtra dati , fare clic su Aggiungi.
Nella prima casella della finestra di dialogo Specifica condizioni di filtro verificare che sia selezionato il campo di connessione della tabella secondaria, in questo esempio Prodotti.
Importante
Se i campi di connessione hanno lo stesso nome in entrambe le tabelle, assicurarsi di selezionare quello corretto. I campi di ogni tabella vengono ordinati insieme nell'elenco. Pertanto, è possibile usare i nomi dei campi circostanti per determinare quale sia quello corretto. In questo esempio viene selezionato il campo IDCategoria visualizzato con gli altri campi della tabella Prodotti.
Nella terza casella fare clic su Seleziona un campo o un gruppo.
Nella finestra di dialogo Selezionare un campo o un gruppo nella finestra di dialogo Origine dati fare clic su Principale, quindi sul campo listBox1 e quindi su OK.
È stato ora configurato un filtro che confronta il valore selezionato nella casella di riepilogo a discesa (campo listBox1) con l'elenco di valori nella casella di riepilogo standard.Fare clic su OK tre volte per tornare alla finestra di dialogo Proprietà casella di riepilogo .
Fate clic su Seleziona XPath
accanto alla casella Valore (Value ).Nella finestra di dialogo Seleziona un campo o un gruppo selezionare il valore che si desidera salvare quando l'utente esegue una selezione nella casella di riepilogo. In questo esempio si vuole salvare il campo IDProdotto per un uso successivo. Quindi, selezioniamo il gruppo :P roductID , quindi facciamo clic su OK.
Fate clic su Seleziona XPath
accanto alla casella Nome visualizzato (Display Name ).Nella finestra di dialogo Selezionare un campo o un gruppo fare clic sul nome del campo che si desidera visualizzare nella casella di riepilogo (in questo esempio, :P nomeprodotto).
Fare clic su OK due volte.
Testare le caselle di riepilogo
Dopo aver connesso la seconda casella di riepilogo al database e applicato il filtro, è possibile testare le caselle di elenco per verificarne il corretto funzionamento.
- Per verificare le modifiche, fare clic su Anteprima nella barra degli strumenti Standard oppure premere CTRL+MAIUSC+B.
- Selezionare un valore nell'elenco a discesa. La casella di riepilogo standard dovrebbe mostrare i valori appropriati della tabella secondaria, a seconda del campo di connessione scelto.
Suggerimento
Se le caselle di riepilogo non funzionano correttamente, esaminare il filtro per la seconda casella di riepilogo per assicurarsi che il campo listBox1 venga confrontato con il campo IDCategoria .
Inizio pagina