Creare una soluzione di Asset Tracker con InfoPath ed Excel

Microsoft Office InfoPath consente di creare modelli di modulo per l'immissione di dati e la raccolta. Microsoft Office Excel 2007 consente agli utenti di calcolare, progettare e analizzare i dati. Usando sia questi programmi che XML, è possibile creare facilmente una soluzione aziendale semplice ma efficace senza codice per il rilevamento di asset in una società.

Panoramica della soluzione di inventario beni mobili

In questo articolo

Introduzione alla creazione di una soluzione di Asset Tracker

Passaggio 1: personalizzare il modello di modulo Asset Tracker

Passaggio 2: eseguire il mapping del file di schema e personalizzare il layout di tabella in Excel

Passaggio 3: creare un report di riepilogo di tabella pivot e di grafico pivot

Passaggio 4: raccogliere le informazioni sugli asset dagli utenti

Passaggio 5: importare moduli in Excel

Considerazioni finali: considerare l'uso di un elenco di SharePoint o di un database di Access

Introduzione alla creazione di una soluzione di Asset Tracker

È possibile scambiare dati XML tra InfoPath ed Excel. Anche se il comando Esporta di InfoPath è un modo semplice e diretto per inviare dati del modulo a Excel, è possibile adottare un altro approccio che offre maggiore flessibilità. Associando in modo esplicito il file di schema XML di InfoPath (con estensione XSD) in Excel e quindi importando i file del modulo di InfoPath (con estensione XML) in Excel, è possibile personalizzare il layout dei dati e sfruttare meglio le caratteristiche di Excel per gestire e analizzare i dati in modo più efficiente.

In questo articolo useremo il modello di modulo di esempio di InfoPath Asset Tracker per illustrare in che modo è possibile far collaborare InfoPath, XML ed Excel. Immaginate che ogni anno l'organizzazione inventari gli asset nell'ufficio di ogni dipendente. Viene quindi eseguito un report di Excel che consente di decidere come assegnare il preventivo per l'anno prossimo. Il diagramma seguente illustra come raccogliere, tenere traccia e segnalare i dati degli asset nel reparto.

a

1. viene creato il modello di modulo Asset Tracker.

2. il file di schema viene mappato a una tabella di Excel e il layout della tabella è personalizzato.

3. viene creato un rapporto di riepilogo tabella pivot e grafico pivot vuoto.

4. il modulo Asset Tracker viene usato per raccogliere dati dagli utenti.

5. tutti i dati del modulo vengono esportati nella tabella di Excel e i rapporti di tabella pivot e grafico pivot vengono aggiornati.

Questa soluzione include i seguenti ruoli utente e prodotti:

Icona Supporto completo = obbligatorio Icona Nessun supporto = non necessario

Requisiti software

Ruoli

Office InfoPath 2007

Office Outlook 2007

Office Excel 2007

Progettazione soluzioni

Icona Supporto completo

Icona Supporto completo

Icona Supporto completo

Decision-Maker

Icona Supporto completo

Icona Supporto completo

Icona Supporto completo

Dipendenti

Icona Supporto completo

Icona Supporto completo

Icona Nessun supporto

Inizio pagina

Passaggio 1: personalizzare il modello di modulo Asset Tracker

Il modello di modulo Asset Tracker, incluso in InfoPath, consente di raccogliere informazioni su ogni risorsa nell'ufficio di un dipendente, il reparto a cui appartiene il dipendente, le categorie di risorse e i dettagli su ogni risorsa. In questa soluzione, un progettista di moduli invia il modello di modulo all'account di posta elettronica del decision-maker usando Office Outlook 2007.

Modello per inventario beni

Attività 1: aprire e personalizzare il modello di modulo di Asset Tracker

Dato che non è possibile pubblicare un modello di modulo in un elenco di destinatari di posta elettronica se dispone di un controllo casella di testo RTF contenente immagini collegate, è necessario apportare una piccola modifica al modulo del modello di esempio Asset Tracker.

  1. Nel menu file fare clic su Progetta modello di modulo.

  2. Nella finestra di dialogo Progetta modello di modulo , in aprire un modello di modulo, fare clic su Personalizza un esempio.

  3. Nella finestra di dialogo Introduzione fare clic su Tracker asset di esempioe quindi in attività modulofare clic su Progetta modulo.

  4. Fare clic con il pulsante destro del mouse sul controllo assetNotes , scegliere proprietà casella di testo RTF , fare clic sulla scheda Visualizza e quindi in formattazione disponibiledeselezionare la casella di controllo Immagini collegate .

Attività 2: definire le opzioni di invio

L'attività successiva consiste nel definire le opzioni di invio in modo che i dipendenti possano inviare un file di modulo con nome univoco (con estensione XML) all'account di posta elettronica del responsabile della decisione come file allegato.

  1. Scegliere Invia opzionidal menu strumenti .

  2. Nella finestra di dialogo Opzioni di invio selezionare la casella di controllo Consenti agli utenti di inviare questo modulo .

  3. Fare clic su Invia i dati del modulo a una singola destinazionee quindi, nell'elenco, fare clic su posta elettronica.

  4. Fare clic su Aggiungi.

    Viene visualizzata la connessione guidata dati .

  5. Nella casella a Digitare l'alias del decision maker che riceverà tutti i moduli inviati.

  6. Per specificare una riga dell'oggetto univoco, nella casella oggetto :

    • Fare clic su Inserisci Formula Icona del pulsante .

    • Digitare la formula seguente:

concat(my:employee/my:employeeName, my:employee/my:employeeDepartment)

  • Fare clic su Verifica formulae quindi fare clic due volte su OK .

  • Nella casella Introduzione Digitare un messaggio appropriato o aggiungere istruzioni importanti per questa soluzione.

  • Fare clic su Avanti.

  • Nella pagina successiva della procedura guidata fare clic su Invia i dati del modulo come allegatoe quindi selezionare il modello allega modulo per verificare che gli utenti possano aprire la casella di controllo modulo .

    In questo modo, i dipendenti possono accedere al file del modello di modulo (con estensione xsn) nel caso in cui non possano accedervi dal proprio percorso di rete.

  • Per specificare un nome di file univoco per ogni file di modulo (con estensione XML) nella casella nome allegato :

    1. Fare clic su Inserisci Formula Icona del pulsante .

    2. Digitare la stessa formula di quella nella riga dell' oggetto :

concat(my:employee/my:employeeName, my:employee/my:employeeDepartment)

  1. Fare clic su Verifica formulae quindi fare clic due volte su OK .

  • Fare clic su Avanti.

  • Nella pagina successiva della procedura guidata, nella casella immettere un nome per la connessione dati Digitare un nome descrittivo per la connessione di invio dati.

  • Verificare che le informazioni siano corrette nella sezione Riepilogo e quindi fare clic su fine.

  • Salvare il modulo in una cartella di rete pubblica accessibile per il decision maker e per tutti i dipendenti.

Inizio pagina

Passaggio 2: eseguire il mapping del file di schema e personalizzare il layout di tabella in Excel

La configurazione della connessione tra InfoPath ed Excel richiede tre attività: estrazione del file di schema per il modello di modulo Asset Tracker, mapping del file di schema in Excel e personalizzazione del layout predefinito della tabella di Excel che conterrà tutto il codice XML importato file di dati del modulo.

Attività 1: estrarre il file dello schema da InfoPath

  1. In InfoPath aprire il file del modello di modulo Asset Tracker.

  2. Nel menu strumenti fare clic su Progetta modulo.

  3. Nel menu file fare clic su Salva come file di origine.

  4. Nella finestra di dialogo Sfoglia per la cartella selezionare una cartella o creare una nuova cartella in cui si vuole archiviare il file dello schema.

Nota la posizione della cartella in cui vengono salvati tutti i file di origine e il nome del file di schema, in questo caso, schema. xsd, che contiene la definizione dello schema dei dati XML del modulo.

Attività 2: mappare il file dello schema di InfoPath in Excel

  1. Creare un nuovo file di Excel e salvarlo in un percorso accessibile per il decision maker.

  2. Se la scheda sviluppo non è visibile in Excel, eseguire le operazioni seguenti:

    1. Fare clic sul pulsante Microsoft Office Icona del pulsante Office e quindi su Opzioni di Excel.

    2. Nella categoria Popular , in Opzioni principali per l'uso di Excel, selezionare la casella di controllo Mostra scheda sviluppo sulla barra multifunzione e quindi fare clic su OK.

      Nota: La barra multifunzione è un componente dell'interfaccia utente Microsoft Office Fluent.

  3. Nel gruppo XML della scheda Sviluppo fare clic su Origine.

    Gruppo XML sulla barra multifunzione

    Viene visualizzato il riquadro attività origine XML .

  4. Fare clic su mapping XMLe quindi, nella finestra di dialogo mappe XML , fare clic su Aggiungi.

  5. In un computer che utilizza Windows Vista    

    1. Nella barra degli indirizzifare clic sull'unità o la cartella che contiene il file schema. xsd creato nel passaggio 2 della sezione attività 1: estrarre il file di schema da InfoPath.

      In un computer che utilizza Microsoft Windows XP    

    2. Nell'elenco Cerca in fare clic sull'unità o la cartella che contiene il file schema. xsd creato nel passaggio 2 della sezione attività 1: estrarre il file di schema da InfoPath.

  6. Fare clic sul file e quindi su Apri.

  7. Quando viene visualizzata la finestra di dialogo più radici , fare clic sul nodo radice di assetTracking definito nel file schema. xsd e quindi fare clic su OK.

    Il mapping XML viene visualizzato nel riquadro attività origine XML .

  8. Trascinare l'elemento ns1: asset node, che è un elemento XML ripetuto, nella posizione del foglio di lavoro in cui si vuole visualizzare la tabella di Excel.

    Mapping del file di schema InfoPath in Excel

Attività 3: personalizzare il layout della tabella di Excel

Per impostazione predefinita, Excel usa i nomi degli elementi XML come intestazioni di colonna per la tabella. È tuttavia possibile modificare le intestazioni di colonna modificando le celle dell'intestazione di colonna.

  1. Per modificare le intestazioni di colonna predefinite, mantieni selezionata la tabella di Excel, trova il prefisso di stringa seguente, ns1: assete rimuovilo. Ad esempio, cambierai ns1: assetID in ID.

    Personalizzazione delle intestazioni di tabella in Excel

  2. Per regolare la larghezza della colonna, fare clic sul pulsante Seleziona tutto e quindi fare doppio clic su un contorno di colonna.

Inizio pagina

Passaggio 3: creare un report di riepilogo di tabella pivot e di grafico pivot

I responsabili decisionali usano i rapporti di tabella pivot e di grafico pivot per analizzare, esplorare e visualizzare i dati di riepilogo. Impostando i rapporti di tabella pivot e di grafico pivot che si vuole usare in questo scenario in anticipo, sarà un'operazione semplice per un decisore per l'esecuzione del report con i dati completati in un secondo momento.

  1. Selezionare una cella nella tabella di Excel.

  2. Nel gruppo tabelle della scheda Inserisci fare clic su tabella pivote quindi su tabella pivot.

    Immagine della barra multifunzione di Excel

    Verrà visualizzata la finestra di dialogo Crea tabella pivot.

  3. Per inserire il rapporto di tabella pivot in un nuovo foglio di lavoro a partire dalla cella a1, fare clic su nuovo fogliodi lavoro e quindi fare clic su OK.

    Excel aggiunge un rapporto di tabella pivot vuoto nella posizione specificata e visualizza l' elenco di campi della tabella pivot in modo da poter aggiungere campi, creare un layout e personalizzare il rapporto di tabella pivot.

  4. Per creare un report tra tabulazioni dei dati, trascinare il campo ID nell'area valori, il campo reparto nell'area etichette di colonna, il campo categoria nell'area etichette di riga e il campo AssegnatoA nell'area filtro report.

  5. Fare clic sul rapporto di tabella pivot.

  6. Nel gruppo grafici della scheda Inserisci fare clic sul tipo di grafico a barre .

    Immagine della barra multifunzione di Excel

  7. In barra2D selezionare barra raggruppata.

  8. Modificare le dimensioni e la posizione del rapporto di grafico pivot in preferenza.

Rapporti di tabella pivot e grafico pivot vuoti

Inizio pagina

Passaggio 4: raccogliere le informazioni sugli asset dagli utenti

Ora che il modello di modulo è pronto per essere compilato da tutti i dipendenti, è necessario pubblicare il modulo e inviarlo a ogni dipendente. Quando ogni dipendente invia il modulo completato, viene inviato come file di dati XML (con estensione XML) allegato in un messaggio di posta elettronica all'account di posta elettronica dell'autore del processo decisionale. Il decision maker può quindi trasferire tutti i messaggi in una cartella di InfoPath dedicata in Outlook. In questo scenario, è consigliabile assegnare un periodo di tempo specifico per tutti gli utenti per completare i moduli in modo che il responsabile della decisione possa eseguire il report con tutti i moduli completati al raggiungimento della scadenza della raccolta dei dati.

Immissione di dati nei moduli di registrazione dei beni

  1. In InfoPath aprire il modello di modulo (con estensione xsn) salvato nel passaggio 1: progettare il modello di modulo di esempio Asset Tracker

  2. Nel menu strumenti fare clic su Progetta modulo.

  3. Nel menu file fare clic su pubblica.

  4. Nella pubblicazione guidata fare clic su un elenco di destinatari di posta elettronicae quindi fare clic su Avanti.

  5. Nella pagina successiva della procedura guidata digitare un nome per il modello di modulo nella casella nome modello di modulo e quindi fare clic su Avanti. Il nome del modello di modulo verrà visualizzato nell'intestazione dell'oggetto del messaggio inviato ai destinatari del messaggio di posta elettronica.

  6. Facoltativamente, nella pagina successiva della procedura guidata è possibile creare colonne che verranno visualizzate nelle cartelle di Outlook per organizzare i messaggi di posta elettronica.

  7. Fare clic su Avanti.

  8. Fare clic su Pubblica.

  9. Dopo che la pubblicazione guidata ha terminato la pubblicazione del modello di modulo, verrà aperto un messaggio di posta elettronica con il modulo.

  10. Compilare il messaggio, digitare i nomi dei dipendenti oppure usare una lista di distribuzione e quindi inviare il messaggio.

In Outlook, il decision-maker può organizzare tutti i moduli XML inoltrati in uno dei due modi seguenti:

  • Se la finestra di dialogo cartelle moduli di InfoPath viene visualizzata la prima volta che si apre il messaggio, fare clic su Crea cartella modulo.

  • Creare una regola in Outlook per trasferire tutti i moduli di InfoPath correlati in una cartella di InfoPath.

    Per altre informazioni, vedere gestire i messaggi con le regole.

Inizio pagina

Passaggio 5: importare moduli in Excel

Poiché hai già creato i passaggi 2 e 3 della cartella di lavoro di Excel, è semplice che il decision maker esporti e riveda i dati del modulo. Il decision maker deve semplicemente esportare i file XML (con estensione XML) da Outlook, importare tutti i file di modulo (con estensione XML) nella cartella di lavoro di Excel e quindi aggiornare i dati.

Attività 1: esportare i moduli da Outlook in una cartella di Windows

  1. In Outlook selezionare la cartella che contiene tutti i moduli ricevuti dai dipendenti e quindi premere CTRL + a per selezionare tutti i messaggi di posta elettronica del modulo.

  2. Fare clic con il pulsante destro del mouse sulla selezione, scegliere azioni di InfoPathe quindi fare clic su Esporta moduli.

  3. Nella finestra di dialogo Esporta moduli selezionare una cartella e quindi premere OK.

Attività 2: importare i moduli in Excel

  1. Nella cartella di lavoro di Excel creata al passaggio 2: eseguire il mapping del file di schema e personalizzare il layout di tabella in Excel, selezionare una delle celle mappate nella tabella di Excel.

  2. Nel gruppo XML della scheda sviluppo fare clic su Importa.

    Gruppo XML sulla barra multifunzione

    Verrà visualizzata la finestra di dialogo Importa XML .

  3. In un computer che utilizza Windows Vista    

  4. Eseguire una delle operazioni seguenti:

    • Se i file sono contigui, premere MAIUSC e quindi fare clic sul primo e sull'ultimo file nell'elenco.

    • Se i file non sono contigui, premere CTRL e quindi fare clic su ogni file che si vuole importare nell'elenco.

  5. Fare clic su Importa.

    Tabella di Excel dei dati importati

Per impostazione predefinita, Excel sovrascrive tutti i dati esistenti nelle celle mappate, ovvero il risultato finale desiderato per questa soluzione aziendale. Tuttavia, un decisore può, ad esempio, importare più volte i dati per valutare lo stato di avanzamento prima della scadenza programmata.

Nota: In Excel è anche possibile accodare i dati usando l'opzione Accoda nuovi dati a tabelle XML esistenti (nel gruppo XML della scheda sviluppo fare clic su Proprietà mappa), che potrebbe essere appropriata per altre soluzioni.

Per altre informazioni, vedere connettersi a un file XML.

Attività 3: aggiornare i report di tabella pivot e di grafico pivot

  • Fare clic su una cella nel rapporto di tabella pivot.

  • Nel gruppo dati della scheda Opzioni fare clic sulla freccia accanto a Aggiorna tutto, quindi fare clic su Aggiorna.

    Barra multifunzione di Outlook

Rapporto finale tabella pivot e grafico pivot

La cartella di lavoro di Excel contiene ora tutti i dati e i report di riepilogo necessari per assegnare il budget per l'anno prossimo. Naturalmente, se necessario, è possibile eseguire ulteriori analisi nella cartella di lavoro di Excel, ad esempio l'ordinamento, il filtro o la formattazione condizionale dei dati.

Inizio pagina

Considerazioni finali: considerare l'uso di un elenco di SharePoint o di un database di Access

In alternativa, è consigliabile usare un elenco di SharePoint o un database di Access, anziché XML, per trasferire dati tra InfoPath ed Excel.

Usare un elenco di SharePoint

Da InfoPath puoi usare facilmente un elenco di SharePoint come origine dati di sola lettura. È possibile eseguire una delle due operazioni seguenti:

  • Nell'elenco SharePoint esportare i dati in Excel, che crea automaticamente una connessione dati in Excel.

  • Da Excel, creare esplicitamente una connessione dati all'elenco SharePoint.

Dopo aver creato una connessione dati, è possibile aggiornare i dati in Excel per recuperare i dati aggiornati.

È possibile usare un elenco di SharePoint per aggiungere e aggiornare i dati, usare un modulo di InfoPath per visualizzare un elemento dall'elenco, ad esempio un elemento complesso o lungo, meglio visualizzato verticalmente, e quindi usare Excel per analizzare ulteriormente i dati.

Combinazione di InfoPath, elenco di SharePoint ed Excel

1. visualizzare un singolo elemento per semplificare la revisione in InfoPath.

2. aggiungere e aggiornare i dati in un elenco di SharePoint.

3. aggiornare e segnalare i dati aggiornati con Excel.

Per altre informazioni, vedere aggiungere una connessione dati a una raccolta documenti di SharePoint o un elenco

Usare un database di Access

In InfoPath è possibile creare una connessione di lettura/scrittura a un database di Access. Da Excel è possibile creare in modo esplicito una connessione dati al database di Access che è possibile aggiornare per recuperare i dati aggiornati. È anche possibile definire la connessione per l'aggiornamento automatico all'apertura della cartella di lavoro o l'aggiornamento periodico, ad esempio ogni 5 minuti.

È possibile usare un database di Access come intermediario tra InfoPath ed Excel. Quando si invia un modulo di InfoPath per l'accesso, si aggiorna il database di Access. Quando si aggiorna la connessione dati in Excel, è possibile recuperare i dati aggiornati da Access. In effetti, i dati vengono inoltrati indirettamente da InfoPath a una cartella di lavoro di Excel.

combinazione di infopath, access ed excel

1. visualizzare e inviare un modulo a un database di Access.

2. archiviare i dati in un database di Access.

3. aggiornare e segnalare i dati aggiornati con Excel.

Per altre informazioni, vedere progettare un modello di modulo basato su un database di Microsoft Access.

Suggerimento: Si è certi di poter creare un modulo di InfoPath direttamente da Access? Se gli utenti hanno Outlook 2007 o 2010 e InfoPath 2007 o 2010 installati nei propri computer, è possibile raccogliere dati provenienti da utenti diversi direttamente da Access tramite la procedura guidata raccolta dati da messaggi di posta elettronica . Per altre informazioni, vedere l'argomento della Guida di Access, aggiungere i dati raccolti tramite posta elettronica al database di Access.

Inizio pagina

Nota:  Questa pagina è stata tradotta automaticamente e potrebbe contenere errori di grammatica o imprecisioni. L'intento è quello di rendere fruibile il contenuto. Queste informazioni sono risultate utili' Questo è l'articolo in inglese per riferimento.

Sii sempre un passo avanti con Microsoft 365

Serve aiuto?

Amplia le tue competenze su Office
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×