È possibile usare la funzione SE.ERRORE per intercettare e gestire gli errori in una formula. SE.ERRORE restituisce un valore specificato se una formula restituisce un errore. in caso contrario, restituisce il risultato della formula.

Sintassi

SE.ERRORE(valore; se_errore)

Gli argomenti della sintassi della funzione SE.ERRORE sono i seguenti:

  • valore    Obbligatorio. Argomento in cui viene verificata la presenza di un errore.

  • value_if_error    Obbligatorio. Valore da restituire se la formula restituisce un errore. Vengono valutati i tipi di errore seguenti: #N/A, #VALUE!, #REF!, #DIV/0!, #NUM!, #NAME?o #NULL!.

Osservazioni

  • Se valore o value_if_error è una cella vuota, SE.ERRORE la considera come valore stringa vuota ("").

  • Se valore è una formula di matrice, SE.ERRORE restituirà una matrice di risultati per ogni cella dell'intervallo specificato in valore. Vedere il secondo esempio riportato di seguito.

Esempi

Copiare i dati di esempio contenuti nella tabella seguente e incollarli nella cella A1 di un nuovo foglio di lavoro di Excel. Per visualizzare i risultati delle formule, selezionarle, premere F2 e quindi premere INVIO.

Quota

Unità vendute

210

35

55

0

23

Formula

Descrizione

Risultato

=SE.ERRORE(A2/B2; "Errore nel calcolo")

Verifica la presenza di un errore nella formula nel primo argomento (210 diviso 35), non trova errori e quindi restituisce i risultati della formula.

6

=SE.ERRORE(A3/B3; "Errore nel calcolo")

Verifica la presenza di un errore nella formula nel primo argomento (55 diviso 0), trova un errore di divisione per 0 e quindi restituisce valore_se_errore.

Errore nel calcolo

=SE.ERRORE(A4/B4; "Errore nel calcolo")

Verifica la presenza di un errore nella formula nel primo argomento ("" diviso 23), non trova errori e quindi restituisce i risultati della formula.

0

Esempio 2

Quota

Unità vendute

Rapporto

210

35

6

55

0

Errore nel calcolo

23

0

Formula

Descrizione

Risultato

=C2

Verifica la presenza di un errore nella formula nel primo argomento nel primo elemento della matrice (A2/B2 o 210 diviso 35), non trova errori e quindi restituisce il risultato della formula.

6

=C3

Verifica la presenza di un errore nella formula nel primo argomento nel secondo elemento della matrice (A3/B3 o 55 diviso 0), trova un errore di divisione per 0 e quindi restituisce valore_se_errore.

Errore nel calcolo

=C4

Verifica la presenza di un errore nella formula nel primo argomento nel terzo elemento della matrice (A4/B4 o "" diviso 23), non trova errori e quindi restituisce il risultato della formula.

0

Nota: se si ha una versione corrente di Microsoft 365, è possibile immettere la formula nella cella superiore sinistra dell'intervallo di output, quindi premere INVIO per confermare la formula come formula di matrice dinamica. In caso contrario, è necessario immettere la formula come formula di matrice legacy selezionando prima l'intervallo di output, immettendo la formula nella cella superiore sinistra dell'intervallo di output, quindi premere CTRL+MAIUSC+INVIO per confermarla. Excel inserisce automaticamente parentesi graffe all'inizio e alla fine della formula. Per ulteriori informazioni sulle formule di matrice, vedere Formule di matrice: indicazioni ed esempi.

Servono altre informazioni?

È sempre possibile rivolgersi a un esperto nella Tech Community di Excel oppure ottenere supporto nella community Microsoft.

Serve aiuto?

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa a Microsoft Insider

Queste informazioni sono risultate utili?

Quanto ti soddisfa la qualità della traduzione?
Cosa ha influito sulla tua esperienza?

Grazie per il feedback!

×