Questo articolo descrive gli elementi dell'interfaccia utente di Access e fornisce collegamenti ad altre informazioni su questi elementi e su come personalizzare l'esperienza utente.

In questo articolo

Panoramica

I tre componenti principali dell'interfaccia utente di Access sono:

  • Barra multifunzione    è l'elenco di schede nella parte superiore della finestra del programma che contiene gruppi di comandi.

  • Visualizzazione Backstage    è la raccolta di comandi che viene visualizzata nella scheda File sulla barra multifunzione.

  • Riquadro di spostamento    è il riquadro sul lato sinistro della finestra del programma di Access che consente di usare gli oggetti di database. 

Questi tre elementi forniscono l'ambiente in cui si creano e si usano i database.

Barra multifunzione

La barra multifunzione è il principale sostituto di menu e barre degli strumenti. È costituita principalmente da schede con gruppi di pulsanti.

La barra multifunzione contiene le schede principali che raggruppano i comandi di uso più comune, le schede contestuali che vengono visualizzate solo quando è possibile usarle e la barra di accesso rapido, una piccola barra degli strumenti che è possibile personalizzare con i comandi preferiti.

Nelle schede della barra multifunzione alcuni pulsanti offrono una raccolta di opzioni, mentre altri avviano un comando.

Visualizzazione Backstage

La visualizzazione Backstage contiene i comandi e le informazioni applicabili a un intero database, ad esempio Compatta e ripristina,oltre ai comandi presenti nel menu File delle versioni precedenti, ad esempio Stampa.

Riquadro di spostamento

Il riquadro di spostamento consente di organizzare gli oggetti di database ed è il principale strumento per aprire o modificare la struttura di un oggetto di database.

Il riquadro di spostamento è organizzato per categorie e gruppi. È possibile scegliere tra diverse opzioni dell'organizzazione e anche creare uno schema di organizzazione personalizzato nel riquadro di spostamento. Per impostazione predefinita, in un nuovo database viene utilizzata la categoria Tipo di oggetto, che contiene gruppi che corrispondono ai vari tipi di oggetto di database. La categoria Tipo di oggetto organizza gli oggetti di database in modo simile alla visualizzazione predefinita Finestra database delle versioni precedenti.

È possibile ridurre a icona il riquadro di spostamento ed è anche possibile nasconderlo, ma non nasconderlo aprendo oggetti di database davanti.

Visualizzazione Backstage

La visualizzazione Backstage occupa la scheda File della barra multifunzione e contiene molti comandi. La visualizzazione Backstage contiene anche altri comandi applicabili a un intero file di database. Quando apri Access ma non apri un database (ad esempio se apri Access dal menu Start di Windows), viene visualizzata la visualizzazione Backstage.

Nella visualizzazione Backstage è possibile creare un nuovo database, aprirne uno esistente ed eseguire molte attività di manutenzione di file e database.

Creare un nuovo database vuoto

  1. Avviare Access dal menu Start o da un collegamento.

    Viene visualizzata la visualizzazione Backstage.

  2. Eseguire una delle operazioni seguenti:

    • Creare un nuovo database Web

      1. In Modelli disponibili fareclic su Database Web vuoto.

      2. A destra, in Database Webvuoto, digitare un nome per il file di database nella casella Nome file o usare quello fornito.

      3. Fare clic su Crea.

        Il nuovo database viene creato e una nuova tabella viene aperta in visualizzazione Foglio dati.

    • Creare un nuovo database desktop

      1. In Modelli disponibili fareclic su Database vuoto.

      2. A destra, in Databasevuoto, digitare un nome per il file di database nella casella Nome file o usare quello fornito.

      3. Fare clic su Crea.

        Il nuovo database viene creato e una nuova tabella viene aperta in visualizzazione Foglio dati.

Con il prodotto access sono disponibili diversi modelli ed è possibile scaricarli da Office.com. Un modello di Access è un database predefinito che contiene tabelle, maschere e report dal design professionale. I modelli danno un grande punto di partenza quando crei un nuovo database.

Creare un nuovo database da un modello di esempio

  1. Avviare Access dal menu Start o da un collegamento.

    Viene visualizzata la visualizzazione Backstage.

  2. Fare clic su Modellidi esempio e quindi esplorare i modelli disponibili.

  3. Dopo aver trovato il modello da usare, fare clic sul modello.

  4. Nella casella Nome file a destra digitare un nome file o usare quello fornito.

  5. Fare clic su Crea.

    Il nuovo database verrà creato dal modello e verrà aperto.

È possibile scaricare altri modelli di Access da office.com direttamente dalla visualizzazione Backstage.

Creare un nuovo database da un modello Office.com dati

  1. Avviare Access dal menu Start o da un collegamento.

    Viene visualizzata la visualizzazione Backstage.

  2. In Office.com riquadro Modelli fare clic su una categoria e quindi, quando vengono visualizzati i modelli in quella categoria, fare clic su un modello.

    Nota: È anche possibile cercare un modello usando la casella di ricerca disponibile.

  3. Nella casella Nome file digitare un nome file o usare quello fornito.

  4. Fare clic su Download.

    Access scarica automaticamente il modello, crea un nuovo database basato su tale modello, lo archivia nella cartella documenti (ad esempio, la cartella Documenti) e apre il database.

Quando si apre (o si crea e si apre) un database, Il nome e il percorso del database vengono aggiunti a un elenco interno dei documenti usati più di recente. Questo elenco viene visualizzato nella scheda Recenti della visualizzazione Backstage in modo da poter aprire facilmente i database usati più di recente.

Aprire un database usato di recente

  1. Avviare Access.

  2. Nella visualizzazione Backstage fare clicsu Recenti e quindi sul database da aprire.

    Access apre il database.

Aprire un database dalla visualizzazione Backstage

  1. Avviare Access.

  2. Fare clic sulla scheda File e quindi su Apri. Quando viene visualizzata la finestra di dialogo Apri, individuare e selezionare un file e quindi fare clic su Apri.

    Il database si apre.

Inizio pagina

Barra multifunzione

La barra multifunzione costituisce la principale sostituzione di menu e barre degli strumenti e offre l'interfaccia di comando principale di Access. Uno dei vantaggi principali della barra multifunzione è il consolidamento, in un'unica posizione, delle attività o dei punti di ingresso che prima richiedeva la visualizzazione di menu, barre degli strumenti, riquadri attività e altri componenti dell'interfaccia utente. In questo modo si ha un'unica posizione in cui cercare i comandi, invece di tanti luoghi.

Quando si apre un database, la barra multifunzione viene visualizzata nella parte superiore della finestra principale di Access, in cui sono visualizzati i comandi della scheda di comando attiva.

Barra multifunzione di Access

La barra multifunzione contiene una serie di schede di comandi che contengono comandi. In Access, le schede dei comandi principali sono File,Home,Crea,Datiesterni e Strumenti database. Ogni scheda contiene gruppi di comandi correlati e questi gruppi visualizzano alcuni dei nuovi elementi dell'interfaccia utente, ad esempio la raccolta, che è un nuovo tipo di controllo che presenta le opzioni visivamente.

I comandi disponibili sulla barra multifunzione riflettono anche l'oggetto attualmente attivo. Se ad esempio è aperta una tabella in visualizzazione Foglio dati e si fa clic su Maschera nel gruppo Maschere della scheda Crea, la maschera verrà creata automaticamente in base alla tabella attiva. In altri caso, il nome della tabella attiva viene immesso nella proprietà RecordSource della nuova maschera. Inoltre, alcune schede della barra multifunzione vengono visualizzate solo in determinati contesti. Ad esempio, la scheda Progettazione viene visualizzata solo quando è aperto un oggetto in visualizzazione Struttura.

È possibile usare le scelte rapide da tastiera con la barra multifunzione. Tutte le scelte rapide da tastiera di una versione precedente di Access continuano a funzionare. Il sistema di accesso tramite tastiera sostituisce gli acceleratori di menu delle versioni precedenti di Access. Questo sistema usa piccoli indicatori con una singola lettera o combinazione di lettere che vengono visualizzate sulla barra multifunzione quando si preme ALT. Questi indicatori mostrano la scelta rapida da tastiera che attiva il controllo al di sotto.

Dopo aver selezionato una scheda di comando, è possibile esplorare i comandi disponibili all'interno di tale scheda.

Selezionare una scheda di comando

  1. Avviare Access.

  2. Fare clic sulla scheda desiderata.

-oppure-

  1. Avviare Access.

  2. Premere e rilasciare ALT.

    Vengono visualizzati i suggerimenti della tastiera.

  3. Premere il tasto o i tasti visualizzati nel suggerimento della tastiera o più vicino alla scheda di comando desiderata.

È possibile eseguire un comando in vari modi. La route più rapida e più diretta è usare la scelta rapida da tastiera associata al comando.

Per altre informazioni sulle scelte rapide da tastiera, vedere Scelte rapide da tastiera per Access.

Eseguire un comando

  1. Avviare Access.

  2. Fare clic sulla scheda appropriata per il comando. La tabella seguente mostra un campione rappresentativo delle schede e dei comandi disponibili in ogni scheda. Le schede e i comandi disponibili variano a seconda dell'operazione che si sta eseguendo.

Scheda Comando

Operazioni comuni

HOME

Selezionare una visualizzazione diversa.

Copiare e incollare dagli Appunti.

Impostare le caratteristiche del tipo di carattere corrente.

Impostare l'allineamento del carattere corrente.

Applicare il formato RTF a un campo Memo.

Usare i record (Aggiorna, Nuovo, Salva, Elimina, Totali, Controllo ortografia, Altro).

Ordinare e filtrare i record.

Trovare record.

Creare

Creare una nuova tabella vuota.

Creare una nuova tabella usando un modello di tabella.

Creare un elenco in un sito di SharePoint e una tabella nel database corrente collegata all'elenco appena creato.

Creare una nuova tabella vuota in visualizzazione Struttura.

Creare una nuova maschera basata sulla tabella o sulla query attiva.

Creare una nuova tabella pivot o un nuovo grafico.

Creare un nuovo report in base alla tabella o alla query attiva.

Creare una nuova query, una macro, un modulo o un modulo di classe.

Dati esterni

Importare o collegare dati esterni.

Esportare i dati.

Raccogliere e aggiornare dati tramite posta elettronica.

Creare importazioni ed esportazioni salvate.

Eseguire Gestione tabelle collegate.

Strumenti database

Spostare alcune o tutte le parti di un database in un sito di SharePoint nuovo o esistente.

Avviare l Visual Basic editor di macro o eseguire una macro.

Creare e visualizzare le relazioni tra tabelle.

Mostrare/nascondere le dipendenze degli oggetti.

Eseguire l'Analizzatore database o analizzare le prestazioni.

Spostare i dati Microsoft SQL Server un database di Access (solo tabelle).

Gestire i componenti aggiuntivi di Access.

Creare o modificare un Visual Basic, Applications Edition (VBA).

  1. Fare clic sul controllo che rappresenta il comando. In alternativa, se si conosce la scelta rapida da tastiera per il comando di una versione precedente di Access, immettere la scelta rapida da tastiera usando la tastiera.

    -oppure-

    Premere e rilasciare ALT.

    Vengono visualizzati i tasti di scelta.

    Premere il tasto o i tasti visualizzati nella descrizione comando associata al comando desiderato.

Schede dei comandi contestuali

Oltre alle schede dei comandi standard, Access include anche le schede dei comandi contestuali. A seconda del contesto( ad esempio l'oggetto su cui si sta lavorando e l'oggetto in uso), è possibile che vengano visualizzate una o più schede comandi contestuali accanto alle schede dei comandi standard.

Schede contestuali

Attivare una scheda di comando contestuale

  • Fare clic sulla scheda del comando contestuale.

-oppure-

  1. Premere e rilasciare ALT.

    Vengono visualizzati i tasti di scelta.

  2. Premere il tasto o i tasti visualizzati nel tasto di scelta visualizzato o più vicino alla scheda comando contestuale.

Le schede dei comandi contestuali contengono comandi e caratteristiche che è necessario usare in un contesto specifico. Ad esempio, quando si apre una tabella in visualizzazione Struttura, le schede contestuali contengono comandi che vengono applicati solo quando si lavora con una tabella in tale visualizzazione. In un altro esempio, quando si apre una tabella in visualizzazione Struttura, accanto alla scheda Strumenti avanzati viene visualizzata una scheda di comando contestuale denominata Progettazione. Quando si fa clic sulla scheda Progettazione, sulla barra multifunzione vengono visualizzati i comandi disponibili solo quando l'oggetto è in visualizzazione Struttura.

Raccolte    

Sulla barra multifunzione viene inoltre utilizzato un tipo di controllo denominato raccolta. Il controllo raccolta è progettato per attirare l'attenzione su come ottenere i risultati desiderati. Invece di visualizzare semplicemente i comandi, il controllo raccolta mostra il risultato dell'uso di tali comandi. L'idea è di offrire un modo visivo per esplorare e vedere cosa può fare Access 2010, concentrandosi sui risultati, invece di concentrarsi unicamente sui comandi stessi.

Raccolta margini

Le raccolte hanno forme e dimensioni diverse. È disponibile un layout griglia, una rappresentazione menu-simile a un elenco a discesa e persino un layout su barra multifunzione che posiziona il contenuto della raccolta stessa sulla barra multifunzione.

Nascondere la barra multifunzione

A volte può essere necessario più spazio da dedicare all'area di lavoro. Per questo motivo, la barra multifunzione può essere compressa in modo che rimanga solo la barra con le schede dei comandi. Per nascondere la barra multifunzione, fare doppio clic sulla scheda del comando attivo. Per visualizzare di nuovo il comando, fare di nuovo doppio clic sulla scheda del comando attivo.

Nascondere e ripristinare la barra multifunzione

  1. Fare doppio clic sulla scheda del comando attivo (la scheda attiva è la scheda evidenziata).

  2. Fare di nuovo doppio clic sulla scheda del comando attivo per ripristinare la barra multifunzione.

Barra di accesso rapido

La barra di accesso rapido è una barra degli strumenti adiacente alla barra multifunzione che consente l'accesso con un solo clic ai comandi. Il set predefinito di comandi includeSalva,Annulla e Ripeti ed è possibile personalizzare la barra di accesso rapido in modo da includere altri comandi di uso frequente. È anche possibile modificare la posizione della barra degli strumenti e modificarla dalle dimensioni predefinite ridotte a grandi. La piccola barra degli strumenti viene visualizzata accanto alle schede dei comandi sulla barra multifunzione. Quando si passa alle dimensioni grandi, la barra degli strumenti viene visualizzata sotto la barra multifunzione ed estende l'intera larghezza.

Barra di accesso rapido

Personalizzare la barra di accesso rapido

  1. Fare clic sulla freccia a discesa più a destra nella barra degli strumenti.

  2. In Personalizza barra di accesso rapidofare clic sul comando da aggiungere.

    In caso contrario, se il comando non è presente nell'elenco, fare clic su Altri comandie procedere con il passaggio successivo della procedura.

  3. Nella finestra di dialogo Opzioni di Access selezionare il comando o i comandi da aggiungere e quindi fare clic su Aggiungi.

  4. Per rimuovere un comando, evidenziarlo nell'elenco a destra e quindi fare clic su Rimuovi. In alternativa, fare doppio clic sul comando nell'elenco.

  5. Al termine, scegliere OK.

Inizio pagina

Riquadro di spostamento

Quando si apre un database o se ne crea uno nuovo, i nomi degli oggetti di database vengono visualizzati nel riquadro di spostamento. Gli oggetti di database includono tabelle, maschere, report, pagine, macro e moduli.

Riquadro di spostamento di Northwind 2007

Per aprire un oggetto di database o applicare un comando a un oggetto di database, fare clic con il pulsante destro del mouse sull'oggetto e scegliere una voce di menu dal menu di scelta rapida. I comandi del menu di scelta rapida variano in base al tipo di oggetto.

Aprire un oggetto di database, ad esempio una tabella, una maschera o un report

  • Nel riquadro di spostamento fare doppio clic sull'oggetto.

    -oppure-

    Nel riquadro di spostamento selezionare l'oggetto e quindi premere INVIO.

    -oppure-

  • Nel riquadro di spostamento fare clic con il pulsante destro del mouse su un oggetto e quindi scegliere Apri.

Si noti che è possibile impostare un'opzione per aprire gli oggetti con un solo clic nella finestra di dialogo Opzioni di spostamento.

Il riquadro di spostamento divide gli oggetti di database in categorie e queste categorie contengono gruppi. Alcune categorie sono predefinite ed è anche possibile creare gruppi personalizzati.

Per impostazione predefinita, il riquadro di spostamento viene visualizzato all'apertura di un database, inclusi i database creati in versioni precedenti di Access. È possibile impedire che il riquadro di spostamento venga visualizzato per impostazione predefinita impostando un'opzione di programma. I passaggi seguenti illustrano come eseguire ogni azione.

Per visualizzare o nascondere il riquadro di spostamento    

  • Fare clic sul pulsante nell'angolo in alto a destra del riquadro di spostamento (Pulsante di apertura/chiusura della barra di ridimensionamento per il riquadro di spostamento in Access) oppure premere F11.

Impedire la visualizzazione del riquadro di spostamento per impostazione predefinita

  1. Fare clic sulla scheda File e quindi su Opzioni.

    Viene visualizzata la finestra di dialogo Opzioni di Access.

  2. Nel riquadro sinistro fare clic su Database corrente.

  3. In Spostamentodeselezionare la casella di controllo Visualizza riquadro di spostamento e quindi fare clic su OK.

Per altre informazioni sul riquadro di spostamento, vedere l'articolo Visualizzare e gestire oggetti usando il riquadro di spostamento.

Inizio pagina

Documenti a schede

Per l'uso interattivo quotidiano, si può preferire l'interfaccia a schede dei documenti. È possibile abilitare o disabilitare i documenti a schede impostando le opzioni di Access (vedere Mostrare o nascondere le schede dei documentipiù avanti in questo articolo). Tuttavia, se si modificano le impostazioni dei documenti a schede, è necessario chiudere e riaprire il database per fare in modo che le nuove impostazioni appartienino.

Oggetto a schede in Access 2007

Mostrare o nascondere le schede dei documenti

  1. Fare clic sulla scheda File e quindi su Opzioni.

    Viene visualizzata la finestra di dialogo Opzioni di Access.

  2. Nel riquadro sinistro fare clic su Database corrente.

  3. Nella sezione Opzioni applicazione, in Opzioni finestra documento,selezionare Documenti a schede.

  4. Selezionare o deselezionare la casella di controllo Visualizza schede documento. Se si deseleziona la casella di controllo, le schede del documento vengono disattivate.

  5. Fare clic su OK.

    Note: 

    • L'impostazione Visualizza schede documento è un'impostazione per database. È necessario impostare questa opzione in modo indipendente per ogni database.

    • Dopo aver modificato l'impostazione Visualizza schede documento, è necessario chiudere e riaprire il database per visualizzare la modifica.

    • I nuovi database creati con Access visualizzano le schede dei documenti per impostazione predefinita.

    • I database creati con una versione precedente di Access usano per impostazione predefinita finestre sovrapposte.

Inizio pagina

barra di stato

È possibile visualizzare una barra di stato nella parte inferiore della finestra. Questo elemento standard dell'interfaccia utente continua a essere lo spazio in cui cercare messaggi di stato, suggerimenti per le proprietà, indicatori di stato e così via. La barra di stato assume inoltre due funzioni standard, visualizzate anche nella barra di stato di altre applicazioni di Office: Visualizzazione/Finestra e Zoom.

È possibile passare rapidamente dalla finestra attiva a una delle visualizzazioni disponibili usando i controlli disponibili sulla barra di stato. Se si sta visualizzando un oggetto che supporta lo zoom variabile, è possibile regolare il livello di zoom per fare zoom avanti o indietro usando il dispositivo di scorrimento sulla barra di stato.

La barra di stato può essere abilitata o disabilitata nella finestra di dialogo Opzioni di Access.

Visualizzare o nascondere la barra di stato

  1. Fare clic sulla scheda File e quindi su Opzioni.

    Viene visualizzata la finestra di dialogo Opzioni di Access.

  2. Nel riquadro sinistro fare clic su Database corrente.

  3. In Opzioni applicazione selezionareo deselezionare la casella di controllo Visualizza barra di stato. Deselezionando la casella di controllo si disattiva la visualizzazione della barra di stato.

  4. Fare clic su OK.

Inizio pagina

Scheda GENERALE durante la configurazione di una query in una web part Ricerca contenuto

È possibile formattare il testo in modo più semplice usando la barra di formattazione rapida. Quando si seleziona il testo per la formattazione, la barra di formattazione rapida viene visualizzata automaticamente sopra il testo selezionato. Se si sposta il puntatore del mouse più vicino alla barra di formattazione rapida, la barra di formattazione rapida si dissolve ed è possibile usarla per applicare il grassetto, il corsivo, le dimensioni del carattere, il colore e così via. Quando si sposta il puntatore allontanato dalla barra di formattazione rapida, la barra di formattazione rapida si dissolve. Se non si vuole usare la barra di formattazione rapida per applicare la formattazione del testo a una selezione, spostare il puntatore a pochi pixel di distanza e la barra di formattazione rapida scompare.

Scheda GENERALE durante la configurazione di una query in una web part Ricerca contenuto

Formattare il testo usando la barra di formattazione rapida

  1. Selezionare il testo da formattare.

    La barra di formattazione rapida viene visualizzata in modo trasparente sopra il testo.

  2. Applicare la formattazione usando la barra di formattazione rapida.

Inizio pagina

Serve aiuto?

Amplia le tue competenze

Esplora i corsi di formazione >

Ottieni in anticipo le nuove caratteristiche

Partecipa a Microsoft Insider >

Queste informazioni sono risultate utili?

Come valuti la qualità della lingua?
Cosa ha influito sulla tua esperienza?

Grazie per il feedback!

×