Excel per Mac incorpora la tecnologia Power Query, chiamata anche Get & Transform, per fornire funzionalità più avanzate durante l'importazione, l'aggiornamento e l'autenticazione di origini dati, la gestione di origini dati Power Query, la cancellazione delle credenziali, la modifica della posizione delle origini dati basate su file e la modifica della forma dei dati in una tabella che soddisfa i propri requisiti.  È anche possibile creare una query di Power Query usando VBA. 

Importante: Le origini dati seguenti possono essere importate solo in Anteprima canale corrente: XML, JSON, elenco di SharePoint Online, OData, tabella vuota, query vuota. L'origine dati SQL Server Database può essere importata solo nella versione beta di Insider.

  1. Selezionare Dati > Recupera dati.

    Pulsante principale e menu per il recupero dei dati

  2. Per selezionare l'origine dati desiderata, selezionare Recupera dati (Power Query).

  3. Nella finestra di dialogo Scegli origine dati selezionare una delle origini dati disponibili. 

    Esempio di origini dati da selezionare nella finestra di dialogo

  4. Connettersi all'origine dati. Per altre informazioni su come connettersi a ogni origine dati, vedere Importare dati da origini dati.

  5. Scegliere i dati da importare.

  6. Caricare i dati facendo clic sul pulsante Carica .

Risultato

I dati importati vengono visualizzati in un nuovo foglio.

Risultati tipici per una query

Passaggi successivi

Per modellare e trasformare i dati usando la editor di Power Query, selezionare Trasforma dati. Per altre informazioni, vedere Modellare i dati con editor di Power Query.

Importante: Questa funzionalità è disponibile per i partecipanti al Programma Windows Insider che usano Canale corrente Preview o Canale beta, in cui è in esecuzione la versione 16.64 (build 22072501) o successiva di Excel per Mac.  In precedenza era disponibile solo per i partecipanti al Programma Windows Insider del Canale beta che hanno aderito al programma Office Insider. Se si ha un abbonamento a Microsoft 365, verificare di avere la versione più recente di Office.

È possibile importare dati in Excel usando Power Query da un'ampia gamma di origini dati: Cartella di lavoro di Excel, Testo/CSV, XML, JSON, database SQL Server, elenco di SharePoint Online, OData, Tabella vuota e Query vuota.

Procedura

  1. Selezionare Dati > Recupera dati (Power Query).Select Data> Get Data (Power Query).

  2. Per aprire il Editor di query, seleziona Avvia editor di Power Query.

    Menu di comando Recupera dati (Power Query)

    Suggerimento: È anche possibile accedere al Editor di query selezionando Recupera dati (Power Query), scegliendo un'origine dati e quindi facendo clic su Avanti.

  3. Modellare e trasformare i dati usando la Editor di query come si farebbe in Excel per Windows.



    Il editor di Power Query Per altre informazioni, vedere la Guida di Power Query per Excel.

  4. Al termine, selezionare Home > Chiudi & Carica.

Risultato

I nuovi dati importati vengono visualizzati in un nuovo foglio.

Risultati tipici per una query

È possibile aggiornare le origini dati seguenti: file di SharePoint, elenchi di SharePoint, cartelle di SharePoint, OData, file di testo/CSV, cartelle di lavoro di Excel (.xlsx), file XML e JSON, tabelle e intervalli locali e un database di Microsoft SQL Server.

Aggiornare la prima volta

La prima volta che si prova ad aggiornare le origini dati basate su file nelle query della cartella di lavoro, potrebbe essere necessario aggiornare il percorso del file.

  1. Selezionare Dati,la  freccia accanto a Recupera dati e quindi Impostazioni origine dati. Viene visualizzata la finestra di dialogo Impostazioni origine dati .

  2. Selezionare una connessione e quindi selezionare Modifica percorso file.

  3. Nella finestra di dialogo Percorso file selezionare una nuova posizione e quindi Recupera dati.

  4. Seguire le istruzioni visualizzate nella finestra, quindi selezionare Chiudi.

Aggiornare gli orari successivi

Per aggiornare:

  • Tutte le origini dati nella cartella di lavoro selezionare Dati > Aggiorna tutto.

  • Un'origine dati specifica, fare clic con il pulsante destro del mouse su una tabella di query in un foglio e quindi scegliere Aggiorna.

  • Una tabella pivot, selezionare una cella nella tabella pivot e quindi selezionare Analizza tabella pivot > Aggiorna dati.

La prima volta che si accede a SharePoint, SQL Server, OData o altre origini dati che richiedono l'autorizzazione, è necessario fornire le credenziali appropriate. È anche possibile cancellare le credenziali per immetterne di nuove.

Immettere le credenziali

Quando si aggiorna una query per la prima volta, potrebbe essere richiesto di eseguire l'accesso. Selezionare il metodo di autenticazione e specificare le credenziali di accesso per connettersi all'origine dati e continuare con l'aggiornamento.

Se è richiesto l'accesso, viene visualizzata la finestra di dialogo Immetti credenziali .

Ad esempio:

  • Credenziali di SharePoint:

    Richiesta di credenziali di SharePoint su Mac

  • SQL Server credenziali:

    Finestra di dialogo SQL Server per immettere server, database e credenziali

Cancellare le credenziali

  1. Selezionare Dati > Recupera dati > Impostazioni origine dati.

  2. Nella finestra di dialogo Impostazioni origine datiselezionare la connessione desiderata.

  3. Nella parte inferiore selezionare Cancella Permissions.

  4. Verifica che questa sia l'operazione che vuoi eseguire e quindi seleziona Elimina.

Anche se la creazione nel editor di Power Query non è disponibile in Excel per Mac, VBA supporta Power Query creazione. Il trasferimento di un modulo di codice VBA in un file da Excel per Windows a Excel per Mac prevede due passaggi. Alla fine di questa sezione viene fornito un programma di esempio.

Passaggio 1: Excel per Windows

  1. In Excel Windows sviluppare query usando VBA. Anche il codice VBA che usa le entità seguenti nel modello a oggetti di Excel funziona in Excel per Mac: oggetto Query, oggetto WorkbookQuery, proprietà Workbook.Queries.Per altre informazioni, vedere Informazioni di riferimento su VBA per Excel.

  2. In Excel verificare che Visual Basic Editor sia aperto premendo ALT+F11.

  3. Fare clic con il pulsante destro del mouse sul modulo e scegliere Esporta file. Viene visualizzata la finestra di dialogo Esporta .

  4. Immetti un nome file, assicurati che l'estensione sia bas e quindi seleziona Salva.

  5. Caricare il file VBA in un servizio online per renderlo accessibile dal Mac.

    È possibile usare Microsoft OneDrive. Per altre informazioni, vedere Sincronizzare i file con OneDrive in Mac OS X.

Passaggio 2: Excel per Mac

  1. Scaricare il file VBA in un file locale, il file VBA salvato nel "Passaggio uno: Excel per Windows" e caricato in un servizio online.

  2. In Excel per Mac selezionare Strumenti > Macro > Visual Basic Editor. Viene visualizzata la finestra Visual Basic Editor .

  3. Fare clic con il pulsante destro del mouse su un oggetto nella finestra Progetto e quindi scegliere Importa file. Viene visualizzata la finestra di dialogo Importa file .

  4. Individuare il file VBA e quindi selezionare Apri.

Codice di esempio

Ecco alcuni codici di base che puoi adattare e usare. Questa è una query di esempio che crea un elenco con valori da 1 a 100.

Sub CreateSampleList()
    ActiveWorkbook.Queries.Add Name:="SampleList", Formula:= _
        "let" & vbCr & vbLf & _
            "Source = {1..100}," & vbCr & vbLf & _
            "ConvertedToTable = Table.FromList(Source, Splitter.SplitByNothing(), null, null, ExtraValues.Error)," & vbCr & vbLf & _
            "RenamedColumns = Table.RenameColumns(ConvertedToTable,{{""Column1"", ""ListValues""}})" & vbCr & vbLf & _
        "in" & vbCr & vbLf & _
            "RenamedColumns"
    ActiveWorkbook.Worksheets.Add
    With ActiveSheet.ListObjects.Add(SourceType:=0, Source:= _
        "OLEDB;Provider=Microsoft.Mashup.OleDb.1;Data Source=$Workbook$;Location=SampleList;Extended Properties=""""" _
        , Destination:=Range("$A$1")).QueryTable
        .CommandType = xlCmdSql
        .CommandText = Array("SELECT * FROM [SampleList]")
        .RowNumbers = False
        .FillAdjacentFormulas = False
        .PreserveFormatting = True
        .RefreshOnFileOpen = False
        .BackgroundQuery = True
        .RefreshStyle = xlInsertDeleteCells
        .SavePassword = False
        .SaveData = True
        .AdjustColumnWidth = True
        .RefreshPeriod = 0
        .PreserveColumnInfo = True
        .ListObject.DisplayName = "SampleList"
        .Refresh BackgroundQuery:=False
    End With
End Sub

  1. Aprire la cartella di lavoro di Excel.

  2. Se viene visualizzato un avviso di sicurezza relativo alla disabilitazione delle connessioni dati esterne, selezionare Abilita contenuto.

  3. Se viene visualizzata la finestra di dialogo Concedi accesso ai file , selezionare Seleziona e quindi Selezionare Concedi accesso alla cartella di primo livello contenente i file dell'origine dati.

  4. Selezionare Dati > da testo (legacy).Select Data> From Text (Legacy). Viene visualizzata la finestra di dialogo Inder F.

  5. Individuare il .txt o .csv file e selezionare Apri. Verrà visualizzata l'Importazione guidata testo .

    Mancia     Controllare ripetutamente l'anteprima del riquadro dati selezionato per confermare le scelte effettuate.

  6. Nella prima pagina eseguire le operazioni seguenti:

    Tipo di file    Per scegliere il tipo di file di testo, selezionare Delimitato o Larghezza fissa.

    Numero di riga    In Inizia importazione da riga selezionare un numero di riga per specificare la prima riga di dati da importare.

    Set di caratteri     In Origine file selezionare il set di caratteri usato nel file di testo. Nella maggior parte dei casi, è possibile lasciare questa impostazione come predefinita.

  7. Nella seconda pagina eseguire le operazioni seguenti:

    Delimitato

    Se si è scelto Delimitato nella prima pagina, in Delimitatori selezionare il carattere di delimitatore oppure usare la casella di controllo Altro per immetterne uno non elencato.

    Selezionare Considera i delimitatori consecutivi come uno se i dati contengono un delimitatore di più di un carattere tra i campi dati o se i dati contengono più delimitatori personalizzati.

    In Qualificatore di testo selezionare il carattere che racchiude i valori nel file di testo, che corrisponde più spesso all'virgoletta (").

    Larghezza

    fissa Se si è scelto Larghezza fissa nella prima pagina, seguire le istruzioni per creare, eliminare o spostare una riga di interruzione nella casella Anteprima dei dati selezionati .

  8. Nella terza pagina eseguire le operazioni seguenti:

    Per ogni colonna in Anteprima dei dati selezionati selezionarla e, se si vuole, modificarla in un formato di colonna diverso. È possibile impostare ulteriormente il formato della data e selezionare Avanzate per modificare le impostazioni dei dati numerici. È anche possibile convertire i dati dopo l'importazione.

    Selezionare Fine. Viene visualizzata la finestra di dialogo Importa dati .

  9. Scegliere dove aggiungere i dati: nel foglio esistente, in un nuovo foglio o in una tabella pivot.

  10. Scegliere OK.

    Per assicurarsi che la connessione funzioni, immettere alcuni dati e quindi selezionare Connessioni > Aggiorna.

  1. Selezionare Dati > DaSQL Server ODBC.  Viene visualizzata la finestra di dialogo Connetti a origine dati ODBC SQL Server.

    Finestra di dialogo SQL Server per immettere server, database e credenziali

  2. Immettere il server nella casella Nome server e, facoltativamente, immettere il database nella casella Nome database .

    Ottenere queste informazioni dall'amministratore del database.

  3. In Autenticazione selezionare un metodo nell'elenco: Nome utente/Password, Kerberos o NTLM.

  4. Immettere le credenziali nelle caselle Nome utente e Password.

  5. Seleziona Connetti. Viene visualizzata la finestra di dialogo Strumento di navigazione .

  6. Nel riquadro sinistro passare alla tabella desiderata e quindi selezionarla.

  7. Confermare l'istruzione SQL nel riquadro destro. È possibile modificare l'istruzione SQL secondo le proprie esigenze.

  8. Per visualizzare in anteprima i dati, selezionare Esegui.

  9. Quando sei pronto, seleziona Restituisci dati. Viene visualizzata la finestra di dialogo Importa dati

    Finestra di dialogo Importa dati usata per individuare i dati

  10. Scegliere dove aggiungere i dati: nel foglio esistente, in un nuovo foglio o in una tabella pivot.

  11. Per impostare le proprietà di connessione nelle schede Utilizzo e Definizione della finestra di dialogo Proprietà , selezionare Proprietà. Dopo aver importato i dati, è anche possibile selezionare Dati > Connessioni e quindi nella finestra di dialogo Proprietà connessione selezionare Proprietà.

  12. Scegliere OK.

  13. Per assicurarsi che la connessione funzioni, immettere alcuni dati e quindi selezionare Dati > Aggiorna tutto.

Se si vuole usare un'origine esterna non database SQL, ad esempio FileMaker Pro, è possibile usare un driver ODBC (Open Database Connectivity) installato nel Mac. Le informazioni sui driver sono disponibili in questa pagina Web. Dopo aver installato il driver per l'origine dati, procedere come segue:

  1. Selezionare Dati > da database (Microsoft Query).Select Data> From Database (Microsoft Query).

  2. Aggiungere l'origine dati per il database e quindi scegliere OK.

  3. Alla richiesta di credenziali di SQL Server immettere il metodo di autenticazione, il nome utente e la password.

    testo alternativo

  4. A sinistra selezionare la freccia accanto al server per visualizzare i database.

  5. Selezionare la freccia accanto al database desiderato.

  6. Selezionare la tabella desiderata.

  7. Per visualizzare in anteprima i dati, selezionare Esegui.

  8. Quando sei pronto, seleziona Restituisci dati.

  9. Nella finestra di dialogo Importa dati scegliere dove si vogliono inserire i dati: nel foglio esistente, in un nuovo foglio o in una tabella pivot.

  10. Selezionare OK.

  11. Per assicurarsi che la connessione funzioni, immettere alcuni dati e quindi selezionare Dati > Aggiorna tutto.

Se le autorizzazioni non funzionano, è possibile non cancellarle e quindi accedere.

  1. Selezionare Connessioni> dati . Viene visualizzata la finestra di dialogo Connessioni cartella di lavoro.

  2. Selezionare la connessione desiderata nell'elenco e quindi selezionare Cancella autorizzazioni.

    Rimozione delle credenziali salvate per una connessione dati su Mac

Vedere anche

Guida di Power Query per Excel

Driver ODBC compatibili con Excel per Mac

Creare una tabella pivot per analizzare i dati di un foglio di lavoro

Serve aiuto?

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa a Microsoft Office Insider

Queste informazioni sono risultate utili?

Come valuti la qualità della lingua?
Cosa ha influito sulla tua esperienza?

Grazie per il feedback!

×