INDICE (funzione INDICE)

La funzione INDICE restituisce un valore o il riferimento a un valore da una tabella o un intervallo.

Il browser in uso non supporta le funzionalità video.

La funzione INDICE può essere usata in due modi:

  • Se si vuole restituire il valore di una cella o di una matrice di celle specificata, vedere Matrice.

  • Se si vuole restituire un riferimento alle celle specificate, vedere Riferimento.

Matrice

Descrizione

Restituisce il valore di un elemento di una tabella o di una matrice, selezionato in base all'indice dei numeri di riga e di colonna.

Usare la forma per matrice se il primo argomento della funzione INDICE è una costante di matrice.

Sintassi

INDICE(matrice; riga; [col])

Gli argomenti della forma di matrice della funzione INDICE sono i seguenti:

  • matrice    Obbligatorio. Intervallo di celle o costante di matrice.

    • Se matrice contiene una sola riga o colonna, l'argomento row_num o column_num è facoltativo.

    • Se matrice contiene più righe e più colonne e viene usato solo row_num o column_num, INDICE restituirà una matrice dell'intera riga o colonna nella matrice.

  • row_num    Obbligatorio, a meno column_num non sia presente. Seleziona la riga nella matrice da cui restituire un valore. Se row_num viene omesso, column_num obbligatorio.

  • column_num    Facoltativo. Seleziona la colonna nella matrice da cui restituire un valore. Se column_num viene omesso, row_num obbligatorio.

Osservazioni

  • Se vengono usati sia gli argomenti row_num che column_num, INDICE restituirà il valore nella cella all'intersezione tra row_num e column_num.

  • row_num e column_num devono puntare a una cella all'interno della matrice. in caso contrario, INDICE restituisce un #REF! errore.

  • Se si imposta row_num o column_num su 0 (zero), INDICE restituirà rispettivamente la matrice di valori per l'intera colonna o riga. Per usare i valori restituiti come matrice, immettere la funzione INDICE come formula di matrice.

    Nota: Se si ha una versione corrente di Microsoft 365,è possibile immettere la formula nella cella superiore sinistra dell'intervallo di output, quindi premere INVIO per confermare la formula come formula di matrice dinamica. In caso contrario, è necessario immettere la formula come formula di matrice legacy selezionando prima l'intervallo di output, immettendo la formula nella cella superiore sinistra dell'intervallo di output, quindi premere CTRL+MAIUSC+INVIO per confermarla. Excel inserisce automaticamente parentesi graffe all'inizio e alla fine della formula. Per ulteriori informazioni sulle formule di matrice, vedere Formule di matrice: indicazioni ed esempi.

Esempi

Esempio 1

In questi esempi la funzione INDICE viene utilizzata per trovare il valore nella cella di intersezione dove si incontrano una riga e una colonna.

Copiare i dati di esempio contenuti nella tabella seguente e incollarli nella cella A1 di un nuovo foglio di lavoro di Excel. Per visualizzare i risultati delle formule, selezionarle, premere F2 e quindi premere INVIO.

Dati

Dati

Mele

Limoni

Banane

Pere

Formula

Descrizione

Risultato

=INDICE(A2:B3;2;2)

Valore all'intersezione della seconda riga e della seconda colonna nell'intervallo A2:B3.

Pere

=INDICE(A2:B3;2;1)

Valore all'intersezione della seconda riga e della prima colonna nell'intervallo A2:B3.

Banane

Esempio 2

In questo esempio si utilizza la funzione INDICE in una formula in forma di matrice per trovare i valori in due celle specificate in una matrice 2x2.  

Nota: Se si ha una versione corrente di Microsoft 365,è possibile immettere la formula nella cella superiore sinistra dell'intervallo di output, quindi premere INVIO per confermare la formula come formula di matrice dinamica. In caso contrario, la formula deve essere immessa come formula di matrice legacy selezionando prima due celle vuote, immettendo la formula nella cella superiore sinistra dell'intervallo di output, quindi premere CTRL+MAIUSC+INVIO per confermarla. Excel inserisce automaticamente parentesi graffe all'inizio e alla fine della formula. Per ulteriori informazioni sulle formule di matrice, vedere Formule di matrice: indicazioni ed esempi.

Formula

Descrizione

Risultato

=INDICE({1;2;3;4};0;2)

Valore trovato nella prima riga, seconda colonna della matrice. La matrice contiene 1 e 2 nella prima riga e 3 e 4 nella seconda riga.

2

Valore trovato nella seconda riga, seconda colonna della matrice (matrice identica a quella dell'esempio precedente).

4

Inizio pagina


Modulo di riferimento

Descrizione

Restituisce il riferimento della cella all'intersezione di una particolare riga e colonna. Se il riferimento è costituito da selezioni non adiacenti, è possibile selezionare la selezione da cercare.

Sintassi

INDICE(rif; riga; [col]; [area])

Gli argomenti della forma di riferimento della funzione INDICE sono i seguenti:

  • riferimento    Obbligatorio. Riferimento a uno o più intervalli di celle.

    • Se si immette un intervallo non adiacente per il riferimento, racchiudere il riferimento tra parentesi.

    • Se ogni area in riferimento contiene una sola riga o colonna, l'argomento row_num o column_num, rispettivamente, è facoltativo. Ad esempio, per un riferimento a una singola riga, utilizzare INDICE(rif;;col).

  • row_num    Obbligatorio. Numero della riga in rif dal quale si desidera restituire un riferimento.

  • column_num    Facoltativo. Numero della colonna in rif dal quale si desidera restituire un riferimento.

  • area_num    Facoltativo. Seleziona un intervallo nel riferimento da cui restituire l'intersezione tra row_num e column_num. La prima area selezionata o immessa viene contrassegnata dal numero 1, la seconda dal numero 2 e così via. Se area_num viene omesso, INDICE usa l'area 1.  Le aree elencate qui devono essere tutte nello stesso foglio.  Se si specificano aree che non si trovano nello stesso foglio, verrà generato un errore #VALORE!.  Se occorre usare intervalli che si trovano in fogli diversi, è consigliabile usare il formato di matrice della funzione INDICE e usare un'altra funzione per calcolare l'intervallo che costituisce la matrice.  Ad esempio, si potrebbe usare la funzione SCEGLI per calcolare l'intervallo che verrà usato.

Ad esempio, se Riferimento descrive le celle (A1:B4,D1:E4,G1:H4), area_num 1 è l'intervallo A1:B4, area_num 2 è l'intervallo D1:E4 e area_num 3 è l'intervallo G1:H4.

Osservazioni

  • Dopo che riferimento e area_num hanno selezionato un intervallo specifico, row_num e column_num selezionano una cella specifica: row_num 1 è la prima riga dell'intervallo, column_num 1 è la prima colonna e così via. Il riferimento restituito da INDICE è l'intersezione tra row_num e column_num.

  • Se si imposta row_num o column_num su 0 (zero), INDICE restituirà rispettivamente il riferimento per l'intera colonna o riga.

  • row_num, column_num e area_num deve puntare a una cella all'interno di un riferimento; in caso contrario, INDICE restituisce un #REF! errore. Se row_num e column_num vengono omesse, INDICE restituirà l'area in riferimento specificata da area_num.

  • Il risultato della funzione INDICE è un riferimento e viene interpretato come tale dalle altre formule. A seconda della formula, il valore restituito da INDICE può essere utilizzato come riferimento o come valore. Ad esempio, la formula CELLA("larghezza";INDICE(A1:B2;1;2)) è uguale a CELLA("larghezza";B1). La funzione CELLA utilizza il valore restituito da INDICE come riferimento di cella. D'altro lato, una formula come 2*INDICE(A1:B2;1;2) traduce il valore restituito da INDICE nel numero della cella B1.

Esempi

Copiare i dati di esempio contenuti nella tabella seguente e incollarli nella cella A1 di un nuovo foglio di lavoro di Excel. Per visualizzare i risultati delle formule, selezionarle, premere F2 e quindi premere INVIO.

Frutta

Prezzo

Numero

Mele

€ 0,69

40

Banane

€ 0,34

38

Limoni

€ 0,55

15

Arance

€ 0,25

25

Pere

€ 0,59

40

Mandorle

€ 2,80

10

Anacardi

€ 3,55

16

Arachidi

€ 1,25

20

Noci

€ 1,75

12

Formula

Descrizione

Risultato

=INDICE(A2:C6; 2; 3)

L'intersezione della seconda riga e della terza colonna nell'intervallo A2:C6, ossia il contenuto della cella C3.

38

=INDICE((A1:C6; A8:C11); 2; 2; 2)

L'intersezione della seconda riga e della seconda colonna nella seconda area di A8:C11, ossia il contenuto della cella B9.

1,25

=SOMMA(INDICE(A1:C11; 0; 3; 1))

La somma della terza colonna nella prima area dell'intervallo A1:C11, ossia la somma di C1:C11.

216

=SOMMA(B2:INDICE(A2:C6; 5; 2))

La somma dell'intervallo che ha inizio in B2 e termina all'intersezione della quinta riga e della seconda colonna dell'intervallo A2:A6, ossia la somma di B2:B6.

2,42

Inizio pagina

Vedere anche

CERCA.VERT

CONFRONTA

INDIRETTO

Formule di matrice: linee guida ed esempi

Funzioni di ricerca e di riferimento (riferimento)

Serve aiuto?

Amplia le tue competenze su Office
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×