Importante
Il supporto per Microsoft InfoPath 2013 è terminato il 14 luglio 2026. È consigliabile eseguire la migrazione dei moduli e dei flussi di lavoro di InfoPath esistenti alle soluzioni Microsoft 365 supportate. Altre informazioni sul ritiro di InfoPath.
In un modello di modulo di Microsoft Office InfoPath è possibile usare una casella di testo per raccogliere informazioni dagli utenti o per visualizzare dati da un database o da un'altra origine dati esterna.
Contenuto dell'articolo
- Quando usare una casella di testo
- Esperienza utente
- Inserire una casella di testo
- Suggerimenti per il layout
Quando usare una casella di testo
Usare una casella di testo se si vuole:
- Consentire agli utenti di digitare qualsiasi quantità di testo normale in un modulo.
- Visualizzare informazioni, ad esempio il risultato di una formula o la data corrente.
Nella figura seguente, le caselle di testo vengono utilizzate per raccogliere le informazioni di contatto degli utenti.
Per impostazione predefinita, quando si inserisce una casella di testo nel modello di modulo, InfoPath aggiunge una casella di testo a riga singola. Se invece si vuole visualizzare più righe di testo nella casella di testo, è possibile abilitare le interruzioni di paragrafo o la disposizione del testo per la casella di testo dopo averla inserita. In alternativa, è possibile utilizzare una casella di testo RTF.
Controlli correlati
InfoPath include controlli simili alle caselle di testo, ma con scopi diversi. Per identificare il controllo ottimale per il proprio modello di modulo, fare riferimento all'elenco seguente:
Casella di testo RTF Come una normale casella di testo, una casella di testo RTF consente agli utenti di digitare, modificare o visualizzare il testo. A differenza di una casella di testo, in una casella di testo RTF vengono visualizzate più righe di testo per impostazione predefinita. Gli utenti possono anche aggiungere elementi di formattazione a una casella di testo RTF, ad esempio testo in grassetto o corsivo, immagini e tabelle. I dati formattati in una casella di testo RTF vengono archiviati come XHTML, che potrebbe non essere compatibile con le origini dati che prevedono brevi sequenze di testo normale.
Casella di espressione Una casella di espressione viene in genere utilizzata per visualizzare testo di sola lettura, per visualizzare il valore di un altro controllo nella maschera o per creare formule basate su espressioni XPath. A differenza di una casella di testo, una casella di espressione non memorizza né salva dati. Usare quindi una casella di espressione solo se non si vuole salvarne il valore o farvi riferimento in un'altra formula.
È possibile usare le caselle di testo da sole o aggiungerle a tabelle ripetute, sezioni o altri controlli correlati al layout. Ad esempio, le caselle di testo vengono spesso visualizzate all'interno delle celle di una tabella ripetuta.
Inizio pagina
Esperienza utente
Immettere i dati in una casella di testo è facile. Gli utenti posizionano il cursore all'interno della casella di testo e quindi digitano le informazioni richieste. I dati vengono visualizzati nel modulo come testo normale.
Suggerimento
Se si vuole consentire agli utenti di applicare la formattazione di carattere al testo in una casella di testo, è possibile usare una casella di testo RTF invece di una casella di testo standard.
Le caselle di testo includono diverse funzionalità familiari di Microsoft Office System. Ad esempio, se gli utenti scrivono in modo scorretto una parola in una casella di testo, vedranno la familiare sottolineatura rossa ondulata, che segnala un possibile errore di ortografia.
Oltre al correttore ortografico, la funzionalità Completamento automatico è abilitata per le caselle di testo per impostazione predefinita. Completamento automatico salva le voci precedenti digitate dagli utenti in un modulo. Quando un utente digita i primi caratteri in una casella di testo, InfoPath elenca le possibili corrispondenze di voci digitate in precedenza dall'utente. In questo modo gli utenti possono immettere più facilmente dati comuni o ripetitivi, come il nome o l'indirizzo, nei moduli compilati.
Nota
Quando si progetta un modello di modulo in InfoPath, è possibile scegliere di progettare un modello di modulo compatibile con browser. Quando si progetta un modello di modulo compatibile con browser, alcune funzionalità, ad esempio il correttore ortografico, non sono disponibili in InfoPath perché non funzionano in un Web browser.
Inizio pagina
Inserire una casella di testo
La procedura per l'inserimento di una casella di testo varia leggermente a seconda che si stia progettando un nuovo modello di modulo vuoto o basando la progettazione del modello di modulo su un database o su un'altra origine dati esterna.
Nella figura seguente viene illustrato l'aspetto di una casella di testo quando è selezionata in modalità progettazione.
I controlli possono essere associati o non associati. I controlli associati sono connessi a un campo o a un gruppo nell'origine dati, in modo che i dati immessi al loro interno vengano salvati in un file di modulo (con estensione xml) sottostante. I controlli non associati non sono connessi a un campo o a un gruppo, quindi i dati immessi al loro interno non vengono salvati. Se si seleziona o si sposta il puntatore su un controllo, nell'angolo superiore destro del controllo vengono visualizzati il testo e un'icona di associazione. Il testo indica il gruppo o il campo a cui il controllo è associato nell'origine dati. L'icona indica se il controllo è correttamente associato a tale gruppo o campo. Se l'associazione è corretta, viene visualizzata un'icona verde. Se invece c'è un errore, verrà visualizzata un'icona blu o rossa.
L'origine dati del modello di modulo è composta da campi e gruppi organizzati gerarchicamente nel riquadro attività Origine dati. Le caselle di testo sono sempre associate a campi. Nell'esempio seguente la casella di testo Cognome della maschera è associata al campo Cognome nel riquadro attività Origine dati .
Inserire una casella di testo in un nuovo modello di modulo vuoto
Quando si progetta un nuovo modello di modulo vuoto, per impostazione predefinita è selezionata la casella di controllo Crea automaticamente origine dati del riquadro attività Controlli. In questo modo InfoPath può creare automaticamente campi e gruppi nell'origine dati quando vengono aggiunti controlli al modello di modulo. Questi campi e gruppi sono rappresentati da icone di cartelle e file nel riquadro attività Origine dati.
- Nel modello di modulo inserire il cursore nel punto in cui aggiungere il controllo.
- Se il riquadro attività Controlli non è visibile, fare clic su Altri controlli nel menu Inserisci oppure premere ALT+I, C.
- In Controlli Inserisci fare clic su Casella di testo.
- Per aggiungere un'etichetta al controllo, digitare il testo sopra o a sinistra del controllo, seguito da due punti (:). Ad esempio, se la casella di testo ha lo scopo di raccogliere il cognome di un utente, è possibile digitare Cognome:.
Inserire una casella di testo in un modello di modulo basato su un'origine dati esistente
Se il progetto del modello di modulo si basa su un file XML (Extensible Markup Language), un database o un servizio Web esistente, InfoPath ricava i campi e i gruppi del riquadro attività Origine dati da questa origine dati esistente. In questo scenario è possibile inserire una casella di testo trascinando un campo dal riquadro attività Origine dati al modello di modulo oppure inserendo invece una casella di testo dal riquadro attività Controlli , come descritto nella procedura seguente:
Nel modello di modulo inserire il cursore nel punto in cui aggiungere il controllo.
Se il riquadro attività Controlli non è visibile, fare clic su Altri controlli nel menu Inserisci oppure premere ALT+I, C.
In Controlli Inserisci fare clic su Casella di testo.
Nella finestra di dialogo Associazione caselle di testo selezionare il campo in cui si desidera memorizzare i dati della casella di testo e quindi fare clic su OK.
InfoPath utilizza il nome del campo o gruppo come etichetta di controllo. Se necessario, modificare il testo dell’etichetta.
Suggerimento
È anche possibile usare il riquadro attività Origine dati per inserire i controlli. Nel riquadro attività Origine dati fare clic con il pulsante destro del mouse sul campo a cui si desidera associare la casella di testo e quindi scegliere Casella di testo dal menu di scelta rapida.
Inizio pagina
Suggerimenti per il layout
Prima di inserire le caselle di testo nel modello di modulo, pensare a come disporle. È possibile aggiungere caselle di testo trascinandole dove si vuole nel modello di modulo, ma ciò può comportare una progettazione casuale. Se si vuole avere un modello di modulo più organizzato, è possibile aggiungere una tabella layout e quindi inserire etichette e controlli all'interno delle singole celle in modo che si allineino correttamente. Nella figura seguente viene usata una tabella di layout a quattro righe e due colonne per disporre etichette e controlli.
Oltre a usare le tabelle layout per organizzare le caselle di testo, è possibile eseguire una o più delle operazioni seguenti:
- Per modificare le dimensioni di più caselle di testo contemporaneamente, selezionare le caselle di testo di cui si desidera modificare le dimensioni, scegliere Proprietà dal menu Formato, fare clic sulla scheda Dimensioni e quindi apportare le modifiche necessarie.
- Ridimensionare le caselle di testo nel modello di modulo per adattarsi alla lunghezza del testo che si prevede gli utenti digitino nelle caselle.
- Per modificare il bordo o il colore di più caselle di testo contemporaneamente, selezionare le caselle di testo da modificare, scegliere Bordi e ombreggiatura dal menu Formato, fare clic sulla scheda Bordi e quindi apportare le modifiche necessarie.
- Per personalizzare il testo visualizzato in una casella di testo, usare le caselle Carattere e Dimensioni carattere sulla barra degli strumenti Formattazione . Per modificare il tipo e le dimensioni del carattere per tutte le caselle di testo del modello di modulo contemporaneamente, selezionare la casella di testo che contiene la formattazione desiderata e quindi fare clic su Applica tipo di carattere a tutti i controlli casella di testo nel menu Formato .
- Per vedere l'aspetto delle caselle di testo con il testo effettivo, fare clic su Dati di esempio nel menu Visualizza . In questo modo si avrà un'idea di come sarà il modulo quando gli utenti lo compilano.
- Usare i margini per regolare la spaziatura intorno all'esterno di una casella di testo. Usa la spaziatura interna per regolare la spaziatura intorno al testo all'interno della casella di testo. Entrambe le impostazioni si trovano nella scheda Dimensioni nella finestra di dialogo Proprietà casella di testo .
- In alcuni casi, il testo all'interno di una casella di testo e l'etichetta a sinistra della casella di testo possono apparire leggermente disallineati. Per riallinearle rapidamente, fare doppio clic sulla casella di testo, fare clic su Allinea nella scheda Dimensioni , quindi fare clic su Applica. Se l'etichetta e la casella di testo si trovano in celle diverse in una tabella layout, fare clic con il pulsante destro del mouse sulla cella che contiene l'etichetta, scegliere Proprietà tabella dal menu di scelta rapida e quindi fare clic su Centro sotto Allineamento verticale nella scheda Cella .
Inizio pagina