Accedi a Microsoft
Accedi o crea un account.
Salve,
Select a different account.
Hai più account
Scegli l'account con cui vuoi accedere.

È possibile pubblicare una cartella di lavoro in una raccolta di Microsoft SharePoint per consentire ad altre persone di visualizzarla o modificarla in un Web browser, anche se non hanno installato Excel nel proprio computer. La pubblicazione è essenzialmente analoga al salvataggio, ma offre in più alcune opzioni predefinite che consentono di controllare i contenuti che le altre persone possono visualizzare quando aprono la cartella di lavoro in un browser.

L'adozione dell'abitudine di salvare o pubblicare, a livello di organizzazione, una cartella di lavoro in un sito di SharePoint centrale può evitare il diffondersi di versioni leggermente diverse della stessa cartella di lavoro quando viene inviata tramite posta elettronica all'interno dell'organizzazione.

Impostando alcune opzioni di pubblicazione, è possibile enfatizzare parti specifiche della cartella di lavoro, ad esempio i grafici, o escludere altre parti dalla visualizzazione nel browser. Ad esempio, è possibile visualizzare un grafico ma non i dati sottostanti. In alternativa, è possibile mostrare solo determinati fogli di lavoro agli utenti che hanno l'esigenza di visualizzarli e nascondere gli altri fogli di lavoro.

Questo articolo illustra come pubblicare una cartella di lavoro da Excel per Windows e non illustra la connessione di dati di una cartella di lavoro o di una cartella di lavoro a una web part Excel Web Access in una pagina di SharePoint.

Quando si pubblica una cartella di lavoro in un sito di SharePoint, l'intera cartella di lavoro viene salvata in SharePoint. Un utente con le necessarie autorizzazioni di SharePoint può visualizzare e usare l'intera cartella di lavoro nel browser nell'applicazione desktop Excel.

Se Office per il Web viene distribuito in SharePoint, è possibile visualizzare e usare i dati nel browser in modo molto simile a quanto avviene con l'applicazione desktop Excel. Ma a differenza dell'applicazione desktop Excel, più utenti possono modificare contemporaneamente una cartella di lavoro nel browser. Se quando si apre una cartella di lavoro nel browser è visualizzato il pulsante Modifica in Excel Online, significa che Office per il Web è pronto per l'uso.

Preparare la cartella di lavoro

Prima di pubblicare la cartella di lavoro è possibile scegliere di selezionare solo i fogli di lavoro o gli elementi che si desidera rendere visibili nel browser. È tuttavia necessario ricordare che, sebbene sia possibile limitare gli elementi da rendere visibili in questa modalità, sul server di SharePoint viene comunque salvato tutto il contenuto della cartella di lavoro.

Se si desidera includere interi fogli di lavoro come elemento, oltre ad altri elementi quali grafici o tabelle pivot, definire l'intero foglio di lavoro come intervallo denominato. Selezionare l'intero foglio di lavoro e quindi definire un intervallo denominato. Tale intervallo denominato verrà quindi visualizzato come elemento disponibile nella finestra di dialogo Opzioni pubblicazione al momento della pubblicazione.

Per consentire agli utenti di immettere un valore in una cella per usare una formula in un'altra cella, impostare la cella come nome definito in Excel prima di pubblicare la cartella di lavoro. Aggiungere quindi il nome definito come parametro nella scheda Parametri della finestra di dialogo Opzioni visualizzazione browser.

Ad esempio, di seguito è illustrata una cella D2 con il nome definito "Tariffa". Nel browser l'utente immette il valore 5,625 nella casella Tariffa del riquadro Parametri e quindi fa clic su Applica. Tale valore viene quindi visualizzato nella cella D2 e la formula in A2 usa il valore di D2. Il risultato della formula, €1.151,31, viene quindi ricalcolato e visualizzato nella cella A2.

Il parametro immesso nel riquadro viene usato nella cella D2

Nota: Se si crea un filtro dei dati per una tabella di Excel e si definisce un nome per l'intervallo di celle contenenti la tabella e il filtro, non sarà possibile applicare tale filtro alla tabella nel browser se si pubblica l'intervallo definito. Se si pubblica la tabella o l'intero foglio di lavoro o la relativa cartella di lavoro, il filtro funzionerà come previsto nel browser.

Pubblicare la cartella di lavoro

  1. Fare clic sulla scheda File, su Salva con nome e quindi su SharePoint.

  2. Se la cartella di SharePoint è visualizzata in Corrente, Recenti o Meno recenti, fare clic sulla cartella desiderata.

    Verrà visualizzata la finestra di dialogo Salva con nome.


    In caso contrario, fare clic su Sfoglia, immettere l'indirizzo Web del sito di SharePoint e quindi passare alla cartella in cui si vuole pubblicare la cartella di lavoro.

    Fare clic su una cartella di SharePoint oppure su Sfoglia
  3. Per selezionare singoli fogli di lavoro o elementi da pubblicare dalla cartella di lavoro, fare clic su Opzioni visualizzazione browser.

    Nella finestra di dialogo Salva con nome fare clic su Opzioni visualizzazione browser

    Verranno visualizzate le schede Mostra e Parametri.

  4. Se si vuole pubblicare l'intera cartella di lavoro, fare clic su Salva. In caso contrario, eseguire una delle operazioni seguenti:

    • Per visualizzare l'intera cartella di lavoro nel browser, nella scheda Mostra selezionare Tutta la cartella nella casella di riepilogo.

    • Per visualizzare solo fogli di lavoro specifici nel browser, nella scheda Mostra selezionare Fogli nella casella di riepilogo e quindi deselezionare le caselle di controllo corrispondenti ai fogli che non si vuole nascondere.

      Per impostazione predefinita, sono selezionati tutti i fogli. Per rendere rapidamente visibili tutti i fogli dopo aver deselezionato alcune caselle di controllo, selezionare la casella di controllo Tutti i fogli.

    • Per visualizzare solo elementi specifici nel browser, ad esempio intervalli denominati, grafici, tabelle o tabelle pivot, nella scheda Mostra selezionare Elementi nella cartella di lavoro nella casella di riepilogo e quindi selezionare le caselle di controllo degli elementi che si vuole visualizzare.

    • Nella scheda Parametri aggiungere i nomi definiti da usare per specificare le celle che devono risultare modificabili quando gli utenti visualizzano la cartella di lavoro nel browser, quindi fare clic su OK.

  5. Salvare la cartella di lavoro.

Note: 

  • Se si selezionano più elementi con lo stesso nome, ad esempio un grafico e la tabella di dati sottostante, nel browser sarà disponibile uno solo di questi elementi. Per visualizzare tutti gli elementi, è necessario verificare che ognuno di essi abbia un nome univoco.

  • È possibile rinominare le tabelle nel gruppo Proprietà della scheda Progettazione, le tabelle pivot nel gruppo Tabella pivot della scheda Opzioni e i grafici o i grafici pivot nel gruppo Proprietà della scheda Layout. Gli elementi duplicati, ad esempio gli intervalli denominati, possono essere rinominati nel gruppo Nomi definiti della scheda Formule.

Se Office per il Web viene distribuito in SharePoint, è possibile visualizzare e usare i dati nel browser in modo molto simile a quanto avviene con l'applicazione desktop Excel. Ma a differenza dell'applicazione desktop Excel, più utenti possono modificare contemporaneamente una cartella di lavoro nel browser. Se quando si apre una cartella di lavoro nel browser è visualizzato il pulsante Modifica in Excel Online, significa che Office per il Web è pronto per l'uso.

Comando Modifica in Excel Online nel menu Modifica cartella di lavoro

Per altre informazioni, vedere l'articolo Differenze nell'uso di una cartella di lavoro in Excel e in Excel Services.

Preparare la cartella di lavoro

Prima di pubblicare la cartella di lavoro è possibile scegliere di selezionare solo i fogli di lavoro o gli elementi che si desidera rendere visibili nel browser. È tuttavia necessario ricordare che, sebbene sia possibile limitare gli elementi da rendere visibili in questa modalità, sul server di SharePoint viene comunque salvato tutto il contenuto della cartella di lavoro.

Se si desidera includere interi fogli di lavoro come elemento, oltre ad altri elementi quali grafici o tabelle pivot, definire l'intero foglio di lavoro come intervallo denominato. Selezionare l'intero foglio di lavoro e quindi definire un intervallo denominato. Tale intervallo denominato verrà quindi visualizzato come elemento disponibile nella finestra di dialogo Opzioni pubblicazione al momento della pubblicazione.

Per consentire agli utenti di immettere un valore in una cella per usare una formula in un'altra cella, impostare la cella come nome definito in Excel prima di pubblicare la cartella di lavoro. Aggiungere quindi il nome definito come parametro nella scheda Parametri della finestra di dialogo Opzioni visualizzazione browser.

Ad esempio, di seguito è illustrata una cella D2 con il nome definito "Tariffa". Nel browser un utente immette un valore, 5,625, nella casella del riquadro Parametri e fa clic su Applica. Tale valore viene quindi visualizzato nella cella D2 e la formula in A2 usa il valore di D2. Il risultato della formula, €1.151,31, viene quindi ricalcolato e visualizzato nella cella A2.

Vedere la Guida di Excel per informazioni su come definire gli intervalli.

Il parametro immesso nel riquadro viene usato nella cella D2

Nota: Se si crea un filtro dei dati per una tabella di Excel e si definisce un nome per l'intervallo di celle contenenti la tabella e il filtro, non sarà possibile applicare tale filtro alla tabella nel browser se si pubblica l'intervallo definito. Se si pubblica la tabella o l'intero foglio di lavoro o la relativa cartella di lavoro, il filtro funzionerà come previsto nel browser.

Pubblicare la cartella di lavoro

  1. Fare clic su File > Salva con nome >SharePoint.

  2. Se la cartella di SharePoint è visualizzata inCartella corrente o Cartelle recenti, fare clic sulla cartella desiderata. In caso contrario, fare clic su Sfoglia e immettere l'indirizzo Web del sito di SharePoint. Passare quindi alla cartella in cui si vuole pubblicare la cartella di lavoro. Verrà visualizzata la finestra di dialogo Salva con nome.

  3. Per selezionare singoli fogli di lavoro o elementi da pubblicare dalla cartella di lavoro, fare clic su Opzioni visualizzazione browser. Verranno visualizzate una scheda Mostra e una scheda Parametri . Se si vuole pubblicare l'intera cartella di lavoro, fare clic su Salva. In caso contrario, eseguire una delle operazioni seguenti:

    • Per visualizzare l'intera cartella di lavoro nel browser, nella scheda Mostra selezionare Tutta la cartella nella casella di riepilogo.

    • Per visualizzare solo fogli di lavoro specifici nel browser, nella scheda Mostra selezionare Fogli nella casella di riepilogo e quindi deselezionare le caselle dei fogli che non si desidera nascondere nel browser.

      Per impostazione predefinita, sono selezionati tutti i fogli. Per rendere rapidamente tutti i fogli nuovamente visibili dopo aver deselezionato alcune caselle, selezionare la casella di controllo Tutti i fogli .

    • Per visualizzare solo elementi specifici nel browser, ad esempio intervalli denominati, grafici, tabelle o tabelle pivot, nella scheda Mostra selezionare Elementi nella cartella di lavoro nella casella di riepilogo e quindi selezionare le caselle relative agli elementi da visualizzare.

    • Nella scheda Parametri aggiungere i nomi definiti da usare per specificare le celle modificabili quando gli utenti visualizzano la cartella di lavoro nel browser. Quindi fare clic su OK per chiudere la finestra di dialogo.

  4. Salvare la cartella di lavoro.

Note: 

  • Se si selezionano più elementi con lo stesso nome, ad esempio un grafico e la tabella di dati sottostante, nel browser sarà disponibile uno solo di questi elementi. Per visualizzare tutti gli elementi, è necessario verificare che ognuno di essi abbia un nome univoco.

  • Se si selezionano più elementi con lo stesso nome, ad esempio un grafico e la tabella di dati sottostante, nel browser sarà disponibile uno solo di questi elementi. Per visualizzare tutti gli elementi, è necessario verificare che ognuno di essi abbia un nome univoco.

  • È possibile rinominare le tabelle nel gruppo Proprietà della scheda Progettazione, le tabelle pivot nel gruppo Tabella pivot della scheda Opzioni e i grafici o i grafici pivot nel gruppo Proprietà della scheda Layout. Gli elementi duplicati, ad esempio gli intervalli denominati, possono essere rinominati nel gruppo Nomi definiti della scheda Formule.

  • È possibile rinominare le tabelle nel gruppo Proprietà della scheda Progettazione, le tabelle pivot nel gruppo Tabella pivot della scheda Opzioni e i grafici o i grafici pivot nel gruppo Proprietà della scheda Layout. Gli elementi duplicati, ad esempio gli intervalli denominati, possono essere rinominati nel gruppo Nomi definiti della scheda Formule.

Per altre informazioni sulle web part Excel Web Access, vedere l'articolo Visualizzare una cartella di lavoro in una web part Excel Web Access.

Quando si pubblica una cartella di lavoro in un server di SharePoint, l'intero contenuto della cartella di lavoro viene salvato nel server e può essere visualizzato e utilizzato se si apre la cartella di lavoro nell'applicazione desktop Excel. Se Office App Web vengono distribuiti nel server di SharePoint, la visualizzazione e l'uso dei dati nel Web browser possono essere molto simili a come si usano i dati nell'applicazione desktop Excel. Infatti, la modifica simultanea di una cartella di lavoro è possibile nella griglia del browser quando vengono distribuite le App Web di Office. Quando si visualizza una cartella di lavoro nel browser, se il pulsante Modifica nel browser è visibile, significa che Office App Web sono disponibili.

Pulsante Modifica nel browser

Per altre informazioni, vedere l'articolo Differenze nell'uso di una cartella di lavoro in Excel e in Excel Services.

Preparare la cartella di lavoro

Prima di pubblicare la cartella di lavoro, è possibile, nella finestra di dialogo Opzioni pubblicazione , selezionare i fogli di lavoro o gli elementi da visualizzare nel browser quando la modifica non è stata abilitata facendo clic sul pulsante Modifica nel browser . Tenere presente che, anche se è possibile selezionare gli elementi visualizzabili in questa modalità, l'intero contenuto della cartella di lavoro viene comunque salvato nel server di SharePoint.

Se si desidera includere interi fogli di lavoro come elemento, oltre ad altri elementi quali grafici o tabelle pivot, definire l'intero foglio di lavoro come intervallo denominato. Selezionare l'intero foglio di lavoro e quindi definire un intervallo denominato. Tale intervallo denominato verrà quindi visualizzato come elemento disponibile nella finestra di dialogo Opzioni pubblicazione al momento della pubblicazione.

Se si vuole consentire agli utenti di fornire un parametro a una formula durante la visualizzazione di un foglio di lavoro in un browser, impostare una cella come nome definito. È quindi possibile aggiungere il nome definito come parametro nella scheda Parametri della finestra di dialogo Opzioni pubblicazione .

Ad esempio, nell'immagine seguente che mostra un foglio di lavoro nel browser, la cella D2 ha il nome Tasso definito. Nel browser un utente ha immesso un valore, 5,625, nella casella del riquadro Parametri e quindi ha fatto clic su Applica. Tale valore viene quindi visualizzato nella cella D2 e la formula in A2 usa il valore di D2. Il risultato della formula, €1.151,31, viene quindi ricalcolato e visualizzato nella cella A2.

Utilizzo di un parametro nel browser

Vedere la Guida di Excel per informazioni su come definire gli intervalli.

Pubblicare la cartella di lavoro

  1. Fare clic sulla scheda File e quindi su Salva e invia.

  2. Fare clic su Salva in SharePoint.
    Nota     Se il comando Salva in SharePoint non è disponibile, è comunque possibile salvare la cartella di lavoro in un sito di SharePoint usando il comando Salva con nome . La finestra di dialogo Opzioni pubblicazione non sarà disponibile. È anche possibile caricare la cartella di lavoro direttamente da una raccolta di SharePoint. Gli utenti possono visualizzare e modificare il contenuto della cartella di lavoro nel browser accedendo direttamente al sito in cui è salvata la cartella di lavoro.

    Comando Salva con nome

  3. Per selezionare singoli fogli di lavoro o elementi da pubblicare nella cartella di lavoro, fare clic sul pulsante Opzioni pubblicazione . In caso contrario, se si vuole pubblicare l'intera cartella di lavoro, andare direttamente al passaggio 4.
    Nella scheda Mostra eseguire le operazioni seguenti:

    • Per visualizzare l'intera cartella di lavoro nel browser, selezionare Intera cartella di lavoro nella casella di riepilogo.

    • Per visualizzare solo fogli di lavoro specifici nel browser, selezionare Fogli nella casella di riepilogo e quindi deselezionare le caselle di controllo relative ai fogli che non si desidera rendere visibili.
      Nota    Per impostazione predefinita, sono selezionati tutti i fogli. Per rendere tutti i fogli nuovamente visibili dopo aver deselezionato alcune caselle di controllo, è possibile selezionare la casella di controllo Tutti i fogli .

    • Per visualizzare solo elementi specifici nel browser, ad esempio intervalli denominati, grafici, tabelle o tabelle pivot, selezionare Elementi nella cartella di lavoro nella casella di riepilogo e quindi selezionare le caselle di controllo degli elementi da visualizzare.
      Nota Se si selezionano elementi con lo stesso nome, ad esempio un grafico e la tabella di dati sottostante, nel browser sarà disponibile solo uno di questi elementi. Per visualizzare tutti gli elementi, è necessario verificare che ogni elemento della cartella di lavoro abbia un nome univoco. È possibile rinominare le tabelle nel gruppo Proprietà della scheda Progettazione, le tabelle pivot nel gruppo Tabella pivot della scheda Opzioni e i grafici o i grafici pivot nel gruppo Proprietà della scheda Layout. Gli elementi duplicati, ad esempio gli intervalli denominati, possono essere rinominati nel gruppo Nomi definiti della scheda Formule.
      Selezione di elementi o fogli di lavoro

    • Nella scheda Parametri aggiungere i nomi definiti da usare per specificare le celle modificabili quando gli utenti visualizzano la cartella di lavoro nel browser. Quindi fare clic su OK per chiudere la finestra di dialogo.
      Impostazione di parametri

  4. Scegliere un percorso in cui pubblicare la cartella di lavoro.
    È possibile che siano già presenti posizioni del server salvate in Posizione corrente, Percorsi recenti o Percorsi da cui è possibile scegliere. Se non sono presenti posizioni di questo tipo o se si vuole salvarle in una nuova posizione, in Posizioni fare doppio clic su Cerca percorso.

  5. Nella finestra di dialogo Salva con nome immettere l'indirizzo Web del sito di SharePoint e quindi passare al sito o alla raccolta in cui salvare la cartella di lavoro.

  6. Se non sono già stati selezionati singoli fogli di lavoro o elementi o non sono stati impostati parametri, fare clic sul pulsante Opzioni pubblicazione .

  7. Nella casella Nome file accettare il nome suggerito per la cartella di lavoro oppure digitare un nuovo nome, se si vuole.

  8. Per visualizzare il contenuto della cartella di lavoro in una finestra del browser immediatamente dopo il completamento dell'operazione di pubblicazione, verificare che la casella di controllo Apri con Excel nel browser sia selezionata.

  9. Fare clic su Salva.

Serve aiuto?

Amplia le tue competenze

Esplora i corsi di formazione >

Ottieni in anticipo le nuove caratteristiche

Partecipa a Microsoft Insider >

Queste informazioni sono risultate utili?

Come valuti la qualità della lingua?
Cosa ha influito sulla tua esperienza?

Grazie per il feedback!

×