SOMMA.SE (funzione SOMMA.SE)

SOMMA.SE (funzione SOMMA.SE)

È possibile usare la funzione SOMMA.SE per sommare i valori di un intervallo che soddisfano i criteri specificati. Supponiamo ad esempio di voler sommare in una colonna contenente numeri solo i valori maggiori di 5. In tal caso, usare la formula seguente: =SOMMA.SE(B2:B25;">5")

Creare un grande impatto con gli annunci

Questo video fa parte di un corso di formazione intitolato Sommare numeri in Excel.

Suggerimenti: 

  • Se si vuole, è possibile applicare i criteri a un intervallo e sommare i valori corrispondenti in un altro intervallo. Ad esempio, la formula =SOMMA.SE(B2:B5; "Luca"; C2:C5) sommerà solo i valori dell'intervallo C2:C5 per cui il contenuto delle celle corrispondenti nell'intervallo B2:B5 è uguale a "Luca".

  • Per sommare le celle in base a più criteri, vedere la funzione SOMMA.PIÙ.SE.

Importante: La funzione somma.se restituisce risultati non corretti quando viene usata per corrispondere stringhe di lunghezza superiore a 255 caratteri o alla stringa #VALUE.

Sintassi

SOMMA.SE(intervallo; criteri; [int_somma])

Gli argomenti della sintassi della funzione SOMMA.SE sono i seguenti:

  • intervallo   Obbligatorio. Intervallo di celle da valutare in base ai criteri. Le celle di ogni intervallo devono contenere numeri oppure nomi, matrici o riferimenti che includono numeri. Le celle vuote e i valori di testo verranno ignorati. L'intervallo selezionato può contenere date nel formato standard di Excel (vedere gli esempi di seguito).

  • criteri   Obbligatorio. Criteri in forma di numero, espressione, riferimento di cella, testo o funzione che definisce le celle che verranno sommate. I caratteri jolly possono essere inclusi: un punto interrogativo (?) in modo che corrisponda a qualsiasi singolo carattere, un asterisco (*) in modo che corrisponda a qualsiasi sequenza di caratteri. Se si desidera trovare un punto interrogativo o un asterisco, digitare una tilde (~) prima del carattere.

    Ad esempio, i criteri possono essere espressi come 32, ">32", B5, "3?", "Apple *", "* ~?" o oggi ().

    Importante: Qualsiasi criterio di testo o di altro tipo comprendente simboli logici o matematici deve essere racchiuso tra virgolette doppie ("). Se il criterio è numerico, le virgolette doppie non saranno necessarie.

  • int_somma   Facoltativo. Celle effettivamente da sommare, se si vogliono sommare celle diverse da quelle specificate nell'argomento intervallo. Se l'argomento int_somma è omesso, verranno sommate le celle specificate nell'argomento intervallo, ovvero le stesse celle a cui vengono applicati i criteri.

    Sum_range deve avere le stesse dimensioni e la stessa forma dell' intervallo. In caso affermativo, le prestazioni potrebbero risentirne e la formula somma un intervallo di celle che inizia con la prima cella in Sum_Range ma ha le stesse dimensioni dell' intervallo. Per esempio:

    intervallo

    int_somma

    Celle sommate effettive

    A1:A5

    B1:B5

    B1:B5

    A1:A5

    B1: K5

    B1:B5

Esempi

Esempio 1

Copiare i dati di esempio contenuti nella tabella seguente e incollarli nella cella A1 di un nuovo foglio di lavoro Excel. Per visualizzare i risultati delle formule, selezionarle, premere F2 e quindi premere INVIO. Se necessario, è possibile regolare la larghezza delle colonne per visualizzare tutti i dati.

Valore proprietà

Commissione

Dati

€ 100.000

€ 7.000

€ 250.000

€ 200.000

€ 14.000

€ 300.000

€ 21.000

€ 400.000

€ 28.000

Formula

Descrizione

Risultato

=SOMMA.SE(A2:A5;">160000";B2:B5)

Somma delle commissioni relative ai valori di proprietà maggiori di € 160.000.

€ 63.000

=SOMMA.SE(A2:A5;">160000")

Somma dei valori di proprietà maggiori di € 160.000.

€ 900.000

=SOMMA.SE(A2:A5;300000;B2:B5)

Somma delle commissioni relative ai valori di proprietà uguali a € 300.000.

€ 21.000

=SOMMA.SE(A2:A5;">" & C2;B2:B5)

Somma delle commissioni relative ai valori di proprietà maggiori del valore in C2.

€ 49.000

Esempio 2

Copiare i dati di esempio contenuti nella tabella seguente e incollarli nella cella A1 di un nuovo foglio di lavoro di Excel. Per visualizzare i risultati delle formule, selezionarle, premere F2 e quindi premere INVIO. Se necessario, adattare l'ampiezza delle colonne per visualizzare tutti i dati.

Categoria

Cibo

Vendite

Verdura

Pomodori

€ 2.300

Verdura

Sedano

€ 5.500

Frutta

Arance

€ 800

Burro

€ 400

Verdura

Carote

€ 4.200

Frutta

Mele

€ 1.200

Formula

Descrizione

Risultato

=SOMMA.SE(A2:A7;"Frutta";C2:C7)

Somma delle vendite di tutti gli alimenti della categoria "Frutta".

€ 2.000

=SOMMA.SE(A2:A7;"Verdura";C2:C7)

Somma delle vendite di tutti gli alimenti della categoria "Verdura".

€ 12.000

=SOMMA.SE(B2:B7;"*e";C2:C7)

Somma delle vendite di tutti gli alimenti il cui nome finisce per "e" (Zucchine, Arance e Mele).

€ 4.300

=SOMMA.SE(A2:A7;"";C2:C7)

Somma delle vendite di tutti gli alimenti non assegnati a una categoria specifica.

€ 400

Inizio pagina

Servono altre informazioni?

È sempre possibile rivolgersi a un esperto nella Tech Community di Excel, ottenere supporto nella community Microsoft o suggerire una nuova funzionalità o un miglioramento in Excel UserVoice.

Vedere anche

La funzione SOMMA.PIÙ.SE somma tutti gli argomenti che soddisfano più criteri

La funzione SOMMA.Q somma più valori dopo avere calcolato il quadrato di ciascuno

La funzione CONTA.SE conta solo i valori che soddisfano un singolo criterio

La funzione CONTA.PIÙ.SE conta solo i valori che soddisfano più criteri

Funzione PIÙ.SE (Office 365, Excel 2016 e versioni successive)

Panoramica delle formule in Excel

Come evitare errori nelle formule

Rilevare gli errori nelle formule

Funzioni matematiche e trigonometriche

Funzioni di Excel (in ordine alfabetico)

Funzioni di Excel (in base alla categoria)

Nota:  Questa pagina è stata tradotta automaticamente e potrebbe contenere errori di grammatica o imprecisioni. L'intento è quello di rendere fruibile il contenuto. Queste informazioni sono risultate utili' Questo è l'articolo in inglese per riferimento.

Amplia le tue competenze su Office
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×