Usare i collegamenti in Excel

Per accedere rapidamente alle informazioni correlate in un altro file o in una pagina Web, è possibile inserire un collegamento ipertestuale in una cella di un foglio di lavoro. Si possono inoltre inserire collegamenti in elementi specifici di un grafico.

Nota: La maggior parte degli screenshot in questo articolo sono stati acquisiti in Excel 2016. Se si usa una versione diversa, la visualizzazione potrebbe risultare leggermente diversa ma, se non diversamente specificato, le funzionalità sono le stesse.

  1. In un foglio di lavoro, fare clic all'interno della cella in cui si desidera creare un collegamento.

    È inoltre possibile selezionare un oggetto, ad esempio un'immagine o un elemento di un grafico, che rappresenterà il collegamento.

    • Alla scheda Inserisci, nel gruppo Collegamenti, fare clic su Collegamento Pulsante Collegamento ipertestuale .

    È inoltre possibile fare clic con il pulsante destro del mouse sulla cella o sull'elemento grafico e quindi scegliere Collegamento oppure premere CTRL+K.

  2. In Collega a fare clic su Crea nuovo documento.

  3. Nella casella Nome del nuovo documento digitare il nome del nuovo file.

    Suggerimento: Per specificare una posizione diversa da quella visualizzata in Percorso completo, è possibile digitare la nuova posizione preceduta dal nome nella casella Nome del nuovo documento, oppure è possibile fare clic su Modifica per selezionare la posizione desiderata e fare clic su OK.

  4. In Modifica il nuovo documento fare clic su In seguito o su Adesso per specificare quando si desidera aprire il nuovo file per modificarlo.

  5. Nella casella Testo da visualizzare, digitare il testo da usare per rappresentare il collegamento.

  6. Per visualizzare informazioni utili quando si posiziona il puntatore del mouse sul collegamento, fare clic su Descrizione comando, digitare il testo desiderato nella casella Testo della descrizione e quindi fare clic su OK.

  1. In un foglio di lavoro, fare clic all'interno della cella in cui si desidera creare un collegamento.

    È inoltre possibile selezionare un oggetto, ad esempio un'immagine o un elemento di un grafico, che rappresenterà il collegamento.

    • Alla scheda Inserisci, nel gruppo Collegamenti, fare clic su Collegamento Pulsante Collegamento ipertestuale .

    È inoltre possibile fare clic con il pulsante destro del mouse sulla cella o sull'oggetto, quindi scegliere Collegamento oppure premere CTRL+K.

  2. In Collega a fare clic su File o pagina Web esistente.

  3. Eseguire una delle operazioni seguenti:

    • Per selezionare un file, fare clic su Cartella corrente e quindi sul file da collegare.

      È possibile cambiare la cartella corrente selezionandone una diversa nell'elenco Cerca in.

    • Per selezionare una pagina Web, fare clic su Pagine visualizzate, quindi fare clic sulla pagina Web che si desidera collegare.

    • Per selezionare un file usato di recente, fare clic su File recenti, quindi fare clic sul file che si desidera collegare.

    • Per specificare il nome e il percorso di un file o di una pagina Web nota a cui si vuole creare il collegamento, digitarlo nella casella Indirizzo.

    • Per trovare una pagina Web, fare clic su Esplora il Web Pulsante esplora il web , aprire la pagina Web a cui associare il collegamento e quindi tornare in Excel senza chiudere il browser.

  4. Per creare un collegamento a una posizione specifica all'interno del file o della pagina Web, fare clic su Segnalibro, quindi fare doppio clic sul segnalibro che si vuole usare.

    Nota: Il file o la pagina Web che si stanno collegando devono contenere un segnalibro.

  5. Nella casella Testo da visualizzare, digitare il testo da usare per rappresentare il collegamento.

  6. Per visualizzare informazioni utili quando si posiziona il puntatore del mouse sul collegamento, fare clic su Descrizione comando, digitare il testo desiderato nella casella Testo della descrizione e quindi fare clic su OK.

Per creare un collegamento ipertestuale a una sezione nel foglio di lavoro corrente o in un altro foglio di lavoro, è possibile definire il nome delle celle di destinazione o utilizzare riferimenti di cella.

  1. Per utilizzare un nome, è necessario assegnare un nome alle celle del foglio di lavoro di destinazione.

    Come assegnare un nome a una cella o a un intervallo di celle

    1. Selezionare la cella, l'intervallo di celle o le selezioni non adiacenti per cui si vuole definire un nome.

    2. Fare clic sulla casella Nome all'estremità sinistra di barra della formula Icona del pulsante .

      Casella Nome

      Callout 4 Casella nome

    3. Nella casella Nome, digitare il nome delle celle e premere INVIO.

      Nota: I nomi non possono contenere spazi e devono iniziare con una lettera.

  2. In un foglio di lavoro della cartella di lavoro di origine, fare clic sulla cella in cui creare un collegamento.

    È inoltre possibile selezionare un oggetto, ad esempio un'immagine o un elemento di un grafico, che rappresenterà il collegamento.

    • Alla scheda Inserisci, nel gruppo Collegamenti, fare clic su Collegamento Pulsante Collegamento ipertestuale .

    È inoltre possibile fare clic con il pulsante destro del mouse sulla cella o sull'oggetto, quindi scegliere Collegamento oppure premere CTRL+K.

  3. In Collega a, eseguire una delle operazioni seguenti:

    • Per creare un collegamento a una sezione nella cartella di lavoro corrente, fare clic su Inserisci nel documento.

    • Per creare un collegamento a una sezione di un'altra cartella di lavoro, fare clic su File o pagina Web esistente, individuare e selezionare la cartella di lavoro da collegare e quindi fare clic su Segnalibro.

  4. Eseguire una delle operazioni seguenti:

    • Nella casella O selezionare una parte del documento in Riferimento di cella fare clic sul foglio di lavoro a cui associare il collegamento, digitare il riferimento di cella nella casella Digitare il riferimento di cella e quindi fare clic su OK.

    • Nell'elenco Nomi definiti fare clic sul nome che corrisponde alle celle alle quali si desidera creare il collegamento ipertestuale e quindi fare clic su OK.

  5. Nella casella Testo da visualizzare, digitare il testo da usare per rappresentare il collegamento.

  6. Per visualizzare informazioni utili quando si posiziona il puntatore del mouse sul collegamento, fare clic su Descrizione comando, digitare il testo desiderato nella casella Testo della descrizione e quindi fare clic su OK.

È possibile usare la funzione COLLEG.IPERTESTUALE per creare un collegamento che apra un documento archiviato in un server di rete, un Intranet, o Internet. Quando si fa clic sulla cella contenente la funzione COLLEG.IPERTESTUALE, Microsoft Excel aprirà il file memorizzato nella posizione del collegamento.

Sintassi

COLLEG.IPERTESTUALE(posizione_collegamento; nome_collegamento)

Posizione_collegamento     è il percorso e il nome file al documento da aprire come testo. Posizione_collegamento può fare riferimento a una posizione in un documento, come una cella specifica o un determinato intervallo in un foglio di lavoro o in una cartella di lavoro di Excel, oppure a un segnalibro in un documento di Microsoft Word. Il percorso può portare a un file archiviato su un'unità del disco rigido, oppure può essere un percorso di convenzione di denominazione universale su un server (in Microsoft Excel per Windows) o un percorso Uniform Resource Locator (URL) su Internet o in una Intranet.

  • Posizione_collegamento può essere rappresentato da una stringa di testo racchiusa tra virgolette o da una cella contenente il collegamento come stringa di testo.

  • Se il collegamento specificato in posizione_collegamento non esiste o non può essere esplorato, verrà visualizzato un messaggio di errore quando si fa clic sulla cella.

Nome_descrittivo     è il testo o il valore numerico del collegamento visualizzato nella cella. Nome_collegamento viene visualizzato in blu e sottolineato. Se nome_collegamento viene omesso, nella cella verrà visualizzato posizione_collegamento come testo del collegamento.

  • Nome_collegamento può essere rappresentato da un valore, una stringa di testo, un nome o una cella contenente il testo o il valore numerico del collegamento.

  • Se nome_collegamento restituisce un valore di errore, quale #VALORE!, nella cella verrà visualizzato l'errore anziché il testo del collegamento.

Esempi

Nell'esempio seguente viene aperto un foglio di lavoro denominato Budget Report.xlsx memorizzato su Internet nella posizione example.microsoft.com/report e viene visualizzato il testo "Fare clic per visualizzare il report":

=HYPERLINK("http://example.microsoft.com/report/budget report.xls", "Click for report")

Nel seguente esempio viene creato un collegamento alla cella F10 nel foglio di lavoro denominato Annual nella cartella di lavoro Budget Report.xls, che è archiviato su Internet nella posizione denominata example.microsoft.com/report. Nella cella del foglio di lavoro che contiene il collegamento viene visualizzato il contenuto della cella D1 come testo del collegamento:

=HYPERLINK("[http://example.microsoft.com/report/budget report.xls]Annual!F10", D1)

Nel seguente esempio viene creato un collegamento denominato DeptTotal nel foglio di lavoro First Quarter nella cartella di lavoro Budget Report.xls, che è archiviato su Internet nella posizione denominata example.microsoft.com/report. Nella cella del foglio di lavoro contenente il collegamento viene visualizzato il testo "Fare clic per visualizzare il totale delle vendite del reparto relative al primo trimestre":

=HYPERLINK("[http://example.microsoft.com/report/budget report.xls]First Quarter!DeptTotal", "Click to see First Quarter Department Total")

Per creare un collegamento a un punto specifico all'interno di un documento di Microsoft Word, utilizzare un segnalibro per definire il punto a cui si desidera passare nel documento. Nell'esempio seguente viene creato un collegamento al segnalibro denominato QrtlyProfits nel documento Annual Report.doc in example.microsoft.com:

=HYPERLINK("[http://example.microsoft.com/Annual Report.doc]QrtlyProfits", "Quarterly Profit Report")

In Excel per Windows, nell'esempio seguente viene visualizzato il contenuto della cella D5 come testo del collegamento e viene aperto il file 1stqtr.xls memorizzato nella condivisione Statements sul server FINANCE. In questo esempio viene utilizzato un percorso UNC:

=HYPERLINK("\\FINANCE\Statements\1stqtr.xls", D5)

Nell'esempio seguente viene aperto il file 1stqtr.xlsx di Excel per Windows archiviato nella cartella Finance sull'unità D e viene visualizzato il valore numerico memorizzato nella cella H10:

=HYPERLINK("D:\FINANCE\1stqtr.xls", H10)

In Excel per Windows, nell'esempio seguente viene creato un collegamento ipertestuale a un'area denominata Totals in un'altra cartella di lavoro esterna denominata Mybook.xls:

=HYPERLINK("[C:\My Documents\Mybook.xls]Totals")

In Microsoft Excel per Macintosh, nell'esempio seguente viene visualizzato "Fare clic qui" nella cella e viene aperto il file denominato First Quarter arhiviato in una cartella denominata Budget Reports sul disco rigido denominato Macintosh HD:

=HYPERLINK("Macintosh HD:Budget Reports:First Quarter", "Click here")

È possibile creare collegamenti all'interno di un foglio di lavoro per passare da una cella a un'altra. Se, ad esempio, il foglio di lavoro attivo è il foglio denominato June nella cartella di lavoro denominata Budget, la formula seguente creerà un collegamento alla cella E56. Il valore contenuto nella cella E56 è lo stesso testo del collegamento.

=HYPERLINK("[Budget]June!E56", E56)

Per passare a un foglio diverso nella stessa cartella di lavoro, modificare il nome del foglio nel collegamento. Nell'esempio precedente, per creare un collegamento alla cella E56 sul foglio di Settembre, cambiare la parola Giugno in Settembre.

Quando si fa clic su un collegamento a un indirizzo di posta elettronica, viene aperto automaticamente il programma di posta elettronica e viene creato un messaggio di posta elettronica con l'indirizzo corretto nella casella A, a condizione che sia installato un programma di posta elettronica.

  1. In un foglio di lavoro, fare clic all'interno della cella in cui si desidera creare un collegamento.

    È inoltre possibile selezionare un oggetto, ad esempio un'immagine o un elemento di un grafico, che rappresenterà il collegamento.

    • Alla scheda Inserisci, nel gruppo Collegamenti, fare clic su Collegamento Pulsante Collegamento ipertestuale .

    È inoltre possibile fare clic con il pulsante destro del mouse sulla cella o sull'oggetto, quindi scegliere Collegamento oppure premere CTRL+K.

  2. In Collega a, fare clic su Indirizzo di posta elettronica.

  3. Nella casella Indirizzo di posta elettronica, digitare l'indirizzo desiderato.

  4. Nella casella Oggetto, digitare l'oggetto del messaggio di posta elettronica.

    Nota: Alcuni browser Web e programmi di posta elettronica potrebbero non riconoscere la riga dell'oggetto.

  5. Nella casella Testo da visualizzare, digitare il testo da usare per rappresentare il collegamento.

  6. Per visualizzare informazioni utili quando si posiziona il puntatore del mouse sul collegamento, fare clic su Descrizione comando, digitare il testo desiderato nella casella Testo della descrizione e quindi fare clic su OK.

    È anche possibile creare un collegamento a un indirizzo di posta elettronica in una cella digitando l'indirizzo direttamente nella cella. Se ad esempio si digita un indirizzo di posta elettronica, come someone@example.com, verrà creato automaticamente un collegamento.

È possibile inserire uno o più riferimenti esterni (chiamati anche collegamenti), da una cartella di lavoro a un'altra presente sulla Intranet o su Internet. La cartella di lavoro non deve essere salvata come file HTML.

  1. Aprire la cartella di lavoro di origine e selezionare la cella o l'intervallo di celle che si desidera copiare.

  2. Nel gruppo Appunti della scheda Home fare clic su Copia.

    Pulsanti Copia e Incolla nella scheda Home
  3. Passare al foglio di lavoro in cui si desidera inserire le informazioni e quindi fare clic nella cella in cui si desidera visualizzarle.

  4. Nel gruppo Appunti della scheda Home fare clic su Incolla speciale.

  5. Fare clic su Incolla collegamento.

    Verrà creato un collegamento di riferimento esterno per la cella o per ogni cella dell'intervallo di celle.

Nota: Può risultare più semplice creare un collegamento di riferimento esterno senza aprire la cartella di lavoro sul Web. Fare clic su ogni cella della cartella di lavoro di destinazione in cui inserire il collegamento al riferimento esterno e quindi digitare un segno di uguale (=), l'indirizzo URL e la posizione nella cartella di lavoro. Ad esempio:

='http://www.someones.homepage/[file.xls]Sheet1'!A1

='ftp.server.somewhere/file.xls'!MyNamedCell

Per selezionare un collegamento ipertestuale senza attivare il collegamento alla relativa destinazione, eseguire una delle operazioni seguenti:

  • Fare clic sulla cella contenente il collegamento, tenere premuto il pulsante del mouse fino a quando il puntatore assume la forma di una croce Cursore di selezione di Excel e quindi rilasciare il pulsante del mouse.

  • Utilizzare i tasti di direzione per selezionare la cella contenente il collegamento.

  • Se il collegamento è rappresentato da un elemento grafico, tenere premuto CTRL e quindi fare clic su di esso.

È possibile modificare un collegamento nella cartella di lavoro cambiandone la destinazione, l'aspetto oppure il testo o l'elemento grafico che lo rappresenta.

Modificare la destinazione di un collegamento

  1. Selezionare la cella o l'elemento grafico che contiene il collegamento da modificare.

    Suggerimento: Per selezionare una cella che contiene un collegamento senza passare alla relativa destinazione, fare clic sulla cella e tenere premuto il pulsante del mouse fino a quando il puntatore assume la forma di una croce Cursore di selezione di Excel , quindi rilasciarlo. Per selezionare la cella è anche possibile usare i tasti di direzione. Per selezionare un elemento grafico, tenere premuto CTRL mentre si fa clic su di esso.

    • Alla scheda Inserisci, nel gruppo Collegamenti, fare clic su Collegamento. Pulsante Collegamento ipertestuale

    È inoltre possibile fare clic con il pulsante destro del mouse sulla cella o sull'elemento grafico e quindi scegliere Modifica collegamento oppure premere CTRL+K.

  2. Nella finestra di dialogo Modifica collegamento ipertestuale apportare le modifiche desiderate.

    Nota: Se il collegamento è stato creato con la funzione del foglio di lavoro COLLEG.IPERTESTUALE, è necessario modificare la formula per cambiare la destinazione. Selezionare la cella che contiene il collegamento, quindi fare clic su barra della formula per modificare la formula.

Per modificare l'aspetto dell'intero testo di un collegamento nella cartella di lavoro corrente, è possibile cambiare lo stile cella per i collegamenti.

  1. Alla scheda Home, nel gruppo Stili, fare clic su Stili cella.

  2. In Dati e modelli eseguire le operazioni seguenti:

    • Per modificare l'aspetto dei collegamenti su cui non è stato fatto clic per passare alle loro destinazioni, fare clic con il tasto destro del mouse su Collegamento, quindi fare clic su Modifica.

    • Per modificare l'aspetto dei collegamenti su cui è stato fatto clic per passare alle loro destinazioni, fare clic con il tasto destro del mouse su Collegamento seguito, quindi fare clic su Modifica.

      Nota: Lo stile cella del Collegamento è disponibile solo quando la cartella di lavoro contiene un collegamento. Lo stile cella del Collegamento seguito è disponibile solo quando la cartella di lavoro contiene un collegamento su cui è stato fatto clic.

  3. Nella finestra di dialogo Stile fare clic su Formato.

  4. Nella scheda Carattere e nella scheda Riempimento selezionare le opzioni di formattazione desiderate e quindi fare clic su OK.

    Note: 

    • Le opzioni selezionate nella finestra di dialogo Formato celle sono uguali a quelle selezionate in Lo stile include nella finestra di dialogo Stile. È possibile deselezionare le caselle di controllo relative alle opzioni che non si desidera applicare.

    • Le modifiche apportate agli stili cella del Collegamento e del Collegamento seguito si applicano a tutti i collegamenti nella cartella di lavoro corrente. Non è possibile modificare l'aspetto dei singoli collegamenti.

  1. Selezionare la cella o l'elemento grafico che contiene il collegamento da modificare.

    Suggerimento: Per selezionare una cella che contiene un collegamento senza passare alla relativa destinazione, fare clic sulla cella e tenere premuto il pulsante del mouse fino a quando il puntatore assume la forma di una croce Cursore di selezione di Excel , quindi rilasciarlo. Per selezionare la cella è anche possibile usare i tasti di direzione. Per selezionare un elemento grafico, tenere premuto CTRL mentre si fa clic su di esso.

  2. Eseguire una o più delle operazioni seguenti:

    • Per modificare il testo del collegamento, fare clic in barra della formula e modificare il testo.

    • Per modificare il formato di un elemento grafico, fare clic con il pulsante destro del mouse su di esso e quindi scegliere le opzioni di formattazione che si desidera modificare.

    • Per cambiare il testo di un elemento grafico, selezionarlo, fare doppio clic e apportare le modifiche desiderate.

    • Per cambiare l'elemento grafico che rappresenta il collegamento, inserire un nuovo elemento grafico impostando un collegamento con la stessa destinazione. Eliminare quindi l'elemento grafico e il collegamento precedenti.

  1. Fare clic con il pulsante destro del mouse sul collegamento ipertestuale che si desidera copiare o spostare e quindi scegliere Copia o Taglia nel menu a comparsa.

  2. Fare clic con il pulsante destro del mouse sulla cella in cui si desidera copiare o spostare il collegamento, quindi scegliere Incolla nel menu a comparsa.

Per impostazione predefinita, i percorsi non specificati ai file di destinazione collegamento ipertestuale si riferiscono alla posizione della cartella di lavoro attiva. Usare questa procedura per impostare un percorso predefinito diverso. Ogni volta in cui viene creato un collegamento a un file in tale posizione, sarà solo necessario specificare il nome file, non il percorso, nella finestra di dialogo Inserisci collegamento ipertestuale.

Seguire uno di questi passaggi, a seconda della versione Excel in uso:

  • In Excel 2016, Excel 2013 e Excel 2010:

    1. Fare clic sulla scheda File.

    2. Fare clic su Informazioni.

    3. Fare clic su Proprietà e quindi selezionare Proprietà avanzate.

      Proprietà avanzate
    4. Nella scheda Riepilogo, nella casella di testo Base del collegamento ipertestuale, digitare il percorso che si desidera usare.

      Nota: È possibile ignorare l'indirizzo di base del collegamento digitando l'indirizzo completo o assoluto nella finestra di dialogo Inserisci collegamento ipertestuale.

  • In Excel 2007:

    1. Fare clic sul pulsante Microsoft Office Icona del pulsante Office , scegliere Prepara, quindi fare clic su Proprietà.

    2. Nel riquadro Informazioni documento, fare clic su Proprietà, quindi su Proprietà avanzate.

      Proprietà avanzate
    3. Fare clic sulla scheda Riepilogo.

    4. Nella casella Base del collegamento ipertestuale digitare il percorso che si desidera utilizzare.

    Nota: È possibile ignorare l'indirizzo di base del collegamento digitando l'indirizzo completo o assoluto nella finestra di dialogo Inserisci collegamento ipertestuale.

Per eliminare un collegamento, eseguire una delle operazioni seguenti:

  • Per eliminare un collegamento e il testo che lo rappresenta, fare clic con il pulsante destro del mouse sulla cella che contiene il collegamento e scegliere Cancella contenuto.

  • Per eliminare un collegamento e l'elemento grafico che lo rappresenta, tenere premuto CTRL facendo clic sull'elemento grafico e premere CANC.

  • Per disattivare un singolo collegamento, fare clic con il tasto destro del mouse sul collegamento, quindi su Rimuovi collegamento sul menu a comparsa.

  • Per disattivare più collegamenti insieme, eseguire le operazioni seguenti:

    1. In una cella vuota, digitare il numero 1.

    2. Fare clic con il pulsante destro del mouse sulla cella, quindi scegliere Copia dal menu a comparsa.

    3. Tenere premuto CTRL e selezionare ogni collegamento che si desidera disattivare.

      Suggerimento: Per selezionare una cella che contiene un collegamento senza passare alla relativa destinazione, fare clic sulla cella e tenere premuto il pulsante del mouse fino a quando il puntatore assume la forma di una croce Cursore di selezione di Excel , quindi rilasciarlo.

    4. Alla scheda Home, nel gruppo Appunti, fare clic sulla freccia sotto Incolla, quindi su Incolla speciale.

      Pulsanti Copia e Incolla nella scheda Home
    5. In Operazione, fare clic su Moltiplica, quindi su OK.

    6. Alla scheda Home, nel gruppo Stili, fare clic su Stili cella.

    7. In Bene, Male e Neutro, selezionare Normale.

Quando si fa clic su di esso, un collegamento apre un'altra pagina o un file. La destinazione è in genere un'altra pagina Web, ma può anche essere un'immagine, un indirizzo di posta elettronica o un programma. Il collegamento stesso può essere rappresentato da testo o da un'immagine.

Quando un utente di un sito fa clic sul collegamento, la destinazione viene visualizzata in un Web browser, aperto o eseguito, a seconda del tipo di destinazione. Ad esempio, un collegamento a una pagina mostra la pagina nel browser Web e un collegamento a un file AVI apre il file in un lettore multimediale.

Utilizzo dei collegamenti

È possibile utilizzare i collegamenti per eseguire le operazioni seguenti:

  • Passare a un file o a una pagina Web su una rete Intranet, o su Internet

  • Passare a un file o a una pagina Web che si intende creare in futuro

  • Inviare un messaggio di posta elettronica

  • Avviare il trasferimento di un file, ad esempio tramite download o FTP

Quando si posiziona il mouse su una stringa di testo o un'immagine associata a un collegamento, il puntatore assume la forma di una mano Puntatore a forma di mano , per indicare che è possibile fare clic sul testo o sull'immagine.

Descrizione e funzionalità degli URL

Quando si crea un collegamento, la relativa destinazione viene codificata come Uniform Resource Locator (URL), ad esempio:

http://esempio.microsoft.com/news.htm

file://NomeComputer/CartellaCondivisa/NomeFile.htm

Un URL contiene un protocollo, come HTTP, FTP o FILE, un server Web o un percorso di rete e un percorso e nome file. Nella figura seguente sono definiti i componenti dell'URL:

I quattro componenti di un URL

1. Protocollo utilizzato (http, ftp, file)

2. Server Web o percorso di rete

3. Percorso

4. Nome di file

Collegamenti assoluti e relativi

Un URL assoluto è costituito da un indirizzo completo, inclusi il protocollo, il server Web e il percorso e nome file.

In un URL relativo mancano una o più parti. Le informazioni mancanti vengono acquisite dalla pagina che contiene l'URL. Se mancano ad esempio il protocollo e il server Web, il Web browser userà il protocollo e il dominio della pagina corrente, ad esempio .com, .org o .edu.

Per le pagine Web in genere si usano URL relativi contenenti solo un percorso parziale e il nome del file. Se i file vengono spostati in un altro server, i collegamenti continueranno a funzionare purché le relative posizioni delle pagine rimangano invariate. Ad esempio, un collegamento in Products.htm indirizza a una pagina denominata apple.htm nella cartella Food; se entrambe le pagine vengono spostate in una cartella denominata Food su un server diverso, l'URL nel collegamento sarà ancora corretto.

Per impostazione predefinita, in una cartella di lavoro di Excel, i percorsi non specificati ai file di destinazione del collegamento sono relativi alla posizione della cartella di lavoro attiva. È possibile impostare un indirizzo di base diverso da usare per impostazione predefinita, così che ogni volta in cui viene creato un collegamento a un file in tale posizione, sarà solo necessario specificare il nome file, non il percorso, nella finestra di dialogo Inserisci collegamento ipertestuale.

  1. In un foglio di lavoro, selezionare la cella in cui si desidera creare un collegamento.

  2. Nella scheda Inserisci, selezionare Collegamento ipertestuale.

    È anche possibile fare clic con il tasto destro del mouse sulla cella e selezionare Collegamento ipertestuale... nel menu a comparsa, oppure è possibile premere CTRL+K.

  3. In Testo visualizzato:, digitare il testo che si desidera usare per rappresentare il collegamento.

  4. In URL:, digitare l'Uniform Resource Locator (URL) completo della pagina Web che si desidera collegare.

  5. Selezionare OK.

Per eseguire un collegamento a una posizione nella cartella di lavoro corrente, è possibile definire un nome per le celle di destinazione o usare un riferimento di cella.

  1. Per utilizzare un nome, è necessario assegnare un nome alle celle di destinazione nella cartella di lavoro.

    Come definire un nome per una cella o un intervallo di celle
     

    Nota: In Excel sul web non è possibile creare intervalli rinominati. È solo possibile selezionare una pagina rinominata esistente dal controllo Intervalli denominati. In alternativa, è possibile aprire il file nell'app desktop di Excel, creare un intervallo denominato e accedere a questa opzione da Excel sul web.

    1. Selezionare la cella o l'intervallo di celle a cui assegnare un nome.

    2. Nella casella Nome casella all'estremità sinistra di barra della formula Icona del pulsante , digitare il nome delle celle, quindi premere INVIO.

      Nota: I nomi non possono contenere spazi e devono iniziare con una lettera.

  2. In un foglio di lavoro, selezionare la cella in cui si desidera creare un collegamento.

  3. Nella scheda Inserisci, selezionare Collegamento ipertestuale.

    È anche possibile fare clic con il tasto destro del mouse sulla cella e selezionare Collegamento ipertestuale... nel menu a comparsa, oppure è possibile premere CTRL+K.

  4. In Testo visualizzato:, digitare il testo che si desidera usare per rappresentare il collegamento.

  5. In Posiziona in questo documento:, immettere il nome definito o il riferimento.

  6. Selezionare OK.

Quando si fa clic su un collegamento a un indirizzo di posta elettronica, viene aperto automaticamente il programma di posta elettronica e viene creato un messaggio di posta elettronica con l'indirizzo corretto nella casella A, a condizione che sia installato un programma di posta elettronica.

  1. In un foglio di lavoro, fare clic all'interno della cella in cui si desidera creare un collegamento.

  2. Nella scheda Inserisci, selezionare Collegamento ipertestuale.

    È anche possibile fare clic con il tasto destro del mouse sulla cella e selezionare Collegamento ipertestuale... nel menu a comparsa, oppure è possibile premere CTRL+K.

  3. In Testo visualizzato:, digitare il testo che si desidera usare per rappresentare il collegamento.

  4. In Indirizzo di posta elettronica:, digitare l'indirizzo e-mail desiderato.

  5. Selezionare OK.

È anche possibile creare un collegamento a un indirizzo di posta elettronica in una cella digitando l'indirizzo direttamente nella cella. Se ad esempio si digita un indirizzo di posta elettronica, come someone@example.com, verrà creato automaticamente un collegamento.

È possibile usare la funzione COLLEG.IPERTESTUALE per creare un collegamento a un URL.

Nota: Posizione_collegamento può essere una stringa di testo racchiusa tra virgolette o da un riferimento a una cella che contiene il collegamento come stringa di testo.

Per selezionare un collegamento ipertestuale senza attivare il collegamento al relativo destinazione, eseguire una delle operazioni seguenti:

  • Selezionare una cella facendo clic su di essa quando il puntatore è una freccia.

  • Utilizzare i tasti di direzione per selezionare la cella contenente il collegamento.

È possibile modificare un collegamento esistente nella cartella di lavoro cambiandone la destinazione, l'aspetto oppure il testo o l'elemento grafico che lo rappresenta.

  1. Selezionare la cella che contiene il collegamento da modificare.

    Suggerimento: Per selezionare un collegamento ipertestuale senza attivare il collegamento al relativo destinazione, usare i tasti di direzione per selezionare la cella che contiene il collegamento.

  2. Nella scheda Inserisci, selezionare Collegamento ipertestuale.

    È inoltre possibile fare clic con il pulsante destro del mouse sulla cella o sull'elemento grafico e quindi scegliere Modifica collegamento ipertestuale... nel menu a comparsa, oppure premere CTRL+K.

  3. Nella finestra di dialogo Modifica collegamento ipertestuale apportare le modifiche desiderate.

    Nota: Se il collegamento è stato creato con la funzione del foglio di lavoro COLLEG.IPERTESTUALE, è necessario modificare la formula per cambiare la destinazione. Selezionare la cella che contiene il collegamento, quindi selezionare barra della formula per modificare la formula.

  1. Fare clic con il pulsante destro del mouse sul collegamento ipertestuale che si desidera copiare o spostare e quindi selezionare Copia o Taglia nel menu a comparsa.

  2. Fare clic con il tasto destro del mouse sulla cella in cui si desidera copiare o spostare il collegamento, quindi selezionare Incolla nel menu a comparsa.

Per eliminare un collegamento, eseguire una delle operazioni seguenti:

  • Per eliminare un collegamento, selezionare la cella e premere Elimina.

  • Per disattivare un collegamento (eliminare il collegamento ma mantenere il testo che lo rappresenta), fare clic con il tasto destro del mouse sulla cella e selezionare Rimuovi collegamento ipertestuale.

Servono altre informazioni?

È sempre possibile rivolgersi a un esperto nella Tech Community di Excel oppure ottenere supporto nella community Microsoft.

Vedere anche

Rimuovere o disattivare i collegamenti

Serve aiuto?

Amplia le tue competenze su Office
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

×