Quando è necessario trovare dati che soddisfano più condizioni, ad esempio unità vendute tra aprile e gennaio o unità vendute da Nancy, è possibile usare le funzioni Ee O insieme. Ecco un esempio:

Uso di E e O nella stessa formula

Questa formula annida la funzione E all'interno della funzione O per cercare le unità vendute tra il 1° aprile 2011 e il 1° gennaio 2012 o le unità vendute da Nancy. Puoi vedere che restituisce Vero per le unità vendute da Nancy e anche per le unità vendute da Tim ed Ed durante le date specificate nella formula.

Ecco la formula in un modulo che è possibile copiare e incollare. Se si vuole riprodurlo in una cartella di lavoro di esempio, vedere la fine di questo articolo.

=OR(E(C2>DATA(2011;4;30),C2<DATA(2012;1;1)),B2="Nancy")

Diamo un'analisi più approfondita della formula. La funzione O richiede un set di argomenti (parti di dati) che può testare per verificare se sono vere o false. In questa formula il primo argomento è la funzione E e la funzione DATA annidata al suo interno, il secondo è "Nancy". È possibile leggere la formula in questo modo: Verificare se una vendita è stata effettuata dopo il 30 aprile 2011 e prima del 1° gennaio 2012 o se è stata effettuata da Nancy.

La funzione E restituisce anche Vero o Falso. Nella maggior parte dei casi, si usa AND per estendere le funzionalità di un'altra funzione, ad esempio O e SE. In questo esempio la funzione OR non trova le date corrette senza la funzione E.

Usare E e O con SE

È anche possibile usare E e O con la funzione SE.

Le funzioni E e O nidificate in una funzione SE

In questo esempio, le persone non guadagnano bonus finché non vendono beni per un valore minimo di 125.000 euro, a meno che non lavorino nell'area meridionale in cui il mercato è più piccolo. In questo caso, si qualificano per un bonus dopo $ 100.000 nelle vendite.

=SE(O(C4>=125000;AND(B4="Sud";C4>=100000)=VERO,C4*0,12;"Nessun bonus")

Diamo un'occhiata un po' più in profondità. La funzione SE richiede tre parti di dati (argomenti) per l'esecuzione corretta. Il primo è un test logico, il secondo è il valore che si vuole verificare se il test restituisce Vero e il terzo è il valore che si vuole verificare se il test restituisce False. In questo esempio la funzione OR e tutti gli elementi annidati al suo interno forniscono il test logico. È possibile leggerlo come: Cercare valori maggiori o uguali a 125.000, a meno che il valore nella colonna C non sia "Sud", quindi cercare un valore maggiore di 100.000 e ogni volta che entrambe le condizioni sono vere, moltiplicare il valore per 0,12, l'importo della commissione. In caso contrario, visualizzare le parole "Nessun bonus".

Inizio pagina

Dati di esempio

Se si vogliono usare gli esempi di questo articolo, copiare la tabella seguente nella cella A1 del foglio di calcolo. Assicurarsi di selezionare l'intera tabella, inclusa la riga di intestazione.


Agente di vendita

Area geografica

Vendite

Formula/risultato

Castiglione

Est

87925

=SE(O(C2>=125000;AND(B2="Sud";C2>=100000)=VERO,C2*0,12;"Nessun bonus")

Castiglione

Nord

100000

=SE(O(C3>=125000;AND(B3="Sud";C3>=100000)=VERO,C3*0,12,"Nessun bonus")

Sabbatini

Ovest

145000

=SE(O(C4>=125000;AND(B4="Sud";C4>=100000)=VERO,C4*0,12;"Nessun bonus")

Russo

Sud

200750

=SE(O(C5>=125000;AND(B5="Sud";C5>=100000)=VERO,C5*0,12;"Nessun bonus")

Udinesi

Sud

178650

=SE(O(C6>=125000;AND(B6="Sud";C6>=100000))=VERO,C6*0,12;"Nessun bonus")

Tommaso

Nord

99555

=SE(O(C7>=125000;E(B7="Sud";C7>=100000))=VERO,C7*0,12;"Nessun bonus")

Keever

Est

147000

=SE(O(C8>=125000;AND(B8="Sud";C8>=100000)=VERO,C8*0,12;"Nessun bonus")

Cassazza

Nord

213450

=SE(O(C9>=125000;AND(B9="Sud";C9>=100000)=VERO,C9*0,12;"Nessun bonus")

Brownlee

Sud

122680

=SE(O(C10>=125000;AND(B10="Sud";C10>=100000))=VERO,C10*0,12;"Nessun bonus")

Smithberg

Ovest

92500

=SE(O(C11>=125000;AND(B11="Sud";C11>=100000))=VERO,C11*0,12;"Nessun bonus")

Benson

Est

88350

=SE(O(C12>=125000;AND(B12="Sud";C12>=100000))=VERO,C12*0,12;"Nessun bonus")

Lettura

Ovest

102500

=SE(O(C13>=125000;AND(B13="Sud";C13>=100000))=VERO,C13*0,12;"Nessun bonus")

Inizio pagina

Serve aiuto?

Amplia le tue competenze

Esplora i corsi di formazione >

Ottieni in anticipo le nuove caratteristiche

Partecipa a Microsoft Insider >

Queste informazioni sono risultate utili?

Come valuti la qualità della lingua?
Cosa ha influito sulla tua esperienza?

Grazie per il feedback!

×