L'uso di una funzione come uno degli argomenti di una formula che usa una funzione è detto annidamento e si fa riferimento a tale funzione come funzione annidata. Ad esempio, annidando la funzione MEDIA e SOMMA negli argomenti della funzione SE, la formula seguente somma un set di numeri (G2:G5) solo se la media di un altro set di numeri (F2:F5) è maggiore di 50. In caso contrario, restituisce 0.

funzioni annidate

Le funzioni MEDIA e SOMMA sono annidate nella funzione SE.

È possibile annidare fino a 64 livelli di funzioni in una formula.

  1. Fare clic sulla cella in cui si desidera immettere la formula.

  2. Per iniziare la formula con la funzione, fare clic su Inserisci funzione Icona del pulsante sulla barra della formula Callout 4.

    Verrà inserito automaticamente il segno di uguale (=).

  3. Nella casella Oppure selezionare una categoria selezionare Tutte.

    Se si ha familiarità con le categorie di funzione, è anche possibile selezionare una categoria.

    In caso di incertezze sulla funzione da utilizzare, è possibile digitare nella casella Cerca una funzione una domanda che descriva l'operazione da eseguire. "Aggiungere numeri" ad esempio restituisce la funzione SOMMA.

  4. Per immettere un'altra funzione come argomento, immettere la funzione nella casella dell'argomento desiderato.

    Le parti della formula visualizzate nella finestra di dialogo Argomenti funzione riflettono la funzione selezionata nel passaggio precedente.

    Se è stato fatto clic su SE, nella finestra di dialogo Argomenti funzione vengono visualizzati gli argomenti per la funzione SE. Per annidare un'altra funzione, è possibile immetterla nella casella dell'argomento. Ad esempio, è possibile immettere SOMMA(G2:G5) nella Value_if_true della funzione SE.

  5. Immettere gli eventuali argomenti aggiuntivi necessari per completare la formula.

    Anziché digitare riferimenti di cella, è inoltre possibile selezionare le celle a cui si desidera fare riferimento. Fare Callout 4 per ridurre a icona la finestra di dialogo, selezionare le celle a cui si vuole fare riferimento e quindi fare clic su Callout 4 per espandere di nuovo la finestra di dialogo.

    Suggerimento: Per ulteriori informazioni sulla funzione e sui relativi argomenti, fare clic sulla Guida relativa a questa funzione.

  6. Dopo avere completato gli argomenti della formula, fare clic su OK.

  1. Fare clic sulla cella in cui si desidera immettere la formula.

  2. Per iniziare la formula con la funzione, fare clic su Inserisci funzione Icona del pulsante sulla barra della formula Callout 4.

  3. Nella finestra di dialogo Inserisci funzione selezionare Tutte nella casella Selezionare una categoria.

    Se si ha familiarità con le categorie di funzione, è anche possibile selezionare una categoria.

  4. Per immettere un'altra funzione come argomento, immettere la funzione nella casella dell'argomento nel Generatore di formule o direttamente nella cella.

  5. Immettere gli eventuali argomenti aggiuntivi necessari per completare la formula.

  6. Dopo aver completato gli argomenti per la formula, premere INVIO.

Esempi

Di seguito è illustrato un esempio di utilizzo delle funzioni SE annidate per assegnare un voto di lettera a un punteggio di test numerico.

Copiare i dati di esempio contenuti nella tabella seguente e incollarli nella cella A1 di un nuovo foglio di lavoro di Excel. Per visualizzare i risultati delle formule, selezionarle, premere F2 e quindi premere INVIO. Se necessario, è possibile regolare la larghezza delle colonne per visualizzare tutti i dati.

Punteggio

45

90

78

Formula

Descrizione

Risultato

'=SE(A2>89;"A";SE(A2>79;"B"; SE(A2>69;"C";SE(A2>59;"D";"F")))

Usa condizioni SE annidate per assegnare un voto di lettera al punteggio nella cella A2.

=SE(A2>89;"A";SE(A2>79;"B";SE(A2>69;"C";SE(A2>59;"D";"F")))

'=SE(A3>89;"A";SE(A3>79;"B"; SE(A3>69;"C";SE(A3>59;"D";"F")))

Usa condizioni SE annidate per assegnare un voto di lettera al punteggio nella cella A3.

=SE(A3>89;"A";SE(A3>79;"B";SE(A3>69;"C";SE(A3>59;"D";"F")))

'=SE(A4>89;"A";SE(A4>79;"B"; SE(A4>69;"C";SE(A4>59;"D";"F")))

Usa condizioni SE annidate per assegnare un voto di lettera al punteggio nella cella A4.

=SE(A4>89;"A";SE(A4>79;"B";SE(A4>69;"C";SE(A4>59;"D";"F"))))

Suggerimenti: 

Servono altre informazioni?

È sempre possibile rivolgersi a un esperto nella Tech Community di Excel oppure ottenere supporto nella community Microsoft.

Vedere anche

Video: Funzioni SE annidate

Serve aiuto?

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa a Microsoft Insider

Queste informazioni sono risultate utili?

Quanto ti soddisfa la qualità della traduzione?
Cosa ha influito sulla tua esperienza?

Grazie per il feedback!

×