KB2289254 - Aggiornamento cumulativo 1 per SQL Server 2008 Service Pack 2

Si applica a
SQL Server 2008 Standard SQL Server 2008 Developer SQL Server 2008 Enterprise SQL Server 2008 Workgroup SQL Server 2008 Web SQL Server 2008 Express SQL Server 2008 Express with Advanced Services

INTRODUZIONE

Gli hotfix per Microsoft SQL Server 2008 vengono creati per Service Pack specifici di SQL Server. È necessario applicare un aggiornamento rapido rapido per SQL Server 2008 Service Pack 2 a un'installazione di SQL Server 2008 Service Pack 2. Per impostazione predefinita, qualsiasi hotfix fornito in un service pack di SQL Server è incluso nel service pack di SQL Server successivo.

L'aggiornamento cumulativo 1 per SQL Server 2008 Service Pack 2 (SP2) è inteso come aggiornamento cumulativo post-service pack per i clienti di SQL Server 2008 che intendono eseguire l'aggiornamento a SQL Server 2008 SP2 e mantenere ancora gli hotfix da SQL Server 2008 SP1Aggiornamento cumulativo 9 a SQL Server 2008 SP1Aggiornamento cumulativo 10.

Nota: questa build del pacchetto di aggiornamento cumulativo è nota anche come build 10.00.4266.00.

È consigliabile testare gli hotfix prima di distribuirli in un ambiente di produzione. Poiché le build sono cumulative, ogni nuova versione di correzione contiene tutte le correzioni rapide e di sicurezza incluse nella versione precedente di correzione di SQL Server 2008. Si consiglia di applicare l'ultima versione della correzione che contiene questo aggiornamento rapido (hotfix).
  Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:

2402659 Le SQL Server build 2008 rilasciate dopo SQL Server rilascio del Service Pack 2 2008

Note importanti sul pacchetto di aggiornamento cumulativo

  • Gli hotfix di SQL Server 2008 sono ora multilingue. Di conseguenza, è disponibile un solo pacchetto di aggiornamenti rapidi cumulativo per tutte le lingue.
  • Un pacchetto di hotfix cumulativo include tutti i pacchetti di componenti. Il pacchetto di aggiornamento cumulativo aggiorna solo i componenti installati nel sistema.

Altre informazioni

Come ottenere l'aggiornamento cumulativo 1 per SQL Server 2008 Service Pack 2

Un pacchetto di aggiornamento cumulativo supportato è ora disponibile da Microsoft. Tuttavia, ha lo scopo di correggere solo i problemi descritti in questo articolo. Applicalo solo ai sistemi che riscontrano questi problemi specifici. Questo pacchetto di aggiornamento cumulativo potrebbe essere sottoposto a ulteriori test. Pertanto, se nessuno di questi problemi è gravemente colpito, è consigliabile attendere il successivo Service Pack di SQL Server 2008 contenente gli aggiornamenti rapidi in questo pacchetto di aggiornamento cumulativo.

Se l'aggiornamento cumulativo è disponibile per il download, all'inizio di questo articolo della Knowledge Base è presente una sezione "Download dell'aggiornamento rapido disponibile". Se questa sezione non viene visualizzata, contattare il servizio supporto tecnico Microsoft per ottenere il pacchetto di aggiornamento cumulativo.

Nota: se si verificano ulteriori problemi o è necessaria una risoluzione dei problemi, potrebbe essere necessario creare una richiesta di servizio separata. I normali costi di supporto verranno applicati alle domande e ai problemi di supporto aggiuntivi che non rientrano in questo specifico pacchetto di aggiornamento cumulativo. Per un elenco completo dei numeri di telefono del servizio clienti e del supporto tecnico Microsoft o per creare una richiesta di servizio separata, visita il seguente sito Web Microsoft:

/contactus/?ws=support Nota: nel modulo "Download degli aggiornamenti rapidi disponibili" sono visualizzate le lingue per cui è disponibile l'aggiornamento cumulativo. Se la lingua in uso non è visualizzata, significa che non è disponibile un pacchetto di aggiornamento cumulativo per tale lingua.

Aggiornamenti rapidi inclusi nell'aggiornamento cumulativo 1 per SQL Server 2008 Service Pack 2

  Gli articoli della Microsoft Knowledge Base che illustrano questi hotfix verranno rilasciati non appena saranno disponibili.

  Per ulteriori informazioni sui bug di SQL Server, fare clic sui numeri degli articoli della Microsoft Knowledge Base riportati di seguito:

Numero di bug VSTS Numero articolo della Knowledge Base Descrizione
561807 942712 FIX: Il processo di W3WP.exe di Internet Information Services si arresta in modo imprevisto quando si configura una replica di tipo merge che utilizza la sincronizzazione Web in SQL Server 2005 e SQL Server 2008
549033 nessuno Il processo di acquisizione CDC può riscontrare la condizione di asserzione seguente quando CDC è abilitato nelle tabelle di database con colonne XML o di altro tipo di dati BLOB:

Asserzione: File: <nome del file>
line=<numero di> riga asserzione non riuscita = 'fNoWriters' -AND-
line=<numero di> riga asserzione non riuscita = 'fNoReaderWriterConflict'
576988 979212 FIX: Un valore DateTime viene sostituito da un valore NULL quando un conflitto viene risolto utilizzando un resolver personalizzato nella replica di tipo merge di Microsoft SQL Server 2005, Microsoft SQL Server 2008 o Microsoft SQL Server 2008 R2
576899 980142 FIX: Viene visualizzato un messaggio di errore "Errore di caricamento del provider" o il processo di Wmiprvse.exe smette di rispondere quando si utilizza un provider WMI SQL Server per ottenere informazioni sui servizi SQL Server 2005, SQL Server 2008 o SQL Server 2008 R2
548967 980350 FIX: Il word breaker polacco causa la restituzione di un risultato incompleto da parte di una query di Full-Text in SQL Server 2008
548983 980570 FIX: Messaggio di errore "Errore di indice fulltext durante la compressione o la decompressione" quando si ricompila l'indice di ricerca full-text in Microsoft SQL Server 2008 o in Microsoft SQL Server 2008 R2
548985 980832 FIX: Messaggio di errore "Un controllo dell'asserzione del sistema non è riuscito" quando si esegue una query Transaction-SQL in Microsoft SQL Server 2008 o in Microsoft SQL Server 2008 R2
576971 980849 FIX: Si verifica un'alta latenza per gli agenti di distribuzione peer-to-peer in Microsoft SQL Server 2005, Microsoft SQL Server 2008 o Microsoft SQL Server 2008 R2
548999 980883 FIX: La memorizzazione nella cache attiva viene avviata in modo imprevisto quando si inseriscono dati in SQL Server 2005, SQL Server 2008 R2 o SQL Server 2008
576984 980948 FIX: I metadati sono danneggiati quando si spostano le cartelle dati SSAS 2005, SSAS 2008 R2 o SSAS 2008 da un computer a un altro
548987 981120 FIX: Messaggio di errore quando si abilita TDE in un database con l'isolamento snapshot abilitato in SQL Server 2008 o in SQL Server 2008 R2
549015 981502 FIX: Una query che usa un piano di query parallelo restituisce risultati diversi ogni volta che si esegue la query in SQL Server 2005, SQL Server 2008 R2 o SQL Server 2008
576985 981713 FIX: Una query restituisce un risultato non corretto se usa un indice che viene ricompilato online in SQL Server 2005, SQL Server 2008 R2 o SQL Server 2008
576992 981867 FIX: Un membro calcolato che utilizza membri dimensione filtrati restituisce un risultato non corretto in SSAS 2005, SSAS 2008 R2 o SSAS 2008
576993 981888 FIX: "Il monitoraggio deadlock non è riuscito a risolvere questo deadlock. Il server potrebbe richiedere il riavvio per risolvere questa condizione" messaggio di errore durante il ripristino di un database in Microsoft SQL Server 2005, Microsoft SQL Server 2008 o Microsoft SQL Server 2008 R2
548989 982034 FIX: La caratteristica di conversione non funziona quando si esegue un'azione di raggruppamento in una tabella pivot di Excel che usa SSAS 2008 o SSAS 2008 R2 come origine dati
577024 982363 FIX: SQL Server 2005, SQL Server 2008 o SQL Server 2008 R2 potrebbe richiedere molto tempo per completare un'istruzione ALTER TABLE che modifica una colonna con tipo di dati XML da "NOT NULL" a "NULL" in una tabella
576999 982376 FIX: Un errore di scheduler non cedevole o un errore 8623 si verifica quando si esegue una query che contiene una clausola IN di grandi dimensioni in SQL Server 2005, SQL Server 2008 o SQL Server 2008 R2
561817 982808 Un rapporto drill-through potrebbe non funzionare correttamente se l'opzione "Richiedi credenziali" viene utilizzata nelle origini dati in SQL Server 2008 Reporting Service
548995 982854 FIX: "Memoria di sistema insufficiente nel pool di risorse 'interno' per eseguire questa query" messaggio di errore quando si esegue una query full-text che usa parole composte in Microsoft SQL Server 2008 o in Microsoft SQL Server 2008 R2
548997 982857 FIX: Messaggio di errore quando si configura una replica transazionale per un database in SQL Server 2008 o in SQL Server 2008 R2
577003 982932 Le prestazioni delle query diminuiscono dopo l'applicazione di SQL Server 2005 SP2 Aggiornamento cumulativo 7 o una versione successiva
577002 983429 FIX: Un deadlock si verifica quando si esegue una query o una stored procedure contenente una colonna XML in SQL Server 2005, SQL Server 2008 o SQL Server 2008 R2
549007 983446 In un report di SSRS 2008 viene visualizzata la prima riga duplicata per ogni gruppo di sottoreport quando si esporta il report in formato CSV
577006 983480 FIX: Si verificano vari problemi quando un database è coinvolto in una sessione di mirroring del database e in una replica transazionale se è abilitato il flag di traccia 1448
577007 983500 FIX: Il processo di sincronizzazione dei ruoli è ritardato quando si verifica un failover automatico del mirroring in SQL Server 2005, SQL Server 2008 o SQL Server 2008 R2
549013 983577 FIX: Il processo di esportazione non termina mai quando si esporta un report che contiene elementi tablix annidati in SSRS 2008 o in SSRS 2008 R2 nelle estensioni supportate dai renderer con interruzione di pagina
442541 2022254 SQL Server può segnalare l'errore 18272 durante le operazioni di ripristino
549017 2028406 FIX: Gli spazi vuoti tra alcuni elementi vengono generati in modo non corretto in un report di SQL Server 2008 o SQL Server 2008 R2
561732 2028727 FIX: I valori dei gruppi di colonne vengono visualizzati solo nell'ultimo gruppo di righe figlio dei gruppi di righe adiacenti in SSRS 2008
549020 2028755 FIX: Quando si esegue una query LIKE con caratteri jolly e regole di confronto Latin1_General_100_CS_AS, viene restituito un risultato non corretto in Microsoft SQL Server 2008 o in Microsoft SQL Server 2008 R2
561809 2028830 FIX: I componenti condivisi vengono installati nel percorso errato quando si implementa un'installazione del cluster di failover di SQL Server 2008
561744 2121407 FIX: Messaggio di errore quando si utilizza l'utilità sqlcmd per eseguire la query Transact-SQL in SQL Server 2008 e SQL Server 2008 R2
549026 2152148 FIX: Errore interno: si è verificata un'eccezione imprevista" messaggio di errore quando si esegue una query MDX (Multidimensional Expressions) usando la funzionalità di Business Intelligence per le gerarchie temporali in Microsoft SQL Server Analysis Services 2008
549039 2200755 FIX: Messaggio di errore quando si esegue una query MDX in SSAS 2008 o in SSAS 2008 R2
561746 2214666 FIX: Un pacchetto SSIS che usa la trasformazione Unpivot può produrre risultati incoerenti in SQL Server 2008
549041 2220252 FIX: Un report di SQL Server 2005 che usa la funzionalità di attivazione/disattivazione visibilità viene eseguito in modo non corretto in SQL Server 2008 o in SQL Server 2008 R2
577012 2222998 FIX: Viene restituita una stima di cardinalità non corretta quando si esegue una query in SQL Server 2005, SQL Server 2008 o SQL Server 2008 R2
549031 2248999 FIX: Si verifica un danneggiamento dell'indice quando si aggiorna una visualizzazione in Microsoft SQL Server 2008 o in Microsoft SQL Server 2008 R2
549043 2255410 Una query restituisce risultati incoerenti prima che la cache dei dati venga riscaldata in SSAS 2008 o in SSAS 2008 R2
561750 2256829 FIX: Un certo numero delle ultime colonne XML potrebbe non essere replicato correttamente se si utilizza la sincronizzazione Web per la replica di tipo merge in SQL Server 2008
561757 2260502 FIX: Le prestazioni della query diminuiscono dopo l'aggiornamento a SQL Server 2008 da SQL Server 2000 se la query usa una funzione scalare definita dall'utente
561760 2261403 FIX: L'oggetto prestazioni "SQL Server:SSIS Pipeline 10.0" non viene visualizzato nell'elenco "Oggetto prestazioni" quando un altro utente accede ad alcuni contatori della pipeline SSIS in SQL Server 2008 o in SQL Server 2008 R2
549028 2264562 FIX: Una query full-text che usa il predicato CONTAINS o FREETEXT insieme all'operatore "OR" richiede molto tempo per essere eseguita in SQL Server 2008 o in SQL Server 2008 R2
577013 2268122 FIX: "L'utente 'guest' non dispone dell'autorizzazione per eseguire DBCC checkdb per database 'mssqlsystemresource'" messaggio di errore quando si esegue il comando DBCC CHECKDB('master') in un computer che esegue SQL Server 2005, SQL Server 2008 o SQL Server 2008 R2
561766 2276330 FIX: La funzione "CHANGETABLE" è lenta in SQL Server 2008 e in SQL Server 2008 R2
561768 2276717 FIX: Codice di errore 1456 quando si aggiunge un server di controllo a una nuova sessione di mirroring del database con lo stesso nome di una sessione di mirroring del database esistente in Microsoft SQL Server 2005, Microsoft SQL Server 2008 e Microsoft SQL Server 2008 R2
577014 2277207 FIX: Il valore dell'etichetta "Asse" viene visualizzato in ogni colonna e il valore "Intervallo linea griglia" non viene rispettato dopo l'aggiornamento di un file RDL da SSRS 2005 a SSRS 2008
561770 2278042 FIX: Una trasformazione di colonna derivata può generare risultati non corretti in SSIS 2008 o in SSIS 2008 R2 quando una colonna viene derivata sia in modalità di sola lettura che in quella di lettura/scrittura
561773 2282743 FIX: I caratteri speciali vengono visualizzati in modo non corretto in un controllo "Casella di testo" di un file PDF quando si esegue il rendering di un report in SSRS 2008
577017 2283072 FIX: È disponibile un aggiornamento rapido che consente a SQL Server 2008 Reporting Services e SQL Server 2008 R2 Reporting Services di utilizzare una chiave RSA a 2048 bit per crittografare una chiave Reporting Services per la conformità FIPS
561791 2287990 FIX: La trasformazione "Colonna derivata" potrebbe produrre risultati non corretti quando si esegue un pacchetto in Microsoft SQL Server 2008 Integration Services
561789 2292725 FIX: si riscontrano prestazioni ridotte quando si esegue una query MDX in SQL Server 2008 SP1 con l'aggiornamento cumulativo 5 o una versione successiva del pacchetto di aggiornamento installato
577020 2297308 FIX: "Un precedente tentativo di configurazione di filestream è stato incompleto" e una violazione di accesso si verificano quando si esegue la configurazione post-installazione della funzionalità FILESTREAM in un cluster di failover di SQL Server 2008 o SQL Server 2008 R2
561783 2297709 FIX: È possibile che venga visualizzato un messaggio di errore quando si esegue una query "INSERIMENTO BULK" in un database che usa il modello di recupero "BULK_LOGGED" o "SIMPLE" in SQL Server 2008
577018 2297903 FIX: L'ID evento 322 viene registrato quando viene restituito un controllo server in SQL Server 2008 o SQL Server 2008 R2
561801 2300689 FIX: Non è possibile ripristinare un backup di un database in un'altra istanza di SQL Server se si disabilita Transparent Data Encryption prima di creare il backup in SQL Server 2008 o in SQL Server 2008 R2
561787 2306162 FIX: Prestazioni scarse e alcuni errori occasionali di scheduler non redditizi si verificano quando si crea una visualizzazione complessa che fa riferimento a una grande quantità di viste o tabelle annidate in SQL Server 2008
561785 2316135 FIX: "Si è verificata un'eccezione imprevista" Errore interno e danneggiamento dell'heap quando si esegue una query MDX generata da software di terze parti in SSAS 2008
561793 2344600 FIX: L'errore "Non-yielding Scheduler" può verificarsi quando si utilizza la funzione CONTAINSTABLE insieme a molti predicati OR e AND in SQL Server 2008
561795 2352413 FIX: Errore di query e un messaggio di errore "Nome colonna non valido" si verificano quando si esegue una query su un server collegato a un'altra istanza di SQL Server 2008
561742 2379466 FIX: Codice errore "0x84B10001", SQL Server 2008 errore di installazione e un'eccezione non gestita si verificano quando si esegue SQL Server 2008 Installazione
561797 2380361 FIX: Messaggio di errore quando si esegue la stored procedure "sp_createstats" in SQL Server 2008 o in SQL Server 2008 R2 se la tabella contiene una colonna calcolata non deterministica
561799 2380435 FIX: Il piano di query per una stored procedure non viene memorizzato nella cache se la stored procedure utilizza una variabile BLOB e la variabile viene utilizzata in una funzione stringa in Microsoft SQL Server 2008 o in Microsoft SQL Server 2008 R2
561803 2384766 FIX: La proprietà ANSI_NULLS di una visualizzazione indicizzata viene impostata su FALSE dopo la replica della visualizzazione indicizzata nel database di sottoscrizione in SQL Server 2008 o in SQL Server 2008 R2
561805 2387686 FIX: Il messaggio di errore "Si è verificato un errore di sintassi MOF" quando si tenta di installare SQL Server 2008 o SQL Server 2008 R2
561813 2399715 FIX: Un'istruzione "UPDATE CUBE" restituisce un messaggio di errore non corretto quando si tenta di aggiornare una misura calcolata o un membro calcolato in SSAS 2008
561811 2407172 FIX: Un'eccezione si verifica prima che l'output degli errori per i dati non validi di un'attività "Origine XML" venga reindirizzato in SSIS 2005 o SSIS 2008

Informazioni sul pacchetto di aggiornamento cumulativo

Prerequisiti

Microsoft SQL Server 2008 Service Pack 2
Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:

968382 Come ottenere il service pack più recente per SQL Server 2008

Informazioni sul riavvio

  Potrebbe essere necessario riavviare il computer dopo aver applicato questo pacchetto di aggiornamento cumulativo.

Informazioni del Registro di sistema

  Per usare uno degli aggiornamenti rapidi inclusi in questo pacchetto, non è necessario apportare modifiche al Registro di sistema.

Riferimenti

  Per ulteriori informazioni sul modello di servizio incrementale per SQL Server, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:

935897
  Un modello di servizio incrementale è disponibile dal team di SQL Server per fornire correzioni rapide per i problemi segnalati

  Per ulteriori informazioni sullo schema di denominazione per gli aggiornamenti di SQL Server, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:

822499
  Nuovo schema di denominazione per i pacchetti di aggiornamento software di Microsoft SQL Server
   Per ulteriori informazioni sulla terminologia degli aggiornamenti software, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:

824684
  Descrizione della terminologia standard usata per descrivere gli aggiornamenti software Microsoft