INTRODUZIONE
L'aggiornamento cumulativo 3 per SQL Server 2008 Service Pack 2 contiene aggiornamenti rapidi per i problemi di Microsoft SQL Server 2008 che sono stati risolti dopo il rilascio di SQL Server 2008 Service Pack 2.
Nota: questa build del pacchetto di aggiornamento cumulativo è nota anche come build 10.00.4279.00.
È consigliabile testare gli hotfix prima di distribuirli in un ambiente di produzione. Poiché le build sono cumulative, ogni nuova versione di correzione contiene tutte le correzioni rapide e di sicurezza incluse nella versione precedente di correzione di SQL Server 2008. Si consiglia di applicare l'ultima versione della correzione che contiene questo aggiornamento rapido (hotfix).
Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
2402659 Le SQL Server build 2008 rilasciate dopo SQL Server rilascio del Service Pack 2 2008
Note importanti sul pacchetto di aggiornamento cumulativo
- Gli hotfix di SQL Server 2008 sono ora multilingue. Di conseguenza, è disponibile un solo pacchetto di aggiornamenti rapidi cumulativo per tutte le lingue.
- Un pacchetto di hotfix cumulativo include tutti i pacchetti di componenti. Il pacchetto di aggiornamento cumulativo aggiorna solo i componenti installati nel sistema.
Altre informazioni
Come ottenere l'aggiornamento cumulativo 3 per SQL Server 2008 Service Pack 2
Un pacchetto di aggiornamento cumulativo supportato è ora disponibile da Microsoft. Tuttavia, ha lo scopo di correggere solo i problemi descritti in questo articolo. Applicalo solo ai sistemi che riscontrano questi problemi specifici. Questo pacchetto di aggiornamento cumulativo potrebbe essere sottoposto a ulteriori test. Pertanto, se nessuno di questi problemi è gravemente colpito, è consigliabile attendere il successivo Service Pack di SQL Server 2008 contenente gli aggiornamenti rapidi in questo pacchetto di aggiornamento cumulativo.
Se l'aggiornamento cumulativo è disponibile per il download, all'inizio di questo articolo della Knowledge Base è presente una sezione "Download dell'aggiornamento rapido disponibile". Se questa sezione non viene visualizzata, contattare il servizio supporto tecnico Microsoft per ottenere il pacchetto di aggiornamento cumulativo.
Nota: se si verificano ulteriori problemi o è necessaria una risoluzione dei problemi, potrebbe essere necessario creare una richiesta di servizio separata. I normali costi di supporto verranno applicati alle domande e ai problemi di supporto aggiuntivi che non rientrano in questo specifico pacchetto di aggiornamento cumulativo. Per un elenco completo dei numeri di telefono del servizio clienti e del supporto tecnico Microsoft o per creare una richiesta di servizio separata, visita il seguente sito Web Microsoft:
/contactus/?ws=support Nota: nel modulo "Download degli aggiornamenti rapidi disponibili" sono visualizzate le lingue per cui è disponibile l'aggiornamento cumulativo. Se la lingua in uso non è visualizzata, significa che non è disponibile un pacchetto di aggiornamento cumulativo per tale lingua.
Aggiornamenti rapidi inclusi nell'aggiornamento cumulativo 3 per SQL Server 2008 Service Pack 2
Gli articoli della Microsoft Knowledge Base che illustrano questi hotfix verranno rilasciati non appena saranno disponibili.
Per ulteriori informazioni sui bug di SQL Server, fare clic sui numeri degli articoli della Microsoft Knowledge Base riportati di seguito:
| Numero di bug VSTS | Numero articolo della Knowledge Base | Descrizione |
|---|---|---|
| 650633 | 975951 | Quando si configura un cluster di failover di SQL Server 2008 in una subnet contenente solo indirizzi IPv6, viene visualizzato un messaggio di errore |
| 649231 | 2142496 | FIX: Un pacchetto di SQL Server 2008 R2 o SQL Server 2008 Integration Services non viene eseguito in SQL Server Business Intelligence Development Studio quando si utilizza una tabella di configurazione SQL condivisa |
| 661286 | 2163958 | FIX: Il dashboard dell'utilità SQL Server potrebbe segnalare un utilizzo non corretto della CPU nei database DAC in SQL Server 2008 R2 |
| 621226 | 2401548 | FIX: Un'immagine incorporata di un report viene visualizzata erroneamente come croce rossa in SQL Server 2008 Reporting Services e in SQL Server 2008 R2 Reporting Services |
| 642792 | 2403218 | FIX: La sessione di mirroring del database viene sospesa in SQL Server 2005, in SQL Server 2008 e in SQL Server 2008 R2 se viene utilizzata la modalità ad alte prestazioni (asincrona) |
| 648779 | 2445812 | FIX: Una colonna che utilizza il tipo di dati DATETIME non viene replicata in un sottoscrittore Oracle utilizzando una replica transazionale in SQL Server 2008 |
| 642078 | 2451540 | FIX: In SQL Server 2005, in SQL Server 2008, in SQL Server 2008 e in SQL Server 2008 R2 potrebbero verificarsi prestazioni insufficienti |
| 650630 | 2455614 | FIX: BIDS per SQL Server 2008 o SQL Server 2008 R2 risponde molto lentamente quando si progetta una query MDX con molti parametri di query |
| 650619 | 2459027 | FIX: "L'indice non era compreso nei limiti della matrice" Messaggio di errore SMO quando ci si connette a un'istanza di Motore di database CTP1 di SQL Server con nome in codice 'Denali' in SSMS 2008 R2 e in SSMS 2008 |
| 649217 | 2478032 | FIX: 0xC002F325 errore durante l'esecuzione contemporanea di due pacchetti SSIS 2008 in SQL Server 2008 Integration Services o in SQL Server 2008 R2 Integration Services |
| 654637 | 2478514 | FIX: Il agente di merge si interrompe con un messaggio di errore e righe con la colonna genstatus impostata su 4 nella tabella di sistema msmerge_genhistory: "Il processo di unione non è riuscito ad accedere ai dati delle righe" |
| 648030 | 2480368 | FIX: SSAS 2008 o SSAS 2008 R2 si arresta in modo anomalo dopo l'esecuzione di un'operazione ProcessFull su un gruppo di misure per un cubo basato su server se SSAS tenta di pulire una sessione che contiene un cubo di sessione |
| 648038 | 2481245 | FIX: Il rapporto di tabella pivot potrebbe non restituire valori dopo l'applicazione di un filtro complesso in SSAS 2008 o SSAS 2008 R2 |
| 671186 | 2481274 | FIX: Una query che usa la funzione DATEDIFF può essere eseguita lentamente in SQL Server 2005 o in SQL Server 2008 |
| 649223 | 2482977 | FIX: 10061 Il codice di errore Winsock si verifica quando un'applicazione usa le proprietà di inizializzazione OLE DB estese per il provider OLE DB di SQL Server Native Client 10.0 nella stringa di connessione |
| 649227 | 2484392 | FIX: La colonna "xact_seqno" nella tabella "MSrepl_errors" non registra una riga ignorata in SQL Server 2008 se si utilizza il parametro "-SkipErrors" nella agente di distribuzione |
| 669146 | 2489667 | FIX: Il processo di SQL Server Agent non viene eseguito correttamente se è pianificato per essere eseguito ogni ora l'ultimo giorno di ogni settimana o mese in SQL Server 2005 o in SQL Server 2008 |
| 671189 | 2490920 | FIX: Errore "Msg 2601, livello 14, stato 1, riga 1 Impossibile inserire riga chiave duplicata" quando si esegue l'istruzione ALTER PARTITION FUNCTION per dividere o unire un intervallo di partizioni in SQL Server 2005 o in SQL Server 2008 |
| 649221 | 2491210 | FIX: Il piano di manutenzione non esegue il backup di un database impostato su AUTO_CLOSE, RESTORING o STANDBY in SQL Server 2008 o in SQL Server 2008 R2 |
| 642835 | 2497585 | FIX: Report in stile notiziario non corretto quando un valore di casella di testo si estende da una colonna a un'altra in SSRS 2008 se si usa il formato renderer interruzione di pagina |
| 651086 | 2498818 | FIX: Errore 7359 quando si esegue una query su una funzione definita dall'utente o una visualizzazione che utilizza un sinonimo in un server collegato in SQL Server 2005 o SQL Server 2008 |
| 660073 | 2506795 | FIX: Errore "Dati insufficienti per un'immagine" quando si apre un file di .pdf esportato da un ambiente SQL Server 2008 Reporting Services |
| 668229 | 2509659 | FIX: Lo schema dbo viene preaggiunto quando si utilizza una stored procedure personalizzata nella stored procedure sp_addarticle |
| 669441 | 2510668 | Ora è possibile utilizzare l'Installazione guidata pacchetto (Dtsinstall.exe) per eseguire il file manifesto di distribuzione di un pacchetto SSIS quando SSIS 2008 non è installato |
| 672739 | 2511963 | FIX: SQL Server 2008 si blocca quando si modifica o si interrompe una sessione Eventi estesi |
Informazioni sul pacchetto di aggiornamento cumulativo
Prerequisiti
Per applicare questo pacchetto di aggiornamento cumulativo, è necessario eseguire Microsoft SQL Server 2008 Service Pack 2.
Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
968382 Come ottenere il service pack più recente per SQL Server 2008
Informazioni sul riavvio
Potrebbe essere necessario riavviare il computer dopo aver applicato questo pacchetto di aggiornamento cumulativo.
Informazioni del Registro di sistema
Per usare uno degli aggiornamenti rapidi inclusi in questo pacchetto, non è necessario apportare modifiche al Registro di sistema.
Riferimenti
Per ulteriori informazioni sul modello di servizio incrementale per SQL Server, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
935897
Un modello di servizio incrementale è disponibile dal team di SQL Server per fornire correzioni rapide per i problemi segnalati
Per ulteriori informazioni sullo schema di denominazione per gli aggiornamenti di SQL Server, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
822499
Nuovo schema di denominazione per i pacchetti di aggiornamento software di Microsoft SQL Server
Per ulteriori informazioni sulla terminologia degli aggiornamenti software, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
824684
Descrizione della terminologia standard usata per descrivere gli aggiornamenti software Microsoft