Sintomi
Si consideri lo scenario seguente:
- Si dispone di un'istanza di SQL Server 2022 con un gruppo di disponibilità indipendente distribuito.
- Gli utenti creano oggetti a livello di server (accessi e processi) nel contesto del gruppo di disponibilità indipendente.
In questo scenario, uno degli errori seguenti si verifica dopo l'installazione di un aggiornamento cumulativo in questa istanza di SQL Server.
Errore 1
Il processo di SQL Server Agent ha esito negativo e viene visualizzato il messaggio di errore seguente:
Impossibile avviare l'esecuzione del passaggio 2 (motivo: JobOwner <JobOwner> non dispone delle autorizzazioni per usare il proxy <#> per il sistema SSIS secondario). Il passaggio non è riuscito.
Il log degli errori di SQL Server Agent registra messaggi di errore simili ai seguenti:
<Data e ora> - ! [298] Errore SQLServer: 208, nome oggetto non valido 'syssubsystems'. [SQLSTATE 42S02]
<Data e ora> - ! [517] Errore SQL numero 208, gravità 16
In questa fase, la syssubsystems tabella non è presente msdb nel database del gruppo di disponibilità indipendente ed esiste nel database a livello msdb di istanza. Per correggere questi errori e consentire la corretta esecuzione dei processi, è possibile copiare manualmente la tabella a livello syssubsystems di istanza nel msdb database del gruppo di disponibilità indipendente connettendosi al listener e creando la tabella e le righe nella tabella.
Errore 2
Dopo aver creato un gruppo di disponibilità indipendente, verrà visualizzato il messaggio di errore seguente ogni cinque secondi:
Il processo attivato '[dbo]. [sp_syspolicy_events_reader]' in esecuzione nella coda '<AGName>_AG_SYNC_CONTAINED_msdb.dbo.syspolicy_event_queue' restituisce il risultato seguente: 'Impossibile eseguire come entità di database perché l'entità "##MS_PolicyEventProcessingLogin##" non esiste, questo tipo di entità non può essere rappresentato o non si dispone dell'autorizzazione.'
Errore 3
Dopo che la posta elettronica database ha smesso di funzionare, provando ad eseguire la sysmail stored procedure verrà segnalato un messaggio di errore simile al seguente:
L'oggetto '[dbo]. [sp_syspolicy_events_reader]" non esiste nel database "master" o non è valido per questa operazione.
Errore 4
Dopo aver creato un gruppo di disponibilità indipendente, se ci si connette al listener del gruppo di disponibilità indipendente e si crea un'entità di accesso di SQL Server, verrà visualizzato l'errore seguente in SQL Server Management Studio (SSMS) quando ci si connette tramite l'entità di accesso:
Errore durante la connessione al <listener>
Impossibile recuperare i dati per questa richiesta. (Microsoft.SqlServer.Management.Sdk.Sfc)
Si è verificata un'eccezione durante l'esecuzione di un'istruzione Transact-SQL o di un batch. (Microsoft.SqlServer.ConnectionInfo)
L'autorizzazione EXECUTE è stata negata per l'oggetto 'xp_msver', database 'mssqlsystemresource', schema 'sys'. (Microsoft SQL Server, errore: 229)
Questo errore si verifica perché al public ruolo non è stata concessa l'autorizzazione per la EXECUTExp_msver stored procedure estesa nel master del gruppo di disponibilità contenuto.
Risoluzione
Questo problema è stato risolto nel seguente aggiornamento cumulativo per SQL Server:
Aggiornamento cumulativo 4 per SQL Server 2022
Informazioni sugli aggiornamenti cumulativi per SQL Server
Ogni nuovo aggiornamento cumulativo per SQL Server contiene tutte le correzioni a caldo e di sicurezza presenti nella build precedente. È consigliabile installare la build più recente per la versione di SQL Server:
Aggiornamento cumulativo più recente per SQL Server 2022
Stato
Microsoft sta analizzando questi problemi. Questo articolo verrà aggiornato man mano che troveremo altre informazioni o indicazioni. Fino a tale data, è possibile adottare le precauzioni necessarie seguenti prima di installare un aggiornamento cumulativo a un'installazione con un gruppo di disponibilità contenuto:
- Creare script per gli oggetti a livello di server e gli oggetti SQL Server Agent.
- Eliminare il gruppo di disponibilità contenuto.
- Applica l'aggiornamento cumulativo.
- Ricreare il gruppo di disponibilità contenuto.
Microsoft ha confermato che si tratta di un problema relativo ai prodotti elencati nella sezione "Si applica a".
Riferimenti
Informazioni sulla terminologia utilizzata da Microsoft per descrivere gli aggiornamenti software.