Data di rilascio: 12 marzo 2026
Versione: 16.0.4245.2
Riepilogo
Questo articolo descrive il pacchetto di aggiornamento cumulativo 24 (CU24) per Microsoft SQL Server 2022. Questo aggiornamento contiene 14 correzioni rilasciate dopo il rilascio dell'aggiornamento cumulativo 23 di SQL Server 2022. Aggiorna i componenti nelle build seguenti:
- SQL Server - Versione prodotto: 16.0.4245.2, versione file: 2022.160.4245.2
- Analysis Services - Versione del prodotto: 16.0.43.252, versione del file: 2022.160.43.252
Problemi noti in questo aggiornamento
Comportamento non corretto di SESSION_CONTEXT nei piani paralleli
Le query che usano la funzione predefinita SESSION_CONTEXT potrebbero restituire risultati non corretti o attivare file di dump di violazione di accesso (AV) se eseguite in piani di query paralleli. Questo problema si verifica a causa del modo in cui SESSION_CONTEXT interagisce con i thread di esecuzione parallela, in particolare se la sessione viene reimpostata per il riutilizzo.
Per altre informazioni, vedere la sezione Problemi noti in SESSION_CONTEXT.
Le query del server collegato che usano MSDASQL hanno esito negativo con l'errore 7416
Le query su server collegati che usano il provider (provider OLE DB per driver ODBC) MSDASQL e specificano una stringa del provider (@provstr) hanno esito negativo e restituiscono il messaggio di errore seguente:
Messaggio 7416, livello 16
L'accesso al server remoto viene negato perché non esiste alcun mapping di accesso.
Un controllo di convalida della connessione più rigoroso in Motore di database può rifiutare le connessioni per determinate configurazioni di server collegati che usano il MSDASQL provider, anche se le build precedenti consentivano tali connessioni.
Per ulteriori informazioni e soluzioni alternative, vedi Le query su server collegati che usano MSDASQL hanno esito negativo con l'errore 7416.
Errore 10013 del listener del gruppo di disponibilità nel registro degli errori
Se si configura un gruppo di disponibilità di SQL Server con un listener, all'avvio del servizio SQL Server o si verifica un failover del gruppo di disponibilità, nel log degli errori di SQL Server potrebbero essere visualizzati errori che indicano un problema con l'oggetto listener. L'esempio seguente mostra l'aspetto di questi errori:
The Service Broker endpoint is in disabled or stopped state.
Error: 26075, Severity: 16, State: 1.
Failed to start a listener for virtual network name '<YourAGListener>'. Error: 10013.
The Service Broker endpoint is in disabled or stopped state.
Stopped listening on listener network name '<YourAGListener>' (VNN or DISTRIBUTED_NETWORK_NAME). No user action is required.
The Service Broker endpoint is in disabled or stopped state.
Error: 10800, Severity: 16, State: 1.
The listener for the WSFC resource '<YourWSFCguid>' failed to start, and returned error code 10013, 'An attempt was made to access a socket in a way forbidden by its access permissions. '. For more information about this error code, see "System Error Codes" in the Windows Development Documentation.
Error: 19452, Severity: 16, State: 1.
The availability group listener (network name) with Windows Server Failover Clustering resource ID '<YourWSFCguid>', DNS name '<YourAGListener>', port 1433 failed to start with a permanent error: 10013. Verify port numbers, DNS names and other related network configuration, then retry the operation.
Inoltre, dopo aver applicato questo aggiornamento, se si crea un nuovo listener, potrebbe essere visualizzato un errore simile a questo esempio:
Msg 19486, Level 16, State 1, Line 3
The configuration changes to the availability group listener were completed, but the TCP provider of the instance of SQL Server failed to listen on the specified port [<YourAGListener>]. This TCP port is already in use. Reconfigure the availability group listener, specifying an available TCP port. For information about altering an availability group listener, see the "ALTER AVAILABILITY GROUP (Transact-SQL)" topic in SQL Server Books Online.
Questo aggiornamento causa anche che SQL Server tenta di aprire una porta TCP già in uso all'avvio o alla creazione di un listener. Questo comporta solo la registrazione di messaggi di errore e non influisce sulla funzionalità. Le connessioni listener continuano a funzionare.
Microsoft è a conoscenza del problema e sta studiando una correzione.
Correzioni e miglioramenti inclusi in questo aggiornamento
È disponibile una cartella di lavoro scaricabile di Microsoft Excel contenente un elenco di riepilogo delle build, insieme al relativo ciclo di vita del supporto corrente, se disponibile. Il file di Excel contiene anche elenchi di correzioni dettagliate per SQL Server 2022, SQL Server 2019 e SQL Server 2017. Scarica subito questo file di Excel.
Nota
Alle singole voci della tabella seguente può essere fatto riferimento direttamente tramite un segnalibro. Se selezioni un ID riferimento bug nella tabella, all'URL viene aggiunto un tag segnalibro con il formato "#NNNNNNN". Puoi quindi condividere questo URL con altri in modo che possano passare direttamente alla correzione desiderata nella tabella.
Per altre informazioni sui bug corretti e sui miglioramenti inclusi in questo aggiornamento cumulativo, vedi la tabella seguente.
| Riferimento bug | Descrizione | Area di correzione | Componente | Piattaforma |
|---|---|---|---|---|
| 4868211 | Aggiunge un nuovo parametro facoltativo, @multi_subnet_failover, a sp_adddistributor. |
Motore di SQL Server | Replica | Tutto |
| 4874339 | Risolve un problema che si verifica durante la creazione o il ripristino di un database in una connessione a un gruppo di disponibilità indipendente. | Motore di SQL Server | Disponibilità elevata e ripristino di emergenza | Tutto |
| 4911747 | Risolve un problema nel calcolo del buffer di ordinamento in memoria che causa un ciclo infinito quando il numero di pagine richiesto supera i limiti supportati. | Motore di SQL Server | Ripristino di backup | Tutto |
| 4917971 | Risolve un'eccezione a virgola mobile che si verifica quando si passa da una pila Hekaton a una non Hekaton. Questa azione causa l'interruzione dell'esecuzione della query. | Hekaton | Elaborazione di query | Tutto |
| 4931278 | Risolve un problema a causa del quale un'operazione di ordinamento in un set di righe più grande di quattro miliardi di righe ha esito negativo e genera un errore di asserzione. | Motore di SQL Server | Metodi di accesso | Tutto |
| 4931830 | Risolve un problema per cui il server di distribuzione fa parte di un gruppo di disponibilità e usa regole di confronto con distinzione tra maiuscole e minuscole (_CS). L'agente di distribuzione utilizza in modo errato il nome della replica primaria del gruppo di disponibilità anziché il nome del listener del gruppo di disponibilità. | Motore di SQL Server | Replica | Tutto |
| 4953763 | Risolve un problema a causa del quale la replica di solo configurazione di un gruppo di disponibilità indipendente non può essere connessa dopo un riavvio a causa di un errore di avvio. | Motore di SQL Server | Disponibilità elevata e ripristino di emergenza | Tutto |
| 4955136 | Risolve un problema che si verifica quando si usa un server di monitoraggio locale per la distribuzione di log e il gruppo di disponibilità indipendente dopo il failover. | Motore di SQL Server | Disponibilità elevata e ripristino di emergenza | Tutto |
| 4955493 | Corregge un errore di ios_in_progess digitazione correggendo sys.dm_os_linux_disk_stats a ios_in_progress. |
Connettività SQL | Linux | Linux |
| 4976761 | Risolve un problema a causa del quale la modifica di un trigger DDL disabilitato causa una violazione di accesso alla memoria. | Motore di SQL Server | Programmabilità | Tutto |
| 4984502 | Aggiunge un timeout del batch di ricerca full-text configurabile utilizzando .sp_fulltext_service 'batch_timeout' Specificare un valore compreso tra un minuto e un'ora, in millisecondi. Per impostazione predefinita, i batch scadono dopo 10 minuti se non sono presenti aggiornamenti dello stato di avanzamento. |
Motore di SQL Server | Ricerca | Tutto |
| 5005885 | Risolve i conflitti sulle tabelle dei metadati relativi alla sicurezza aggiungendo sysowners il controllo delle tabelle dei metadati a cui si accede di frequente. |
Motore di SQL Server | Infrastruttura di sicurezza | Tutto |
| 5011606 | Aggiunta del supporto per i collegamenti simbolici nell'API getattribute . |
Motore di SQL Server | Linux | Linux |
| 5011720 | Aggiunge un'opzione di configurazione per aggiungere Bulkadmin operazioni all'elenco dei consentiti. |
Motore di SQL Server | Linux | Linux |
Come ottenere o scaricare questo o l'ultimo pacchetto di aggiornamento cumulativo
Come ottenere o scaricare il pacchetto di aggiornamento cumulativo più recente per Windows (scelta consigliata)
L'aggiornamento seguente è disponibile nell'Area download Microsoft:
Scarica subito il pacchetto di aggiornamento cumulativo più recente per SQL Server 2022
Nota
- L'Area download Microsoft offre sempre la versione più recente dell'aggiornamento cumulativo di SQL Server 2022.
- Se la pagina di download non appare, contatta il servizio di supporto tecnico Microsoft per ottenere il pacchetto di aggiornamento cumulativo.
Come ottenere o scaricare questo pacchetto di aggiornamento cumulativo per Windows da Microsoft Update Catalog
L'aggiornamento seguente è disponibile in Microsoft Update Catalog:
Nota
- Microsoft Update Catalog contiene questo aggiornamento cumulativo di SQL Server 2022 e rilasci di aggiornamenti cumulativo di SQL Server 2022 rilasciati in precedenza.
- Questo aggiornamento cumulativo è disponibile anche tramite Windows Server Update Services (WSUS).
- È consigliabile installare sempre l'aggiornamento cumulativo più recente disponibile.
Come ottenere o scaricare il pacchetto di aggiornamento cumulativo più recente per Linux
Per aggiornare SQL Server 2022 in Linux all'aggiornamento cumulativo più recente, devi prima configurare il repository degli aggiornamenti cumulativi. Aggiorna quindi i pacchetti di SQL Server usando il comando di aggiornamento appropriato specifico della piattaforma.
Per le istruzioni per l'installazione e i collegamenti diretti ai download dei pacchetti di aggiornamento cumulativo, vedi le Note sulla versione di SQL Server 2022.
Informazioni sui file
Informazioni sull'hash dei file
È possibile verificare il download calcolando l'hash del fileSQLServer2022-KB5080999-x64.exe tramite il comando seguente:
certutil -hashfile SQLServer2022-KB5080999-x64.exe SHA256
| Nome file | Hash SHA256 |
|---|---|
| SQLServer2022-KB5080999-x64.exe | 57FC522E34FA4654F5EE8DBC9768EFE3265971C8D6854F32118022B2610D40E2 |
Informazioni sul file del pacchetto di aggiornamento cumulativo
Scaricare l'elenco dei file inclusi in KB5080999.
Note per questo aggiornamento
Prerequisiti
Per applicare questo pacchetto di aggiornamento cumulativo, devi eseguire SQL Server 2022.
Informazioni sul riavvio
Una volta applicato il pacchetto di aggiornamento cumulativo, potrebbe essere necessario riavviare il computer.
Informazioni del Registro di sistema
Per usare uno degli aggiornamenti rapidi inclusi in questo pacchetto, non è necessario apportare modifiche al Registro di sistema.
Avvisi importanti
Questo articolo fornisce anche le seguenti informazioni importanti.
Versione della build dell'aggiornamento cumulativo di Analysis Services
A partire da Microsoft SQL Server 2017, il numero di versione della build di Analysis Services e il numero di versione della build del motore di database di SQL Server non corrispondono. Per altre informazioni, vedi Verificare la versione della build dell'aggiornamento cumulativo di Analysis Services.
Aggiornamenti cumulativi (CU)
- Ogni nuovo aggiornamento cumulativo contiene tutte le correzioni incluse nell'aggiornamento cumulativo CU precedente per la versione installata di SQL Server.
- Gli aggiornamenti cumulativi di SQL Server sono certificati per gli stessi livelli dei service pack e devono essere installati con lo stesso livello di confidenza.
- È consigliabile eseguire un'installazione continua e proattiva degli aggiornamenti cumulativi non appena diventano disponibili in base alle linee guida seguenti:
- Dati storici mostrano che un numero significativo di casi di supporto riguarda un problema che è già stato affrontato in un aggiornamento cumulativo rilasciato.
- Gli aggiornamenti cumulativi potrebbero contenere un valore aggiunto oltre agli aggiornamenti rapidi. Sono inclusi gli aggiornamenti relativi a supportabilità, gestibilità e affidabilità.
- È consigliabile testare gli aggiornamenti cumulativi di SQL Server prima di distribuirli in ambienti di produzione.
Distribuzione in ambienti ibridi
Quando si distribuisce un aggiornamento in un ambiente ibrido (ad esempio Always On, replica, cluster e mirroring), è consigliabile fare riferimento agli articoli seguenti prima di distribuire l'aggiornamento:
Aggiornare un'istanza del cluster di failover
Nota
Se non vuoi usare il processo di aggiornamento in sequenza, seguire questi passaggi per applicare un aggiornamento:
- Installa l'aggiornamento nel nodo passivo.
- Installa l'aggiornamento nel nodo attivo (richiede il riavvio del servizio).
-
Nota
Se hai abilitato Always On insieme al catalogo SSISDB, vedi le informazioni su SSIS con Always On su come applicare un aggiornamento in questi ambienti.
Come applicare un aggiornamento rapido per SQL Server in una topologia di replica
Panoramica dell'installazione della manutenzione di SQL Server
Supporto lingue
Gli aggiornamenti cumulativi di SQL Server attualmente sono multilingue. Di conseguenza, questo pacchetto di aggiornamento cumulativo non è specifico di una sola lingua. Si applica a tutte le lingue supportate.
Componenti (funzionalità) aggiornati
Un pacchetto di aggiornamento cumulativo include tutti gli aggiornamenti disponibili per tutti i componenti (funzionalità) di SQL Server 2022. Tuttavia, il pacchetto di aggiornamento cumulativo aggiorna solo i componenti installati nell'istanza di SQL Server selezionata per la manutenzione. Se una funzionalità di SQL Server (ad esempio Analysis Services) viene aggiunta all'istanza dopo l'applicazione di questo aggiornamento cumulativo, è necessario riapplicare questo aggiornamento cumulativo per aggiornare la nuova funzionalità a questo aggiornamento cumulativo.
Supporto per questo aggiornamento
Se si verificano altri problemi o se è necessaria una risoluzione dei problemi, potrebbe essere necessario creare una richiesta di servizio. I normali costi di supporto verranno applicati alle domande di supporto aggiuntive e ai problemi che non sono idonei per questo specifico pacchetto di aggiornamento cumulativo. Per un elenco completo dei numeri di telefono del Supporto tecnico Microsoft o per creare una richiesta di servizio separata, visita il sito Web del Supporto tecnico Microsoft.
Come disinstallare questo aggiornamento
Come disinstallare questo aggiornamento in Windows
- Nel Pannello di controllo apri la voce Programmi e funzionalità e seleziona Visualizza aggiornamenti installati.
- Individua la voce che corrisponde a questo pacchetto di aggiornamento cumulativo in SQL Server 2022.
- Tieni premuto o fai clic con il pulsante destro del mouse sull'app, quindi seleziona Disinstalla.
Come disinstallare questo aggiornamento su Linux
Per disinstallare questo aggiornamento cumulativo in Linux, devi eseguire un ripristino dello stato precedente del pacchetto. Per altre informazioni su come eseguire il ripristino dello stato precedente dell'installazione, vedi Ripristino dello stato precedente di SQL Server.
Riferimenti
- Annuncio degli aggiornamenti di ISM (Incremental Servicing Model) di SQL Server
- I Service Pack di SQL Server non sono più supportati a partire da SQL Server 2017
- Determinare la versione e l'edizione del Motore di database di SQL Server in esecuzione
- Modelli di manutenzione per SQL Server
- Schema di denominazione e descrizioni delle aree di correzione per i pacchetti di aggiornamento software di SQL Server
- Descrizione della terminologia standard usata per descrivere gli aggiornamenti software Microsoft