Come ridurre i metadati nei documenti di Microsoft Word 2000

Per la versione di Microsoft Word 2002 di questo articolo, vedere
290945.
Per la versione di Microsoft Word 97 di questo articolo, vedere
223790.

IN QUESTA ATTIVITÀ

Riepilogo

In questo articolo vengono illustrati diversi metodi che è possibile utilizzare per ridurre al minimo la quantità di metadati nei documenti di Word.

Quando si crea, aprire o salvare un documento in Microsoft Word 2000, il documento può includere contenuto che è possibile che si desidera condividere con altri utenti quando si distribuisce elettronicamente. Questa informazione è nota come "metadati". Per migliorare la modifica, visualizzazione, archiviazione e recupero dei documenti di Office, i metadati vengono utilizzati per diversi scopi.

Alcuni di essi sono facilmente accessibili attraverso l'interfaccia utente di Microsoft Word; altri sono accessibili solo attraverso mezzi straordinari, come l'apertura di un documento in un editor di file binari di basso livello. Di seguito sono riportati alcuni esempi di metadati che possono essere memorizzati nei documenti:

  • Il tuo nome

  • Le iniziali

  • Il nome della società o organizzazione

  • Il nome del computer

  • Il nome del server di rete o disco rigido in cui è stato salvato il documento

  • Altre informazioni di riepilogo e le proprietà di file

  • Parti non visibili di oggetti OLE incorporati

  • I nomi degli autori di documento precedente

  • Revisioni dei documenti

  • Versioni del documento

  • Informazioni sul modello

  • Testo nascosto

  • Commenti

I metadati vengono creati in vari modi nei documenti di Word. Di conseguenza, non vi è nessun singolo metodo per rimuovere tale contenuto dai documenti. Le sezioni seguenti descrivono aree in cui i metadati possono essere salvati nei documenti di Word.

Come rimuovere il proprio nome utente dai documenti

Per visualizzare o modificare il nome utente, attenersi alla seguente procedura:

  1. Scegliere Opzioni dal menu Strumenti . Selezionare la scheda Informazioni utente .

    Vengono visualizzate le seguenti caselle di modifica:

    Nome
    Iniziali
    Indirizzo postale

  2. Se non si desidera che queste informazioni siano contenute nei propri documenti, immettere stringhe insignificanti o spazi nelle appropriate caselle di modifica e quindi fare clic su OK per accettare le modifiche.

Nota: I nuovi documenti creati conterranno queste informazioni, anziché i valori predefiniti immettono durante l'installazione di Office. Tuttavia, i documenti esistenti potrebbero già contenere queste informazioni.

Come rimuovere le informazioni di riepilogo personali

Quando si crea o si salva un documento in Word, le informazioni di riepilogo possono essere salvate nel documento. Esistono diversi metodi che è possibile utilizzare per accedere a queste informazioni:

  • Aprire il documento. Scegliere proprietà dal menu File. Le schede di Riepilogo, statistiche, contenutoe personalizzato possono contenere diverse proprietà come il nome, il nome del manager e il nome della società.

  • In Esplora risorse, il pulsante destro del documento e quindi scegliere proprietà dal menu di scelta rapida. Le schede nella finestra di dialogo proprietà potrebbero contenere informazioni.

  • È possibile utilizzare un Visual Basic, Applications Edition macro o codice di altri programmi per leggere le proprietà visualizzate nella finestra di dialogo proprietà .

Per cancellare informazioni riepilogative da un documento o modello esistente, procedere come segue:

  1. Aprire il documento o modello.

  2. Scegliere proprietà dal menu File.

  3. Nella scheda Riepilogo , deselezionare l' autore, Manager, societàe altre caselle di modifica che si desidera distribuire.

  4. Nella scheda Personalizza , eliminare eventuali proprietà contenenti informazioni che si desidera distribuire.

  5. Al termine, fare clic su OK. Scegliere Salva dal menu File e quindi scegliere Chiudi dal menu File .

Dopo avere completato questi passaggi, il documento non deve contenere informazioni di riepilogo.

Come rimuovere le informazioni di riepilogo personali quando si è connessi a una rete

Se si è connessi a una rete, il proprio nome utente potrebbe apparire in autore casella di modifica della scheda Riepilogo e nel campo Autore ultimo salvataggio della scheda statistiche , quando si salva un documento. Ciò può verificarsi anche se è stato rimosso tutte le altre informazioni personali dal computer.

Per rimuovere le informazioni di riepilogo da un documento quando utilizza una rete:

  1. Se il documento è archiviato su un server di rete, copiarlo sul disco rigido locale.

  2. Avviare il computer, ma non accedono alla rete. Quando viene visualizzato nella finestra di dialogo di accesso di rete, fare clic su Annulla o premere ESC.

    Nota: se è possibile avviare Windows premendo ESC (ad esempio, il computer è in esecuzione Windows NT), è possibile continuare questa procedura.

  3. Aprire il documento.

  4. Scegliere proprietà dal menu File.

  5. Nella scheda Riepilogo , deselezionare l' autore, Manager, societàe nelle altre caselle che contengono informazioni che non si desidera distribuire.

  6. Nella scheda Personalizza , eliminare eventuali proprietà contenenti informazioni che si desidera distribuire.

  7. Al termine, fare clic su OK. Scegliere Salva dal menu File . Scegliere Chiudi dal menu File .

Quando si accede alla rete, non aprire il file. In tal caso, il proprio nome utente può essere scritti nel file. Tuttavia, è possibile utilizzare Esplora risorse per copiare il file in un server di rete o un disco floppy.

Rimozione dei commenti nei documenti

Microsoft Word offre la possibilità di aggiungere commenti ai documenti. In genere, i commenti contengono il nome della persona che ha creato, in modo da poter distinguere autore li.

In genere i commenti vengono visualizzati come una sezione evidenziata del testo; pulsante destro del mouse all'interno del commento e quindi scegliere Elimina commento dal menu di scelta rapida.

I nuovi commenti creati non devono contenere il nome utente, perché è stato rimosso dalla finestra di dialogo Opzioni , come illustrato in precedenza.

Rimozione di intestazioni e piè di pagina dai documenti

Intestazioni e piè di pagina nei documenti possono contenere informazioni di identificazione. Per rimuovere informazioni da intestazioni e piè di pagina:

  1. Dal menu Visualizza , scegliere intestazione e piè di pagina.

  2. L'intestazione e piè di pagina vengono visualizzati nella parte superiore e inferiore di ogni pagina del documento; modificarli come desiderato.

  3. Al termine, fare clic su Chiudi sulla barra degli strumenti intestazione e piè di pagina .

Come rimuovere i segni di revisione

I documenti possono contenere segni di revisione che consentono di determinare l'autore di determinate modifiche a un documento. Quando si accetta o rifiuta i segni di revisione, il testo revisionato viene salvato nel documento e vengono rimossi i segni di revisione.

Per accettare o rifiutare le revisioni:

  1. Scegliere Revisioni dal menu Strumenti e quindi fare clic su accetta o rifiuta modifiche.

  2. Nella finestra di dialogo accetta o rifiuta modifiche , utilizzare i due pulsanti Trova per ricercare revisioni specifiche per accettarle o rifiutarle singolarmente oppure fare clic su Accetta tutto o Rifiuta tutto.

  3. Al termine, fare clic su Chiudi.

Per la disattivazione del salvataggio veloce

Salvataggio veloce consente di velocizzare il processo di salvataggio salvando solo le modifiche apportate a un documento.

A causa della progettazione della funzionalità di salvataggio veloce, il testo eliminato da un documento rimanga nel documento, anche dopo aver salvato il documento. Se si costituisce un problema, è necessario eseguire i passaggi seguenti:

  1. Scegliere Opzioni dal menu Strumenti.

  2. Scegliere la scheda Salva .

  3. Fare clic per deselezionare la casella di controllo Consenti salvataggio veloce . Fare clic su OK.

Per ulteriori informazioni sul salvataggio veloce, vedere i seguenti articoli della Microsoft Knowledge Base:

211209 WD2000: apertura documento di Word in Editor di testo Visualizza testo eliminato

197978 WD2000: domande frequenti su "Consenti salvataggio veloce"

Come cercare e rimuovere il testo formattato come nascosto

Nei documenti di Word, è possibile formattare il testo come nascosto. Poiché il testo nascosto può contenere informazioni che non è possibile distribuire, è possibile visualizzarlo e rimuoverlo. Per rimuovere tutto il testo in un documento formattato come nascosto, attenersi alla seguente procedura:

  1. Scegliere Opzioni dal menu Strumenti. Selezionare la scheda visualizzazione .

  2. Fare clic per selezionare la casella di controllo testo nascosto e quindi fare clic su OK.

  3. Scegliere Sostituiscidal menu Modifica .

  4. Fare clic sul pulsante più per espandere la finestra di dialogo.

  5. Fare clic nella casella accanto a Trova.

  6. Fare clic sul pulsante formato e quindi fare clic su carattere. Fare clic per selezionare la casella di controllo nascosto e quindi fare clic su OK.

  7. Fare clic su Sostituisci tutto.

Tutto il testo nascosto viene rimosso dal documento. Per disattivare la visualizzazione del testo nascosto, attenersi alla seguente procedura:

  1. Scegliere Opzioni dal menu Strumenti. Selezionare la scheda visualizzazione .

  2. Fare clic per deselezionare la casella di controllo testo nascosto . Fare clic su OK.

Rimozione di collegamenti ipertestuali dai documenti

I documenti possono contenere collegamenti ipertestuali ad altri documenti o pagine Web su una rete intranet o Internet. In genere vengono visualizzati come stringhe di testo blu sottolineato.

Per eliminare manualmente un collegamento ipertestuale da un documento, pulsante destro del mouse sul collegamento ipertestuale, scegliere collegamento ipertestuale dal menu di scelta rapida e quindi fare clic su Rimuovi collegamento ipertestuale.

Se si desidera eliminare tutti i collegamenti ipertestuali in un documento, è possibile utilizzare un Visual Basic, Applications Edition macro per eseguire questa operazione. Nell'esempio seguente di Visual Basic, Applications Edition macro consente di rimuovere tutti i collegamenti ipertestuali in un documento.

Nota: In questa macro di esempio, viene rimosso solo il collegamento. Il testo del collegamento ipertestuale rimane nel documento.

Sub RemoveHyperlinks()

Dim oDoc As Document
Dim oStory As Range
Dim oHlink As Hyperlink

For Each oStory In ActiveDocument.StoryRanges
For Each oHlink In oStory.Hyperlinks
oHlink.Delete
Next
Next

End Sub

Per rimuovere tutte le tracce sia il collegamento ipertestuale e il testo del collegamento ipertestuale del documento, è possibile utilizzare la seguente macro di esempio.

Sub RemoveAllHyperlinks()

Dim oDoc As Document
Dim oStory As Range
Dim oHlink As Hyperlink

For Each oStory In ActiveDocument.StoryRanges
For Each oHlink In oStory.Hyperlinks
oHlink.Range.Delete
Next
Next

End Sub

Per ulteriori informazioni su come utilizzare il codice di esempio in questo articolo, fare clic sul numero dell'articolo per visualizzare l'articolo della Microsoft Knowledge Base riportato di seguito:

212536 OFF2000: come eseguire il codice di esempio da articoli della Knowledge Base

Rimozione degli stili dai documenti

I documenti possono includere stili contenenti metadati. È possibile rimuovere questi stili o rinominarli. Per eseguire questa operazione:

  1. Aprire il documento che contiene gli stili.

  2. Scegliere stiledal menu formato .

  3. Selezionare lo stile che si desidera eliminare o rinominare. Fare clic su Elimina per eliminare lo stile oppure fare clic su Modifica per rinominarlo.

Rimozione di versioni precedenti dei File dai documenti

Word include una funzionalità che consente di salvare più versioni dello stesso documento nello stesso file. Si consiglia di eliminare le versioni precedenti del documento prima di condividerlo con altri utenti.

Per eliminare uno o più versioni di un documento, effettuare le seguenti operazioni:

  1. Scegliere versionidal menu File .

  2. Selezionare la versione del documento che si desidera eliminare. È possibile selezionare più di una versione premendo il tasto CTRL mentre si selezionano le versioni.

  3. Fare clic su Elimina.

  4. Dopo aver terminato l'eliminazione delle vecchie versioni del documento, scegliere Salva dal menu File .

Rimozione di collegamenti dai codici di campo

Le immagini collegate e altri oggetti nei documenti di Word possono contenere informazioni sul collegamento, il percorso per il collegamento a un'immagine o l'oggetto. È possibile rimuovere informazioni sul collegamento dal documento modificando i codici di campo.

Per visualizzare i codici di campo:

  1. Scegliere Opzioni dal menu Strumenti. Selezionare la scheda visualizzazione .

  2. Fare clic per selezionare la casella di controllo codici di campo . Fare clic su OK.

Dopo i codici di campo sono visibili, è possibile visualizzare se uno qualsiasi di essi contengono informazioni di identificazione.

Per rimuovere informazioni sul collegamento da un collegamento a un'immagine o un altro oggetto:

  1. Selezionare il collegamento a un'immagine o un oggetto. O selezionare il codice di immagine o un oggetto, se i codici di campo sono visibili.

  2. Premere CTRL + MAIUSC + F9.

L'immagine o l'oggetto è scollegato. Si noti che l'interruzione del collegamento di un'immagine o un oggetto potrebbero non essere modificabili.

Come rimuovere il nome del modello e la posizione

Tutti i documenti creati in Word si basano su un modello. Per impostazione predefinita, questo è il modello Normal dot nella cartella modelli. Tuttavia, è possibile creare un documento basato su un modello diverso in un'altra posizione. Il percorso e il nome del modello vengono memorizzate nelle proprietà del documento.

Per visualizzare il nome del modello e il percorso, scegliere proprietà dal menu File e selezionare la scheda Riepilogo .

Anche se non si invia il documento con il modello, il documento mantiene il nome e il percorso del modello. Per modificare il nome del modello e la posizione di insignificanti valori, attenersi alla seguente procedura:

  1. Scegliere modelli e aggiuntedal menu Strumenti .

  2. Fare clic su Associa.

  3. Selezionare un modello che ha un nome e un percorso che non sono riservati né univoci. Ad esempio, poiché ogni computer in cui è installato Microsoft Word include Normal. dot, si consiglia di selezionare Normal. dot.

  4. Fare clic su Apri. Quindi fare clic su OK.

Nota: il modello potrebbe contenere macro, voci di glossario, stili personalizzati e barre degli strumenti personalizzate. Modifica di modelli potrebbe rendere alcuni di questi elementi non disponibili per il documento.

Come rimuovere le informazioni allegate

Se si invia un documento tramite posta elettronica utilizzando una lista di distribuzione, le informazioni di routing vengono allegate al documento. Per rimuovere queste informazioni dal documento, è necessario salvare il documento in un formato che mantenga le informazioni allegate.

In Microsoft Word, salvare il documento in formato HTML o RTF (Rich Text Format). Chiudere il documento e quindi riaprire il nuovo file. Poiché le informazioni della lista di distribuzione non sono presente, è ora possibile salvare il documento in formato Microsoft Word.

È inoltre possibile utilizzare le seguenti operazioni:

  1. Disattivare l'opzione Consenti salvataggio veloce seguendo le istruzioni in questo articolo.

  2. Dal menu File , scegliere Invia ae quindi fare clic su Altro destinatario di distribuzione.

  3. Fare clic su Cancella per rimuovere la lista. Quindi fare clic su OK.

  4. Dal menu File, fare clic su Salva.

A questo punto, il documento viene salvato senza le informazioni di trasporto.

Come rimuovere i nomi degli autori precedenti

Word memorizza i nomi degli ultimi 10 utenti che hanno lavorato su un documento del documento. Si tratta di una funzionalità automatica che non può essere disattivata.

Tuttavia, è possibile rimuovere i nomi degli ultimi 10 autori da un documento salvando il documento in un formato che mantenga tali informazioni. Ad esempio, se si salva il documento in formato HTML o RTF (Rich Text Format), le informazioni sugli autori viene perse. È quindi possibile chiudere e riaprire il documento RTF/HTML e salvarlo in formato Microsoft Word.

Come rimuovere il proprio nome da codice Visual Basic

Quando si registra una macro di Visual Basic in Word, la macro registrata inizia con un'intestazione simile al seguente:

   ' Macro1 Macro
' Macro recorded 3/11/1999 by <User Name>

Per rimuovere il nome dell'utente dalle macro registrate:

  1. Aprire il documento che contiene le macro.

  2. Scegliere Macrodal menu Strumenti e quindi fare clic su Visual Basic Editor. O premere ALT + F11.

  3. Nella finestra progetto, fare doppio clic sul modulo che contiene le macro.

  4. Rimuovere il proprio nome dal codice della macro registrata.

Al termine della rimozione del nome, premere ALT + Q per tornare al programma. Scegliere Salva dal menu File .

Come rimuovere riferimenti di Visual Basic ad altri file

Nell'Editor di Visual Basic, è possibile creare un riferimento a un altro file. Se un utente apre un documento che contiene riferimenti ad altri file, è possibile leggervi i nomi dei file.

Per rimuovere questi riferimenti, procedere come segue:

  1. Aprire il documento che contiene i riferimenti.

  2. Scegliere Macrodal menu Strumenti e quindi fare clic su Visual Basic Editor. O premere ALT + F11.

  3. Scegliere riferimentidal menu Strumenti .

  4. Fare clic per deselezionare la casella di controllo accanto ai file di riferimento. Al termine, fare clic su OK.

  5. Premere ALT + Q.

  6. Dal menu File, fare clic su Salva.

Nota: la rimozione di riferimenti ad altri file possono ridurre la capacità di macro contenute nel documento di funzionare correttamente.

Rimozione di informazioni sui dischi rigidi o rete

Quando si salva un documento sul disco rigido locale o su un server di rete, le informazioni che identificano il disco rigido locale o un server di rete possono essere scritte nel documento.

Per rimuovere queste informazioni dal documento, attenersi alla seguente procedura:

  1. Aprire il documento.

  2. Scegliere Salva con nome dal menu File . Salvare il documento sull'unità disco floppy (in genere, a:).

  3. Dal menu File , fare clic su Chiudi.

  4. Rimuovere il disco floppy dall'unità disco floppy.

È ora possibile utilizzare Esplora risorse per copiare il documento dal disco floppy a qualsiasi disco rigido o server di rete.

Nota: a causa dei limiti di spazio di un disco floppy (in genere 1,44 MB), questo metodo non può essere utilizzato se le dimensioni del file supera la quantità di spazio libero sul disco floppy.

Gli oggetti incorporati nei documenti possono contenere metadati

Se si incorpora un oggetto in un documento, l'oggetto conserva le sue proprietà, indipendentemente dalle operazioni eseguite per il documento. Ad esempio, se si incorpora una cartella di lavoro di Microsoft Excel, un documento, il documento e la cartella presenta proprietà.

È possibile rimuovere metadati da un oggetto incorporato, attivare l'oggetto, rimuovere eventuali metadati come descritto in precedenza, riattivare il documento contenitore (come nell'esempio precedente, questo è il documento di Word), quindi salvare il documento contenitore.

Nota: quando si attiva un oggetto incorporato in un documento, solo una parte dell'oggetto incorporato viene visualizzata nel documento. l'oggetto potrebbe contenere informazioni aggiuntive che non viene visualizzato. Se si desidera che il documento contenga solo un rendering dell'oggetto incorporato e non l'effettivo contenuto, tagliare l'oggetto e quindi utilizzare il comando Incolla speciale dal menu Modifica per incollare l'oggetto nel documento utilizzando un formato Metafile. Dopo questa operazione, non modificare l'oggetto incorporato. Tuttavia, non conterrà tutti i metadati.

Le variabili di documento possono contenere metadati

Microsoft fornisce esempi di programmazione a scopo puramente illustrativo, senza alcuna garanzia espressa o implicita. Ciò include, ma non limitato a, le garanzie implicite di commerciabilità o idoneità per uno scopo particolare. In questo articolo si presuppone che si abbia familiarità con il linguaggio di programmazione in questione e gli strumenti utilizzati per creare ed eseguire la procedura di debug. I tecnici del supporto Microsoft possono spiegare la funzionalità di una particolare procedura, ma in nessun caso possono modificare questi esempi per fornire funzionalità aggiuntive o creare procedure atte a soddisfare specifiche esigenze.
Per ulteriori informazioni su come utilizzare il codice di esempio in questo articolo, fare clic sul numero dell'articolo per visualizzare l'articolo della Microsoft Knowledge Base riportato di seguito:

212536 OFF2000: come eseguire il codice di esempio da articoli della Knowledge Base
Per eliminare le variabili di documento contenute nel documento di Word, utilizzare la macro di esempio seguente:

Sub DeleteDocVars()

Dim Response
Dim myVar As Variable

For Each myVar In ActiveDocument.Variables
Response = MsgBox("The document variable: " & myVar.Name & vbCr & _
"Value: " & myVar.Value & vbCr & vbCr & _
"Do you want to delete the variable from this document?", vbYesNo)

If Response = "6" Then
' Delete the variable.
myVar.Delete
Else
End
End If
Next myVar

MsgBox "There are no variables in the document."

End Sub

Per ulteriori informazioni sulle variabili, in Visual Basic Editor scegliere Guida in linea di Microsoft Visual Basic dal menu ? , digitare Proprietà variabili nell'Assistente di Office o nella ricerca libera e quindi fare clic su Cerca per visualizzare il argomento.

Suggerimenti generali sulla protezione

Di seguito sono riportati alcuni suggerimenti generali che è possibile utilizzare per aumentare il livello di protezione dell'ambiente:

  • Quando non si utilizza il computer, è possibile proteggerlo con un password screen saver sia protetto, password di accensione o la funzione di blocco di Windows NT.

  • Se nel computer sono presenti cartelle condivise, assicurarsi di applicare password a essi in modo che solo gli utenti autorizzati possono accedere le condivisioni. Per aumentare ulteriormente la protezione, utilizzare il controllo di accesso a livello utente, in modo che è possibile controllare esattamente chi accede alle condivisioni del computer.

  • Quando si elimina un file, svuotare il Cestino immediatamente. È possibile prendere in considerazione un'utilità che cancelli o sovrascriva file quando questi vengono eliminati completamente.

  • Quando si esegue il backup dei dati, archiviare i file di backup in un luogo sicuro, ad esempio una cassaforte, una cassetta di sicurezza o un armadietto dotato di serratura. Memorizzare una copia di backup in un luogo esterno protetto nel caso in cui la posizione primaria è inutilizzabile.

  • Documenti importanti vanno protetti da password, per assicurarsi che solo gli utenti autorizzati possono aprirli. Le password devono essere memorizzate in un luogo sicuro e separato. Si noti che se non si ricorda la password, non esiste alcun modo per recuperare il contenuto di un documento protetto da password.

  • Non distribuire documenti in formato elettronico. Al contrario, stamparli. Non utilizzare elementi identificativi come caratteri distintivi, filigrane, logo o carta speciale, a meno che non è necessario (ad esempio, per una presentazione).

  • Posta elettronica non anonimo. Non di posta elettronica un documento se si teme la propria identità possa essere allegata in alcun modo al documento.

  • Non inviare un documento via Internet utilizzando il protocollo HTTP o FTP. Le informazioni inviate con questi protocolli sono trasmesse "testo non crittografato", il che significa che è tecnicamente possibile, tuttavia poco probabile, che vengano intercettate.

Riferimenti

Per ulteriori informazioni

Per ulteriori informazioni relative agli argomenti discussi in precedenza in questo articolo, vedere i seguenti articoli della Microsoft Knowledge Base:

195007 WD2000: alcune proprietà del documento vengono automaticamente popolati.

194606 WD2000: informazioni di riepilogo in proprietà non è crittografate.

WD 209638 : nessuna richiesta di Password per "Modifica" nel Client di posta elettronica

Serve aiuto?

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa a Microsoft Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×