Come risolvere i problemi di una pubblicazione danneggiata in Publisher

Per una versione di Microsoft Publisher 98 di questo articolo, vedere 191131.

Riepilogo

Se si verificano comportamenti imprevisti quando si usa una pubblicazione in Microsoft Publisher, è possibile che la pubblicazione sia danneggiata. I sintomi di una pubblicazione danneggiata includono i seguenti:

  • Si riceve un errore di pagina non valido, un errore di protezione generale o viene visualizzato un messaggio errato di istruzioni.

  • Quando si prova ad aprire la pubblicazione, viene visualizzato uno dei messaggi di errore seguenti:

    -Questa non è una pubblicazione di Publisher.

    -Publisher non può aprire il tipo di file rappresentato da <nomefile>.

    -Parte del file non è presente.

  • Viene visualizzato un messaggio di errore di memoria insufficiente o un messaggio di errore risorse di sistema basso.

Nota Potrebbe essere visualizzato uno di questi messaggi di errore per motivi diversi da una pubblicazione danneggiata. Tuttavia, se questo comportamento si verifica solo quando si usa una particolare pubblicazione, è probabile che la pubblicazione sia danneggiata.

Ulteriori informazioni

Per risolvere il problema, riavviare il computer in modalità provvisoria. Quindi, USA i metodi di risoluzione dei problemi appropriati per il problema.Nota Considerando l'esistenza di diverse versioni di Microsoft Windows, la procedura descritta di eseguito potrebbe variare da computer a computer. In questo caso, fare riferimento alla documentazione del prodotto per completare la procedura.

Riavviare il computer in modalità provvisoria

Per riavviare il computer in modalità provvisoria, usare il metodo appropriato per la versione di Microsoft Windows in uso.

  1. Chiudere e riavviare il computer.

  2. Quando viene visualizzato il messaggio "selezionare il sistema operativo da avviare", premere F8.

  3. Nel menu Opzioni avanzate di Windows usare i tasti di direzione per selezionare modalità provvisoriae quindi premere INVIO.

  4. Se si ha un computer dual-boot o un computer multiboot, selezionare il sistema operativo appropriato nell'elenco e quindi premere INVIO.

Per altre informazioni sulla modalità provvisoria, fare clic sui numeri di articolo seguenti per visualizzare gli articoli della Microsoft Knowledge Base:

315222 Descrizione delle opzioni di avvio in modalità provvisoria in Windows XP

202485 Descrizione della modalità di avvio sicura in Windows 2000

180902 Come avviare un computer basato su Windows 98 in modalità provvisoria

Provare ad aprire la pubblicazione

Dopo aver avviato il computer in modalità provvisoria, provare ad aprire la pubblicazione. Se non viene visualizzato un messaggio di errore, un programma o un dispositivo caricato quando il computer è in modalità normale potrebbe interferire con la pubblicazione.

Se non è possibile aprire la pubblicazione

Se non è possibile aprire la pubblicazione dopo aver avviato il computer in modalità provvisoria, usare i metodi seguenti nell'ordine in cui vengono presentati.

Incollare la pubblicazione nel file di programma di Publisher

Potrebbe essere possibile aprire la pubblicazione incollarla nel file di programma dell'editore. A tal fine, attenersi alla seguente procedura:

  1. Avviare Esplora risorse.

  2. Individuare il file di pubblicazione.

  3. Fare clic con il pulsante destro del mouse sul file di pubblicazione e quindi scegliere copia.

  4. Chiudere Esplora risorse.

  5. Fare clic sul pulsante Start, scegliere Esegui, digitare una delle righe seguenti nella casella Apri e quindi fare clic su OK:

    Per Publisher 2003c:\Program Files\Microsoft Office\Office11per Publisher 2002c:\Program Files\Microsoft Office\Office10.per Publisher 2000c:\Program Files\Microsoft Office\Office

  6. Fare clic con il pulsante destro del mouse sul file di programma MSPUB. exe e quindi scegliere Incolla.

Se non è possibile aprire la pubblicazione, passa al metodo successivo.

Fare doppio clic sul file di pubblicazione in Esplora risorse

Per fare doppio clic sul file di pubblicazione in Esplora risorse, eseguire le operazioni seguenti:

  1. Fare clic su Start, scegliere programmie quindi fare clic su Esplora risorse.

  2. Individuare il file di pubblicazione.

  3. Fare doppio clic sul file di pubblicazione.

Se non è possibile aprire la pubblicazione, passa al metodo successivo.

Configurare Publisher per nascondere le immagini

Per configurare Publisher per nascondere le immagini, eseguire le operazioni seguenti:

  1. Avviare Publisher e quindi aprire una nuova pubblicazione vuota.

  2. Nel menu Visualizza fare clic su visualizzazione immagine in Publisher 2000 oppure fare clic su Immagini in Publisher 2003 o in Publisher 2002.

  3. Fare clic su Nascondi immaginie quindi su OK.

  4. Nel menu File fare clic su Apri.

  5. Individuare il file di pubblicazione.

  6. Fare clic per selezionare la pubblicazione e quindi fare clic su Apri.

Se è possibile aprire la pubblicazione, la pubblicazione può contenere un oggetto danneggiato o un segnaposto di oggetto. Per rimuovere o sostituire un oggetto danneggiato o un segnaposto di oggetto, passa al metodo successivo. Se non è possibile aprire la pubblicazione, accedere al metodo "copiare la pubblicazione in un secondo computer".

Trovare e rimuovere un oggetto danneggiato o un segnaposto di oggetto

Per trovare e rimuovere un oggetto danneggiato o un segnaposto di oggetto, eseguire le operazioni seguenti:

  1. Nella pubblicazione fare clic con il pulsante destro del mouse su un segnaposto di oggetto e quindi scegliere Elimina oggetto.

  2. Nel menu File fare clic su Salva con nome.

  3. Nella casella nome Digitare un nuovo nome per la pubblicazione e quindi fare clic su Salva.

  4. Nel menu Visualizza fare clic su visualizzazione immagine in Publisher 2000 oppure fare clic su Immagini in Publisher 2003 o in Publisher 2002.

  5. Fare clic su visualizzazione dettagliatae quindi su OK.Nota Se viene visualizzato un messaggio di errore, passare al passaggio 8.

  6. Nel menu file fare clic su Chiudi.

  7. Nel menu file fare clic su Aprie quindi fare clic sulla pubblicazione salvata nel passaggio 3. Se è possibile aprire la pubblicazione, l'oggetto o il segnaposto dell'oggetto eliminato nel passaggio 1 è danneggiato. Modificare il layout per l'oggetto o il segnaposto dell'oggetto mancanti. In alternativa, disegna un nuovo segnaposto di oggetto e Sostituisci l'oggetto eliminato con uno non danneggiato. A questo scopo, usa il metodo appropriato per l'origine dell'oggetto.Dalla raccolta ClipArt

    1. Scegliere immaginedal menu Inserisci e quindi fare clic su ClipArt.

    2. Da una delle categorie disponibili, fare clic per inserire l'immagine, l'audio o il clip di animazione desiderato.

    3. Salvare e quindi chiudere la pubblicazione. Provare quindi a riaprire la pubblicazione.

    Da una posizione diversa dalla raccolta ClipArt

    1. Usare lo strumento cornice immagine per disegnare un nuovo segnaposto di oggetto.

    2. Fare clic per selezionare il segnaposto, scegliere immagine dal menu Inserisci e quindi fare clic su da file.

    3. Individuare l'immagine che si vuole inserire e quindi fare clic per selezionarla.

    4. Fare clic su Inserisci.

    5. Salvare e quindi chiudere la pubblicazione. Provare quindi a riaprire la pubblicazione.

    Se non è possibile aprire la pubblicazione, ripetere il metodo "Configura Publisher per nascondere le immagini". Quindi, vai al passaggio 8.

  8. Ripetere i passaggi da 1 a 7 fino a quando non è possibile aprire la pubblicazione con l'opzione di visualizzazione dettagliata abilitata.

  9. Quando è possibile aprire la pubblicazione, usare uno dei metodi seguenti:

    • Sostituire l'oggetto eliminato o il segnaposto di oggetto con uno non danneggiato.

    • Modificare il layout per l'oggetto o il segnaposto dell'oggetto mancanti.

  10. Nel menu file fare clic su Salva.

Se non è ancora possibile aprire la pubblicazione, passa al metodo successivo.

Trasferire il file di pubblicazione in un altro disco

Se il file di pubblicazione si trova in un disco rimovibile, ad esempio un disco floppy o un disco zip, potrebbe non essere possibile leggere il file. In questo scenario, copiare il file nel disco rigido. Se non è possibile copiare il file dal disco rimovibile, è possibile che il file sia collegato incrociato con altri file o cartelle. In alternativa, il file potrebbe trovarsi in un settore danneggiato del disco. In entrambi gli scenari passare al metodo "Esegui il controllo degli errori sul disco".

Copiare la pubblicazione in un secondo computer

In alcuni scenari è possibile aprire una pubblicazione danneggiata dopo aver copiato la pubblicazione in un secondo computer in cui è installato Publisher. A tal fine, attenersi alla seguente procedura:

  1. Avviare Esplora risorse.

  2. Individuare il file di pubblicazione.

  3. Fare clic con il pulsante destro del mouse sul file di pubblicazione e quindi scegliere copia.

  4. Per copiare la pubblicazione in un secondo computer, usare uno dei metodi seguenti:

    • Copiare il file di pubblicazione in un disco rimovibile, ad esempio un disco floppy o un disco zip. Copia quindi la pubblicazione dal disco rimovibile in un secondo computer.

    • Copiare il file di pubblicazione in un secondo computer tramite una rete.

  5. Nel secondo computer avviare Esplora risorse.

  6. Individuare e quindi fare doppio clic sul file di pubblicazione.

Se è possibile aprire la pubblicazione, esaminare ogni pagina per determinare se sono presenti segnaposto di oggetto vuoti. Per ogni segnaposto di oggetto vuoto individuato, fare clic con il pulsante destro del mouse sul file e quindi scegliere Elimina. Salvare la pubblicazione e quindi copiare di nuovo il file di pubblicazione nel primo computer. Se non è possibile aprire la pubblicazione, passa al metodo successivo.

Eseguire il controllo degli errori sul disco

Eseguire il controllo errori per ripristinare tutti gli errori sul disco. Istruire il controllo degli errori per ripristinare tutti i file interconnessi e per convertire i frammenti persi in file.Nota Anche se il controllo degli errori può determinare che il file di pubblicazione è reticolato e quindi Ripristina il file, questo metodo non garantisce che Publisher possa leggere il file dopo che il controllo degli errori ha terminato la ricerca e la correzione di errore. Per eseguire il controllo degli errori, seguire questa procedura:

  1. Chiudere tutti i programmi in uso.

  2. Fare doppio clic sull'icona del mio computer sul desktop.

  3. Fare clic con il pulsante destro del mouse sul disco locale che si desidera controllare e quindi scegliere Proprietà.

  4. Nella scheda strumenti fare clic su Controlla ora in controllo errori.

  5. In Opzioni del disco di controllofare clic su per selezionare la casella di controllo ricerca e tentativo di ripristino dei settori danneggiati . Fare quindi clic su Start.

  6. Quando il controllo degli errori termina la digitalizzazione e la correzione, fare clic su Chiudi.

  7. Avviare Publisher e quindi provare ad aprire la pubblicazione.

Se non è possibile aprire la pubblicazione, passa al metodo successivo.

Provare a recuperare il testo nella pubblicazione

Questo metodo descrive come recuperare il testo dalla pubblicazione danneggiata e come inserire il testo recuperato in una nuova pubblicazione vuota. È quindi necessario ricreare il layout e reinserire tutti gli oggetti dalla pubblicazione danneggiata nella nuova pubblicazione. Per recuperare il testo dalla pubblicazione danneggiata e quindi inserire il testo in una nuova pubblicazione, eseguire le operazioni seguenti:

  1. Avviare Publisher e quindi creare una nuova pubblicazione a pagina intera vuota.

  2. Usare lo strumento cornice di testo in Publisher 2000 o lo strumento casella di testo in Publisher 2003 o in Publisher 2002 per disegnare una cornice di testo nella pagina vuota.

  3. Nel menu Inserisci fare clic su file di testo.

  4. Nella casella tipo file fare clic sufile di Publisher (*. pub).

  5. Fare clic sulla pubblicazione e quindi su OK. Se viene visualizzato un messaggio che indica il modo in cui il testo che si vuole inserire si inserisce nella pagina, fare clic su .

Se è possibile aprire la pubblicazione danneggiata

Se è possibile aprire la pubblicazione in modalità provvisoria, usare uno dei metodi seguenti per ricreare la pubblicazione.

Copiare pagine dalla pubblicazione danneggiata in una nuova pubblicazione

Per copiare pagine da una pubblicazione danneggiata in una nuova pubblicazione, eseguire le operazioni seguenti:

  1. Avviare Publisher e quindi aprire la pubblicazione danneggiata.

  2. Avviare un'altra istanza di Publisher.

  3. Creare una nuova pubblicazione vuota configurata come la pubblicazione danneggiata.

  4. Nella pubblicazione danneggiata selezionare tutti gli oggetti in una pagina specifica.

  5. Scegliere copiadal menu modifica .

  6. Premere ALT + TAB per passare alla nuova pubblicazione.

  7. Scegliere Incolla dal menu Modifica.

  8. Ripetere i passaggi da 4 a 7 fino a quando tutte le pagine vengono incollate nella nuova pubblicazione.

Nota Se si nota un comportamento strano nella nuova pubblicazione dopo la copia di una pagina nella nuova pubblicazione, la pagina copiata contiene probabilmente un oggetto danneggiato. In questo scenario, usare uno dei metodi seguenti per aggirare il problema:

  • Copiare un oggetto alla volta dalla pagina problema alla nuova pubblicazione per determinare l'oggetto danneggiato. Quindi, assicurati di non includere l'oggetto danneggiato nella nuova pubblicazione.

  • Ricompilare la pagina problema nella nuova pubblicazione.

Se ogni pagina della pubblicazione è danneggiata, passa al metodo successivo.

Salvare la pubblicazione in formato RTF (Rich Text Format)

Se il danneggiamento della pubblicazione sembra diffuso, salvare la pubblicazione in formato RTF per recuperare il testo della pubblicazione. A tal fine, attenersi alla seguente procedura:

  1. Aprire la pubblicazione.

  2. Fare clic su una cornice di testo.

  3. Nella casella Salva con nome fare clic suformato RTF (Rich Text Format).

  4. Nella casella nome file Digitare il nome del file desiderato.

  5. Nella casella Salva in fare clic sulla cartella in cui si vuole salvare il testo della pubblicazione.

  6. Fare clic su Salvae quindi su OK.

  7. Chiudere la pubblicazione.

  8. Nel menu File fare clic su Apri.

  9. Nella casella tipo file fare clic suformato RTF (Rich Text Format).

  10. Nell'elenco dei file fare clic sul file di testo salvato nel passaggio 6.

  11. Fai clic su Apri.

  12. Disporre e formattare il testo in modo da duplicare il layout del testo e formattarlo nella pubblicazione danneggiata.

Riferimenti

Per altre informazioni su come risolvere i problemi relativi alle pubblicazioni di Publisher danneggiate, fare clic sui numeri di articolo seguenti per visualizzare gli articoli della Microsoft Knowledge Base:

315222 Descrizione delle opzioni di avvio in modalità provvisoria in Windows XP

164519 Risoluzione dei problemi relativi agli errori di Office Kernel32. dll in Windows 95

179095 Messaggio di errore collegamento file durante l'apertura di Publisher

Serve aiuto?

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa a Microsoft Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

×