Sintomi
In un ambiente dedicato o traffico internazionale in Arms Regulations (ITAR) Microsoft Office 365, un utente viene richiesto da una finestra di dialogo Avviso di protezione che include il seguente messaggio di errore:
Il nome nel certificato di sicurezza non è valido o non corrisponde al nome del sito.
Ad esempio, la finestra di dialogo Avviso di protezione analogo al seguente: Questo problema può verificarsi nelle seguenti circostanze:
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L'utente tenta di creare un nuovo profilo in Microsoft Office Outlook.
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L'utente tenta di avviare un client di Outlook.
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Il problema si verifica in modo intermittente quando il client di Outlook è in esecuzione.
Se l'utente fa clic su Sì, l'utente può continuare l'operazione. Tuttavia, se l'utente fa clic su No, ricerca di individuazione automatica ha esito negativo. L'errore di ricerca di individuazione automatica impedisce alle seguenti funzionalità di funzionare come previsto:
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Creazione automatica di un profilo di Outlook tramite l'individuazione automatica
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Assistente Fuori sede
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Informazioni sulla disponibilità
Causa
In genere, questo problema si verifica quando l'URL che si sta tentando di accedere non è elencato nel soggetto o il nome alternativo del soggetto (SAN) del certificato Secure Sockets Layer (SSL) per il sito Web. Anche se le configurazioni di organizzazioni diverse possono differire leggermente, questo problema si verifica in genere perché i record DNS (Domain Name System) di individuazione automatica dell'organizzazione non sono configurati correttamente.
Risoluzione
Per risolvere questo problema, potrebbe essere necessario modificare i record DNS di individuazione automatica (interni, esterni o entrambi). Tuttavia, queste modifiche non devono essere prese alla leggera, perché la funzionalità di individuazione automatica potrebbe non funzionare se i record DNS non sono configurati correttamente. Prima di modificare i record DNS di individuazione automatica, è necessario comprendere come il client Outlook tenta di individuare il servizio di individuazione automatica. Il client Outlook tenta di individuare il servizio di individuazione automatica utilizzando il seguente ordine fondamentale delle operazioni. Tuttavia, il passaggio in cui si trova il servizio di individuazione automatica varia da distribuzione a distribuzione. Questo percorso dipende dalla coesistenza di una soluzione locale e dall'ambiente di posta elettronica locale specifico, ad esempio Microsoft Exchange Server locale, Lotus Notes locale o un altro ambiente. Nella tabella seguente viene visualizzato l'ordine fondamentale delle operazioni per il modo in cui il client Outlook individua il servizio di individuazione automatica:
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Risultato Se il servizio di individuazione automatica non viene trovato da uno di questi metodi, l'individuazione automatica ha esito negativo. |
In sintesi, il servizio di individuazione automatica può essere risolto utilizzando un record A, un record CNAME o un record SRV. Per determinare i record attualmente utilizzati, eseguire i comandi seguenti al prompt dei comandi o in Windows PowerShell:
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Per individuare un record A, eseguire i comandi seguenti. Assicurarsi di sostituire SMTPDomain.com di seguito con il dominio con il valore nella parte superiore dell'errore di certificato.
nslookup
set type=A
Autodiscover.SMTPDomain.com
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Per individuare un record SRV, eseguire i seguenti comandi:
nslookup
set type=SRV
_autodiscover._tcp.SMTPDomain.com
Nell'esempio seguente, il client Outlook può individuare il servizio di individuazione automatica utilizzando il record A per l'URL di individuazione automatica come descritto nel passaggio 3 della tabella precedente:
autodiscover.proseware.comTuttavia, come accennato nella sezione "Cause", questo URL non è elencato nella SAN del certificato SSL utilizzato dal servizio di individuazione automatica. Ad esempio, vedere la schermata seguente:For example, see the following screen shot: Per risolvere questo problema, utilizzare il metodo seguente.
Sostituire il record A esistente utilizzando un record SRV che punta a uno spazio dei nomi già presente nella SAN del certificato SSL
Questo è il metodo di risoluzione preferito nella progettazione del servizio corrente perché il certificato SSL esistente non deve essere aggiornato e distribuito. In base all'ordine fondamentale delle operazioni elencate in precedenza in questa sezione, l'organizzazione può implementare il nuovo record utilizzando un modo controllato e testato per evitare interruzioni del servizio di individuazione automatica. Per risolvere questo problema, attenersi alla seguente procedura:
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Creare un nuovo record SRV. Il record SRV deve essere creato nella zona DNS che corrisponde al dominio SMTP dell'utente. Il record SRV deve avere le seguenti proprietà:
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Servizio: _autodiscover
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Protocollo: _tcp
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Porta: 443
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Host: URL per il reindirizzamento. Questo URL può essere l'URL di Outlook Web Access (OWA) perché l'indirizzo IP risolto deve essere lo stesso del servizio di individuazione automatica. Inoltre, questo può variare da distribuzione a distribuzione.
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Prima di rimuovere il record A esistente, il nuovo record SRV deve essere testato modificando il file host di un utente per reindirizzare il record A corrente a un indirizzo IP non valido. Questo test può verificare che il nuovo record SRV funzioni come previsto prima di distribuire i nuovi record DNS all'intera organizzazione. Nota: Quando il record SRV viene utilizzato da un client di Outlook, l'utente potrebbe ricevere il seguente messaggio che invita l'utente del reindirizzamento che sta per verificarsi. Si consiglia all'utente di selezionare la casella di controllo Non visualizzare più questo sito Web in modo che il messaggio non venga visualizzato di nuovo.
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Quando il record SRV funziona come previsto, è possibile rimuovere il record A esistente dal DNS.
Ulteriori informazioni
Per ulteriori informazioni sul servizio di individuazione automatica, visitare il seguente sito Web Microsoft TechNet: