Accedi con Microsoft
Accedi o crea un account.
Salve,
Seleziona un altro account.
Hai più account
Scegli l'account con cui vuoi accedere.

Sintomi

Considerare lo scenario descritto di seguito:

  • Si dispone di un'applicazione avanzata-programma a programma Communications (APPC) o un'interfaccia di programmazione comune per l'applicazione di comunicazione (CPI-C) che invia le transazioni in un'applicazione partner tramite Microsoft Host Integration Server 2009.

  • L'opzione supporta dynamic remote APPC LU definition è attivata nelle proprietà della connessione in SNA Manager.

  • Non esistono active APPC sessioni sul servizio SNA Server al momento che l'applicazione APPC o applicazione CPI-C invia le richieste di transazioni concorrenti.

In questo scenario, l'applicazione APPC o applicazione CPI-C smetta di rispondere (bloccarsi) non appena vengono avviate le transazioni.Nota Questo problema può verificarsi anche quando si utilizza Host Integration Server 2004 o Host Integration Server 2006.

Causa

Questo problema si verifica perché il servizio SNA Server (Snaservr.exe) non gestisce correttamente la seconda richiesta di sessione APPC ricevuto durante l'elaborazione della prima richiesta di sessione APPC. Questo problema si verifica solo quando è attivata l'opzione supporta dynamic remote APPC LU definition sulla connessione in cui le unità di logica APPC (UBA) sono definite in SNA Manager problema non si verifica se vengono utilizzati definiti in modo esplicito i LU APPC remoti .

Risoluzione

Informazioni sull'hotfix

Un hotfix supportato è disponibile da Microsoft. Questo hotfix è tuttavia destinato esclusivamente alla risoluzione del problema descritto in questo articolo. Applicare questo hotfix solo ai sistemi in cui si verifica il problema descritto in questo articolo. Questo hotfix potrebbe essere sottoposto ad ulteriori test. Se il problema non causa gravi difficoltà, si consiglia di attendere il successivo aggiornamento software contenente tale hotfix. Se l'hotfix è disponibile per il download, è presente una sezione "Hotfix disponibile per il download" all'inizio di questo articolo della Knowledge Base. Se questa sezione non viene visualizzata, contattare il servizio clienti Microsoft e supporto tecnico per ottenere l'hotfix. Nota Se si verificano ulteriori problemi o se è necessaria attività di risoluzione aggiuntiva, potrebbe essere necessario creare una richiesta di assistenza separata. I costi di supporto normale verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare specifico hotfix in questione. Per un elenco completo dei numeri di telefono del servizio clienti Microsoft e supporto tecnico o per creare una richiesta di assistenza separata, visitare il seguente sito Web Microsoft:

http://support.microsoft.com/contactus/? ws=supportNota Il modulo "Hotfix disponibile per il download" Visualizza le lingue per cui è disponibile l'hotfix. Se non viene visualizzata la lingua, è perché un aggiornamento rapido non è disponibile per tale lingua.

Requisiti

È necessario disporre di Host Integration Server 2009 per applicare questo hotfix.

Informazioni sul riavvio

Non è necessario riavviare il computer dopo avere applicato questo hotfix.

Informazioni sui file

La versione in lingua inglese di questo hotfix presenta gli attributi di file elencati nella tabella seguente (o attributi successivi). Le date e le ore di questi file sono espresse nel formato UTC (Coordinated Universal Time). Quando esaminate le informazioni del file, viene convertito in orario locale. Per calcolare la differenza tra ora UTC e ora locale, utilizzare la scheda fuso orario nell'elemento di Data e ora nel Pannello di controllo.

Per tutte le versioni basate su x86 di Host Integration Server 2009

Nome file

Versione file

Dimensione file

Date

Ora

Piattaforma

Snaservr.exe

8.0.3776.2

679,760

14-Sep-2010

00:42

x86

Trcservr.exe

8.0.3776.2

920,912

14-Sep-2010

00:42

x86

Per tutte le versioni basate su x64 di Host Integration Server 2009

Nome file

Versione file

Dimensione file

Date

Ora

Piattaforma

Snaservr.exe

8.0.3776.2

967,504

14-Sep-2010

00:44

x64

Trcservr.exe

8.0.3776.2

1,261,904

14-Sep-2010

00:44

x64

Soluzione alternativa

Per risolvere questo problema, disattivare l'opzione supporta dynamic remote APPC LU definition nelle proprietà della connessione in SNA Manager per le connessioni che utilizzano LU APPC. Per impostazione predefinita per le connessioni che utilizzano il servizio di collegamento IP-DLC, il supporto dynamic remote APPC LU definition è attivata.

Stato

Microsoft ha confermato che questo problema si verifica nei prodotti elencati nella sezione "Si applica a".

Ulteriori informazioni

Se vengono utilizzati dipendenti LU APPC locale in uno scenario simile a quello descritto di seguito, sarà necessario utilizzare l'utilità di prompt dei comandi SNACFG per assegnare il LU APPC remoti alla connessione che utilizza il dipendente LU APPC locale "Sistema Host" IP-DLC. Per ulteriori informazioni, fare clic sul seguente numero di articolo per visualizzare l'articolo della Microsoft Knowledge Base:

947858 FIX: 17 si verifica quando un'applicazione mainframe tenta di richiamare un'applicazione APPC tramite una connessione IP-DLC utilizzando un'unità logica di LU 6.2 dipendenteSe il LU APPC remoti non sono assegnati manualmente per il connessione "Sistema Host" utilizzando Snacfg.exe, il servizio SNA Server verrà dinamicamente IP-DLC creare LU APPC remoti per le richieste di sessione APPC. Ciò si verifica anche se il LU APPC remoti definiti in modo esplicito nella configurazione di Host Integration Server. Per ulteriori informazioni su come configurare dipendenti LU APPC locale quando si utilizza il servizio di collegamento IP-DLC, fare clic sul numero riportato di seguito per visualizzare l'articolo della Microsoft Knowledge Base riportato di seguito:

939193 Come impostare la connessione e le unità logiche per un'applicazione APPC quando si utilizza il servizio di collegamento IP-DLC in Host Integration Server 2006 e unità logiche di dipendenti APPC

Serve aiuto?

Vuoi altre opzioni?

Esplorare i vantaggi dell'abbonamento e i corsi di formazione, scoprire come proteggere il dispositivo e molto altro ancora.

Le community aiutano a porre e a rispondere alle domande, a fornire feedback e ad ascoltare gli esperti con approfondite conoscenze.

Queste informazioni sono risultate utili?

Come valuti la qualità della lingua?
Cosa ha influito sulla tua esperienza?
Premendo Inviare, il tuo feedback verrà usato per migliorare i prodotti e i servizi Microsoft. L'amministratore IT potrà raccogliere questi dati. Informativa sulla privacy.

Grazie per il feedback!

×