Sintomi
Quando un computer client che esegue Microsoft Windows XP effettua una richiesta a un oggetto remoto Microsoft COM+, la richiesta potrebbe non riuscire. Inoltre, può essere generato il codice di errore 0x800706BA.
Nota: Codice errore 0x800706BA indica che il server remote procedure call (RPC) non è disponibile.
Causa
Questo problema si verifica quando il computer client che esegue Windows XP rilascia l'oggetto remoto COM+. Circa 20 secondi a 30 secondi dopo che il client rilascia COM+ oggetto remoto e vengono chiuse le porte RPC utilizzate da DCOM sul server. Se la rete viene disconnessa immediatamente dopo che il client rilascia l'oggetto remoto COM+, le porte RPC utilizzate da DCOM sul server rimangano aperte per diverse ore. Ciò può causare l'esaurimento di porta. Le successive richieste provenienti dal computer client all'oggetto remoto COM+ esito negativo.
Risoluzione
Informazioni sull'hotfix
Un hotfix supportato è disponibile da Microsoft. Tuttavia, questo hotfix è destinato esclusivamente alla correzione del problema descritto in questo articolo. Applicare questo hotfix solo ai sistemi in cui si verificano questo problema specifico. Questo hotfix potrebbe essere sottoposto ad ulteriori test. Se il problema non causa gravi difficoltà, si consiglia di attendere il successivo aggiornamento software contenente tale hotfix.
Se l'hotfix è disponibile per il download, è presente una sezione "Hotfix disponibile per il download" all'inizio di questo articolo della Knowledge Base. Se questa sezione non viene visualizzata, contattare il servizio clienti Microsoft e supporto tecnico per ottenere l'hotfix.
Nota: Se si verificano ulteriori problemi o se è necessaria attività di risoluzione aggiuntiva, potrebbe essere necessario creare una richiesta di assistenza separata. I costi di supporto normale verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare specifico hotfix in questione. Per un elenco completo dei numeri di telefono del servizio clienti Microsoft e supporto tecnico o per creare una richiesta di assistenza separata, visitare il seguente sito Web Microsoft:
http://support.microsoft.com/contactus/?ws=supportNota: Il modulo "Hotfix disponibile per il download" Visualizza le lingue per cui è disponibile l'hotfix. Se non viene visualizzata la lingua, è perché un aggiornamento rapido non è disponibile per tale lingua.
Prerequisiti
È necessario disporre di Windows XP per applicare questo hotfix.
Informazioni sul riavvio
Dopo avere applicato questo hotfix, è necessario riavviare il computer.
Informazioni del Registro di sistema
Non è necessario creare chiavi di registro per attivare questo hotfix. Inoltre, non è necessario modificare alcuna chiave del Registro di sistema per attivare questo hotfix.
Informazioni sui file
La versione inglese di questo hotfix presenta gli attributi di file (o attributi successivi) elencati nella tabella riportata di seguito. Le date e ore dei file sono elencate in base al formato UTC (Coordinated Universal Time Coordinated). Quando si visualizzano le informazioni sul file, viene convertito in ora locale. Per calcolare la differenza tra ora UTC e ora locale, utilizzare la scheda fuso orario nell'elemento di Data e ora nel Pannello di controllo.
Nome del file |
Versione del file |
Dimensione del file |
Data |
Ora |
---|---|---|---|---|
Ole32.dll |
5.1.2600.3124 |
1,287,168 |
23-Apr-2007 |
14:20 |
Rpcss.dll |
5.1.2600.3124 |
399,360 |
23-Apr-2007 |
14:20 |
Updspapi.dll |
6.2.29.0 |
371,424 |
19-Jan-2006 |
19:29 |
Stato
Microsoft ha confermato che si tratta di un bug nei prodotti Microsoft elencati nella sezione "Si applica a".
Ulteriori informazioni
Per ulteriori informazioni, fare clic sul seguente numero di articolo per visualizzare l'articolo della Microsoft Knowledge Base:
824684 descrizione della terminologia standard utilizzata per descrivere gli aggiornamenti software Microsoft