Sintomi
Supponiamo che si stiano usando una o più applicazioni basate su Lync SDK nel computer e si partecipa a una riunione con molti partecipanti. In questo caso, il client Lync o Skype for business non risponde per un periodo.
Causa
Partecipare a una riunione con molti partecipanti genera migliaia di eventi interni, che vengono poi accodati ed elaborati.
La presenza di un'applicazione basata su Lync SDK fa sì che il client Lync o Skype for business invii questi eventi interni a code aggiuntive. Queste code usano le chiamate COM Inter-Apartment che richiedono molto più tempo per il completamento. Durante l'elaborazione della coda, l'interfaccia utente del client non risponde finché non viene deselezionata.
Soluzione alternativa
Per risolvere il problema, chiudere tutte le applicazioni basate su Lync SDK prima di partecipare a una riunione.
Risoluzione
Importante
Seguire attentamente i passaggi in questa sezione. L'errata modifica del Registro di sistema può causare seri problemi. Prima di apportare le modifiche, eseguire il backup del Registro di sistema per il ripristino nel caso si verifichino dei problemi.
Per risolvere il problema, installare gli aggiornamenti più recenti per Skype for business 2016 e Skype for business 2015. Crea quindi un oggetto Criteri di gruppo per aggiungere la nuova chiave del registro di sistema DWORD seguente e imposta il valore sotto il percorso:
HKEY_CURRENT_USER\Software\Microsoft\Office\xx.0\Lync
DWORD EnableLargeMeetingProcessing = 1 DWORD LargeMeetingMinimumRosterCount = 20 (impostazione predefinita) DWORD LargeMeetingRosterLoadingDelayInSec = 30 (impostazione predefinita)
Nota
XX.0 in questo percorso del registro di sistema corrisponde alla versione di skype for business (16,0 = Skype for business 2016, 15,0 = Skype for business 2015).
In alternativa, è possibile abilitare questa correzione creando una voce di criteri personalizzata e aggiungendola al criterio client, come indicato di seguito:
$x = New-CsClientPolicyEntry -Name "EnableLargeMeetingProcessing" -Value "true"
Set-CsClientPolicy -Identity "<ClientPolicyName>" -PolicyEntry @{Add=$x}
Come ottenere gli aggiornamenti più recenti
Nota
Fare clic quiper un elenco completo dei client. A portata di clic è il modo consigliato per installare il client Skype for business. È possibile scaricare il client a portata di clic dal portale di Office365.
Versione basata su Microsoft Installer (con estensione msi)
Versione a portata di clic
Aprire un'applicazione di Office, ad esempio Word, e quindi selezionare File> account> Opzioni di aggiornamento> Aggiorna ora.
Nota
Se nel client non esiste "opzioni di aggiornamento", si tratta di un'installazione MSI.