Accedi con Microsoft
Accedi o crea un account.
Salve,
Seleziona un altro account.
Hai più account
Scegli l'account con cui vuoi accedere.

Questo articolo si applica a Microsoft Dynamics NAV per i paesi e le impostazioni locali della lingua seguenti.

  • Tedesco (Germania) (de-de)

  • Austria (at-at)

  • Francese (Svizzera) (fr-ch)

  • Tedesco (Svizzera) (de-ch)

  • Italiano (Svizzera) (it-ch)

Sintomi

Quando si esegue il valore di "Posted Phys. Invt. Order Diff". Il report non mostra differenze. Il report include le colonne Righe previste, Righe di registrazione e Linee di tracciabilità. La colonna a destra è sempre vuota. Questo problema si verifica nei prodotti seguenti:

  • Versione tedesca di Microsoft Dynamics NAV 2009 R2

  • Versione Austria di Microsoft Dynamics NAV 2009 R2

  • Versione svizzera di Microsoft Dynamics NAV 2009 R2

  • Versione tedesca di Microsoft Dynamics NAV 2009 Service Pack 1

  • Versione Austria di Microsoft Dynamics NAV 2009 Service Pack 1

  • Versione svizzera di Microsoft Dynamics Service Pack 1

Causa

Questo problema si verifica perché la variabile TempPhysInvtDiffListOffice2 del report è una variabile locale e non viene mai assegnata da qualsiasi punto del report. Inoltre, la variabile non è una variabile temporanea. Di conseguenza, la variabile punta al valore effettivo di "Phys. Invt. Diff. Tabella Buffer elenco sempre vuota.

Risoluzione

Informazioni sull'aggiornamento rapido

Microsoft ha ora installato un aggiornamento rapido supportato. Tuttavia, è destinato solo a correggere il problema descritto in questo articolo. Applicarla solo ai sistemi in cui si verifica questo problema specifico. Questo aggiornamento rapido potrebbe ricevere ulteriori test. Pertanto, se non si è severamente interessati da questo problema, è consigliabile attendere il Service Pack di Microsoft Dynamics NAV 2009 successivo o la successiva versione di Microsoft Dynamics NAV che contiene questo aggiornamento rapido.

Nota In casi speciali, gli addebiti normalmente sostenuti per le chiamate di supporto possono essere annullati se un professionista del supporto tecnico per Microsoft Dynamics e prodotti correlati stabilisce che un aggiornamento specifico risolverà il problema. I soliti costi di supporto si applicano ad altre domande e problemi di supporto che non sono idonei per l'aggiornamento specifico in questione.


Informazioni sull'installazione

Microsoft fornisce esempi di programmazione solo a scopo di illustrazione, senza garanzie espresse o implicite. Ciò include, a parte, le garanzie implicite di merchantability o fitness per uno scopo specifico. In questo articolo si presuppone che si abbia familiarità con il linguaggio di programmazione illustrato e con gli strumenti usati per creare ed eseguire il debug di routine. I tecnici del supporto Microsoft possono aiutare a spiegare la funzionalità di una procedura specifica. Tuttavia, non modificheranno questi esempi per fornire funzionalità aggiuntive o creare procedure che soddisfino i requisiti specifici.

Nota Prima di installare questo aggiornamento rapido, verificare che tutti gli utenti client di Microsoft Navision siano disconnessi dal sistema. Sono inclusi gli utenti del client Microsoft Navision Application Services (NAS). È consigliabile essere l'unico utente client connesso durante l'implementazione di questo aggiornamento rapido.

Per implementare questo aggiornamento rapido, è necessario avere una licenza per sviluppatori.

È consigliabile assegnare all'account utente nella finestra Accessi di Windows o database l'ID ruolo "SUPER". Se all'account utente non può essere assegnato l'ID ruolo "SUPER", è necessario verificare che l'account utente abbia le autorizzazioni seguenti:

  • Autorizzazione di modifica per l'oggetto che verrà modificato.

  • Autorizzazione di esecuzione per l'oggetto ID oggetto di sistema 5210 e per l'oggetto ID oggetto di sistema 9015.



Nota Non è necessario avere diritti per gli archivi dati, a meno che non sia necessario eseguire il ripristino dei dati.

Modifiche al codice

Nota Prima di applicare le correzioni ai computer di produzione, testare sempre le correzioni del codice in un ambiente controllato.
Per risolvere questo problema, attenersi alla seguente procedura:

  1. Modificare la variabile TempPhysInvtDiffListOffice2 nella funzione CreateDiffListReport da variabile locale a globale di Posted Phys. Invt. Ordine diff. (5005351) come segue:

    TempPhysInvtDiffListBuffer2@1140019 : TEMPORARY Record 5005363;

    tempphysinvtdifflistbuffer2@1140019

  2. Modificare il codice nella funzione FindOrCreateDiffListCreate nel valore di Posted Phys. Invt. Ordine diff. report (5005351) come segue:
    Codice esistente

      TempPhysInvtDiffListBuffer.INSERT;
    NoOfBufferLines := NoOfBufferLines +1;
    END ELSE BEGIN
    IF NextLineNo = 1 THEN
    ...

    Codice sostitutivo

    ...
    TempPhysInvtDiffListBuffer.INSERT;
    NoOfBufferLines := NoOfBufferLines +1;

    // Add the following lines.
    TempPhysInvtDiffListBuffer2 := TempPhysInvtDiffListBuffer;
    TempPhysInvtDiffListBuffer2.INSERT;
    // End of the lines.

    END ELSE BEGIN
    IF NextLineNo = 1 THEN
    ...

Requisiti

Per applicare questo aggiornamento rapido, è necessario che sia installato uno dei prodotti seguenti:

  • Versione tedesca di Microsoft Dynamics NAV 2009 R2

  • Versione Austria di Microsoft Dynamics NAV 2009 R2

  • Versione svizzera di Microsoft Dynamics NAV 2009 R2

  • Versione tedesca di Microsoft Dynamics NAV 2009 Service Pack 1

  • Versione Austria di Microsoft Dynamics NAV 2009 Service Pack 1

  • Versione svizzera di Microsoft Dynamics Service Pack 1

Informazioni sulla rimozione

Non è possibile rimuovere questo aggiornamento rapido.

Stato

Microsoft ha confermato che questo problema si verifica nei prodotti elencati nella sezione "Si applica a".

Nota Si tratta di un articolo "FAST PUBLISH" creato direttamente dall'organizzazione di supporto Microsoft. Le informazioni qui contenute vengono fornite così come sono in risposta a problemi emergenti. In seguito alla rapidità con cui è disponibile, i materiali possono includere errori tipografici e possono essere rivisti in qualsiasi momento senza preavviso. Per altre considerazioni, vedere le Condizioni per l'utilizzo.

Serve aiuto?

Vuoi altre opzioni?

Esplorare i vantaggi dell'abbonamento e i corsi di formazione, scoprire come proteggere il dispositivo e molto altro ancora.

Le community aiutano a porre e a rispondere alle domande, a fornire feedback e ad ascoltare gli esperti con approfondite conoscenze.

Queste informazioni sono risultate utili?

Come valuti la qualità della lingua?
Cosa ha influito sulla tua esperienza?
Premendo Inviare, il tuo feedback verrà usato per migliorare i prodotti e i servizi Microsoft. L'amministratore IT potrà raccogliere questi dati. Informativa sulla privacy.

Grazie per il feedback!

×