Accedi con Microsoft
Accedi o crea un account.
Salve,
Seleziona un altro account.
Hai più account
Scegli l'account con cui vuoi accedere.

Sintomi

Si verificano i seguenti problemi correlati al servizio SDK OpsMgr in Microsoft System Center Operations Manager 2007.

Problema 1

Il processo di MonitoringHost.exe nel server di gestione radice di Systems Center Operations Manager 2007 può consumare più di 2 gigabyte (GB) di memoria. È possibile visualizzare questo sintomo in Gestione attività.

Problema 2

Un Management Pack in Systems Center Operations Manager 2007 converte gli eventi del servizio OpsMgr SDK in avvisi. Tuttavia, quando si reimporta il Management Pack, gli eventi che sono già stati elaborati vengono elaborati di nuovo.

Causa

Il problema 1 si verifica perché il modulo origine dati del servizio OpsMgr SDK non limita il numero di elementi di dati elaborati contemporaneamente. Il modulo dell'origine dati tenta di leggere tutti gli elementi di dati in sospeso dal database ed elaborare gli elementi di dati in un batch. Il processo di MonitoringHost.exe potrebbe arrestarsi in modo imprevisto in risposta a un'eccezione non gestita se è necessario elaborare troppi elementi di dati.

Risoluzione

Informazioni sull'aggiornamento rapido

Un hotfix supportato è disponibile da Microsoft. Tuttavia, questo hotfix ha lo scopo di correggere solo il problema descritto in questo articolo. Applica questo hotfix solo ai sistemi che stanno riscontrando questo problema specifico. Questo hotfix potrebbe ricevere ulteriori test. Pertanto, se non si è gravemente colpiti da questo problema, è consigliabile attendere il prossimo aggiornamento software che contiene questo hotfix.

Se l'hotfix è disponibile per il download, nella parte superiore di questo articolo della Knowledge Base è presente la sezione "Download di hotfix disponibile". Se questa sezione non viene visualizzata, contattare il supporto tecnico Microsoft per ottenere l'hotfix.

Nota Se si verificano altri problemi o se è necessaria una risoluzione dei problemi, potrebbe essere necessario creare una richiesta di servizio separata. I soliti costi di supporto si applicano a ulteriori domande e problemi di supporto che non sono idonei per questo hotfix specifico. Per un elenco completo dei numeri di telefono del servizio clienti Microsoft e del supporto tecnico Microsoft o per creare una richiesta di servizio separata, visita il seguente sito Web Microsoft:

http://support.microsoft.com/contactus/?ws=supportNota Il modulo "Download di hotfix disponibile" mostra le lingue per cui l'hotfix è disponibile. Se non vedi la tua lingua, è perché non è disponibile un hotfix per tale lingua.

Istruzioni per l'installazione di hotfix

Applicare questo hotfix a tutti i server che ospitano il seguente ruolo server:

  • Server di gestione Operations Manager 2007

A tale scopo, copiare il file SystemCenterOperationsManager2007-RTM-KB943706-X86-X64-ENU.MSI dal pacchetto hotfix in una cartella locale o in una cartella condivisa. Quindi, esegui questo file.

Nota È possibile eseguire questo file in Esplora Windows o al prompt dei comandi. Il processo di installazione di hotfix riavvia il servizio Integrità di OpsMgr.

I computer dell'agente vengono aggiornati automaticamente. Tuttavia, è necessario approvare l'aggiornamento nella cartella "Gestione in sospeso". A tal fine, attenersi alla seguente procedura:

  1. Nel computer che esegue il ruolo Management Server fare clic su Start, scegliere Tutti i programmi, System Center Operations Manager 2007 e quindi fare clic su Console operazioni.

  2. Selezionare la visualizzazione Amministrazione, espandere Amministrazione, espandere Gestione dispositivi e quindi fare clic su Gestione in sospeso.

  3. Nella cartella "Gestione in sospeso" esaminare e approvare i computer dell'agente per applicare questo hotfix.

Nota Se si installa Operations Manager 2007 Agent in qualsiasi computer dopo aver applicato questo hotfix, assicurarsi di approvare l'installazione nella cartella "Gestione in sospeso".

Requisiti

Non sono necessari prerequisiti.

Richiesta di riavvio

Non è necessario riavviare il computer dopo aver applicato questo hotfix.

Informazioni sulla sostituzione degli hotfix

Questo hotfix non sostituisce altri hotfix.

Informazioni sui file

La versione in lingua inglese di questo hotfix presenta gli attributi di file elencati nella tabella seguente (o attributi successivi). Le date e le ore di questi file sono espresse nel formato UTC (Coordinated Universal Time). Quando esaminate le informazioni del file, viene convertito in orario locale. Per trovare la differenza tra UTC e l'ora locale, usare la scheda Fuso orario nell'elemento Data e ora in Pannello di controllo.

System Center Operations Manager 2007, versioni basate su x86

Nome file

Versione file

Dimensione file

Date

Ora

Piattaforma

Microsoft.enterprisemanagement.operationsmanager.common.dll

6.0.5000.39

405,504

24 ottobre 2007

09:34

x86

Microsoft.mom.dataaccesslayer.dll

6.0.5000.39

2,232,320

24 ottobre 2007

09:34

x86

Microsoft.mom.sdkmodules.dll

6.0.5000.39

118,784

24 ottobre 2007

09:34

x86

System Center Operations Manager 2007, versioni basate su x64

Nome file

Versione file

Dimensione file

Date

Ora

Piattaforma

Microsoft.enterprisemanagement.operationsmanager.common.dll

6.0.5000.39

405,504

24 ottobre 2007

09:34

x86

Microsoft.enterprisemanagement.operationsmanager.dll

6.0.5000.31

2,166,784

24 ottobre 2007

09:34

x86

Microsoft.mom.dataaccesslayer.dll

6.0.5000.39

2,232,320

24 ottobre 2007

09:34

x86

Microsoft.mom.sdkmodules.dll

6.0.5000.39

118,784

24 ottobre 2007

09:34

x86

Momperfsnapshothelper.exe

6.0.5000.0

47,104

24 ottobre 2007

09:35

x64

Momperfsnapshothelperproxy.dll

6.0.5000.0

11,776

24 ottobre 2007

09:35

x64

Stato

Microsoft ha confermato che questo problema si verifica nei prodotti elencati nella sezione "Si applica a".

Ulteriori informazioni

Per altre informazioni sulla terminologia di aggiornamento software, fare clic sul numero dell'articolo seguente per visualizzare l'articolo nel Microsoft Knowledge Base:

824684 Descrizione della terminologia standard utilizzata per descrivere gli aggiornamenti software Microsoft

Serve aiuto?

Vuoi altre opzioni?

Esplorare i vantaggi dell'abbonamento e i corsi di formazione, scoprire come proteggere il dispositivo e molto altro ancora.

Le community aiutano a porre e a rispondere alle domande, a fornire feedback e ad ascoltare gli esperti con approfondite conoscenze.

Queste informazioni sono risultate utili?

Come valuti la qualità della lingua?
Cosa ha influito sulla tua esperienza?
Premendo Inviare, il tuo feedback verrà usato per migliorare i prodotti e i servizi Microsoft. L'amministratore IT potrà raccogliere questi dati. Informativa sulla privacy.

Grazie per il feedback!

×