Accedi con Microsoft
Accedi o crea un account.
Salve,
Seleziona un altro account.
Hai più account
Scegli l'account con cui vuoi accedere.

Sintomi

Quando si usa il portale aziendale per Microsoft Dynamics GP, per Microsoft Business Solutions - Great Plains o per Microsoft Dynamics SL, il visualizzatore di report è vuoto quando si fa clic sul nome di un report visualizzato nella pagina centrale.

Causa

Causa 1

La cartella di report in cui sono archiviati i report pubblicati da Microsoft Dynamics GP o da Microsoft Dynamics SL non è condivisa.

Gli utenti e i gruppi seguenti devono avere accesso completo alla condivisione di report:

  • Gruppo Everyone

  • Utente del servizio di rete

  • Utente Identity per l'oggetto Microsoft.BusinessPortal.Reports.FileService COM+

  • Utente Identity per il pool di applicazioni usato dal portale aziendale

Vedere la risoluzione 1 nella sezione "Risoluzione".

Causa 2

L'utente con identità per l'oggetto Microsoft.BusinessPortal.Reports.FileService COM+ non ha accesso completo al file Microsoft.BusinessPortal.Reports.FileService.dll. Vedere la risoluzione 2 nella sezione "Risoluzione".

Causa 3

Il percorso della condivisione di report non è elencato correttamente nella tabella ReportCatalog. Vedere la risoluzione 3 nella sezione "Risoluzione".

Causa 4

Le dimensioni del file Microsoft.BusinessPortal.Reports.FileService.tlb sono 0 kilobyte (KB). Vedere la risoluzione 4 nella sezione "Risoluzione".

Risoluzione

Risoluzione 1

Per condividere la cartella del report e aggiungere l'accesso alla condivisione di report per utenti e gruppi specifici, seguire questa procedura:

  1. In Windows Explorer fare clic con il pulsante destro del mouse sulla cartella che contiene i report pubblicati da Microsoft Dynamics GP o da Microsoft Dynamics SL. Fare quindi clic su Proprietà.

  2. Fare clic sulla scheda Condivisione, fare clic su Condividi la cartellae quindi su Autorizzazioni.

  3. Fare clic suAggiungi , digitare Tutti, fare clic su Controlla nomie quindi su OK.

  4. Fare clic sulla voce Tutti.

  5. Nell'area Autorizzazioni per tutti fare clic per selezionare la casella di controllo Controllo completo e quindi fare clic su OK.

Nota Ripetere i passaggi da 3 a 5 per gli altri utenti e gruppi menzionati nella sezione "Causa". L'utente servizio di rete è un utente locale. Per determinare i nomi degli altri utenti e gruppi da aggiungere, vedere la sezione "Informazioni".

Risoluzione 2

Per aggiungere l'accesso corretto per l'oggetto COM+, seguire questa procedura:

  1. In Windows Explorer fare clic con il pulsante destro del mouse sul file Microsoft.BusinessPortal.Reports.FileService.dll e quindi scegliere Proprietà.

    Nota Per impostazione predefinita, questo file si trova nel percorso seguente:

    C:\Inetpub\wwwroot\bin

  2. Fare clic sulla scheda Sicurezza, fare clic su Aggiungi,su Percorsi,selezionare il nome del server Business Portal e quindi fare clic su OK.

  3. Immettere il nome dell'utente, fare clic su Controlla nomie quindi su OK.

    Nota Per determinare il nome dell'utente dell'identità per l'oggetto Microsoft.BusinessPortal.Reports.FileService COM+, vedere la sezione "Altre informazioni".

  4. Fare clic sul nome utente.

  5. Nell'area Autorizzazioni fare clic per selezionare la casella di controllo Controllo completo e quindi fare clic su OK.

Risoluzione 3

Per correggere il percorso della condivisione di report nella tabella ReportCatalog, eseguire lo script seguente nel database aziendale.

SELECT  * FROM ReportCatalog

La Report_URL colonna deve puntare alla condivisione del report. Ad esempio, se il report Report.txt si trova nella cartella C:\Reports nel server di report BusinessPortalServer, il valore nella colonna Report_URL deve essere il valore seguente:

BusinessPortalServer/Reports/Report.txt

Risoluzione 4

  1. In Windows Explorer individuare il file Microsoft.BusinessPortal.Reports.FileService.tlb.

    Nota Per impostazione predefinita, questo file si trova nella cartella seguente:

    c:\inetpub\wwwroot\bin

  2. Se le dimensioni del file sono di 0 KB, rinominare il file usando il nome file seguente:

    Microsoft.BusinessPortal.Reports.FileService.tlbold

  3. Fare clic sul collegamento seguente per scaricare un nuovo file Microsoft.BusinessPortal.Reports.FileService.tlb:

    https://mbs.microsoft.com/fileexchange/?fileID=aab68342-5ba5-4084-adf0-44271a6f3141

  4. Incollare il file nella stessa cartella in cui si trova l'originale Microsoft.BusinessPortal.Reports.FileService.tlb.

Ulteriori informazioni

Per determinare l'utente dell'identità per l'oggetto Microsoft.BusinessPortal.Reports.FileService COM+, seguire questa procedura:

  1. Fare clic su Start, scegliere Strumenti diamministrazione e quindi Servizi componenti.

  2. Espandere Servizi componenti,Computer,Risorse del computere quindi applicazioni COM+.

  3. Fare clic con il pulsante destro del mouse su Microsoft.BusinessPortal.Reports.FileService, scegliere Proprietàe quindi fare clic sulla scheda Identità.

Per determinare l'utente dell'identità per il pool di applicazioni usato dal portale aziendale, seguire questa procedura:

  1. Fare clic su Start, scegliere Strumenti diamministrazione e quindi fare clic su Gestione Internet Information Services (IIS).

  2. Espandere il nome del computer e quindi pool di applicazioni.

  3. Individuare il pool di applicazioni in uso per il portale aziendale.

  4. Fare clic con il pulsante destro del mouse sul pool di applicazioni, scegliere Proprietàe quindi fare clic su Identità.

Riferimenti

Per altre informazioni sulla procedura di risoluzione dei problemi da usare quando i report FRx non vengono visualizzati nel portale aziendale, fare clic sul numero dell'articolo seguente per visualizzare l'articolo della Microsoft Knowledge Base:

861754 Non è possibile visualizzare i report FRx nel portale aziendale in Salomone e Great Plains

861754

Serve aiuto?

Vuoi altre opzioni?

Esplorare i vantaggi dell'abbonamento e i corsi di formazione, scoprire come proteggere il dispositivo e molto altro ancora.

Le community aiutano a porre e a rispondere alle domande, a fornire feedback e ad ascoltare gli esperti con approfondite conoscenze.

Queste informazioni sono risultate utili?

Come valuti la qualità della lingua?
Cosa ha influito sulla tua esperienza?
Premendo Inviare, il tuo feedback verrà usato per migliorare i prodotti e i servizi Microsoft. L'amministratore IT potrà raccogliere questi dati. Informativa sulla privacy.

Grazie per il feedback!

×