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Sintomi

Nel portale aziendale per Microsoft Dynamics GP o per Microsoft Dynamics SL potrebbe essere visualizzato il messaggio di errore seguente quando si fa clic su Impostazioni sito e quindi su Gestisci utenti:

Errore del server nell'applicazione '/'.
-------------------------------------------------------------------------------- utente


non valido.


Descrizione: si è verificata un'eccezione non gestita durante l'esecuzione della richiesta Web corrente. Esaminare l'analisi dello stack per altre informazioni sull'errore e sulla sua origine nel codice.



Dettagli eccezione: Microsoft.BusinessFramework.Security.AuthenticationException: utente non valido.



Errore di origine: durante l'esecuzione della richiesta Web corrente è stata generata un'eccezione non gestita. Le informazioni relative all'origine e alla posizione dell'eccezione possono essere identificate usando la traccia dello stack delle eccezioni riportata di seguito.



Traccia dello stack:


[AuthenticationException: Utente non valido.] Microsoft.BusinessFramework.UserManager.VerifyUser() +695 Microsoft.BusinessFramework.EnterpriseSession.Initialize(String enterpriseUrl) +1061 Microsoft.BusinessFramework.Security.EnterpriseInitializationModule.OnAcquireRequestState(Object sender, EventArgs e) +150 System.Web.SyncEventExecutionStep.System. Web.HttpApplication+IExecutionStep.Execute() +60 System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) +87


--------------------------------------------------------------------------------

Version Information:
Microsoft .NET Framework Version:1.1.4322.2032;
ASP.NET Versione:1.1.4322.2032

Causa

Questo problema si verifica quando si verifica una o più delle condizioni seguenti:

  • L'account utente usato per installare il portale aziendale non dispone delle autorizzazioni corrette nel server che esegue Microsoft Internet Information Services (IIS). L'account utente non è un membro dei ruoli corretti nel computer che esegue Microsoft SQL Server.

  • L'account utente è un membro di un dominio diverso da quello in cui è stato installato Il portale aziendale.

  • L'account utente non esiste nelle tabelle del portale aziendale nel database Dynamics o nel database di sistema.

  • L'account utente è danneggiato nel portale aziendale.

  • Internet Enhanced Security è abilitato.

Risoluzione

Per risolvere il problema, seguire questa procedura. Dopo aver completato ogni passaggio, fare clic su Impostazionie quindi su Gestisci utenti nel portale aziendale. Se non si riceve il messaggio di errore menzionato nella sezione "Sintomi", il problema sarà stato risolto. In questo caso, non è necessario completare i passaggi rimanenti in questa sezione. Ogni volta che viene visualizzato il messaggio di errore, andare al passaggio successivo.

  1. Verificare che l'account utente usato per installare il portale aziendale abbia almeno le autorizzazioni di amministratore locale nel server che esegue IIS. Assicurarsi inoltre che l'account utente abbia un account Microsoft SQL Server accesso. Assicurarsi che l'account di accesso sia membro dei ruoli del server seguenti in SQL Server:

    • Amministratori della sicurezza

    • Creatori di database

  2. Assicurarsi che l'account utente sia membro del dominio e della rete in cui è installato Il portale aziendale. Verificare inoltre che il dominio abbia un ambiente attendibile configurato nella rete.

  3. Verificare che l'account utente che riceve il messaggio di errore sia presente nelle tabelle seguenti:

    • MbfUserWindowsIdentity

    • MbfUser


    Per verificare l'esistenza dell'account utente, eseguire l'istruzione seguente in SQL Query Analyzer o in SQL Server Management Studio. Per Microsoft Dynamics GP, eseguire l'istruzione nel database Dynamics. Per Microsoft Dynamics SL, eseguire l'istruzione nel database di sistema.

    SELECT WINDOWSCREDENTIALS FROM MbfUserWindowsIdentity
    SELECT ALIAS FROM MbfUser

    Se l'account utente non esiste in queste tabelle, l'utente che ha installato il portale aziendale deve rimuovere e quindi aggiungere l'account utente usando il portale aziendale. Per altre informazioni su come rimuovere o aggiungere un account utente, vedere la sezione "Informazioni".

  4. Se il problema persiste, fare in modo che l'utente che ha installato Il portale aziendale provi a eseguire l'attività. Se l'utente che ha installato Il portale aziendale non riceve il messaggio di errore, l'account utente dell'utente che ha ricevuto il messaggio di errore potrebbe essere danneggiato. L'utente che ha installato Il portale aziendale deve rimuovere e quindi aggiungere l'account utente usando il portale aziendale. Per altre informazioni su come rimuovere o aggiungere un account utente, vedere la sezione "Informazioni".

  5. Nel server IIS fare clic su Start, scegliere Pannello di controllo ,Installazione applicazioni e quindi fare clic su Aggiungi/Rimuovi Windows componenti. Deselezionare la casella di controllo Sicurezza avanzata Internet e quindi procedere con la procedura guidata per rimuovere l'applicazione.




    Note

    • Se si vuole usare La sicurezza avanzata di Internet, assicurarsi di accedere usando un nome utente domain\userID insieme alla password appropriata.

    • La sicurezza avanzata di Internet non è necessaria per un controllo di sicurezza perché il portale aziendale esegue l'autenticazione nel dominio per ogni utente che tenta di accedere al programma.

Ulteriori informazioni

Per rimuovere e quindi aggiungere un account utente nel portale aziendale, seguire questa procedura.

Rimuovere un utente

  1. Avviare il portale aziendale. Usare l'account utente usato per installare il portale aziendale.

  2. In Business Portal 3.0 fare clic su Site Impostazionie quindi su Manage Business Portal users.

    In Portale aziendale per Dynamics GP 10 (e versioni successive) fare clic su Azionisito, fare clic su Impostazioni sito equindi su Utenti nella sezione Amministrazione portale aziendale.

  3. Nell'elenco Elenco utenti selezionare l'account utente.

  4. Nell'area Selezionare un'attività fare clic su Rimuovi utenti.

  5. Nella finestra Remove Business Portal Users fare clic per selezionare l'account utente da rimuovere.

  6. Fare clic su Rimuovi.

Aggiungere un utente

  1. Avviare il portale aziendale. Usare l'account utente usato per installare il portale aziendale.

  2. In Business Portal 3.0 fare clic su Site Impostazionie quindi su Manage Business Portal users.

    In Portale aziendale per Dynamics GP 10 (e versioni successive) fare clic su Azionisito, fare clic su Impostazioni sito equindi su Utenti nella sezione Amministrazione portale aziendale.

  3. Nell'area Selezionare un'attività fare clic su Aggiungi nuovi utenti. Completare i passaggi dell'Aggiunta guidata utenti per aggiungere l'account utente al portale aziendale.

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