Importante Prima di eseguire questa operazione su Fix It, salvare i dati e chiudere l'applicazione. Dopo aver eseguito il Fix It, il computer verrà riavviato dopo 10 minuti.
Sintomi
Su un computer che esegue Windows XP, Windows Vista o Windows 7, alcune icone nelle seguenti posizioni vengono modificate in altre icone in modo casuale:
-
Risorse del computer
-
Esplora risorse
-
Desktop
-
Barra di avvio veloce
Causa
Il problema si verifica, perché la cache delle icone non viene aggiornata correttamente.
Risoluzione
Per risolvere il problema, il primo passaggio consiste nell'accedere ad un altro account utente con diritti di amministratore. Per effettuare questa operazione, attenersi alla seguente procedura:
-
Disconnettersi dall'account utente corrente che rileva la modifica dell'icona.
-
Accedere come un utente con privilegi di amministratore.
Nota Il file deve essere eliminato da un altro utente perché durante il processo di disconnessione, il file IconCache.db potrebbe essere sovrascritto con i dati danneggiati dell'icona.
Importante: in questa sezione, metodo o attività viene illustrata la procedura per modificare il Registro di sistema. L'errata modifica del Registro di sistema può causare seri problemi. Di conseguenza, attenersi scrupolosamente alla procedura indicata. Per maggiore sicurezza, eseguire una copia di backup del Registro di sistema prima di modificarlo. In questo modo, sarà possibile effettuarne il ripristino in caso di problemi. Per ulteriori informazioni sull'esecuzione del backup e del ripristino del Registro di sistema, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:322756 Come eseguire il backup e il ripristino del Registro di sistema in Windows Quindi attenersi alla seguente procedura per risolvere il problema:
-
Se viene visualizzata la finestra di dialogo Chiudi interazione programmi aperti, chiudere tutte le finestre aperte.
-
Creare la chiave del Registro di sistema Max Cached Icons e quindi impostare il valore di tale chiave a 2048. Per effettuare questa operazione, attenersi alla seguente procedura:
-
Fare clic su Start, digitare regedit nella casella Ricerca, quindi fare clic su Regedit nell'elenco dei programmi.
-
Individuare e selezionare la seguente chiave del Registro di sistema:
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Explorer -
Scegliere Nuovo dal menu Modifica e quindi fare clic su Valore stringa.
-
Digitare MaxCachedIcons come nome della chiave del Registro di sistema, quindi premere INVIO.
-
Fare doppio clic sulla chiave di registro Max Cached Icons, immettere 2048 nella casella Dati valore, quindi fare clic su OK.
-
Uscire dall'editor del Registro di sistema.
-
-
Eliminare IconCache.db dal seguente percorso, a seconda del sistema operativo.
Windows XP
C:\Documents and Settings\<User Name>\Local Settings\Application Data
Windows Vista o Windows 7
C:\Users\<User Name>\AppData\LocalNota <User Name> è un segnaposto per il nome dell'account utente che rileva la modifica dell'icona.
Ulteriori informazioni
Modalità di funzionamento del pacchetto MATS per la risoluzione del problema
-
Il pacchetto MATS analizza il computer e rileva se è in esecuzione Windows XP, Windows Vista o Windows 7.
-
Il pacchetto MATS verifica l'eventuale presenza del valore del Registro di sistema Max Cached Icons nelle sottochiavi del Registro di sistema. Se il valore del Registro di sistema Max Cached Icons non è presente, è necessario crearlo e impostarlo su 2048. Se il valore del Registro di sistema Max Cached Icons è presente, è necessario impostarlo su 2048.
Nota Durante questo processo, viene visualizzata una finestra di dialogo. Ciò fornisce l'opzione di risolvere il problema in modo automatico (scelta consigliata) o di selezionare manualmente i singoli problemi da risolvere. Per selezionare manualmente ogni singolo problema da correggere, dalla finestra di dialogo è necessario selezionare l'opzione Personalizzazioni di icone e cartelle o Altri o Non so. -
Il pacchetto MATS verifica che il file IconCache.db venga eliminato correttamente.
Altri problemi che il pacchetto MATS risolve
2394521 Impossibile svuotare il Cestino su Windows XP o su Windows Vista
949109 Errore "Il file o la cartella non esiste" su Windows Vista
934160 "Errore di rete o di accesso al file" o "La cartella non esiste"
2394740 Impossibile selezionare piÙ elementi dopo l'aggiornamento da Windows XP a Windows Vista
813711 Le modifiche relative alle dimensioni, alla visualizzazione, all'icona o alla posizione di una cartella sono andate perse