Accedi con Microsoft
Accedi o crea un account.
Salve,
Seleziona un altro account.
Hai più account
Scegli l'account con cui vuoi accedere.

Sintomi

Quando si prova a eseguire uno degli scenari di aggiornamento nella schermata di manutenzione del database (98.290.00) in Microsoft Dynamics SL, viene visualizzato uno dei messaggi di errore seguenti:messaggio 1

L'eccezione non gestita si è verificata nell'applicazione. Se si fa clic su continua, l'applicazione ignorerà l'errore e cercherà di continuare. Se si fa clic su Chiudi, l'applicazione si chiuderà immediatamente. Il recupero della class factory COM per il componente con CLSID [A440BD76-CFE-4D46-AB1F-15F238437A3D] non è riuscito a causa dell'errore seguente: 80040154.

Messaggio 2

Errore di run-time 429' il componente Active X non può creare l'oggetto ' recuperando la factory della classe COM per il componente con CLSID {10020200-E260-11CF-AE68-00AA004A34d}

Causa

1. Questo problema si verifica perché il file SQLDMO. dll non è registrato nel computer locale.2. Questo problema si verifica perché il file CAPICOM. dll non è registrato nel computer locale.

Risoluzione

Usare una o più delle risoluzioni seguenti, a seconda della situazione.Risoluzione 1 Registrare manualmente il file SQLDMO. dll. A tal fine, attenersi alla seguente procedura:

  1. Individuare il file SQLDMO. dll nel computer locale. Per impostazione predefinita, il file si trova nella cartella c:\Programmi\Microsoft SQL Server\MSSQL\80\Tools\Binn

  2. Fare clic con il pulsante destro del mouse sul file SQLDMO. dll e quindi scegliere Apri con.

  3. Nella finestra di dialogo Windows fare clic su Seleziona il programma da un elencoe quindi fare clic su OK.

  4. Nella finestra di dialogo Apri con fare clic su Sfoglia.

  5. Individuare e quindi aprire la cartella seguente: SystemDrive : \Windows\System32.

  6. Fare doppio clic sul file Regsvr32. exe e quindi fare clic su OK.

  7. Fare clic su OK quando si riceve il messaggio seguente:

    RegSvr32-DllRegisterServer in SQLDMO. dll riuscito.

Nota Se non è possibile registrare il file SQLDMO. dll oppure non esiste alcun file SQLDMO. dll nella directory di contenitori, vedere "risoluzione 3". Risoluzione 2

  1. Individuare il file CAPICOM. dll nel computer locale. Per impostazione predefinita, questo file è in SystemDrive : \Windows\System32.

  2. Fare clic con il pulsante destro del mouse sul file CAPICOM. dll e quindi scegliere Apri con.

  3. Nella finestra di dialogo Windows fare clic su Seleziona il programma da un elencoe quindi fare clic su OK.

  4. Nella finestra di dialogo Apri con fare clic su Sfoglia.

  5. Individuare e quindi aprire la cartella seguente: SystemDrive : \Windows\System32.

  6. Fare doppio clic sul file Regsvr32. exe e quindi fare clic su OK.

  7. Fare clic su OK quando si riceve il messaggio seguente:

    RegSvr32-DllRegisterServer in CAPICOM. dll riuscito.

Nota Se non è possibile registrare il file SQLDMO. dll o non esiste alcun file SQLDMO. dll nella directory, vedere "risoluzione 4." Risoluzione 3 Se non è possibile registrare il file SQLDMO. dll o non esiste alcun file SQLDMO. dll nella directory di contenitori, potrebbe essere indicato che la directory di contenitori è incompleta. In questo caso, copia la directory di contenitori da una workstation funzionante e Sostituisci la directory di contenitori nella workstation che riceve l'errore. Quindi eseguire la risoluzione 1. se non sono disponibili altre workstation da cui è possibile copiare la directory di contenitori, contattare il supporto di Microsoft Dynamics SL per assistenza per la ricostruzione della directory di contenitori.Risoluzione 4 Se non è possibile registrare il file CAPICOM. dll o se il file non è presente, passare al server o a un altro computer che lavora copiare il file CAPICOM. dll da tale origine e incollarlo nella workstation in cui è stato assegnato l'errore. Quindi eseguire la risoluzione 2. se non sono disponibili altre workstation da cui è possibile copiare CAPICOM. dll, contattare il supporto di Microsoft Dynamics SL per ottenere assistenza per il recupero del file CAPICOM. dll.Nota I criteri di carica normale si applicano se viene avviato un caso di supporto.

Serve aiuto?

Vuoi altre opzioni?

Esplorare i vantaggi dell'abbonamento e i corsi di formazione, scoprire come proteggere il dispositivo e molto altro ancora.

Le community aiutano a porre e a rispondere alle domande, a fornire feedback e ad ascoltare gli esperti con approfondite conoscenze.

Queste informazioni sono risultate utili?

Come valuti la qualità della lingua?
Cosa ha influito sulla tua esperienza?
Premendo Inviare, il tuo feedback verrà usato per migliorare i prodotti e i servizi Microsoft. L'amministratore IT potrà raccogliere questi dati. Informativa sulla privacy.

Grazie per il feedback!

×