In questo articolo può contenere un collegamento all'utilità di pulitura di Windows Installer (MSICUU2.exe). Se si viene reindirizzati a questo articolo per risolvere un problema utilizzando l'utilità Windows Installer Cleanup, contattare il produttore del software per il supporto di installazione del prodotto o vedere il seguente articolo della Microsoft Knowledge Base per istruzioni su come risolvere i problemi di disinstallazione di prodotti che utilizzano Windows Installer:

2438651 come risolvere i problemi che possono verificarsi durante l'installazione, Disinstalla o aggiorna un programma in un computer basato su Windows

Sintomi

Quando si tenta di installare Adobe Acrobat o Adobe Reader in Windows Vista, viene visualizzato un messaggio di errore analogo a uno dei seguenti.

Messaggio 1

La funzionalità di cui che si sta tentando di utilizzare è su una risorsa di rete non disponibile. Fare clic su OK per riprovare oppure immettere un percorso alternativo a una cartella contenente il pacchetto di installazione 'Adobe AdobeApplication. msi"nella casella sottostante.

Messaggio 2

Errore 1714. Impossibile rimuovere la versione precedente di Adobe [AdobeApplication]. Contattare il supporto tecnico.

Questo problema si verifica quando si tenta di installare uno dei seguenti prodotti:

  • Adobe Acrobat 6

  • Adobe Acrobat 7

  • Adobe Acrobat 3D

  • Adobe Acrobat 8

  • Adobe Reader

Causa

Questo problema può verificarsi se l'installazione corrente di Acrobat Reader è danneggiata.

Risoluzione

Per risolvere questo problema, utilizzare uno o più dei seguenti metodi, come appropriato alla situazione.

Metodo 1: Installare la versione originale di Acrobat Reader

Utilizzare il file AdobeApplication. msi per installare la versione originale di Acrobat Reader. Ad esempio, per utilizzare il file Acroread.msi per reinstallare Adobe Reader 8.0, procedere come segue:

  1. Nella casella che contiene il messaggio di errore, fare clic su Sfoglia.

  2. Individuare e fare doppio clic sul file Acroread.msi .Nota: In genere, il file Acroread.msi si trova nella cartella programmi Files\Adobe\Reader 8.0\Setup Files \ {GUID}. In questo esempio, il segnaposto GUID rappresenta una stringa che è simile al seguente:

    xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxxNota: Potrebbe essere necessario inserire il supporto di installazione per individuare il file AdobeApplication. msi.

  3. Seguire le istruzioni visualizzate sullo schermo per completare l'installazione.

  4. Se necessario, provare a installare nuovamente l'aggiornamento.

Metodo 2: Disinstallare le versioni precedenti

Disinstallare le versioni precedenti dell'applicazione e quindi installare la versione desiderata. A tale scopo, attenersi alla seguente procedura:

  1. Fare clic su Start  Start button  , digitare appwiz. cpl nella casella Inizia ricerca e quindi fare clic su appwiz. cpl nell'elenco dei file trovati.

  2. Fare doppio clic sulla versione di Acrobat o del lettore che si desidera disinstallare.

  3. Fare clic su se viene chiesto di confermare che si desidera disinstallare il programma.Nota: Se viene chiesto di confermare che si desidera eseguire il programma, fare clic su Consenti.

  4. Fare clic su per riavviare il computer.

  5. Ripetere i passaggi da 2 a 4 per tutte le versioni precedenti di Acrobat Reader.

  6. Riavviare il computer.

  7. Installare la versione di Acrobat Reader che si desidera.

Metodo 3: Ripristinare l'installazione di Acrobat Reader

Ripristinare l'installazione corrente di Acrobat Reader. Ad esempio, se si desidera ripristinare Adobe Reader 8.0, attenersi alla seguente procedura.Nota: Potrebbe essere necessario inserire il supporto di installazione per individuare il file AdobeApplication. msi. Se è installata una versione scaricata di Acrobat Reader, è necessario scaricare nuovamente i file di programma di installazione.

  1. Individuare e fare doppio clic sul file Acroread.msi .Nota: In genere, il file Acroread.msi si trova nella cartella programmi Files\Adobe\Reader 8.0\Setup Files \ {GUID}. In questo esempio, il segnaposto GUID rappresenta una stringa che è simile al seguente:

    xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx

  2. Fare clic su Avanti, fare clic su Ripristina, fare clic su Avantie quindi fare clic su Installa.

  3. Seguire le istruzioni visualizzate sullo schermo per completare l'installazione.

  4. Se necessario, provare a installare nuovamente l'aggiornamento.

Metodo 4: Utilizzare l'utilità Windows Installer CleanUp

Utilizzare l'utilità Windows Installer CleanUp per rimuovere i file e le impostazioni del Registro di sistema che costituiscono le informazioni di configurazione di Windows Installer per Acrobat o Reader. A tale scopo, attenersi alla seguente procedura:

  1. Fare clic su Start  Start button  , digitare appwiz. cpl nella casella Inizia ricerca e quindi fare clic su appwiz. cpl nell'elenco dei file trovati.

  2. Fare doppio clic sulla versione di Acrobat o del lettore che si desidera disinstallare.

  3. Fare clic su se viene chiesto di confermare che si desidera disinstallare il programma.Nota: Se viene chiesto di confermare che si desidera eseguire il programma, fare clic su Consenti.

  4. Fare clic su per riavviare il computer.

  5. Ripetere i passaggi da 2 a 4 per ogni versione di Acrobat o Reader che si desidera disinstallare. Ad esempio, se l'errore descritto nella sezione "Sintomi" si verifica quando si tenta di aggiornare una versione precedente di Acrobat o Reader, disinstallare la versione precedente.

  6. Scaricare e installare l'utilità Windows Installer CleanUp. Per ulteriori informazioni su come scaricare e installare l'utilità Windows Installer CleanUp, fare clic sul numero riportato di seguito per visualizzare l'articolo della Microsoft Knowledge Base:

    Descrizione di 290301 l'utilità Windows Installer CleanUp

  7. Fare clic su Start  Start button  , digitare Msicuu2.exe nella casella Inizia ricerca e quindi nell'elenco dei file trovati fare clic su Msicuu2.exe .

  8. Fare clic sulla versione di Acrobat Reader che si desidera rimuovere e quindi fare clic su Rimuovi.Nota: Se l'errore descritto nella sezione "Sintomi" si verifica quando si tenta di aggiornare una versione precedente di Acrobat o Reader alla versione corrente, rimuovere la versione precedente. Se l'errore si verifica quando si tenta di installare la versione corrente, rimuovere la versione corrente.

  9. Se l'errore descritto nella sezione "Sintomi" si verifica quando si tenta di installare la versione corrente di Acrobat Reader, andare al passaggio 10. Se l'errore descritto nella sezione "Sintomi" si verifica quando si tenta di aggiornare una versione precedente di Acrobat o Reader, attenersi alla seguente procedura:

    1. Reinstallare la versione precedente di Acrobat o Reader.

    2. Fare clic su Start  Start button  , digitare appwiz. cpl nella casella Inizia ricerca e quindi fare clic su appwiz. cpl nell'elenco dei file trovati.

    3. La versione di Acrobat Reader che è stato reinstallato nel passaggio di fare doppio clic su un.

    4. Fare clic su se viene chiesto di confermare che si desidera disinstallare il programma.Nota: Se viene chiesto di confermare che si desidera eseguire il programma, fare clic su Consenti.

  10. Installare la versione corrente di Acrobat Reader e quindi installare eventuali aggiornamenti disponibili.

Serve aiuto?

Vuoi altre opzioni?

Esplorare i vantaggi dell'abbonamento e i corsi di formazione, scoprire come proteggere il dispositivo e molto altro ancora.

Le community aiutano a porre e a rispondere alle domande, a fornire feedback e ad ascoltare gli esperti con approfondite conoscenze.